14:00:33 <ChrisPriceAB> #startmeeting OPNFV TSC Meeting
14:00:33 <collabot> Meeting started Tue Sep 20 14:00:33 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:33 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:33 <collabot> The meeting name has been set to 'opnfv_tsc_meeting'
14:00:36 <dneary> #info Dave Neary
14:00:37 <ChrisPriceAB> #topic Roll Call
14:00:40 <ulik> #info Uli Kleber
14:00:41 <dneary> oops
14:00:44 <ChrisPriceAB> #info Chris Price
14:00:46 <rprakash> #info rprakash
14:00:46 <dneary> too early
14:00:53 <rossella_s> #info Rossella Sblendido
14:00:54 <edgarstp> #info Edgar StPierre
14:01:01 <morgan_orange> #info Morgan Richomme
14:01:10 <fdegir> #info Fatih Degirmenci
14:01:16 <frankbrockners> #info Frank Brockners
14:01:40 <bin_> #info Bin Hu
14:01:49 <bryan_att> #info Bryan Sullivan
14:01:53 <tallgren> #info Tapio Tallgren
14:02:17 <rpaik> we now have a quorum
14:02:17 <Julien-zte> #info Julien
14:02:23 <bjskerry> #info Brian Skerry
14:03:07 <dmcbride> #info David McBride
14:03:17 <aricg> #info Aric Gardner
14:03:23 <JonasArndt> #info JonasArndt
14:03:48 <ChrisPriceAB> #topic Approval of previous minute
14:03:54 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-September13,2016 previous minutes
14:03:59 <ChrisPriceAB> #info approved not comments
14:04:03 <ChrisPriceAB> #topic Agenda Bashing
14:04:14 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-September20,2016 todays agenda
14:05:13 <jmorgan1> #info jack morgan
14:05:39 <ChrisPriceAB> #info no further topics for todays agenda
14:05:50 <ChrisPriceAB> #topic Technical community elections
14:06:11 <ChrisPriceAB> #info Committer Board elections are ongoing (Announcement: Sep. 6/Nomination: Sep 13 - 23/Election: Sep 26 - 30/Result: Oct. 3)
14:06:32 <ChrisPriceAB> #info TSC Chair elections (Announcement: Sep. 12/Nomination: Sep 19 - 30/Election: Oct. 3 - 7/Result: Oct. 10)
14:08:37 <ChrisPriceAB> #topic JIRA Federation
14:09:26 <ChrisPriceAB> #info frankborckners outlines that there is value in having our activities visible in our upstream communities, and that we can see upstream activities relevant for us.
14:10:08 <ChrisPriceAB> #info frank further outlines that by using Jira federation, we would be able to relate to upstream communities using Jira.  Identify blocking issues etc.
14:11:11 <ChrisPriceAB> #info frank proposes that we try to federate the OPNFV and FD.io Jira as a trial to see how the federation works and if it is useful.
14:12:07 <ChrisPriceAB> #info tapio asks frank to elaborate how federation works
14:12:52 <ChrisPriceAB> #info frank answers that we could essentially treat federated community projects like we do across our own projects in that we can relate and link to those items and stories.
14:12:52 <aricg> Unified activity steams
14:12:53 <aricg> Unified reporting dashboards
14:12:53 <aricg> Remote issue links
14:12:53 <aricg> Application navigator
14:12:53 <aricg> Project links
14:12:55 <aricg> JIRA Issue Copy
14:12:57 <aricg> Federated search
14:13:13 <bryan_att> ok as a trial, as long as this is an optional activity that's setup as needed by specific projects and upstream communities, that find this valuable. I would not however want this to become another mandated layer in our JIRA based project management structure.
14:13:20 <ChrisPriceAB> optionally unified, or mandatorily unified?
14:13:46 <fdegir> this is good to capture dependencies
14:13:57 <fdegir> and get indications regarding this
14:15:00 <ChrisPriceAB> #info prakash asks the type of relationship between the Jira instances.   Frank responds that it is a peer to peer relationship.
14:15:47 <ChrisPriceAB> #info chrispriceab asks if there is any impact on unrelated projects.  Frank responds there is no impact.
14:16:36 <ChrisPriceAB> #info rpaik adds that when two instances are federated they do need to use the same ldap solution.  (This will not be an issue for fd.io, but may be for other projects)
14:16:51 <Xavier__> #info Xavier Costa (NEC)
14:17:59 <ChrisPriceAB> #info chrispriceab asks if anyone has issue with this proposal
14:18:12 <ChrisPriceAB> #agree the TSC agrees to start this federation trial.
14:18:37 <ChrisPriceAB> #action frankbrockners to report back to the TSC on this project.
14:18:55 <ChrisPriceAB> #topic Non Apache-2 license for the Moon project
14:19:00 <rpaik> #link https://wiki.opnfv.org/display/DEV/Licensing+in+OPNFV licensing in OPNFV
14:19:48 <ChrisPriceAB> #chair rpaik
14:19:48 <collabot> Current chairs: ChrisPriceAB rpaik
14:20:02 <ChrisPriceAB> #chair dmcbride
14:20:02 <collabot> Current chairs: ChrisPriceAB dmcbride rpaik
14:20:44 <ChrisPriceAB> #link https://wiki.opnfv.org/download/attachments/2925933/inclusion_of_third-party_open_source_software_template%20v2-MOON-%20Sep13%272016.docx?version=1&modificationDate=1473972647000&api=v2 Moon survey on third party opensource
14:21:29 <ChrisPriceAB> #info Ruan outlines the activities in Moon.  That they use identify federation across both OpenDaylight and OpenStack.
14:21:52 <ChrisPriceAB> #info the Moon roject has developed some code in ODL, to facilitate this which exists in the OPNFV Moon repository
14:22:20 <ChrisPriceAB> #info Moon has contributed this to ODL and it is under review, however the patch has not bee merged yet.
14:22:58 <ChrisPriceAB> #info Moon asks if it is OK to carry the fork in OPNFV for the Colorado release.  This would require an exception to use Eclipse in the repository.
14:23:29 <ChrisPriceAB> #inof rpaik adds that the legal committee will be reviewing this request prior to addressing the board.
14:24:13 <ChrisPriceAB> #info rpaik also outlines that technical community input is necessary to proceed.
14:26:00 <ChrisPriceAB> #info dneary asks about the previous discussion around using local mirrors in OPNFV  and if we need to approve these types of activities every time.
14:28:16 <ChrisPriceAB> #info dnaery asks how many pathes and the volume of code.
14:28:26 <ChrisPriceAB> #info ruan answers that there are only 10 adjusted files.
14:29:14 <ChrisPriceAB> #info frankbrockners answers that it is more of a legal issue than a technical concern.
14:29:59 <ChrisPriceAB> #info the TSC has no objections to this proposal.
14:30:11 <ChrisPriceAB> #topic Colorado planning and activities
14:30:43 <ChrisPriceAB> #link https://wiki.opnfv.org/download/attachments/6819702/09162016_opnfv_jira.txt?version=1&modificationDate=1474380018016&api=v2 colorado release presentation
14:31:10 <ChrisPriceAB> #info dmcbride outlines that 11 scenario's are currently failing out of a total of 45.
14:31:48 <ChrisPriceAB> #info 18 of our scenario's are currently passing the functest release protocol.
14:32:01 <ChrisPriceAB> #info in addition there are 7 scenario's that require further iterations
14:32:31 <ChrisPriceAB> #info Currently 24-28 scenario owners have indicated they intend to release for Colorado 1.0
14:34:15 <ChrisPriceAB> #info morgan_orange outlines that the result tables should be interpreted as an incremental scale that does not define stability.
14:34:16 <trozet> dmcbride: where is Fuel os-odl_l2-sfc on this graph?
14:34:57 <dmcbride> I think it was removed from Functest
14:35:22 <ChrisPriceAB> Because it is stable and release ready, or because it is faulty?
14:36:06 <ChrisPriceAB> #info morgan_orange outlines that if the scenario score is above around 80% the system is likely to be stable however there may be a documented limitation to be considered.
14:39:46 <ChrisPriceAB> #info dmcbride outlines that Jira resolution looks very good with a small amount of untracked or outstanding issues yet to be closed.
14:40:34 <trozet> dmcbride: when you say issues assigned to Colorado 1.0, do you mean affected or fixed version?
14:40:47 <dmcbride> "fixed version"
14:40:51 <trozet> dmcbride: ok good
14:40:59 <dmcbride> update "fixed version" to a future release
14:41:03 <dmcbride> or, close the issue
14:41:34 <ChrisPriceAB> #info Sofia describes that while a lot of good work has been done to get docs ready there is still some inconsistency and missing documentation remaining.
14:41:49 <morgan_orange> dmcbride:  trozet in functest we consider all the CI test results  since 10 days, if the scenario is no more here, it means that we were not able to collect any results since 10 days, which is the case for fuel/odl_l2-sfc...(same for apex/onos)
14:42:35 <ChrisPriceAB> #info dmcbride asks if the release should be delayed due to documentation issues, or if they can be resolved in a Colorado 2.0 or 3.0 update
14:42:52 <trozet> morgan_orange: ok.  The reason I ask is because I think the sfc failures in Apex are due to an ODL bug, so i would expect Fuel to hit it as well, that's why I was looking for it on the graph
14:43:24 <ChrisPriceAB> #info frankbrockners asks what we would be releasing specifically
14:44:08 <dmcbride> #link https://wiki.opnfv.org/display/SWREL/Colorado+Scenario+Status
14:44:40 <dmcbride> see Colorado intent to release columns on the righ-hand side of the table
14:45:12 <sofiawallin> http://artifacts.opnfv.org/opnfvdocs/review/21465/installationprocedure/index.html
14:45:39 <rpaik> #info ChriPriceAB notes his estimate is that ~30% of the scenarios do not have sufficient documentation
14:46:39 <ChrisPriceAB> #link http://artifacts.opnfv.org/opnfvdocs/review/21465/installationprocedure/index.html the list of scenario's are provided here
14:47:22 <ChrisPriceAB> #info morgan_orange adds that generic scenarios are not documented as scenarios in this list which is not a surprise
14:49:27 <jose_lausuch> trozet: maybe a bit late, but we have identified the bug in ODL and are workaround it
14:57:06 <ChrisPriceAB> #action dmcbride to provide a list of candidate scenario's for Colorado and the status of test and documentation for those scenarios.
14:59:09 <ChrisPriceAB> #action rpaik to set up TSC a call on the 21st to review the state of the Colorado scenarios and status.
14:59:56 <ChrisPriceAB> #topic AoB
15:00:35 <rpaik> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012668.html Open-O Meetup
15:00:52 <ChrisPriceAB> #info There will be an open-o developer event in Seattle next Monday 16:30 - 18:30 following the OpenDaylight and fd.io events that day.
15:01:09 * ChrisPriceAB drives a durango, swims in the danube
15:01:59 <ChrisPriceAB> #endmeeting