13:59:34 <ChrisPriceAB> #startmeeting OPNFV TSC
13:59:34 <collabot> Meeting started Tue Oct  4 13:59:34 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:34 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:59:34 <collabot> The meeting name has been set to 'opnfv_tsc'
13:59:39 <ChrisPriceAB> #topic Roll Call
13:59:48 <ChrisPriceAB> #info Chris Price
13:59:50 <mbeierl> #info Mark Beierl (Proxy for Edgar StPierre)
13:59:55 <hongbo> #info hongbo tian
14:00:51 <fzhadaev> #info Fedor Zhadaev
14:00:57 <trevor_intel_> #info Trevor cooper
14:01:14 <jmorgan1> #info Jack Morgan
14:01:19 <dneary> #info dneary
14:01:21 <fdegir> #info Fatih Degirmenci
14:01:21 <bjskerry> #info Brian Skerry
14:01:22 <rprakash> #info rprakash
14:01:24 <morgan_orange> #info Morgan Richomme
14:01:26 <bryan_att> #info Bryan Sullivan
14:01:28 <__szilard_cserey> #info Szilard Cserey
14:01:42 <bin_> #info Bin Hu
14:01:56 <ChrisPriceAB> #topic Approval of previous minutes of meeting
14:02:05 <frankbrockners> #info Frank Brockners
14:02:23 <ulik> #info Uli Kleber
14:02:26 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-September27,2016 previous minutes
14:02:45 <ChrisPriceAB> #info no comments previous minutes approved.
14:02:53 <rpaik> we now have a quorum
14:02:55 <ChrisPriceAB> #topic Agenda Bashing
14:03:14 <ChrisPriceAB> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-October4,2016 todays agenda
14:05:05 <StuartMackie> #info Stuart Mackie
14:05:05 <ChrisPriceAB> #info no additional topics were proposed.
14:05:17 <ChrisPriceAB> #topic Technical community elections
14:06:28 <ChrisPriceAB> #info TSC Chair (Announcement: Sep. 12/Nomination: Sep 19 - 30/Election: Oct. 3 - 7/Result: Oct. 10)
14:06:34 <ChrisPriceAB> #info elections are ongoing.
14:07:31 <rpaik> #info community recognizes ChrisPriceAB for a job well done as a TSC chair over the past 2 years
14:07:37 <ChrisPriceAB> #topic Recap from the OpenDaylight Summit
14:09:20 <rpaik> #info there was good discussion on Dovetail & VNF Onboarding on Thursday at the ODL Summit
14:09:34 <ChrisPriceAB> #info chrispriceab outlines that the dovetail meeting at the opendaylight summit was spent building awareness
14:09:44 <ChrisPriceAB> #chair rpaik
14:09:44 <collabot> Current chairs: ChrisPriceAB rpaik
14:10:05 <hongbo> thanks Chris for your loutlines
14:10:05 <rpaik> #link http://meetbot.opnfv.org/meetings/opnfv-polestar/2016/opnfv-polestar.2016-09-29-19.37.html VNF onboarding minutes
14:12:30 <rpaik> #info there was also a meeting with OpenDaylight community on future releases alignment
14:13:22 <ChrisPriceAB> #info chrispriceab describes the collaboration sessions was spent focusing on release alignment and testing collaboration between ODL and OPNFV.
14:13:31 <bryan_att> #info IRC log from the Polestar/MANO/models/EUAG meetup: http://ircbot.wl.linuxfoundation.org/meetings/opnfv-polestar/2016/opnfv-polestar.2016-09-29-19.37.log.html
14:13:55 <ChrisPriceAB> #topic Managing Private Keys in OPNFV
14:14:37 <ChrisPriceAB> #info lukehinds describes that there has been some discussion around the use of private keys that should result in work activities to improve our security handling in OPNFV.
14:15:10 <ChrisPriceAB> #info specifcally there have been multiple private keys stored in repositories for some projects which is generally not considered a best practice.
14:15:42 <bryan_att> One thing re keys that would help, is some specific help on key injection into images e.g. via image customization tools... I have tried to do this but it's not working, and for some tests I need an image with a pre-injected key. I'd rather generate the key and inject it dynamically though.
14:15:46 <ChrisPriceAB> #info ash further explains that the reasonaing for including these keys is to facilitate automation.
14:16:26 <ChrisPriceAB> #info there may be better ways of achieving automation which the security group will further investigate and describe with the community.
14:17:22 <ChrisPriceAB> #info some private keys may be applicable in more than just the automation functions
14:17:46 <hongbo> we need to isolate the risk from the eviroment
14:18:26 <ChrisPriceAB> #info ash has developed a tutorial that helps people onboard activities in secure fashion.
14:18:59 <rpaik> #action ash to post a tutorial presentation on the security team wiki
14:19:26 <ChrisPriceAB> #info luke and ash discus making it available on the security group wiki.
14:20:05 <ChrisPriceAB> #info prakash asks what the relationship is to the CII badge program, luke responds that the CII indicates this should not be done.
14:20:36 <ChrisPriceAB> #infol lhinds asks for a volunteer to help drive this topic.
14:20:54 <ChrisPriceAB> #info lhinds asks for a volunteer to help drive this topic.
14:21:10 <ChrisPriceAB> #undo
14:21:10 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2e80050>
14:21:16 <ChrisPriceAB> #info lhinds asks for volunteers to help drive this topic.
14:21:43 <ChrisPriceAB> #info the Security WG meets wednesdays at 14:00 UTC.
14:22:26 <ChrisPriceAB> #info jmorgan1 adds that there is some additional e-mail discussion on this topic
14:23:44 <ChrisPriceAB> #info ash volunteers
14:24:24 <ChrisPriceAB> #topic Danube development and CI/CD processes discussion
14:25:06 <ChrisPriceAB> #info Fatih outlines that work is ongoing on the CI evolution activity
14:25:18 <ChrisPriceAB> #link https://wiki.opnfv.org/display/INF/CI+Evolution CI evolution wiki, plan and description
14:25:44 <ChrisPriceAB> #info fdegir outlines that there have been some additions to the post-merge job as part of the promotion process
14:25:47 <fdegir> #link https://wiki.opnfv.org/download/attachments/6824933/JenkinsJobStructure_PostMerge.png?version=3&modificationDate=1475590881101&api=v2
14:26:10 <ChrisPriceAB> #info fatih describes the additional jobs on the above diagram
14:27:33 <rpaik> #info fdegir notes that experiments will be done with Fuel & Apex and looking for help with other installers
14:27:50 <fdegir> another view of how this thing would work
14:27:52 <fdegir> #link https://wiki.opnfv.org/download/attachments/6824933/ci_evolution_v2.png?version=1&modificationDate=1475589234060&api=v2
14:28:14 <fdegir> #info the balls in boxes are candidates and the colors are the verdicts taken by merge/daily/weekly jobs
14:28:22 <ChrisPriceAB> #info morgan_orange outlines the importance of this work for the community to begin to leverage our resources more efficiently and do "real CI"
14:33:26 <rpaik> #info fdegir describes similar framework for testing and this is being discussed with Functest/Yardstick teams
14:37:44 <ChrisPriceAB> #topic #info morgan_orange outlines the benefits of test promotion as a tool to facilitate smoothly onboarding test cases into the test frameworks
14:37:50 <ChrisPriceAB> #undo
14:37:50 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2f380d0>
14:37:56 <ChrisPriceAB> #info morgan_orange outlines the benefits of test promotion as a tool to facilitate smoothly onboarding test cases into the test frameworks
14:38:21 <fdegir> #info the main idea is to apply basic principles for test projects as well by making sure we use the versions of test frameworks/cases that are proven to be working.
14:38:37 <fdegir> #info  rather than always using latest versions of test fw/cases.
14:39:55 <ChrisPriceAB> #topic OPNFV October Board meeting
14:40:17 <ChrisPriceAB> #link https://wiki.opnfv.org/download/attachments/2925933/tsc%20board%20update%20october%206th.pdf?version=2&modificationDate=1475591656378&api=v2 latest draft
14:43:06 <rpaik> #info topics to be covered during the October 6th board meeting are Colorado/Danube releases, updates from the ODL Summit, and joint Board-TSC meeting in Barcelona
14:45:18 <rpaik> #info ChrisPriceAB welcomes comments offline
14:45:32 <ChrisPriceAB> #topic Colorado + Danube planning and activities
14:45:34 <bryan_att> Why have "an arch"  when we can support so many?
14:45:49 <ChrisPriceAB> lol
14:46:25 <ChrisPriceAB> #info dmcbride describes that once opening the project we have over 30 projects, including new projects intending to participate in Danube.
14:46:34 <ChrisPriceAB> #undo
14:46:34 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2e91a90>
14:46:45 <ChrisPriceAB> #info dmcbride describes that once opening Danube for participation we have over 30 projects, including new projects intending to participate in Danube.
14:47:27 <ChrisPriceAB> #info dmcbride outlines that release planning is ongoing for Danube and a new template will be presented for discussion on the upcoming release meeting
14:47:51 <rpaik> #link https://wiki.opnfv.org/display/SWREL/Danube+Milestone+Description Danube Milestone page
14:47:58 <hongbo> I can reach out to the Daisy
14:48:08 <hongbo> team
14:48:45 <rpaik> #info ChrisPriceAB adds that new project proposals need to come forward in the next few weeks
14:48:55 <dmcbride> #link https://wiki.opnfv.org/display/SWREL/Projects+Intending+to+Participate+in+the+Danube+Release
14:49:24 <dmcbride> #link https://wiki.opnfv.org/display/DEV/Project+Inclusion+in+OPNFV+Release
14:49:51 <ChrisPriceAB> #topic OpenStack-Barcelona plans
14:50:33 <ChrisPriceAB> #info brandon outlines the activities upcoming on OpenStack barcelona
14:50:44 <rpaik> #info Brandon notes that Doctor project will be featured during the keynote on Day 1
14:51:32 * ChrisPriceAB thinks that sounds complicated!!! (very telco)
14:51:56 <rpaik> #info OPNFV will also be featured in 7 sessions
14:52:16 <ChrisPriceAB> #info brandon further outlines OPNFV related topics and discussion occurring during the summit.
14:53:00 <ChrisPriceAB> #info there will be an OPNFV booth at the summit, we will be showing demo's at the booth including the Doctor project keynote demo.
14:53:20 <bryan_att> We had a good Telco/NFV track at OpenStack Days Seattle last Friday. Pretty well attended for a local event, some good presentations. The VES presentation I gave is shown in the table at https://wiki.opnfv.org/display/ves
14:53:34 <fdegir> we also have a talk about 3rd party ci: https://www.openstack.org/summit/barcelona-2016/summit-schedule/events/15253/the-benefits-of-e2e-integration-between-open-source-communities-using-3rd-party-ci
14:53:57 <bryan_att> We will also be doing a Gluon demo in the demo theater at OpenStack Barcelona
14:54:03 <rpaik> #info OPNFV will also have a booth in the Expo area with demos and there will be a sign-up for booth volunteers
14:54:20 <ChrisPriceAB> #info brandon asks for people to sign up for speanding time at the booth in support of OPNFV
14:54:25 <bryan_att> And a VES demo at the AT&T booth.
14:54:32 <ChrisPriceAB> #info an evening event will be prepared, not yet settled
14:54:55 <rprakash> #info we are planning for Domino Demo
14:55:08 <rpaik> #info there will also be meetings for the end-user advisory group & board
14:55:10 <ChrisPriceAB> #info Brandon reminds us that there will be a face to face board meeting, TSC members are invitade to atend
14:56:19 <ChrisPriceAB> #action rpaik and chrispriceab to set up a wiki to collect OPNFV related OpenStack summit activity.
14:56:32 <ChrisPriceAB> #topic AoB
14:57:23 <ChrisPriceAB> #info frankbrockners raises concerns that the election tool e-mail is not arriving at every-ones inbox
14:58:08 <ChrisPriceAB> #info rpaik will ensure all TSC members are able to vote and can work directly with each member to resolve it.
14:59:00 <ChrisPriceAB> #info ulik adds that there is difficulty in ensuring everyone only votes once.
15:00:24 <ChrisPriceAB> #endmeeting