15:00:33 <fdegir> #startmeeting Infra WG Weekly Meeting
15:00:33 <collabot> Meeting started Wed Oct  5 15:00:33 2016 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:33 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:33 <collabot> The meeting name has been set to 'infra_wg_weekly_meeting'
15:01:14 <fdegir> #topic Roll Call
15:01:20 <rpaik> #info Ray Paik
15:01:24 <jmorgan1> #info Jack Morgan
15:01:28 <ulik> #info Uli
15:01:33 <bramwelt> #info Trevor Bramwell
15:01:36 <fdegir> #info Fatih Degirmenci
15:02:15 <fdegir> #link https://wiki.opnfv.org/display/INF/Infra+Working+Group#InfraWorkingGroup-Agenda
15:03:18 <fdegir> #topic Bitergia Dashboads
15:04:14 <fdegir> #info Jesus is showing Jenkins Bitergia Dashboard
15:04:23 <fdegir> #link https://opnfv.biterg.io/app/kibana#/dashboard/JenkinsOPNFV
15:10:20 <fdegir> #info The idea with the Bitergia Jenkins Dashboard is to extract/collect statistics from OPNFV Jenkins
15:11:12 <dfarrell07> fdegir: just got back from my talk, on cal
15:11:13 <dfarrell07> call*
15:11:14 <fdegir> #info The information presented on the dashboard includes the use of community resources, jobs, scenarios, job success/failure rate and so on
15:11:20 <fdegir> dfarrell07: great
15:11:55 <fdegir> #info The OPNFV Community is requested to take a look/browse through the dashboard and provide feedback regarding issues or additional information
15:13:41 <fdegir> #topic Tracking upstream contributions with the KISS file
15:14:03 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/21057/2/UPSTREAM
15:14:39 <fdegir> #info The proposal by aricg- lists contributions to upstream projects
15:17:27 <bryan_att> this should be even simpler. just a file, per project if needed, that lists the projects and ids of OPNFV members that are contributing to them. Then the tracking tools can just crawl the available datasources.
15:17:35 <fdegir> #info The contributions to track include contributions to upstream repos, bugzilla, launchpad
15:17:52 <bryan_att> #info this should be even simpler. just a file, per project if needed, that lists the projects and ids of OPNFV members that are contributing to them. Then the tracking tools can just crawl the available datasources.
15:17:55 <fdegir> #info The question is if we should have cross referencing by including one of the systems or list all of them
15:20:29 <fdegir> #info bryan_att mentions that Stackalytics shows this type of information and if the people contributing to OpenStack is listed in the file, the contribution infromation can be extracted from Stackalytics
15:21:20 <fdegir> #info More granular approach is required
15:21:55 <fdegir> #info OPNFV works with multiple different upstream communities and it is needed to collect/present this information
15:27:34 <fdegir> #action rpaik to discuss how the upstream contributions can be tracked with/for different upstream/OPNFV projects
15:28:28 <fdegir> #topic ODL -> OPNFV, time to get things moving
15:29:08 <dfarrell07> http://slides.com/dfarrell07/odl-delivery-pipelines#
15:29:24 <fdegir> #info dfarrell07 talks about ODL Delivery Pipelines
15:29:36 <fdegir> #link http://slides.com/dfarrell07/odl-delivery-pipelines#
15:30:44 <fdegir> #info ODL produces artifacts and corresponding CM pieces
15:30:58 <fdegir> #info Artifacts include rpms, debs, and so on
15:32:18 <fdegir> #info ODL has been working on automating pieces of their CI/CD pipelines to reduce the human interaction
15:34:45 <fdegir> #info ODL Ansible playbooks and Puppet manifests are available
15:35:22 <fdegir> #info Docker images and Vagrant boxes are produced as well
15:36:10 <fdegir> #info With this, it makes 3 layers
15:36:41 <fdegir> #info Package layer, CM layer, Pre-configured images
15:38:03 <fdegir> #info Compass and Joid are in talks with ODL, focusing on ansible roles and deb packages
15:51:50 <fdegir> #info dfarrell07 started writing proposal for OPNFV Internship to get ODL -> OPNFV work going on
15:52:13 <fdegir> #action dfarrell07 to post internship project proposal to OPNFV Wiki
15:52:42 <fdegir> #link https://wiki.opnfv.org/display/DEV/Intern-projects-page
15:54:18 <fdegir> #topic OPNFV Infra F2F Session(s) during OpenStack Summit 2016 Barcelona
15:54:27 <fdegir> #link https://wiki.opnfv.org/display/INF/OpenStack+Summit+2016+Barcelona+-+F2F+Session+Topics
16:01:57 <fdegir> #endmeeting