15:11:50 <uli-k> #startmeeting INFRA Working group weekly call
15:11:50 <collabot`> Meeting started Wed Nov  2 15:11:50 2016 UTC.  The chair is uli-k. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:11:50 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:11:50 <collabot`> The meeting name has been set to 'infra_working_group_weekly_call'
15:11:51 <ljlamers> vsperf is on 915183117
15:12:00 <ljlamers> I am on that call/GTM
15:12:16 <jmorgan1> rpaik: i think we should put the schedule on the GTM wiki page in meetings space
15:12:21 <ljlamers> Infra GTM says waiting for organizer
15:12:46 <jmorgan1> rpaik: of who is using what time/GTM account
15:12:58 <uli-k> INFRA Guys please join https://global.gotomeeting.com/join/146311485
15:13:04 <rpaik> this one is my GTM account
15:13:09 <rpaik> for this week only :-)
15:13:19 <ljlamers> Well this week is a mess since UTC moved of DST so they calls staying on UTC moved up an hour
15:13:31 <ljlamers> had a clash at 07:00 PDT too
15:13:41 <jmorgan1> thanks rpaik
15:14:47 <ljlamers> That has the same dial in phone number as vsperf is using
15:15:10 <jmorgan1> ljlamers: ok, thanks
15:18:06 <uli-k> #topic roll call
15:18:18 <bramwelt> #info Trevor Bramwell
15:18:25 <ljlamers> #info Larry Lamers
15:18:30 <rpaik> #info Ray Paik
15:18:31 <mbeierl> #info Mark Beierl
15:18:37 <jmorgan1> #info Jack Morgan
15:19:14 <uli-k> #chair jmorgan1
15:19:14 <collabot`> Current chairs: jmorgan1 uli-k
15:19:16 <HelenYao_> #info HelenYao_
15:19:41 <Julien-zte> #info Julien
15:19:50 <Julien-zte> it tooks us too much time
15:19:56 <lylavoie> #info Lincoln Lavoie
15:23:18 <Julien-zte> #link https://etherpad.opnfv.org/p/barcelona-infra-f2f
15:24:15 <uli-k> #topic Scenario Descriptor File
15:25:28 <uli-k> #link https://gerrit.opnfv.org/gerrit/#/c/23725/2/config/shark.yaml
15:27:55 <uli-k> #info Jack introduces how the scenario files will work
15:28:09 <uli-k> #info People are encouraged to comment using gerrit
15:29:15 <mbeierl> sorry, folks - conflict just came up and need to drop.
15:32:59 <uli-k> #info Bryan notes that the deployment might need to create some additional characterstics during deployment which need to be available to applications/users
15:33:17 <uli-k> #info uli-k notes that that should be saved at a different place.
15:34:00 <uli-k> #topic POD descriptor file
15:34:27 <uli-k> #link https://gerrit.opnfv.org/gerrit/#/c/23727/
15:35:41 <uli-k> #info no questions. but please go on commenting on gerrit
15:36:25 <Julien-zte> jmorgan1, would you have some time to submit a new patch for this review
15:37:11 <uli-k> #info more examples are needed e.g. for remote management via libvirt
15:38:30 <bryan_att> #info The intent (what should be deployed) is indicated by this file. We also need the resulting config items that were not known prior to deployment, e.g, the generated openstack admin password, somewhere in a file that is the same across deployments. A goal would be that anything which is a choice and *can* be fixed pre-deploy, is pre-defined and made
15:38:30 <bryan_att> easily available for test runners, post-install scripts, etc to discover easily.
15:38:34 <uli-k> #topic Danube release plan
15:39:15 <bryan_att> #info ... easily available for test runners, post-install scripts, etc to discover easily. The rest needs to be disclosed through some other file, e.g. admin-openrc in a common place e.g. /opt/opnfv
15:39:28 <jmorgan1> Julien-zte: once we get feedback, we will submit a new patch and revert this one
15:39:43 <uli-k> #info fdegir created a start for the Danube release plan at https://wiki.opnfv.org/display/INF/Danube+Release+Plan
15:40:49 <bryan_att> #info is "CI Evolution" going to include the gated promotion idea talked about earlier?
15:40:59 <uli-k> #action jmorgan1 and uli-k to update the release plan for Pharos and Octopus
15:43:38 <bramwelt> #link https://git.opnfv.org/cgit/releng/tree/jjb/fuel/fuel-verify-jobs.yml
15:43:47 <uli-k> #action fdegir to document how to control the commit gating
15:45:02 <bramwelt> bryan_att: Please let me know if that's not clear and I'll do my best to clarify.
15:45:11 <uli-k> #topic Review  Intern Project: ODL->OPNFV Integration
15:46:08 <rpaik> #info intern for the ODL->OPNFV integration project should be able to start next week
15:46:25 <rpaik> #info she will be working ~20hours/week for 6 months
15:46:56 <uli-k> #topic PODs by Daisy4nfv installer
15:49:41 <uli-k> #info julien informs that the PODs are available, work is ongoing about CI integration of the PODs
15:50:52 <uli-k> #action julien-zte to provide information which 2 PODs are provided
15:50:55 <Julien-zte> #info I will give the update from the team
15:51:15 <uli-k> #topic action items
15:51:16 <Julien-zte> ok
15:52:28 <uli-k> rpaik reported status of second AI (opstream contributions) and will start a pilot as discussed in the board
15:53:06 <bryan_att> bramwelt: perhaps I should clarify my ask first. For the file you posted, it's unclear to me how I would set/change it and use it (e.g. configure gerrit so it's invoked as part of a commit)
15:54:05 <bramwelt> bryan_att: We'll need to work on applying the same JJB format to other projects
15:54:24 <bryan_att> bramwelt: my ask is generally how do I invoke tools that do a QA assessment on various types of files, e.g. docs, code, and invoke any tests that have been defined for those types of files.
15:55:36 <bryan_att> bramwelt: e.g. for code, security and code quality scans. for docs, syntax checks as done for RST files
15:56:13 <bryan_att> bramwelt: then for code, specific unit tests that have been defined somehow (and how do we define them)
15:56:53 <uli-k> #info ZTE POD will run 2 Fuel scenarios: nosdn-ovs and kvm.
15:57:14 <uli-k> #info close the AI.
15:59:31 <uli-k> #info AI of scenario handling can be closed.
16:01:03 <uli-k> #info AI on scenario/POD mapping is ongoing
16:02:05 <uli-k> #endmeeting