16:00:24 <uli-k> #startmeeting INFRA Working group weekly meeting
16:00:24 <collabot`> Meeting started Wed Nov  9 16:00:24 2016 UTC.  The chair is uli-k. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:24 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:24 <collabot`> The meeting name has been set to 'infra_working_group_weekly_meeting'
16:00:28 <aricg> #info Aric Gardner
16:01:05 <uli-k> Hi everybody, I can't start the GTM, some proxy issues.....
16:01:18 <hw_wutianwei> info wu tianwei
16:02:11 <Kingpoo> info Jingbo Hao
16:02:34 <uli-k> aricg or jmorgan1, can you open the GTM?
16:02:55 <hw_wutianwei> #info wu tianwei
16:03:21 <jmorgan1> #info Jack Morgan
16:03:48 <jose_lausuch> #info Jose Lausuch
16:04:16 <uli-k> jmorgan1, can you open the GTM? I am blocked by proxy to login
16:04:21 <bramwelt> #info Trevor Bramwell
16:04:30 <jmorgan1> uli-k: just a sec
16:04:59 <aimeeu> #info Aimee Ukasick
16:05:10 <dmcbride> #info David McBride
16:08:10 <uli-k> hw_wutianwei, are you on gotomeeting?
16:08:19 <hw_wutianwei> I can not open the GTM either.
16:08:35 <uli-k> You should be able to connect now.
16:09:19 <uli-k> #link https://global.gotomeeting.com/join/773318405
16:09:56 <hw_wutianwei> may beMy network is not good,  so I can not join the gotomeeting.
16:10:24 <uli-k> OK. Jack explained shortly. I can share some information with you tomorrow.
16:10:28 <hw_wutianwei> I will discuss in the channel. is this ok?
16:10:35 <jmorgan1> sure
16:11:56 <uli-k> OK let's come back to the topic later (or we have a discussion tomorrow)
16:12:08 <uli-k> #topic Scenario based POD allocation
16:12:37 <hw_wutianwei> let's  come back to the topic later
16:18:39 <dmcbride> Need to step away for a few minutes
16:18:44 <jmorgan1> dmcbride: no problem
16:19:01 <bramwelt> DanSmithEricsson: You audio is extremely faint. :(
16:19:17 <jmorgan1> #info ChrisPB supports the idea
16:19:32 <DanSmithEricsson> ok..  i think we need some alignment here
16:19:40 <DanSmithEricsson> cause what you guys are talking about does not come into play in the approach we are talking
16:19:45 <DanSmithEricsson> we are not dealing with anything at the OS level
16:19:54 <jmorgan1> #info Jonas reminds us that this was tried in Arno and the issue before was clean up scripts were needed and sometimes they failed
16:19:58 <DanSmithEricsson> the approhac for Dynamic POD means that
16:20:04 <DanSmithEricsson> this discussion in now moot
16:21:16 <DanSmithEricsson> sure.. we have a slide
16:21:39 <DanSmithEricsson> we have slides that we showed a while back and Fatih has expanded on them
16:21:43 <uli-k> #topic Scenarios and common config files
16:21:50 <jmorgan1> #info Jack suggests we schedule F2F time at Plugfest/hackfest
16:23:28 <jmorgan1> #info Uli share some slides to discuss the problem and reason for proposal
16:27:39 <jmorgan1> #info Jonas explains that installers already have such a file but those are not common
16:28:33 <jmorgan1> #info Jonas also explains that for a new feature the installer specific file needs to be updated as well
16:30:20 <DanSmithEricsson> it was a bit unclear that last statement.. Jack - did you say a "File with all Installer parameters listed across the board" and then we slice it away for each installer
16:30:30 <DanSmithEricsson> or only for "Feature parameters" that are introduced?
16:30:31 <jmorgan1> #info Uli mentions that the scenario config file is still a WIP and needs to have missing options added in
16:31:19 <jmorgan1> DanSmithEricsson: i just meant that we create a template file which would have all possible supported feature for opnfv
16:31:26 <DanSmithEricsson> cooo
16:31:34 <DanSmithEricsson> cool*..
16:31:52 <jmorgan1> DanSmithEricsson: then installers might take this file and adapt it to their installer - including just those features it supports
16:33:02 <DanSmithEricsson> ok.. so you want a Umbrella that lists "all available features in OPNFV" (good - i like that for a bunch of reasons) - then from there, an "installer" can utline a subset of that list (what they support).. from there, that supportted list then outlines what "scenario combinations" (which are comprised of configs and features" can be "run" on a given setup?
16:33:11 <DanSmithEricsson> (or something like that? ) - i like it :)
16:40:28 <DanSmithEricsson> but this Piece is going to be read from a "ORDER" in the Bookig tool
16:40:37 <DanSmithEricsson> and then you will have an inventory across your Distributed Lab setup
16:40:56 <DanSmithEricsson> so when you "request a scneario" for test and the scneario is of type "ARM" then it will only ordre that to a POD that is able to support hat
16:40:56 <DanSmithEricsson> that
16:42:06 <dmcbride> I'm back
16:44:46 <DanSmithEricsson> Sorry - the voice is really bad..
16:44:59 <DanSmithEricsson> but my question is that by making a SCENARIO description file
16:45:06 <DanSmithEricsson> are we saying that this assumes CI/CD runs
16:45:18 <DanSmithEricsson> and thus you "must use CI/CD with a scenario"
16:45:19 <DanSmithEricsson> ?
16:45:55 <DanSmithEricsson> ok..  so that is fine
16:46:02 <DanSmithEricsson> we are saying that scenario implicity means a CI/CD run
16:53:26 <jmorgan1> #info lively discussion followed covering several details on implementaions
16:53:59 <jmorgan1> #action Jack to collect feedback on the patch and include them
16:55:28 <jmorgan1> #info several people mentioned their concern over the file name
16:55:57 <jmorgan1> #info need to find some combination of features to provide some hint to the scenario contents
16:57:44 <uli-k> #topic Use artifacts to update WIKI of Pharos Labs
16:59:16 <aricg> I got disconnected
17:00:34 <uli-k> #info aricg proposes to just use direct links instead since there are many problems with the plugin
17:01:03 <uli-k> agree to discuss that on the hackfest
17:01:12 * jmorgan1 leaves the building
17:02:11 <uli-k> #endmeeting