14:01:01 <hongbo_tian> #startmeeting dovetail weekly meeting
14:01:01 <collabot`> Meeting started Fri Nov 11 14:01:01 2016 UTC.  The chair is hongbo_tian. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:01 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:01 <collabot`> The meeting name has been set to 'dovetail_weekly_meeting'
14:01:28 <hongbo_tian> #info Hongbo
14:03:41 <hongbo_tian> #topic approval of the minutes
14:07:59 <hongbo_tian> #chair  ChrisPriceAB
14:07:59 <collabot`> Current chairs: ChrisPriceAB hongbo_tian
14:07:59 * ChrisPriceAB can be made chair
14:08:11 <ChrisPriceAB> #topic Plugfest planning
14:08:57 <ChrisPriceAB> #info Hongbo outlines the objectives of the dovetail team at the Plugfest
14:09:45 <ChrisPriceAB> #info The dovetail tools dhoule be able to; run against a VIM&VNFi, verify the results, capture and record the evaluation.
14:10:07 <ChrisPriceAB> #info Leo asks if the objectives may be to high level.
14:10:57 <ChrisPriceAB> #info Hongbo suggest we ask participating teams if they would be willing to run the dovetail tests at the event.
14:11:44 <ChrisPriceAB> #action Leo to check with the plugfest team to identify who will allow dovetail testing at the event
14:12:14 <ChrisPriceAB> #info Wenjing asks if we have a list of test cases that we would run.
14:12:42 <ChrisPriceAB> #info Hongbo answers that all functest and yardstick test cases should be able to be run by the tool.
14:13:23 <bryan_att> #info Bryan Sullivan
14:13:36 <ChrisPriceAB> #info Wenjong asks how many tests, an which test areas are to be considered for the dovetail test suite at the plugfest.
14:17:21 <bryan_att> #info different tests have various levels of functional verification completeness - we need to find those tests that set the bar we are looking for
14:18:32 <bryan_att> #info anyone proposing that a test shoudl qualify for dovetail (e.g. per the JIRA approach I described last week) should explain the level of verification supported by the test. but we also need to set some expectations in the dovetail project.
14:20:14 <bryan_att> #info on that point, I did not see any comment to the Kanban board I setup last time as noted on the meeting: https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=147&projectKey=DOVETAIL&selectedIssue=DOVETAIL-53
14:20:33 <ChrisPriceAB> Agree Bryan, that should fit into the process of test case promotion, where "compliance qualified" might be the highest level.
14:20:43 <bryan_att> #info that was intended to help give us a process to move from the wiki to JIRA for assessment of tests proposed for the dovetail suite
14:20:58 <ChrisPriceAB> That is an activity of the testing WG for Danube and we should have our rquirements and expectations captured in that work.
14:21:08 <ChrisPriceAB> #chair bryan_att
14:21:08 <collabot`> Current chairs: ChrisPriceAB bryan_att hongbo_tian
14:21:31 <ChrisPriceAB> #topic DoveTail scope, blueprint and methodology
14:23:01 <bryan_att> #info if the group agrees, we can proceed to add more tests from the wiki, but I would like to set some expectations on the description of the tests, e.g. per the point we just talked about - how does (or should) the test actually verify the function it's focused on? we need to define a template for tests submitted thru JIRA - and not just an outline, but
14:23:01 <bryan_att> specific expectations for how the proposal meets dovetail's strategy for functional verification
14:29:35 <bryan_att> #info IMO the focus should be on verifying the features that the SUT claims to support. In that case the scenario is irrelevant, except that the SUT provider will declare what features are included in the SUT.
14:35:24 <ChrisPriceAB> #agree the team agrees not to tie testing activities to "scenarios" but to associate testing with "feature sets" supported by OPNFV.
14:37:29 <ChrisPriceAB> #info bryan_att cautions against testing interfaces, unless we intend to validate existing implementations form our source comunities.
14:38:06 <ChrisPriceAB> #info wenjing answers that we intend to validate against inhereted/implemented interfaces.
14:41:33 <bryan_att> #info I suggest for the current release we do not focus on interfaces above the VIM, rather focus e.g. on the portability of the VNF packages as deployable through upper-MANO stack components. If the upper functions/interfaces crystalize consistently then we could focus on them for the future. But for D and probably E, we will not be ready to usefully
14:41:33 <bryan_att> validate any interfaces above the VIM, except where represented as data objects.
14:42:03 <bryan_att> #info ... validate any interfaces above the VIM, except where represented as data objects.
14:45:13 <ChrisPriceAB> end rant'
14:52:05 <ChrisPriceAB> #info bryan_att indicates that we need to work with the project PTL's and test projects to establish a plan for how we will test features in OPNFV.
14:59:48 <ChrisPriceAB> #info wenjing will share his presentation on methodology and will present it on the C&C call.
15:00:38 <ChrisPriceAB> #info hongbo asks about needing to change the time of the cal, to be taken to the lists
15:00:46 <ChrisPriceAB> #undo
15:00:46 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2286fd0>
15:00:51 <ChrisPriceAB> #topic AoB
15:00:54 <ChrisPriceAB> #info hongbo asks about needing to change the time of the cal, to be taken to the lists
15:00:59 <ChrisPriceAB> #endmeeting