15:00:33 <tallgren> #startmeeting Weekly OPNFV TSC meeting
15:00:33 <collabot`> Meeting started Tue Nov 15 15:00:33 2016 UTC.  The chair is tallgren. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:33 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:33 <collabot`> The meeting name has been set to 'weekly_opnfv_tsc_meeting'
15:01:08 <ChrisPriceAB> add dmcbride
15:01:17 <tallgren> #chair dmcbride
15:01:17 <collabot`> Current chairs: dmcbride tallgren
15:01:32 <jmorgan1> #info Jack Morgan
15:01:41 <bin_> #info Bin Hu
15:01:57 <uli-k> #info Uli Kleber
15:02:04 <tallgren> #info Tapio Tallgren
15:02:36 <dmcbride> #info David McBride
15:02:41 <tallgren> #chair uli-k
15:02:41 <collabot`> Current chairs: dmcbride tallgren uli-k
15:02:53 <[1]JonasB> #info Jonas Bjurel (Stand in for Fatih)
15:03:09 <morgan_orange> #info Moragn Richomme
15:03:13 <rpaik> no quorum yet
15:03:17 <XavierCosta> #info XavierCosta
15:03:24 <edgarstp> #info Edgar StPierre
15:03:36 <rpaik> we need a few more for quorum
15:03:41 <trevor_intel_> #info Trevor Cooper for Brian Skerry
15:03:58 <bryan_att> #info Bryan Sullivan
15:04:07 <trozet> #info Tim Rozet (proxy for dave neary)
15:04:20 <rpaik> we now have a quorum
15:04:38 <rpaik> also no comment/feedback on previous minutes
15:04:40 <Julien-zte> #info Julien
15:04:59 <tallgren> #topic Approval of previous meeting minutes
15:05:00 <ChrisPriceAB> thanks [1]JonasB
15:05:16 <uli-k> #topic Agenda bashing
15:06:08 <timirnich> #info Tim Irnich
15:06:14 <uli-k> #info proposal to add discussion on meeting overlaps
15:06:59 <uli-k> #info tallgren informs (again) that Colorado 2.0 got released.
15:07:28 <uli-k> #info tallgren clarifies also the download page is in place now.
15:07:29 <dmcbride> #link https://www.opnfv.org/software/download
15:07:51 <uli-k> #topic Goals & vision for the Danube release
15:08:43 <dmcbride> #info morgan_orange says that he received no feedback on his presentation
15:08:55 <dmcbride> #info presentation is online
15:09:29 * bryan_att needs the link
15:09:40 <dmcbride> #info morgan_orange asks how should we make a decision about "CI Evolution" project?
15:09:59 <jose_lausuch> https://wiki.opnfv.org/display/meetings/TSC?preview=%2F2925933%2F8684550%2FBuilding+a+TSC+vision+for+Danube.pptx
15:09:59 <uli-k> #link https://wiki.opnfv.org/download/attachments/2925933/Building%20a%20TSC%20vision%20for%20Danube.pptx?version=1&modificationDate=1478612403000&api=v2
15:10:18 * uli-k (one of the two should work) ;-)
15:11:39 <bryan_att> I think the last comment was that we should have a list discussion. I didn't agree with the assertion that we are not producing a platform for example.
15:12:17 <tallgren> #link https://specs.openstack.org/openstack/nova-specs/priorities/newton-priorities.html
15:12:26 <tallgren> This is what OpenStack is doing
15:13:04 <bryan_att> #info IMO the deck also adressess multiple topics and thus may have been hard to have a succinct response to.
15:13:40 <dmcbride> #info morgan_orange says that having a vote will put weight behind a request to the board for resources
15:13:47 <bryan_att> #info e.g. re CI evolution I fully support that, but let's address that separately from the other concerns expressed in the deck.
15:15:01 <bryan_att> #info I think that projects that need resource should ask for them directly
15:18:14 <StevenW> Do we have good visibility to actual resource availability in the current dashboards?
15:18:45 <bryan_att> #info If CI evolution needs resources to be realized then let's focus on that specifically and not widen to assess priority across projects with the presumption that this would result in more resources going to "top priority" projects. I don't think that would have the intended effect or a useful one overall.
15:21:47 <bryan_att> #info I agree, we are producing several scenarios that represent options that end-users can pick, as part of an overall set of platform options.
15:22:06 <dmcbride> #info Julien-zte asks how we define our "reference platform"
15:22:28 <dmcbride> #info morgan_orange asserts that we have multiple reference platforms
15:22:54 <bryan_att> #info Thus not a single/unified platform but a flexible toolbox of tested platform components from which a platform can be created. This represents a platform, even if there isn't a single installable product produced by OPNFV.
15:24:02 <bryan_att> #info I'm all for setting expectations that new scenarios come with dedicated resources, including people and lab resources.
15:24:12 <StevenW> The platform in that sense is a set of test suites enforcing some end user use cases which any platform implementation must be able to implement
15:24:40 <Julien-zte> when introduce MANO, there will be more scenarios in the future and more CI resources consumed
15:27:16 <bryan_att> #info IMO scenarios are in some cases a "necessary evil" at this point (due to simple incompatibility) and in others a choice of a sub-community (e.g. Open-O). Both cases while "valid" do not come for free; thus we need explicit resources to support them, provided by the scenario supporters.
15:28:11 <morgan_orange> #link https://etherpad.opnfv.org/p/TestCommunityGoals
15:29:05 <dmcbride> #info other groups (e.g. MANO) should also develop a list of priorities
15:29:10 <bryan_att> #info a wiki page in which people input their vision/priorities makes sense to me
15:30:52 <bryan_att> #info I just caution against codifying that vision/priority and using it in any restrictive way. We can and should address the resourcing issue separately.
15:32:23 <morgan_orange> #action morgan_orange send mail + create etherpad on Danube, E, ..priorities to the community
15:32:37 <ChrisPriceAB> +1
15:32:45 <morgan_orange> bryan_att: for me the summary could be a wiki page as the Openstack page
15:33:00 <dmcbride> #info jmorgan1 suggests that every WG should create a list of priorities, then those lists can be integrated into a master list
15:34:36 <bryan_att> #info morgan_orange that looks like the result of some assessment of the collected vision/priorities. So it's at least a couple of steps down the road (collect input, assess input, create vision/priority statement, agree upon that statement, publish it)
15:35:36 <uli-k> #agree Every project and every working group should create a list of priorities.
15:36:24 <StevenW> It might be more useful to understand how well the project activities and priorities  align with end user requirements
15:38:08 <ChrisPriceAB> Jmorgan1, nice dodge!!!
15:38:20 <uli-k> #action tallgren will start a wiki page
15:38:41 <uli-k> #topic •Colorado + Danube planning and activities
15:40:06 <tallgren> #info Discussion is about how the OpenStack and OPNFV releases will match.
15:40:45 <tallgren> #info OpenStack Ocate will have a shorter release and will be ainly maintenance release
15:41:00 <tallgren> #undo
15:41:00 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x227efd0>
15:41:06 <tallgren> #info OpenStack Ocate will have a shorter release and will be mainly maintenance release
15:41:59 <tallgren> #info dmcbride has sent out a questionnaire to all PTLs about Ocata plan
15:43:18 <tallgren> #info Proposal is: Danube will be based on Newton and E-release will be based on Pike. Ocata would be skipped
15:45:42 <StevenW> Is  an OpenStack update the major feature content change in Danube? I would have thought the MANO related projects e.g. Open O and Open Baton  would be integrating more functionality at this time, and  these seem more likely to be on Newton?
15:47:19 <ChrisPriceAB> hmm, openstack is back on cycle for the P release right
15:47:32 <ChrisPriceAB> ocata is shorter then pike is longer
15:47:46 <ChrisPriceAB> so it is only our e-release that has a deviation
15:47:53 <ChrisPriceAB> why would be shuffle due to that?
15:47:53 <tallgren> Yes
15:48:15 <StevenW> Do we have a coherent view of the release cycles of all our upstream communities somewhere on the Wiki?
15:49:00 <tallgren> @StevenW: there should be such a page
15:49:00 <collabot`> tallgren: Error: "StevenW:" is not a valid command.
15:51:19 <tallgren> #link https://wiki.opnfv.org/display/COM/Release+Dates
15:51:37 <tallgren> Does not seem to be up-to-date
15:51:55 <tallgren> Last update on March 24, 2016
15:52:01 <morgan_orange> #link http://ircbot.wl.linuxfoundation.org/meetings/opnfv-functest/2016/opnfv-functest.2016-11-15-08.01.html
15:52:41 <StevenW> We have some new upstream communities to add  as well as the dates to revise
15:53:16 <morgan_orange> #info Functest agreed that Newton client will be integrated for Danube
15:53:29 <jose_lausuch> we voted that we go for Newton only. We could support ocata if it's agreed, but it would need last minute changes and lack of stability before the release. That is not desired by us.
15:53:38 <morgan_orange> #link https://wiki.opnfv.org/display/functest/OpenStack+python+clients
15:53:55 <dmcbride> #action dmcbride update upstream roadmap pagae
15:54:07 <dmcbride> #link https://wiki.opnfv.org/display/COM/Release+Dates
15:55:17 <dmcbride> #info jose_lausuch says that functest is committed to using OS Newton.   Have not planned to support other versions within the Danube time frame.
15:55:27 <jose_lausuch> 2 options: 1) run feature test in virtual environemnts 2) run feature test in different docker containers with different python client versions
15:56:59 <uli-k> #topic meeting schedule
15:57:04 <dmcbride> jose_lausuch: which vote are you referring to?  Who voted?
15:57:19 <morgan_orange> dmcbride: vote in Functest weekly meeting this morning
15:57:28 <morgan_orange> dmcbride: I put the link in the minutes
15:57:41 <dmcbride> morgan_orange: ok - thanks
15:58:01 <jose_lausuch> dmcbride: yes, we agreed on Newton and I filled the survey after that decission from the project members
15:58:26 <jose_lausuch> dmcbride: let's follow up in the release meeting
15:58:37 <dmcbride> ok
15:59:23 <bryan_att> #info morgan_orange it would be good for the Functest team to send out an outlook calendar invite as I didn't have this on my calendar and would like to have joined (if I had been up at 4AM)
15:59:58 <jose_lausuch> bryan_att: I sent an invitation to the mailing list
16:00:23 <bryan_att> #info a single always-available meeting per account would ensure that at least meetings are never cancelled by someone starting the next
16:00:42 <bryan_att> jose_lausuch: to which list?
16:00:47 <jose_lausuch> tech list
16:01:39 * bryan_att didn't receive it. oh well.
16:01:53 <uli-k> #action dmcbride to work on a proposal to resolve the meeting schedule issue
16:02:05 <jose_lausuch> bryan_att: just forwarded it
16:02:27 <tallgren> #endmeeting