14:58:29 <tallgren> #startmeeting Weekly TSC meeting
14:58:29 <collabot`> Meeting started Tue Nov 22 14:58:29 2016 UTC.  The chair is tallgren. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:58:29 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:58:29 <collabot`> The meeting name has been set to 'weekly_tsc_meeting'
14:58:37 <tallgren> #chair rpaik
14:58:37 <collabot`> Current chairs: rpaik tallgren
14:58:38 <ebrjohn> #info Brady Johnson
14:58:45 <tallgren> #info Tapio Tallgren
14:58:47 <JonasArndt> #info Jonas Arndt
14:58:49 <jmorgan1> #info Jack Morgan
14:58:54 <frankbrockners> #info Frank Brockners
14:59:26 <fdegir> #info Fatih Degirmenci
14:59:36 <rossella__> #info Rossella Sblendido
15:00:11 <uli-k> #info Uli Kleber
15:00:41 <bjskerry> #info Brian Skerry
15:01:00 <cgoncalves> #info Carlos Goncalves (proxy for Xavier Costa)
15:01:09 <bin_> #info Bin Hu
15:01:12 <bryan_att> #info Bryan Sullivan
15:01:17 <tallgren> #info uli-k
15:01:53 <tallgren> #chair uli-k
15:01:53 <collabot`> Current chairs: rpaik tallgren uli-k
15:01:54 <rpaik> we have a quorum
15:02:42 <rpaik> #topic approval of previous minutes
15:02:55 <rpaik> #info no feedback on the minutes so minutes approved
15:03:03 <rpaik> #topic agenda bashing
15:04:00 <edgarstp> #info Edgar StPierre
15:04:08 <rpaik> #info aricg notes that there is a roadblock with Jira Federation as there is no documentation
15:04:38 <aricg> #info
15:04:39 <aricg> https://confluence.atlassian.com/jira063/how-to-make-a-federated-jira-instance-683542380.html
15:04:46 <StuartMackie> #info Stuart Mackie
15:04:51 <rpaik> #topic hackfest/plugfest reminder
15:04:54 <tallgren> #link https://wiki.opnfv.org/display/EVNT/Co-located+Plugfest-Hackfest+Planning+Page
15:05:22 <rpaik> #link https://www.regonline.com/OPNFVPlugfestDec2016 registration for plugfest
15:05:53 <tallgren> #info rpaik reminds everyone to register to the Plugfest/Hackfest, registration will close on Dec. 1
15:06:20 <uli-k> #info rpaik reports that about 70 people from about 25 companies have registered.
15:07:02 <tallgren> #info Three companies will bring hardware + three more will provide remote access to labs
15:07:04 <rpaik> #link https://wiki.opnfv.org/display/EVNT/Co-located+Plugfest-Hackfest+Planning+Page schedule in progress
15:11:14 <rpaik> #topic common configuration files and naming
15:11:21 <tallgren> #link https://gerrit.opnfv.org/gerrit/#/c/23725
15:11:21 <uli-k> #info Most of the discussion meetings of the hackfest will be scheduled on Tuesday/Wednesday/Thursday to allow people travel without breaking the weekend
15:11:34 <tallgren> #link https://gerrit.opnfv.org/gerrit/#/c/23727
15:12:04 <rpaik> #info jmorgan1 notes that more time is needed for community feedback including during the Plugfest/Hackfest
15:13:00 <rpaik> #info there are activities on both POD & scenario descriptions
15:13:42 <Julien-zte> #info Julien
15:14:55 <rpaik> #info frankbrockners suggests that +1 from all installer teams is desired before the TSC
15:15:00 <bryan_att> #info the introspection may not work in all environments, so it may be necessary to be specific to cover all types of environments (e.g. those that do not support IPMI)
15:15:38 <bryan_att> #info can someone post a link to the discussion (in gerrit or JIRA)?
15:15:57 <tallgren> I put the gerrit links above
15:16:23 <tallgren> https://gerrit.opnfv.org/gerrit/#/c/23727
15:17:23 <rpaik> #info uli-k notes that initially not all installers may be able to implement the proposal
15:18:02 <trozet> there shouldn't be any networking in the inventory file...
15:18:02 <uli-k> #info ... but all installers should be able to implement it long term.
15:19:34 <rpaik> #info tallgren suggests reviewing/commenting on gerrit link above
15:19:55 <rpaik> #topic goals and vision for Danube
15:19:56 <tallgren> #link https://etherpad.opnfv.org/p/CommunityGoals
15:20:21 <bryan_att> trozet: how is the networking deployment (e.g. assignment of role to specific NICs) going to be consistent if not specified?
15:20:28 <rpaik> #info so far discussion has taken place in the Test WG
15:20:41 <trozet> bryan_att: that goes in network settings
15:21:16 <bryan_att> trozet: so the patch needs to indicate that there are more than one common config file?
15:21:17 <rpaik> #info there is an action item for the TSC to provide a report out to the Board on December 8th
15:21:59 <trozet> bryan_att: it needs to remove the networking config that is in there imo
15:22:41 <trozet> bryan_att: i left comments in gerrit
15:23:43 <ebrjohn> Automatic removal after 6 months seems a bit aggressive... they should at least be asked their intentions
15:23:54 <ChrisPriceAB> it could be the TSC agrees to a process that does not involve personal feelings :)
15:24:00 <bryan_att> trozet: ok, we'll take it offline, but we need all the config files to be common across installers, for different purposes (network, host, install settings e.g. external net, region name, ...)
15:24:33 <trozet> bryan_att: for CI i dont think it really matters
15:24:40 <rpaik> #info discussion on whether automatic removal of committer belongs in the Danube vision document
15:25:00 <ChrisPriceAB> #link https://wiki.opnfv.org/display/DEV/Committer+Removal current process
15:25:32 <ChrisPriceAB> could change the text to have "inactive" committer removal automated.
15:25:56 <cgoncalves> -1 on automatic removal of committers. there are active people in project teams that do not directly commit but provide valuable input and contribute through other ways
15:26:19 <rpaik> #info encourage other working groups to start/continue the discussion on Danube/future release vision
15:26:19 <cgoncalves> s/do not provide/do provide/
15:26:29 <bryan_att> trozet: I disagree - installs need to run easily across different envs in CI, and tests need to be less complicated /fragile by being able to consistently depend or determine the VIM install parameters
15:26:34 <ebrjohn> cgoncalves: +1, I guess we should also define "activity"
15:27:32 <ebrjohn> in ODL activity is usually defined in terms of gerrit patches, which doesnt really translate well to OPNFV
15:27:45 * ebrjohn ok, enough, sorry
15:28:08 * bryan_att whew!
15:28:21 <rpaik> #topic Colorado + Danube release planning
15:28:59 <rpaik> #info dmcbride note sthat the  test milestone for Danube is today
15:30:28 <ebrjohn> #info dmcbride says we will most likely be using openstack newton in Danube
15:30:38 <rpaik> #info the consensus from PTLs was to stay with OpenStack-Newton for the Danube release
15:31:00 <uli-k> #info dmcbride reports from the survey. Danube will go with Newton, E release with Ocata
15:31:01 <ethfci> Brady good news
15:31:34 <ethfci> i have built fuel amd deployed danube
15:31:47 <rpaik> #info dmcbride adds that there will be several release-related discussion topics at the Plugfest/Hackfest at UNH-IOL
15:33:25 <rpaik> #info Colorado 3.0 is coming up (on Dec. 5th) and dmcbride will be following up with installer PTLs
15:33:40 <bryan_att> dmcbride: can we call it a "retrospective" vs "post mortem" as Colorado is not dead and AFAICT it was not a disaster - which typically precede a "port mortem"
15:34:04 <ebrjohn> Should we already vote on the E release?
15:37:19 <ethfci> vpp: NSH classifier under development: https://jira.fd.io/browse/VPP-482
15:37:48 <ebrjohn> ethfci: can we take that offline, this is the TSC meeting
15:37:59 <ethfci> OK
15:39:02 <ethfci> rpaik: what is the plan for Fuel/Colorado/3.0
15:40:44 <jmorgan1> ethfci: that might be a good discussion for the release meeting in 20min in #opnfv-release
15:41:03 <Julien-zte> I think we should decide the openstack version earlier, then it is earsier for test and integrate
15:43:44 <rpaik> #startvote Should the TSC agree to have the  OPNFV-Danube release be based on OpenStack-Newton? (-1, 0, +1)
15:43:44 <collabot`> Begin voting on: Should the TSC agree to have the  OPNFV-Danube release be based on OpenStack-Newton? Valid vote options are , -1, 0, +1, .
15:43:44 <collabot`> Vote using '#vote OPTION'. Only your last vote counts.
15:44:04 <Julien-zte> #vote +1
15:44:07 <uli-k> #vote +1
15:44:16 <JonasArndt> #vote 0
15:44:19 <ebrjohn> #vote +1
15:44:19 <bryan_att> #vote +1
15:44:19 <StuartMackie> #vote +1
15:44:21 <bjskerry> #vote +1
15:44:47 <tallgren> #vote +1
15:44:49 <jmorgan1> #vote +1
15:44:49 <edgarstp> #vote +1
15:44:51 <fdegir> #vote +1
15:44:52 <cgoncalves> #vote +1
15:44:57 <ebrjohn> #info s/Should/Does/
15:45:01 <rossella__> #vote +1
15:45:05 <rpaik> #vote +1
15:45:08 <frankbrockners> #vote 0
15:45:17 <rpaik> #info proxy for Bin Hu
15:45:25 <rpaik> #endvote
15:45:25 <collabot`> Voted on "Should the TSC agree to have the  OPNFV-Danube release be based on OpenStack-Newton?" Results are
15:45:25 <collabot`> 0 (2): JonasArndt, frankbrockners
15:45:25 <collabot`> +1 (13): ebrjohn, cgoncalves, bryan_att, Julien-zte, tallgren, rpaik, StuartMackie, rossella__, fdegir, uli-k, bjskerry, edgarstp, jmorgan1
15:47:14 <rpaik> #info Daisy team are reporting issues with CI integration so the projects dependent on Daisy should be aware of this
15:48:49 <rpaik> #info dmcbride notes that scenario participating in Colorado 3.0 release should be reflected in the Colorado scenarios page
15:49:34 <dmcbride> #link https://wiki.opnfv.org/display/SWREL/Colorado+Scenario+Status
15:50:43 <rpaik> #topic Jira federation
15:50:57 <tallgren> #action aric will check what will be the effort/price for Jira federation would be
15:51:17 <rpaik> #info frankbrockners suggest creating a wiki page to summarize progress/status on the Jira federation work
15:51:59 <rpaik> #action aricg to contact Atlassian to scope out the work/cost
15:56:04 <rpaik> #topic meeting times
15:56:41 <jmorgan1> my proposal via email was to have LF manage/own OPNFV meetings
15:56:44 <ebrjohn> Best way to resolve UTC: http://www.timeanddate.com/worldclock/meetingdetails.html?year=2015&month=11&day=18&hour=17&min=0&sec=0&p1=224&p2=179&p3=141
15:57:24 <jmorgan1> consolidate GTM accounts to a single meeting
15:57:28 <jmorgan1> and document on wiki
15:58:57 <jmorgan1> there seems to be some ways to improve meetings
15:59:55 <bryan_att> #info the odd and even hour thing is useless unless we standardize on a timezone for all meetings. I vote for the single meeting per account that is always available. That way we have two always-available meetings that will never conflict.
16:00:34 <rpaik> #action rpaik to continue the conversation on mailing lists
16:01:14 <tallgren> #endmeeting