15:59:20 <jmorgan1> #startmeeting Infra Work Group Weekly
15:59:20 <collabot> Meeting started Wed Jan 11 15:59:20 2017 UTC.  The chair is jmorgan1. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:20 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:59:20 <collabot> The meeting name has been set to 'infra_work_group_weekly'
15:59:27 <jmorgan1> #topic Roll Call
15:59:31 <jmorgan1> #info Jack Morgan
16:00:18 <fdegir> #info Fatih Degirmenci
16:00:31 <hongbo2122> #info Hongbo
16:00:34 <hw_wutianwei> info Tianwei Wu
16:01:15 <jmorgan1> hw_wutianwei: need "#info"
16:01:32 <hw_wutianwei> #info Tianwei Wu
16:01:36 <hw_wutianwei> sorry
16:01:49 <hongbo2122> can you hear me?
16:02:03 <dmcbride> #info David McBride
16:02:08 <bryan_att> #info Bryan Sullivan
16:02:13 <bryan_att> no, hongbo2122
16:02:19 <bramwelt> #info Trevor Bramwell
16:02:38 <dmcbride> could someone please give me the GTM link?
16:02:43 <hongbo2122> I will try again logining
16:02:59 <hw_wutianwei> I can not join the GTM
16:03:03 <hongbo2122> https://global.gotomeeting.com/join/819733085
16:03:03 <aimeeu> dmcbride: https://global.gotomeeting.com/join/819733085
16:03:12 <jmorgan1> #topic Dovetail Support
16:03:35 <hongbo2122> go ahead
16:04:46 <jmorgan1> #info MathewLi presents slides on Dovetail requirements
16:05:03 <hongbo2122> I am back
16:05:33 <uli-k> #info Uli Kleber
16:05:40 <jmorgan1> #info details on Dovetail wiki page
16:05:50 * uli-k sorry took me a while to connect.....
16:07:46 <fdegir> #info Dovetail needs stable version of OPNFV deployed in order to run tests
16:07:47 <rprakash> #info rprakash
16:08:11 <fdegir> #info Due to OPNFV turning off CI against stable branches (colorado), Dovetail will not have possibility to run against it
16:08:42 <fdegir> #info In order to run Dovetail, we need Colorado deployed on baremetal PODs
16:09:06 <fdegir> #info But we still lack dynamic allocation of resources so Dovetail probably needs 4 baremetal PODs, 1 per installer
16:09:17 <fdegir> #undo
16:12:01 <fdegir> #info An additional ARM POD is needed for running Dovetail against ARM on Fuel
16:12:08 <fdegir> #info Which makes 5 PODs in total
16:13:13 <jmorgan1> #info Apex is working on ARM support for E release
16:13:51 <jmorgan1> #info Fatih asks how oftern we need to run Dovetail against stable branches
16:16:12 <jmorgan1> #info Dovetail will be part of release testing process
16:18:27 <jmorgan1> #info had some discussion on dedicated hardware vs dovetails jobs on current hardware
16:18:37 <ChrisPriceAB> While we are developing Dovetail for Danube it should be run as a job against Danube during the R&D cycle.  This is just another test job.
16:18:54 <ChrisPriceAB> After release we would want to validate dovetail against stable.
16:19:01 <ChrisPriceAB> When Dovetail is "ready"
16:19:31 <fdegir> ChrisPriceAB: but then this makes me ask the same question
16:19:48 <fdegir> ChrisPriceAB: we need test strategy to come up with how to test the platform itself
16:19:57 <jmorgan1> sounds like this ask is gated until Dynamic CI is ready, no?
16:20:05 <fdegir> ChrisPriceAB: we can't have everything running as part of CI pipeline against the master
16:20:15 <fdegir> ChrisPriceAB: or one single run will take days to complete
16:20:18 <ChrisPriceAB> Yes fdegir but that is a question for the Danube project rather than DoveTail
16:20:38 <fdegir> ChrisPriceAB: yes, it is a general quesiton and valid for other test proejcts that are not part of the CI master runs
16:20:54 <fdegir> as well^
16:20:56 <ChrisPriceAB> not as part of CI, maybe weekly or on change fdegir
16:21:03 <jmorgan1> #info points out that the amount of testing is short - a coupls of tests / a few hours
16:21:48 <jmorgan1> #undo
16:21:48 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2358a90>
16:21:53 <fdegir> ChrisPriceAB: weekly could be done
16:21:59 <jmorgan1> #info Hongbo points out that the amount of testing is short - a coupls of tests / a few hours
16:23:04 <ChrisPriceAB> The difference is after an OPNFV release when the dovetail suite is to be made generally available it needs to be validated against stable.
16:24:19 <jmorgan1> #action fdegir to work with Dovetail in Releng to coordiate a test plan in the short
16:24:44 <jmorgan1> #info fdegir mentions that this will be difficult as we get closer to release time as release testing increases
16:26:25 <jmorgan1> #action MatthewLi to work with releng project to coordiate planning
16:27:52 <jmorgan1> #topic CI resource redundancy
16:28:59 <jmorgan1> #info due to recent ourtage and maintenance work jenkins jobs failed and projects suffered
16:29:23 <jmorgan1> #info need to rebalance jenkins jobs to different labs to add redundancy
16:30:32 <jmorgan1> #info Huawei has POD available for dynamic ci or similar efforts
16:32:35 <jmorgan1> #action tianwei_wu to return to once Huawei POd as available to discuss allocation
16:32:37 <uli-k> #link https://wiki.opnfv.org/display/pharos/Huawei%27s+munich+Lab
16:33:41 <hw_wutianwei> #linkhttps://wiki.opnfv.org/display/pharos/Huawei+Xi%27an+Lab
16:33:56 <jmorgan1> #action Fatih and Jack to propose a solution to rebalancing jenkins jobs in the labs
16:34:04 <fdegir> :)
16:36:40 <jmorgan1> #info the Infra PTL need to consolidate slides to present to TSC then request time at TSC to present
16:37:52 <jmorgan1> #action aricg to follow up with Rudy on UCS support and present update next week
16:38:12 <ChrisPriceAB> bramwelt ducking and weaving nicely!
16:38:50 <bramwelt> ;)
16:45:26 <fdegir> +1 to move
16:47:53 <ChrisPriceAB> The first step toward healing jmorgan1...  maybe it's me
16:49:21 <fdegir> #action jmorgan1 Move Infra WG meeting minutes to general meeting page
16:51:35 <jmorgan1> #info move Infra meeting minutes to Meeting space for reporting and send out update to mailing list
16:51:45 <jmorgan1> #topic MS4 for Danube
16:52:30 <jmorgan1> #info David presents his slides on improving definition of MS4
16:53:37 <jmorgan1> #info MS4 needs better definition of what it means and how to measure it
16:54:22 <jmorgan1> #info MS4 is "infra updates completed" currently for projects/senarios, CI capacity, and Infra WG improvements
16:56:03 <jmorgan1> #info issue #1 timing - when should we have this milestone (currently its 3+ months before release)
16:56:55 <jmorgan1> #info issue #2 release manager - what questions should be asked to provide status update on completion of this milestone
16:57:50 <jmorgan1> #info issue #3 derive capacity - how to collect requirements and what is the process for this
16:58:36 <jmorgan1> #info issue #4 Infra WG plans / improvements - how to coordiante with release manager and how to approve the plan
17:03:06 <jmorgan1> #info David to upload slides to Software release wiki space and send link to Jack to include in meeting minutes
17:03:43 <hongbo2122> to end the meeting?
17:03:56 <hongbo2122> to jmorgan1
17:03:58 <jmorgan1> #info We will discuss this topic again next week to propose solutions to the problem statemnts
17:04:08 <jmorgan1> #endmeeting