#opnfv-meeting: Infra WG Weekly Meeting

Meeting started by fdegir at 15:00:10 UTC (full logs).

Meeting summary

  1. Rollcall (fdegir, 15:00:40)
    1. Thaj (thaj, 15:01:04)
    2. lhinds (lhinds, 15:01:10)
    3. Uli (uli-k, 15:01:13)

  2. Security WG Group Integration with the Infra WG (fdegir, 15:02:19)
    1. lhinds gives background for integrating Security WG and Infra WG (fdegir, 15:03:11)
    2. There is an ongoing collaboration between Security and Infra WGs already (threat analysis, security gate checks, CII badging) (fdegir, 15:03:43)
    3. In order to work on items together and implement things faster, it is beneficial to integrate these WGs (fdegir, 15:04:34)
    4. A vote has been taken by Security WG for this and agreed (fdegir, 15:04:58)
    5. When/If Infra WG agrees, we need to fix the logistics (TSC, informing community, etc.) (fdegir, 15:06:10)
    6. uli-k mentions that there are 2 kinds of main items (fdegir, 15:06:29)
    7. 1. Security issues with development/release process (fdegir, 15:06:45)
    8. 2. Security features of the target platform (fdegir, 15:07:25)
    9. The discussion to combine WGs is valid for first item (fdegir, 15:08:02)
    10. Security Project will continue its existence with its current committers/contributors so the merge of Security and Infra WG doesn't change the project scope/governance (fdegir, 15:09:10)
    11. But the topics for the 2nd (target platform features) can be handled by the project as usual (fdegir, 15:09:41)
    12. AGREED: Infra WG agrees to combine with Security WG (fdegir, 15:10:46)
    13. ACTION: lhinds to notify TSC and Technical community about this change (fdegir, 15:11:08)
    14. ACTION: jmorgan1, uli-k, fdegir, lhinds to update wiki (fdegir, 15:12:04)
    15. PTL from Security WG will also take part in being Infra WG meeting chair (fdegir, 15:12:47)

  3. Static checking (fdegir, 15:12:58)
    1. The thread about static checking is still pending to be resolved (fdegir, 15:13:43)
    2. It is important for community to apply static checking to their development process (fdegir, 15:14:09)
    3. For example Octopus will employ yamllink for SDF (fdegir, 15:14:26)
    4. Projects need to contact Infra WG/Releng to activate static checks (fdegir, 15:14:54)
    5. This needs to be managed in order to make sure we have various static checks employed by the projects (fdegir, 15:15:47)
    6. Flake for python. (thaj, 15:17:39)
    7. Releng has some checks available to community (fdegir, 15:18:13)
    8. https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=blob;f=jjb/releng/opnfv-lint.yml (fdegir, 15:18:16)
    9. https://wiki.opnfv.org/display/INF/Contiuous+Integration (uli-k, 15:18:47)
    10. https://wiki.opnfv.org/display/INF/Continuous+Integration#ContinuousIntegration-StaticCheckToolsofCI (thaj, 15:19:04)
    11. if you scroll down, there is a list of tools (uli-k, 15:19:11)
    12. CII Badging also requires this and run static analysis as applicable (fdegir, 15:19:52)
    13. ACTION: lhinds and Sona to come up with initial list of static checks we can apply to OPNFV proejcts (fdegir, 15:21:30)
    14. ACTION: uli-k to activate yamllint for octopus (fdegir, 15:22:12)
    15. ACTION: jmorgan1 to activate yamllint for pharos (fdegir, 15:22:20)
    16. ACTION: fdegir to activate yamllint for releng/jjb (fdegir, 15:22:50)

  4. Moving Installers to VMs on jumphosts (fdegir, 15:23:52)
    1. This topic needs to be discussed further and flagged as risk due to not having enough people and possibility of causing issues (fdegir, 15:29:56)

  5. Action Item Review (fdegir, 15:30:25)
    1. ACTION: aricg radez Work on creating an additional repo for Apex to trial this before bringing topic to TSC (fdegir, 15:30:37)
    2. ACTION: uli-k jmorgan1 fdegir Identify what can be moved from OPNFV Wiki Infra Space to RTD and what can stay on Wiki (fdegir, 15:31:04)
    3. ACTION: uli-k MatthewLi Come up with different options to handle Dovetail Infra requirements for further discussion (fdegir, 15:31:19)
    4. ACTION: jmorgan1 Collect centralized resource requirements for OPNFV as part of LF Infra Collab/Lab workstream (fdegir, 15:31:45)
    5. ACTION: TBD Start capturing ideas/issues with moving installers into VMs on OPNFV POD Jumphosts for community feedback (fdegir, 15:32:14)


Meeting ended at 15:32:38 UTC (full logs).

Action items

  1. lhinds to notify TSC and Technical community about this change
  2. jmorgan1, uli-k, fdegir, lhinds to update wiki
  3. lhinds and Sona to come up with initial list of static checks we can apply to OPNFV proejcts
  4. uli-k to activate yamllint for octopus
  5. jmorgan1 to activate yamllint for pharos
  6. fdegir to activate yamllint for releng/jjb
  7. aricg radez Work on creating an additional repo for Apex to trial this before bringing topic to TSC
  8. uli-k jmorgan1 fdegir Identify what can be moved from OPNFV Wiki Infra Space to RTD and what can stay on Wiki
  9. uli-k MatthewLi Come up with different options to handle Dovetail Infra requirements for further discussion
  10. jmorgan1 Collect centralized resource requirements for OPNFV as part of LF Infra Collab/Lab workstream
  11. TBD Start capturing ideas/issues with moving installers into VMs on OPNFV POD Jumphosts for community feedback


Action items, by person

  1. fdegir
    1. jmorgan1, uli-k, fdegir, lhinds to update wiki
    2. fdegir to activate yamllint for releng/jjb
    3. uli-k jmorgan1 fdegir Identify what can be moved from OPNFV Wiki Infra Space to RTD and what can stay on Wiki
  2. lhinds
    1. lhinds to notify TSC and Technical community about this change
    2. jmorgan1, uli-k, fdegir, lhinds to update wiki
    3. lhinds and Sona to come up with initial list of static checks we can apply to OPNFV proejcts
  3. uli-k
    1. jmorgan1, uli-k, fdegir, lhinds to update wiki
    2. uli-k to activate yamllint for octopus
    3. uli-k jmorgan1 fdegir Identify what can be moved from OPNFV Wiki Infra Space to RTD and what can stay on Wiki
    4. uli-k MatthewLi Come up with different options to handle Dovetail Infra requirements for further discussion
  4. UNASSIGNED
    1. jmorgan1 to activate yamllint for pharos
    2. aricg radez Work on creating an additional repo for Apex to trial this before bringing topic to TSC
    3. jmorgan1 Collect centralized resource requirements for OPNFV as part of LF Infra Collab/Lab workstream
    4. TBD Start capturing ideas/issues with moving installers into VMs on OPNFV POD Jumphosts for community feedback


People present (lines said)

  1. fdegir (40)
  2. uli-k (3)
  3. collabot` (3)
  4. thaj (3)
  5. lhinds (1)


Generated by MeetBot 0.1.4.