13:00:31 <hongbo12123> #startmeeting dovetail weekly meeting
13:00:31 <collabot`> Meeting started Fri Apr 7 13:00:31 2017 UTC. The chair is hongbo12123. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:31 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:31 <collabot`> The meeting name has been set to 'dovetail_weekly_meeting'
13:01:29 <hongbo12123> #info Hongbo
13:01:37 <georgk> #info Georg Kunz
13:01:42 <Wenjing> #info Wenjing
13:01:47 <thaj> #info Thaj
13:02:08 <lylavoie> #info Lincoln Lavoie
13:02:27 <MatthewLi> #info Jun Li
13:03:55 <hongbo12123> #topic action items review
13:05:38 <hongbo12123> #topic Test strategy doc and task assignments
13:06:21 <hongbo12123> #link https://wiki.opnfv.org/display/meetings/Dovetail
13:06:56 <dneary> I have the agenda here
13:07:17 <trevor_intel_> #info Trevor Cooper
13:08:59 <hongbo12123> #info wenjing went over the stratety page
13:09:00 <Wenjing> #info https://jira.opnfv.org/browse/DOVETAIL-352
13:09:18 <hongbo12123> #chair dneary
13:09:18 <collabot`> Current chairs: dneary hongbo12123
13:09:58 <hongbo12123> #info there is jira ticket for the docoment of dovetail strategies
13:10:53 <dneary> #info Two action items in last week’s minutes, which we will cover:
13:10:53 <dneary> #info #action detail the steps for the user for the workflow
13:10:53 <dneary> #info #action the dovetail team to review the document patch
13:10:53 <dneary> #info Agenda for April 7:
13:10:53 <dneary> #info - Test strategy doc and task assignments – there is an outstanding action item for everyone to review the patch and consider contributions: https://gerrit.opnfv.org/gerrit/#/c/32499/
13:10:55 <dneary> #info - Plugfest activity planning: what should we get done: - Who are going to be there; - What tests we need to do – start testing the software toolchain, the full workflow and test guide docs; - Equipment and installer/scenario combinations; - Review new test areas that are ready
13:10:59 <dneary> #info Test area review status and we need to reach agreement on process. Also take a look at the sdnvpn submission as an example to follow.
13:11:04 <dneary> #info Test case description to help testers and reviewers understand/diagnose etc. – what is needed and what approach to add the descriptions: - The refstack cases; - Other feature cases
13:11:09 <dneary> #info Tools discussion (this is a placeholder in case additional discussion is needed)
13:11:11 <dneary> #info Jira plan still not in good shape – how do we get there before plugfest in 2 weeks.
13:11:13 <dneary> #info Update on the action item: CVP workflow, discussion with LF/Jose et al on hosting, login and related jira task to dovetail.
13:11:16 <dneary> #info Last minute comments on update to TSC/Board.
13:11:21 <dneary> hongbo12123, Wenjing: The agenda C&P from email ^^^
13:11:35 <hongbo12123> thanks
13:12:18 <dneary> Sorry, I realise that the #topic changed
13:12:26 <hongbo12123> that is fine
13:12:34 <dneary> #topic Test strategy document
13:12:47 <dneary> #info Wenjing asks if we can confirm 3 things:
13:13:02 <dneary> #info 1. Is the skeleton for the test strategy doc good enough?
13:13:44 <dneary> #info 2. Who can volunteer to help write the sections?
13:14:19 <dneary> Wenjing, hongbo12123: I missed what #3 was
13:14:40 <dneary> #info Trevor suggests that we need 3 documents:
13:15:54 <hongbo12123> #chair trevor_intel
13:15:54 <collabot`> Current chairs: dneary hongbo12123 trevor_intel
13:16:14 <trevor_intel_> #info Test Strategy
13:16:14 <trevor_intel_> Doc - - Guides development of test tool-chain
13:16:31 <georgk> #link https://gerrit.opnfv.org/gerrit/#/c/32499/
13:17:00 <georgk> trevor proposed this in teh comments of this patchset
13:17:07 <dneary> #info Guide for developing the tool
13:17:18 <dneary> #info The guide to adding new tests to the Dovetail suite
13:18:44 <dneary> #info The test user guide: How to prepare a system, run the test suite, and validate the results
13:19:30 <trevor_intel_> #info https://gerrit.opnfv.org/gerrit/#/c/32499/1
13:19:50 <dneary> #info Dave says his understanding is that the test strategy document is supposed to be destined for how to validate conformance - target audience is people testing an SUT
13:25:46 <dneary> #info Dave suggests a glossary of terms - there is clearly some confusion.
13:26:52 <dneary> #info Trevor suggests that the top priority should be the requirements document of which test areas and test cases we want to develop, and the workflow for proposing tests for inclusion in the test suite
13:30:28 <dneary> #info Georg and Trevor say that what the test cases are, and how they are added to the tool to be run by Dovetail, is a critical tasks, very practical, and the highest priority
13:32:09 <dneary> #info Wenjing agrees with Dave that expectations of the SUT and how to run the test suite is the highest priority
13:32:37 <dneary> #info Dave also suggests that "tool development guide" is not a good name, since adding a test case should not require changing the test tool
13:36:40 <dneary> #info Trevor proposes writing a draft document for tool requirements (in terms of what the tool needs to do for testing specific test areas)
13:43:10 <dneary> #info Sections 3,4,5 of test strategy document are around expectations of the SUT (preparing staging hosts, network configuration, and SUT configuration requirements) - Dave suggests the infra team is the natural owner. Wenjing spoke to Jack who is prepared to help
13:43:44 <hongbo12123> #info dave to talk with chri to find some one for the security section
13:43:56 <dneary> #info Section 6 (test suite execution and reporting) seems like something the testing WG should own
13:44:36 <dneary> #info Dave will talk to Chris to clarify if the Security section is around the security of test reporting and validation, or security considerations for the SUT
13:45:18 <dneary> #info Dave will also approach the security WG to see if they can help with this section
13:47:22 <jmorgan1> dneary: security wg has merged with infra wg (reminder)
13:47:35 <dneary> jmorgan1, Thanks
13:49:00 <dneary> #info Since Security is now under the Infra WG, Wenjing will also discuss the security section with the Infra working group
13:50:13 <dneary> #info Uli is in the Infra group, and has volunteered to take the action item to bring the security concerns back to the Infra WG
13:50:50 <dneary> #topic Plugfest activity planning
13:50:58 <hongbo12123> #link https://wiki.opnfv.org/display/dovetail/Dovetail+PlugFest+Plan+April+24-28
14:04:14 <trevor_intel_> #link https://wiki.opnfv.org/pages/viewpage.action?pageId=9569132
14:12:09 <dneary> #info Hands-on lab track: Goal is to test Dovetail on non-Pharos hardware end-to-end
14:12:42 <dneary> #info Other tracks to propose: Trevor proposed some performance testing
14:13:17 <trevor_intel_> #info Plugfest - proposed add topics to Hackfest planning page 1) review docs 2) planning
14:13:27 <dneary> #info Georg proposed declaring specific goals for plugfest outcomes, to focus people on an objective
14:14:05 <dneary> #info Wenjing proposed reviewing test areas during plugfest as many project participants will be in Paris
14:15:33 <dneary> #info Dave proposed moving back to 1h meetings, as he finds 90 minute meetings a bit long
14:15:49 <dneary> #agreed Revert to 60 minute meetings unless there is a specific need for more time
14:17:09 <hongbo12123> #endmeeting