05:16:18 <rpaik> #startmeeting 2017 OPNFV orientation
05:16:18 <collabot> Meeting started Sun Jun 11 05:16:18 2017 UTC.  The chair is rpaik. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:16:18 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
05:16:18 <collabot> The meeting name has been set to '2017_opnfv_orientation'
05:16:22 <durschatz> #info Dave Urschatz (CENGN)
05:16:43 <durschatz> #info Rick Penwarden (CENGN)
05:16:44 <rpaik> #info Ray Paik
05:16:52 <rpaik> #chair dmcbride
05:16:52 <collabot> Current chairs: dmcbride rpaik
05:17:40 <dmcbride> #info primary channel is "opnfv-meeting"
05:17:58 <dmcbride> #info other channels dedicated to specific OPNFV projects
05:18:52 <dmcbride> #info there is also a dedicated channel for release meetings - "opnfv-release"
05:20:25 <bramwelt> #link webchat.freenode.net
05:20:38 <dmcbride> #topic What is OPNFV?
05:22:14 <dmcbride> #info the idea of Network Function Virtualization (NFV) has been around for a while
05:22:37 <dmcbride> #info a lof of the work has been done in standards bodies, such as ETSI
05:23:04 <dmcbride> #info standards are great, but the industry needs an implementation
05:24:48 <dmcbride> #info many components have been developed in disparate Open Source projects (e.g. SDN, DPDK, VIM, etc.)
05:25:26 <dmcbride> #info we need something to pull all of these separate projects together.  Thus OPNFV
05:26:05 <dmcbride> #info Three major principles:  Integration, Testing, "Upstream First"
05:26:42 <bramwelt> #info Lots of upcoming co-located events happening in next couple of weeks with upstream projects
05:27:44 <bramwelt> #topic Danube Overview
05:28:00 <bramwelt> (don't think I can change topic since I'm not chair..)
05:29:44 <dmcbride> #chair bramwelt
05:29:44 <collabot> Current chairs: bramwelt dmcbride rpaik
05:30:57 <dmcbride> #topic Danube Overview
05:31:17 <dmcbride> #info 7 - 10 test projects
05:31:52 <dmcbride> #info many telco oriented projects, such as Service Function Chaining (SFC)
05:32:21 <dmcbride> #topic release history
05:33:12 <bramwelt> #info Arno: June 4, 2015; Brahmaputra: March 1, 2016; Colorado: September 26, 2016; Danube: April 4, 2017
05:33:15 <dmcbride> #info releases are named after rivers in alphabetical order, switching continents after each release
05:35:32 <dmcbride> #info recent releases have included about 40 projects, each
05:38:16 <dmcbride> #topic Cross-community CI (XCI)
05:41:27 <dmcbride> #info sessions on XCI this week at the Summit.  See the schedule.
05:41:33 <dmcbride> #topic Testing
05:44:02 <bramwelt> #info Testing WG formed to collaborate on testing issues and create a testapi as a unified reporting interface
05:44:13 <dmcbride> #info there will be a panel on Monday that includes all of the test projects (see Summit schedule)
05:44:28 <bramwelt> #link http://testresults.opnfv.org/reporting/
05:44:43 <dmcbride> #info there will also be several sessions on individual test projects
05:46:25 <bramwelt> #info testresults help provide insight to the release manager on scenario status
05:46:45 <dmcbride> #topic Pharos Test Labs
05:49:03 <bramwelt> #link https://wiki.opnfv.org/display/pharos/Community+Labs
05:50:53 <dmcbride> #info more than 70 Pharos pods used for the Danube release
05:51:35 <bramwelt> #info Over 7 thousand deployments of OpenStack during the Danube release
05:53:41 <dmcbride> #topic OPNFV members
05:54:14 <dmcbride> #topic OPNFV projects
05:58:21 <dmcbride> #info each project has a wiki page at wiki.opnfv.org that provides relevant informatin for the project
06:00:38 <dmcbride> #info creating a new project
06:00:47 <dmcbride> #undo
06:00:47 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2507990>
06:01:02 <dmcbride> #topic creating a new OPNFV project
06:01:53 <dmcbride> #info step 1 - create a proposal and allow for a 2 week review period
06:02:25 <dmcbride> #info step 2 - TSC review and vote (simple majority)
06:02:41 <dmcbride> #topic OPNFV project lifecycle
06:03:01 <dmcbride> #info phases:  proposal, incubation, mature, archived
06:05:29 <dmcbride> #info currently too many projects are in "incubation" stage.  Attention to this issue has resulted in projects moving through graduation review (e.g. Functest)
06:06:21 <dmcbride> #topic OPNFV community
06:06:53 <dmcbride> #info OPNFV is fortunate to have an active, engaged community
06:07:24 <dmcbride> #info the OPNFV Code of Conduct is a reflection of the community
06:08:41 <dmcbride> #info the CoC was generated from the bottom up, based on experience from early releases
06:14:42 <bramwelt> #info OPNFV is a worldwide community. It's important to remember English is not everyone's primary language and we should always give people the benefit of the daught.
06:16:36 <bramwelt> #info don't be embarassed about your typing skills. Ray typos messages all the time on IRC.
06:16:49 <dmcbride> #topic meetings
06:16:55 <dmcbride> #link https://wiki.opnfv.org/display/meetings
06:18:01 <bramwelt> #info Several tools for meetings: IRC, GoToMeeting, Mailman, Etherpad
06:18:17 <bramwelt> #topic Community Events
06:18:32 <dmcbride> #link https://wiki.opnfv.org/display/EVNT
06:19:00 <bramwelt> #info twice a year plugfest where the community works on interoperability
06:19:10 <bramwelt> #info hackfest co-located with plugfests
06:19:33 <bramwelt> #info both hackfest and plugfest are free
06:20:21 <bramwelt> #topic Community Dashboard
06:20:33 <bramwelt> #link https://opnfv.biterg.io/
06:20:58 <bramwelt> #info provides visibility into community contributions
06:22:38 <bramwelt> #info Contributions aren't restricted to code. Dashboard shows IRC, mailinglist, wiki, etc.
06:22:48 <bramwelt> #topic Internship Program
06:23:49 <bramwelt> #info Lot of interesting internship projects happening in OPNFV
06:25:53 <rpaik> #topic OPNFV release process
06:28:18 <rpaik> #info dmcbride notes that in addition to major release (every 6 month) we have two minor/maintenance releases
06:32:12 <rpaik> #info OPNFV scenarios compose of installers, set of components, and a configuration
06:33:04 <rpaik> #info dmcbride walks through milestones for OPNFV release
06:34:20 <rpaik> #chair bramwelt
06:34:20 <collabot> Current chairs: bramwelt dmcbride rpaik
06:38:45 <bramwelt> #topic Release Process Milestones
06:39:57 <bramwelt> #info Milestone 3 splitting into 3 phases
06:41:54 <bramwelt> #info Mileston 4 redefined around test frameworks being ready to support feature development
06:42:05 <bramwelt> #undo
06:42:05 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x20e8a10>
06:42:22 <bramwelt> #info Milestone 4 redefined around test frameworks being ready to support feature development
06:42:58 <bramwelt> #info Milestone 5 feature projects completed scenarios integations
06:44:45 <bramwelt> #info dmcbride walks through milestones 6-11, where 11 being the release
06:46:51 <rpaik> #info there's also a new milestone exception process starting with Euphrates
06:50:12 <bramwelt> #topic OPNFV Marketing and PR Programs
06:52:56 <rpaik> #info Brandon Wick and Jill Lovato introduce themselves to the community
06:53:51 <bramwelt> #info Brandon gives an overview of the upcoming presentation
06:54:58 <bramwelt> #info They discuss the challenges of marketing/PR for an open source project
06:55:34 <rpaik> #info Developers are the key demographics for marketing in open source community
06:57:50 <bramwelt> #info Marking shouldn't be 'fluffy'. We should be telling the stories of OPNFV
07:00:28 <bramwelt> #info Role of marking is to rise above the noise (1MM+ github projects) and secure attention
07:09:49 <bramwelt> #info They explain the ways they do marketing/PR for OPNFV
07:15:12 <bramwelt> #info They explain ways the community can get involved: subscribe to marketing channels, getting involved, interfacing with ambassadors, joining meetups
07:16:32 <rpaik> #link https://www.opnfv.org/community/user-groups OPNFV meetup group page
07:23:26 <rpaik> #startvote should we take a 15-minute break? (+1, 0, -1)
07:23:26 <collabot> Begin voting on: should we take a 15-minute break? Valid vote options are , +1, 0, -1, .
07:23:26 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
07:23:32 <bramwelt> #vote +1
07:23:35 <durschatz> #vote +1
07:23:36 <basic`> #vote +1
07:23:37 <donaldh> #vote +1
07:23:40 <rpaik> #vote +1
07:23:48 <rpaik> #endvote
07:23:48 <collabot> Voted on "should we take a 15-minute break?" Results are
07:23:48 <collabot> +1 (5): basic`, rpaik, donaldh, durschatz, bramwelt
07:23:56 <bramwelt> Did we have quarum?
07:36:44 <rpaik> #action Brandon/Jill to post the marketing slides on the orientation wiki page
07:47:21 <rpaik> #topic Developer tools in OPNFV
07:48:19 <rpaik> #info bramwelt walks through developers tools in OPNFV (e.g. git/gerritt/Jenkins/Jira/etc.)
08:01:49 <rpaik> #info hands-on/demonstration of tools such as Etherpad, wiki, etc.
08:03:34 <rpaik> #link https://lists.opnfv.org/mailman/listinfo list of OPNFV mailing lists
08:19:41 <rpaik> #action to add info/instructions on LFID in the OPNFV wiki home page
08:19:45 <rpaik> #undo
08:19:45 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x250ab10>
08:20:00 <rpaik> #action bramwelt to add info/instructions on LFID in the OPNFV wiki home page
08:35:39 <basic`> https://etherpad.opnfv.org/p/demo for those following along
08:50:56 <rpaik> #endmeeting