15:02:43 <fdegir> #startmeeting Infra WG Meeting
15:02:43 <collabot> Meeting started Mon Jun 26 15:02:43 2017 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:43 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:43 <collabot> The meeting name has been set to 'infra_wg_meeting'
15:02:51 <fdegir> #topic Rollcall
15:02:51 <rpaik> #info Ray Paik
15:02:53 <jose_lausuch> #info Jose Lausuch
15:02:57 <lhinds> #info Luke Hinds
15:02:58 <aricg-> #info Aric Gardner
15:02:59 <radez> #info radez
15:03:16 <thaj> #info Thaj
15:03:33 <uli-k> #info Uli
15:03:46 <fdegir> #topic LaaS
15:04:08 <fdegir> #link https://wiki.opnfv.org/display/INF/Lab+as+a+Service
15:04:13 <bryan_att> #info Bryan Sullivan
15:05:18 <Julien-zte> #info Julien
15:07:30 <uli-k> #info LaaS will simplify developer access for readily deployed scenarios.
15:07:39 <fdegir> #info LaaS aims to provide one-click deployments of OPNFV
15:09:09 <fdegir> #info Apart from providing OPNFV deployments, it can also provide just OS installation on a number of machines so developers can do everything from scratch
15:09:16 <Julien-zte> shall we support all the installers or can we only support one installer and one scenario for the deveoper with HA nodes.
15:09:53 <Julien-zte> we can support nfvi first and then maybe add mano installed
15:11:18 <uli-k> #info the necessary things we need to have to be able to go forward here are:
15:11:26 <uli-k> #info 1. hardware resources
15:11:53 <uli-k> #info 2. human resources for the maintenance and for the implemention of the LaaS specifics
15:12:12 <uli-k> #info 3. dynamic CI needs to be available,
15:12:39 <Julien-zte> #info fdegir if PDF and SDF are supported by installers, the dynamic pod can supported easily
15:13:24 <uli-k> #info we don't need the full dynamic CI, but all installers need to use the PDF
15:16:10 <fdegir> #chair uli-k
15:16:10 <collabot> Current chairs: fdegir uli-k
15:18:55 <uli-k> #info we already have some hardware that we can use for LaaS
15:22:13 <fdegir> #info We need to finalize BoM which is listed on Wiki
15:22:15 <fdegir> #link https://wiki.opnfv.org/display/INF/Lab+as+a+Service#LabasaService-LaaSHardware
15:22:55 <Julien-zte> Sorry, I lost the connection just now. In my opinion, before we support dynamic CI, we can choose a scenario in one installer first and use it for developers
15:23:23 <Julien-zte> Is LaaS limited in one node or blade?
15:23:31 <fdegir> #action bryan_att Clarify HW requirements for ONAP
15:24:41 <Julien-zte> Is Lab installed by LaaS necessary connected to OPNFV jenkins?
15:25:22 <fdegir> #info We need to come up with rough cost estimates for development/CI purposes to have an idea about how much it would cost to run this on public cloud vs hosted environment
15:26:18 <Julien-zte> Who will consume the LaaS?
15:26:40 <fdegir> Julien-zte: we want anyone to consume it
15:26:46 <Julien-zte> in my scenario, we only prepare a Lab for intern project.
15:26:57 <Julien-zte> we don't find others scenarios for inner team.
15:27:20 <fdegir> Julien-zte: existing OPNFV developers, developers from other communities, people who want to know what OPNFV is & want to try things out and so on
15:27:22 <Julien-zte> intern actually requires to access some of the opnfv pod
15:27:26 <uli-k> #info bryan_att explains that ONAP part may run in a cloud environment and connect to a LaaS POD
15:28:51 <Julien-zte> if we just provide some labs for other community, we can just provide some dedicated labs to use.
15:29:08 <Julien-zte> other community should also provide resources for their developers
15:31:15 <fdegir> bryan_att: https://wiki.opnfv.org/display/INF/Lab+as+a+Service
15:36:48 <uli-k> #action Bryan_att Provide some use cases on the LaaS page so we can go a second step
15:36:52 <Julien-zte> can we use image to deploy LaaS instead of the installing all the packages just like a baremetal way.
15:38:10 <uli-k> #info further discussion next week based on that use cases.
15:38:14 <fdegir> #info Once we come up with initial usecases, we need to ask OPNFV Installers to see which ones can support them
15:38:20 <Julien-zte> my team only are familiar with fuel and apex, we don't have experience for other installers
15:38:30 <fdegir> Julien-zte: fuel is not there anymore
15:38:46 <Julien-zte> yes, actually, if we can use Danube release, it is there
15:38:51 <fdegir> Julien-zte: their resources are shifted to MCP
15:38:59 <uli-k> #topic ONAP and OPNFV Lab sharing and XCI
15:39:01 <Julien-zte> maybe in the next release, we can use MCP
15:39:05 <fdegir> Julien-zte: so it is very hard to get support from them
15:39:19 <Julien-zte> actually, we support ourselves
15:39:29 <Julien-zte> if we choose fuel.
15:39:38 <fdegir> we are not choosing...
15:39:41 <bryan_att> #link https://wiki.opnfv.org/display/COM/ONAP?preview=/11700125/11700646/ONAP-OPNFV%20%20lab%20sharing.png
15:39:57 <bryan_att> #link https://wiki.opnfv.org/display/COM/ONAP
15:40:26 <fdegir> bryan_att: some very high level use cases for LaaS are listed on: https://wiki.opnfv.org/display/INF/Lab+as+a+Service
15:40:49 <fdegir> sorry, this one https://wiki.opnfv.org/display/INF/Lab+as+a+Service#LabasaService-OPNFVLaaSinitialuse-cases
15:42:08 <uli-k> The picture looks more like how to connect a "ONAP POD" with a "OPNFV POD" right?
15:43:54 <Julien-zte> in the picture OPNFV POD should have a public url for usage? it have may have security issues
15:45:09 <uli-k> #info there needs to be some more details specified about these connections: ONAP will connect to management interface, while tests, and traffic go to different planes.
15:45:23 <uli-k> #info Security also needs to be considered
15:45:55 <uli-k> #info Bryan_att proposes to prototype this in OPNFV
15:47:40 <uli-k> #info LaaS can be such prototype.
15:48:06 <uli-k> #info thus we now go forward with LaaS and then specify more details for this lab sharing ....
15:48:53 <Julien-zte> #info agree uli-k, we'd better start from LaaS and then considering other features.
15:48:59 <Julien-zte> #info labs.opnfv.org
15:49:05 <Julien-zte> #inlik labs.opnfv.org
15:49:11 <Julien-zte> sorry
15:49:19 <Julien-zte> #link labs.opnfv.org
15:51:10 <uli-k> #info another future action is to connect the Pharos dashboard with the LaaS, but let's go first steps first
15:51:30 <Julien-zte> hi jose_lausuch, I'm interested in labs.opnfv.org, I just have no time to try apis
15:51:38 <uli-k> #topic LF status page
15:51:53 <uli-k> #info we already have status.opnfv.org
15:52:07 <rpaik> #link http://status.opnfv.org
15:52:11 <uli-k> #info but we should link that from wiki
15:52:29 <uli-k> #info fdegir proposes directly from Infra page
15:52:38 <aricg-> https://wiki.opnfv.org/display/INF
15:53:03 <uli-k> #info it will be discussed also tomorrow on TSC
15:53:17 <fdegir> +1 to main opnfv wiki
15:53:29 <Julien-zte> #info can we leave a contact in this page, status.opnfv.org?
15:53:43 <Julien-zte> if some thing happens, I don't know who to contact
15:54:11 <fdegir> Julien-zte: opnfv-helpdesk
15:54:33 <Julien-zte> I also hope we can see the history updates in the website.
15:54:38 <fdegir> Julien-zte: helpdesk (at) opnfv.org
15:54:46 <uli-k> #topic utilise signing for pulling img files
15:55:27 <uli-k> #info lhinds explains the security risk of that given command
15:55:45 <uli-k> #info we should introduce at least some checksum verification
15:57:24 <uli-k> #info verify plugin will help users to better understand findings of the verify step
15:57:41 <uli-k> #agree to introduce the verify plugin
16:00:13 <uli-k> #agree to introduce checksum verification when scripts pull img files (checksum will be in the script)
16:00:40 <uli-k> #info it needs to be implemented in the backlog for the anteater issues.
16:01:56 <uli-k> #link a.https://gerrit.googlesource.com/plugins/verify-status/+doc/master/src/main/resources/Documentation/about.md
16:02:05 <aricg-> if anyone wants to discuss this, I know we ran out of time. https://gerrit.opnfv.org/gerrit/#/c/36297/
16:02:09 <uli-k> #info next week, Luke will host the meetings.
16:02:45 <uli-k> #endmeeting