#opnfv-meeting: TSC weekly call

Meeting started by uli-k at 12:59:03 UTC (full logs).

Meeting summary

  1. rollcall (uli-k, 12:59:41)
    1. Luke Hinds (lhinds, 12:59:49)
    2. hongbo (hongbo4536982147, 12:59:51)
    3. Rossella Sblendido (rossella_s, 13:00:16)
    4. Jose Lausuch (Morgan's proxy) (jose_lausuch, 13:00:28)
    5. Yifei Xue (proxy for Justin) (yifei, 13:01:00)
    6. https://wiki.opnfv.org/display/meetings/TSC#TSC-July18,2017 today's agenda (rpaik, 13:01:25)
    7. fuqiao (fuqiao, 13:01:38)
    8. Tim Irnich (timirnich, 13:02:05)
    9. dneary (dneary, 13:02:47)

  2. agenda bashing (rpaik, 13:04:03)
    1. Trevor Cooper (trevor_intel, 13:04:05)

  3. Security gate check/Anteater (rpaik, 13:04:15)
  4. Security gate check/Anteater (uli-k, 13:04:22)
    1. lhinds notes that anteater scans against patchsets and logs are done (e.g. flagging security issues) (rpaik, 13:06:07)
    2. lhinds discussed setting up anteater as a chron job and notifying project team members (PTLs, committers, etc.) and asks how this could be done in a secure manner (rpaik, 13:07:52)
    3. uli-k proposes that scanning could also be scheduled via Jenkins (rpaik, 13:09:17)
    4. The reason to restrict scan results is to prevent security vulnerabilities from being made public (trevor_intel, 13:11:24)
    5. uli-k also proposed to notify PTL and committers about findings (uli-k, 13:12:41)
    6. still looking for the right location where to store these results, so only PTL and committers can access. (uli-k, 13:13:09)
    7. ACTION: lhinds aricg- to provide the missing details for the proposal (uli-k, 13:14:09)
    8. ACTION: lhinds/aricg to start a maling list conversation on where to store/communicate sensitive information from anteater (rpaik, 13:14:32)

  5. multiple repo's for OPNFV projects (rpaik, 13:15:31)
    1. https://gerrit.opnfv.org/gerrit/#/admin/projects/?filter=releng (jose_lausuch, 13:16:31)
    2. trozet shares that for Apex they need to modify upstream code and additional repo's are used to fork upstream code to put NFV features (rpaik, 13:17:43)
    3. https://wiki.opnfv.org/display/INF/Split+up+Releng+Repository (aricg-, 13:18:29)
    4. Apex team had a separate Github repo for upstream work, but this was brought into OPNFV (rpaik, 13:18:36)
    5. Bryan Sullivan (bryan_att, 13:19:41)
    6. uli-k notes if a process is needed for projects having multiple repos, or simply allow projects to create multiple repo's (by default) (rpaik, 13:21:12)
    7. bryan_att suggests not to restrict projects (uli-k, 13:21:26)
    8. ACTION: rpaik to confirm if there's written "rule" somewhere for 1 repo/project (rpaik, 13:22:35)
    9. there seems to be consensus to allow project teams to decide what is best for their project in terms of number of repo's (rpaik, 13:23:30)
    10. ACTION: rpaik to follow-up with community members via mailing list (rpaik, 13:24:45)
    11. in the absence of any specific bylaws constraint I suggest we just enable projects to notify (as a courtesy) the TSC that a new repo has been created, and if for some reason it seems that the freedom to do so is cuasing misbehavior, the TSC can step in later (bryan_att, 13:26:05)
    12. 3rd party license codes have been put into a "3rd party" directory (rpaik, 13:26:23)

  6. Request for OPNFV infra resources for project Bamboo PNDA instance (uli-k, 13:27:05)
    1. Aric and Ray propose to do it via google cloud (uli-k, 13:27:57)
    2. cost estimate would be 350$ (uli-k, 13:28:14)
    3. aricg notes that additional GCE resources maybe needed but donaldh is looking into this (rpaik, 13:28:44)
    4. that could be covered by TSC money (uli-k, 13:29:14)
    5. we need to look at alternatives that are not GCE based (bryan_att, 13:29:26)
    6. suggestion from trevor_intel and bryan_att is to also look at other alternatives and evaluate if resources are being used (after the decision is made) (rpaik, 13:30:06)
    7. ACTION: rpaik to ping donaldh and ask him to return to the next TSC call (rpaik, 13:32:43)
    8. Julien (Julien-zte, 13:32:47)

  7. approval of previous meeting minutes (rpaik, 13:33:13)
    1. no feedback/comments on previous minutes, thus minutes approved (rpaik, 13:33:24)
    2. mchandras (hwoarang, 13:33:38)
    3. Danube/Euphrates update (rpaik, 13:33:45)

  8. Danube/Euphrates update (uli-k, 13:34:03)
    1. dmcbride notes that Danube 3.0 is out (rpaik, 13:34:05)
    2. https://www.opnfv.org/software/downloads SW downloads page (rpaik, 13:34:16)
    3. mchandras (proxy for Fatih) (hwoarang, 13:34:24)
    4. for Euphrates Milestone 5 is July 28th (scenario integration & feature freeze) (rpaik, 13:34:56)
    5. MS6 (test case implementation) is August 11th (rpaik, 13:36:37)
    6. Milestone 5 implies that we don't expect new scenarios created after that (uli-k, 13:38:31)
    7. dmcbride notes that Fuel team has also documented their scenarios (rpaik, 13:39:08)

  9. LF IT/infra update (rpaik, 13:40:40)
    1. Rudy reports from the outage in Portland (uli-k, 13:41:25)
    2. basic notes that there was a power outage in Portland data center last week (rpaik, 13:41:30)
    3. this impacted many of our services in OPNFV (git/gerrit, wiki, etc) (rpaik, 13:42:13)
    4. outage for git/gerritt and JIRA was about 30 minutes, but for wiki it was bout 3 hours (rpaik, 13:44:32)
    5. root cause analysis is still on-going and there will be further communication to mailing lists (rpaik, 13:45:00)
    6. opnfv-tech-discuss is now subscribed to status.opnfv.org page (rpaik, 13:46:30)
    7. ACTION: basic to test the automatic posting on opnfv-tech-discuss (rpaik, 13:47:01)

  10. Test WG proposal (rpaik, 13:47:42)
    1. uli-k notes that there's a further action item for Test WG to work with Infra WG but this has not been done yet (rpaik, 13:48:34)
    2. Gabriel requires for a pod for long term stress test from test WG (Julien-zte, 13:49:11)
    3. https://global.gotomeeting.com/join/798898261 (GTM) (uli-k, 13:51:50)
    4. https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-July/017025.html (rpaik, 13:51:55)
    5. Is this about x-CI or stability testing? (bryan_att, 13:56:00)
    6. we need further discussion on this. I don't understand why we are using a new installer for this rather than the existing installers. (bryan_att, 14:00:43)
    7. we need to do stability testing on the existing OPNFV scenarios using existing OPNFV installers. (bryan_att, 14:01:36)
    8. propose to postpone this discussion to next week (rpaik, 14:01:48)


Meeting ended at 14:02:33 UTC (full logs).

Action items

  1. lhinds aricg- to provide the missing details for the proposal
  2. lhinds/aricg to start a maling list conversation on where to store/communicate sensitive information from anteater
  3. rpaik to confirm if there's written "rule" somewhere for 1 repo/project
  4. rpaik to follow-up with community members via mailing list
  5. rpaik to ping donaldh and ask him to return to the next TSC call
  6. basic to test the automatic posting on opnfv-tech-discuss


Action items, by person

  1. lhinds
    1. lhinds aricg- to provide the missing details for the proposal
    2. lhinds/aricg to start a maling list conversation on where to store/communicate sensitive information from anteater
  2. rpaik
    1. rpaik to confirm if there's written "rule" somewhere for 1 repo/project
    2. rpaik to follow-up with community members via mailing list
    3. rpaik to ping donaldh and ask him to return to the next TSC call


People present (lines said)

  1. rpaik (41)
  2. uli-k (23)
  3. bryan_att (12)
  4. jose_lausuch (6)
  5. Julien-zte (5)
  6. collabot (4)
  7. dneary (3)
  8. trevor_intel (2)
  9. lhinds (2)
  10. aricg- (2)
  11. hongbo4536982147 (2)
  12. hwoarang (2)
  13. yifei (1)
  14. timirnich (1)
  15. fuqiao (1)
  16. rossella_s (1)
  17. trozet (1)


Generated by MeetBot 0.1.4.