16:00:36 <fdegir> #startmeeting Infra WG Weekly Meeting
16:00:36 <collabot> Meeting started Mon Nov 20 16:00:36 2017 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:36 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:36 <collabot> The meeting name has been set to 'infra_wg_weekly_meeting'
16:00:42 <fdegir> #topic Rollcall
16:01:12 <David_Orange> #info David Blaisonneau
16:01:16 <aricg> #info Aric Gardner
16:01:20 <hw_wutianwei> #info Tianwei wu
16:01:32 <fdegir> #info Agenda is its on the usual place
16:01:41 <bramwelt> #info Trevor Bramwell
16:01:41 <jmorgan1> #info Jack Morgan
16:01:43 <dmcbride> #info David McBride
16:01:49 <fdegir> #link https://wiki.opnfv.org/display/INF/Infra+Working+Group
16:01:54 <fdegir> #chair jmorgan1
16:01:54 <collabot> Current chairs: fdegir jmorgan1
16:02:31 <fdegir> #topic Zuulv3 Prototype
16:03:09 <fdegir> #info We brought up 1 VM to start the prototype
16:03:17 <fdegir> #link https://etherpad.opnfv.org/p/opnfv-zuul-prototype
16:03:57 <fdegir> #topic Huawei Lab Migration
16:04:17 <fdegir> #info Huawei lab will be migrated during this week
16:04:18 <timirnich> #info Tim Irnich
16:05:15 <hw_wutianwei> huawei pod7 pod12 and virtual 5 to 7 are in xi' an lab
16:05:47 <hw_wutianwei> these pods will be offline during the time of migrating
16:05:48 <fdegir> #info PODs that will be impacted are pod7 pod12 and virtual 5 to 7
16:06:11 <fdegir> #info The PODs will be offline during the migration
16:07:09 <fdegir> #info Impacted projects are Compass and Joid - needs to be verified
16:07:39 <fdegir> #action hw_wutianwei and fdegir to contact the affected projects
16:08:01 <fdegir> #info An ARM based POD will be added as well
16:09:10 <fdegir> #info To connect the new PODs to Jenkins, a ticket is needed to be sent to LF Helpdesk
16:11:57 <fdegir> #topic CI Resources for JOID
16:12:28 <fdegir> #info narinder` sent a ticket to opnfv-helpdesk
16:12:43 <fdegir> #info Joid doesn't have any resources to run baremetal jobs
16:13:04 <fdegir> #info intel-pod18 needs to be connected to OPNFV Jenkins
16:13:47 <fdegir> #info To connect this POD to OPNFV Jenkins, workaround needs to be applied for port 80
16:14:37 <fdegir> #info Once the POD is connected to Jenkins, it needs to be labelled with joid-baremetal
16:15:14 <fdegir> #info And finally the slave needs to be added to slave-params.yml
16:15:15 <fdegir> #link https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=blob;f=jjb/global/slave-params.yml
16:15:51 <fdegir> #action narinder` to work with aricg/bramwelt to fix the slave
16:16:42 <fdegir> #topic XCI at Plugfest
16:17:50 <fdegir> #info XCI session is scheduled for Day 3
16:17:54 <fdegir> #link https://wiki.opnfv.org/display/EVNT/Euphrates+Plugfest+Schedule#EuphratesPlugfestSchedule-Day3(December6th)Schedule
16:19:05 <fdegir> #info Practices/principles to follow in order to be part of XCI need to be agreed on
16:19:20 <fdegir> #info Infra/CI practices such as PDF/IDF/SDF & dynamic CI, having people/hw, etc. which will be documented
16:23:40 <fdegir> #topic Sending Out MoM
16:23:58 <fdegir> #info Meeting minutes are sent to tech-discuss - see the last week's minutes
16:24:00 <fdegir> #link https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-November/019274.html
16:25:03 <fdegir> #topic How to use special hw and run tests on them
16:25:34 <fdegir> #info Some features require special hw or specific configuration which need to be handled
16:26:02 <fdegir> #info Discussion is needed to find out how to work on this
16:26:29 <fdegir> #info One option could be incorporating this into ongoing discussion to refresh Pharos spec
16:27:55 <fdegir> #info This is needed in order to easily find out which features are offered by which labs/PODs
16:28:48 <fdegir> #info Based on the information provided by the labs, we can automatically decide where a certain deployment should go or enable test frameworks to pick right test cases
16:31:32 <fdegir> #info Pharos spec can have some basic use cases and the above things could be additions on top of the base spec
16:33:34 <fdegir> #info A topic for plugfest has been added to the agenda: Testing hardware/software interactions brainstorming
16:33:40 <fdegir> #link https://wiki.opnfv.org/display/EVNT/Euphrates+Plugfest+Schedule#EuphratesPlugfestSchedule-Day4(December7th)Schedule
16:33:47 <fdegir> #info The day/time might change coming days
16:34:05 <fdegir> #action timirnich to follow up the topic during plugfest
16:35:34 <fdegir> #topic Define test requirements for gating scenarios for the release
16:36:26 <fdegir> #info This is simply improving release criteria by using the results from test runs
16:41:12 <fdegir> #info Tooling support is needed
16:42:15 <fdegir> #info Release Criteria needs to be discussed and brought up to TSC for approval once things are clarified within community
16:43:31 <fdegir> #action dmcbride to followup the topic to ensure this gets discussed during the plugfest
16:44:00 <fdegir> #topic Action Item Review
16:44:15 <fdegir> #info Open: Move PDF from Octopus repo to Pharos repo
16:44:33 <fdegir> #info Open: Talk about OPNFV Zuulv3 prototype within LF Infra/Releng to see how it fits into overall LF strategy/backlog
16:45:19 <fdegir> #info Open: Review the no of PODs installers have
16:45:53 <fdegir> #info Open: Update documents on CI POD requirements
16:47:20 <fdegir> #info Open: Clean up securelab access including creating new ldap group for lab owners
16:47:49 <fdegir> #info The encryption will be done per lab basis as needed and the above action item can be closed once the PDFs moved to pharos repo
16:48:15 <fdegir> #info After some time, securedlab usage should be blocked
16:48:52 <fdegir> #info Open: Clean up non-active Pharos committers - lab owners will be made Pharos committers
16:49:32 <fdegir> #info Open: Pharos project needs to define hardware details to be included
16:49:35 <fdegir> #info Done: Send email to Lab owners to request them to input lab information into dashboard
16:50:13 <fdegir> #info Done: Infra WG needs to decide how to manage documentation - we have two proposal
16:50:30 <fdegir> #action jmorgan1 to decide how to handle pharos/hw infra documentation
16:51:15 <fdegir> #info Done: start email thread on transitioning docker build script to the releng project
16:52:29 <fdegir> #info Open: schedule a Plugfest discussion on logging facilities
16:56:35 <Joe____> #info Joe Kidder
16:56:50 <fdegir> jmorgan1: this is how it looks on mailman: https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-October/018782.html
16:57:04 <fdegir> jmorgan1: did you send as an attachment to the mail?
16:57:23 <fdegir> #endmeeting