#opnfv-meeting: Infra WG Weekly Meeting

Meeting started by fdegir at 16:00:54 UTC (full logs).

Meeting summary

  1. Rollcall (fdegir, 16:01:59)
    1. Jack Morgan (jmorgan1, 16:02:11)
    2. Trevor Bramwell (bramwelt, 16:02:18)

  2. Committer list per repo (fdegir, 16:03:39)
    1. https://docs.openstack.org/infra/system-config/project.html#teams (jmorgan1, 16:05:06)
    2. The proposal has been sent to opnfv-tech-discuss mailing list as well (fdegir, 16:05:08)

  3. Meetings coming weeks (fdegir, 16:06:32)
    1. Upcoming Infra WG Meetings on December 18th, 25th, January 1st (fdegir, 16:07:13)
    2. December 25th and January 1st meetings will be cancelled (fdegir, 16:07:48)
    3. December 18th meeting will be held (fdegir, 16:07:57)
    4. ACTION: fdegir to check with lhinds regarding Infra WG Meeting chair (fdegir, 16:09:10)
    5. ACTION: fdegir to remind the next chair regarding going back to original start time, 15:00UTC (fdegir, 16:09:28)

  4. Follow up decisions from Plugfest (fdegir, 16:09:47)
    1. jmorgan1 to send an email about plugfest discussions regarding PDF (fdegir, 16:10:09)
    2. The template to use is the one in pharos repo (fdegir, 16:10:19)
    3. Network configuration details will be moved to IDF and work with IDF will continue (fdegir, 16:10:38)
    4. Version number will be added to PDF template and this will be inherited into PDFs for the PODs (fdegir, 16:13:03)
    5. The proposed version is 2 digit versioning; x.y (fdegir, 16:13:51)
    6. IDF and SDF need similar versioning and they need to match to each other (fdegir, 16:15:00)
    7. ACTION: bramwelt to create repo and start working on it (fdegir, 16:19:48)
    8. Other things to remember are configuring gsutil and docker credentials (fdegir, 16:22:38)
    9. ACTION: jmorgan1 to pass the names of the slaves connected from Intel lab for removal (fdegir, 16:23:38)
    10. AGREED: Automatically remove Jenkins slaves that have been offline for 4 months or more (fdegir, 16:26:57)
    11. ACTION: aricg to remove the slaves offline for 4 months or more (fdegir, 16:27:03)

  5. Release Automation (fdegir, 16:28:39)
    1. https://etherpad.opnfv.org/p/release-automation (fdegir, 16:28:55)
    2. https://github.com/openstack/releases/tree/master/deliverables (fdegir, 16:29:33)
    3. https://github.com/openstack/releases (fdegir, 16:33:57)
    4. Create a release repo and 1 folder per release and 1 yaml file per project under release folder (fdegir, 16:36:29)
    5. It would be beneficial to look at the schema used by OpenStack Release Team and come with a proposal (fdegir, 16:38:26)
    6. releng/releases/fraser/<project>.yaml (fdegir, 16:39:02)
    7. ACTION: dmcbride to look at the schema used by OpenStack and come up with a simplified proposal for OPNFV (fdegir, 16:40:40)
    8. Euphrates can be sample release to try the schema out (fdegir, 16:41:04)

  6. Action Item Review (fdegir, 16:41:39)
    1. OPEN: Follow up the use of #lf-releng and send notification to opnfv-tech-discuss (fdegir, 16:42:46)
    2. https://epir.at/2016/06/26/redirecting-freenode-channels/ (aricg, 16:43:46)
    3. ACTION: bramwelt to talk to zxiiro about redirection details (fdegir, 16:44:45)
    4. OPEN: Investigate configuring the default path for Jenkins consistently/globally (fdegir, 16:45:04)
    5. OPEN: Propose new committers for Pharos for review - ai moved to jmorgan1 (fdegir, 16:45:43)
    6. OPEN: Clean-up none-active pharos committer (fdegir, 16:47:04)
    7. ACTION: jmorgan1 to talk to BII for moving lab/pod config to pharos (fdegir, 16:48:36)
    8. OPEN: Think about how to automate build server/vPOD configuration (fdegir, 16:49:19)
    9. ACTION: dmcbride to start conversation around defining the test requirements for gating scenarios for the release (fdegir, 16:50:17)
    10. OPEN: Decide how to handle Pharos/HW Infra documentation (fdegir, 16:50:47)
    11. OPEN: Move SDF from Octopus to Pharos repo (fdegir, 16:50:55)
    12. OPEN: Review the no of PODs installers have - aghenda item for the next meetint (fdegir, 16:51:34)
    13. https://gerrit.opnfv.org/gerrit/#/c/48287/ (bramwelt, 16:51:45)
    14. OPEN : Update documents on CI POD requirements ^ (fdegir, 16:51:52)
    15. DONE: schedule a Plugfest discussion on logging facilities (fdegir, 16:52:54)
    16. bramwelt will follow this up in mailing list (fdegir, 16:53:23)
    17. The conversation around Pharos spec refresh will continue during new year (fdegir, 16:54:53)
    18. Pharos spec refresh will be discussed during the Infra WG meeting (fdegir, 16:55:47)


Meeting ended at 16:58:20 UTC (full logs).

Action items

  1. fdegir to check with lhinds regarding Infra WG Meeting chair
  2. fdegir to remind the next chair regarding going back to original start time, 15:00UTC
  3. bramwelt to create repo and start working on it
  4. jmorgan1 to pass the names of the slaves connected from Intel lab for removal
  5. aricg to remove the slaves offline for 4 months or more
  6. dmcbride to look at the schema used by OpenStack and come up with a simplified proposal for OPNFV
  7. bramwelt to talk to zxiiro about redirection details
  8. jmorgan1 to talk to BII for moving lab/pod config to pharos
  9. dmcbride to start conversation around defining the test requirements for gating scenarios for the release


Action items, by person

  1. aricg
    1. aricg to remove the slaves offline for 4 months or more
  2. bramwelt
    1. bramwelt to create repo and start working on it
    2. bramwelt to talk to zxiiro about redirection details
  3. fdegir
    1. fdegir to check with lhinds regarding Infra WG Meeting chair
    2. fdegir to remind the next chair regarding going back to original start time, 15:00UTC
  4. jmorgan1
    1. jmorgan1 to pass the names of the slaves connected from Intel lab for removal
    2. jmorgan1 to talk to BII for moving lab/pod config to pharos
  5. zxiiro
    1. bramwelt to talk to zxiiro about redirection details
  6. UNASSIGNED
    1. dmcbride to look at the schema used by OpenStack and come up with a simplified proposal for OPNFV
    2. dmcbride to start conversation around defining the test requirements for gating scenarios for the release


People present (lines said)

  1. fdegir (56)
  2. aricg (4)
  3. collabot (4)
  4. zxiiro (3)
  5. bramwelt (2)
  6. collabot` (2)
  7. jmorgan1 (2)


Generated by MeetBot 0.1.4.