#opnfv-meeting: Infra WG Meeting

Meeting started by fdegir at 15:00:14 UTC (full logs).

Meeting summary

  1. Rollcall (fdegir, 15:01:02)
    1. Trevor Bramwell (bramwelt, 15:01:59)
    2. Frank Brockners (frankbrockners, 15:02:02)
    3. Aric Gardner (aricg, 15:02:13)

  2. LaaS Update/Progress/Demo (fdegir, 15:02:18)
    1. Automatic email notification is working (fdegir, 15:02:39)
    2. Jack Morgan (jmorgan1, 15:03:03)
    3. There will be downtime a day or two Monday/Tuesday next week for shuffling servers around (fdegir, 15:03:31)
    4. Julien (Julien-zte, 15:04:43)
    5. Work with ARM servers seems to be challenging and community might be able to help to ease things up (fdegir, 15:05:24)
    6. Post build script to connect LaaS machines to OPNFV Sandbox Jenkins is ready and needs to be trialled (fdegir, 15:07:05)
    7. Mail will be sent to the all people who has active booking in addition to opnfv-tech-discuss (fdegir, 15:13:57)
    8. First mail notifying the user about the booking will come in few minutes (fdegir, 15:14:19)
    9. The last mail after the provisioning will arrive in an hour or so (fdegir, 15:14:36)
    10. Mails are sent in cleartext (fdegir, 15:15:23)
    11. the user will receive an access email with vpn credentials (Julien-zte, 15:15:25)
    12. the email sent without encrypt (Julien-zte, 15:15:59)
    13. The hope is to get ARM servers up and running end of next week - but no promises due to challenges with them (fdegir, 15:16:40)

  3. PDF/IDF presentation and approval during TSC Meeting March 6th (fdegir, 15:17:41)
    1. https://wiki.opnfv.org/display/INF/Infra+Working+Group (fdegir, 15:19:07)
    2. The 4 steps to use PDF/IDF in production are (fdegir, 15:20:39)
    3. Stage 1: All CI PODs adapt to PDF/IDF: April 20th (fdegir, 15:20:56)
    4. Stage 2: All installers adapt to PDF/IDF: June 15th (fdegir, 15:21:07)
    5. Stage 3: All community labs adapt to PDF/IDF: August 15th (fdegir, 15:21:15)
    6. Stage 4: CI switched to dynamic resource allocation for baremetal PODs: Augus 30th (fdegir, 15:21:25)
    7. PDFs have been moved from securedlab repo to pharos repo and encryption is enabled (fdegir, 15:22:04)
    8. Patch verification has been enabled as well (fdegir, 15:22:19)

  4. Jenkins Sandbox (fdegir, 15:45:37)
    1. Jenkins Sandbox has been upgraded and it matches to production Jenkins instance (fdegir, 15:46:01)
    2. Move of dev resources to Sandbox Jenkins needs to be discussed further (fdegir, 15:46:29)
    3. Usage Policy for Sandbox Jenkins is needed (fdegir, 15:46:42)
    4. LaaS Machines will be connected to Sandbox Jenkins as part of trials - Jenkins Swarm Plugin could be used (fdegir, 15:47:10)
    5. https://wiki.jenkins.io/display/JENKINS/Swarm+Plugin (fdegir, 15:47:22)
    6. Plugin list on both production and sandbox jenkins will be documented (fdegir, 15:48:27)
    7. Global JJB documentation is available as well and this includes the documentation to use Sandbox Jenkins (fdegir, 15:50:51)

  5. Infra WG Meeting Chair (fdegir, 15:51:30)
    1. https://etherpad.opnfv.org/p/chair_infra_wg (Julien-zte, 15:52:18)
    2. Aric/Trevor to chair Infra WG Meeting between March 12th - April 30th (fdegir, 15:52:44)
    3. ACTION: aricg and bramwelt to send Infra WG meeting invitation for March 12th - April 30th (including April 30th) (fdegir, 15:55:09)


Meeting ended at 15:59:02 UTC (full logs).

Action items

  1. aricg and bramwelt to send Infra WG meeting invitation for March 12th - April 30th (including April 30th)


Action items, by person

  1. aricg
    1. aricg and bramwelt to send Infra WG meeting invitation for March 12th - April 30th (including April 30th)
  2. bramwelt
    1. aricg and bramwelt to send Infra WG meeting invitation for March 12th - April 30th (including April 30th)


People present (lines said)

  1. fdegir (37)
  2. frankbrockners (14)
  3. Julien-zte (6)
  4. collabot` (3)
  5. AlexAvadanii (2)
  6. aricg (1)
  7. bramwelt (1)
  8. jmorgan1 (1)


Generated by MeetBot 0.1.4.