#opnfv-meeting: Weekly Technical Discussion

Meeting started by bh526r at 13:00:28 UTC (full logs).

Meeting summary

  1. Roll Call (bh526r, 13:01:08)
    1. David McBride (bh526r, 13:01:21)
    2. Julien (bh526r, 13:01:26)
    3. Ray Paik (bh526r, 13:01:32)
    4. Aric Gardner (bh526r, 13:01:45)
    5. Ray Paik (rpaik, 13:01:56)
    6. Tim Irnich (bh526r, 13:02:47)
    7. Julien (Julien-zte, 13:03:34)

  2. Fraser Release Checkpoint (bh526r, 13:03:59)
    1. David reviewed Installer status (bh526r, 13:05:06)
    2. Apex and Compass are all positive/green (bh526r, 13:05:31)
    3. Daisy starts to have issues (bh526r, 13:06:00)
    4. and ARMBand has issues too (bh526r, 13:07:02)
    5. Fuel are all green (bh526r, 13:07:09)
    6. Joid: some healthcheck are not running (bh526r, 13:07:33)
    7. Cristina Pauna (CristinaPauna, 13:07:56)
    8. Cedric Ollivier (bh526r, 13:08:16)
    9. Cristina Pauna (ENEA) (bh526r, 13:08:37)
    10. Al Morton (bh526r, 13:08:52)
    11. Bertrand Souville (bh526r, 13:09:14)
    12. Ting Wu (bh526r, 13:09:28)
    13. Looking at test result pages: all have single iteration (bh526r, 13:10:56)
    14. A few have 2 (bh526r, 13:11:28)
    15. Very few results show up recently (bh526r, 13:12:20)
    16. Bryan Sullivan (bh526r, 13:12:43)
    17. Cedric indicated if we look at Jenkins page, we can see which are running, and which are not (bh526r, 13:15:01)
    18. N/A means not executed (bh526r, 13:15:32)
    19. armband fraser runs: https://build.opnfv.org/ci/job/functest-fuel-armband-baremetal-arm-daily-fraser/ (CristinaPauna, 13:16:22)
    20. Cristina indicated that there might be issues in Jenkins page. Some are executed, but not captured in Jenkins page. e.g. above link (bh526r, 13:17:29)
    21. Cedric will fix the Jenkins page issue (bh526r, 13:17:43)
    22. David get a sense that there hasn't been change by Tuesday. So David thinks we need to postpone the release (bh526r, 13:19:06)
    23. Tim summarized that we can package the artifacts and someone can start to use it now, although not formally released. (bh526r, 13:21:42)
    24. Tim asked status of feedback of install PTLs (bh526r, 13:22:12)
    25. David said he has approached the PTLs of those projects that have issues (bh526r, 13:23:29)
    26. David got feedback from all except ARMBand (bh526r, 13:23:51)
    27. the feedback are mostly that PTLs redirect to another person who has more insight of the issues (bh526r, 13:24:37)
    28. One possibility is that by Monday 4/16, there will be significant change of status (bh526r, 13:25:01)
    29. Another possibility is that it is still in debug mode on Monday 4/16 (bh526r, 13:25:22)
    30. Julien indicated that there are some misinformation in jjb files for Daisy (bh526r, 13:26:41)
    31. David will ask PTLs to report most recent status on Monday 4/16. And we will have most recent information on Tuesday TSC meeting to discuss and make decision (bh526r, 13:28:24)
    32. ACTION: David will ask PTLs to report most recent status on Monday 4/16. (bh526r, 13:28:39)

  3. Pharos 2.0 Status (bh526r, 13:28:56)
    1. Julien gave update (bh526r, 13:29:42)
    2. More scenarios to cover: OpenStack as VIM, k8s as VIM and Edge (bh526r, 13:30:19)
    3. More hardware: Accelerators (FPGA and GPU) (bh526r, 13:31:05)
    4. Questions about whether or not to cover whitebox switches and/or TOR (bh526r, 13:31:36)
    5. Performance test includes traffic generator (NFVBench, VSPerf and QTIP) and NIC (SR-IOV) (bh526r, 13:33:57)
    6. Tim suggested to consider smart NIC (bh526r, 13:34:10)
    7. Servers: deatiled settings and specific features (bh526r, 13:34:44)
    8. NIC: from single NIC server to multiple NIC server, NIC bonding and DHCP zones (bh526r, 13:35:14)
    9. Tim suggested to include L1 switch in Pharos spec (bh526r, 13:36:50)
    10. This is something new in Pharos (bh526r, 13:37:04)
    11. ... for further study (bh526r, 13:37:14)
    12. Storage: dedicated storage nodes and external storage service (bh526r, 13:37:55)
    13. Tool: hardware mgmt tools and jump server auto provisioning tool (bh526r, 13:38:55)
    14. Julien plans to get response from community, such as top priority that need to be implemented first (bh526r, 13:41:12)
    15. Those top priority features will be implemented first considering resource limitation (bh526r, 13:41:36)
    16. Tim suggested that the theme is we support both software and hardware, and both OpenStack and k8s (bh526r, 13:43:36)
    17. Tim suggested to model Pharos typical hardware stack spec (bh526r, 13:48:00)
    18. e.g. what are the representative hardware stack (bh526r, 13:48:53)
    19. ACTION: Bin and Julien sync up with the infrastructure resource model in ONAP and the Pharos spec in OPNFV (bh526r, 14:00:29)
    20. Bin and Julien will start email communication, including Tim, Bryan and whoever are interested (bh526r, 14:02:28)
    21. Meeting adjourned (bh526r, 14:03:57)


Meeting ended at 14:04:00 UTC (full logs).

Action items

  1. David will ask PTLs to report most recent status on Monday 4/16.
  2. Bin and Julien sync up with the infrastructure resource model in ONAP and the Pharos spec in OPNFV


People present (lines said)

  1. bh526r (61)
  2. collabot` (3)
  3. CristinaPauna (2)
  4. rpaik (2)
  5. Julien-zte (2)


Generated by MeetBot 0.1.4.