13:00:12 <bh526r> #startmeeting Airship Installer Project Kickoff Meeting
13:00:12 <collabot`> Meeting started Thu Aug  1 13:00:12 2019 UTC.  The chair is bh526r. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:12 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:12 <collabot`> The meeting name has been set to 'airship_installer_project_kickoff_meeting'
13:00:23 <bh526r> #topic Roll Call
13:01:01 <bh526r> #info Bin Hu
13:01:11 <bh526r> #info Sridhar Rao
13:01:31 <bh526r> #info Rajesh Rajamani
13:02:23 <bh526r> #info Bin Yang
13:02:29 <bh526r> #info Georg Kunz
13:04:19 <bh526r> #info Kaspars Skels
13:05:06 <bh526r> #info Mark Beierl
13:05:19 <mbeierl> #info Mark Beierl
13:06:42 <kskels> o/
13:10:27 <bh526r> #topic Admin Update
13:11:39 <bh526r> #info All agreed to 6am PT Thursdays considering all factors
13:11:57 <bh526r> #info Bin Yang suggested biweekly
13:12:41 <bh526r> #info All agreed to biweekly. If needed, we can adjust in the future
13:13:19 <bh526r> #topic Project Plan
13:16:49 <bh526r> #info Mark Shostak
13:20:35 <bh526r> #info Bin shared initial goal of getting Airship deployed manually and proof out everything in one or more community labs
13:21:30 <bh526r> #info Bin shared that we followed community process and requested hardware resources from Intel community lab, and got pod 17 & pod 18 resources
13:22:54 <bh526r> #info Rajesh indicated that Spirent will establish a lab, and replicate the deployment in Intel lab into Spirent lab
13:25:30 <bh526r> #info So we will have at least 2 labs - Intel lab and Spirent lab
13:26:21 <bh526r> #info Bin introduced  initial 3 JIRA issues for this initial goal and activities
13:26:36 <bh526r> #info Kaspars gave more details of the work planned to do
13:27:12 <bh526r> #info Mark asked if we plan to develop a tool to convert PDF into Airship declarative YAML
13:28:41 <bh526r> #info Bin shared that the tool is on the plan of record. Once we finish the initial deployment in Intel lab and Spirent lab, the tool development will be put on the list of tasks.
13:29:14 <bh526r> #info If we will have more community resources to help develop the tool, it will accelerate the work of tool development
13:29:25 <bh526r> #info Mark also asked CI/CD
13:30:26 <bh526r> #info Kaspars shared that current CI/CD is Jenkins based, and managed by Treasuremap component. We are also investigating if CircleCI makes sense.
13:31:26 <bh526r> #info Sridhar asks about the hardware profile, topology etc.
13:32:07 <bh526r> #info Kaspars shared some details of the YAML files for hardware profile, networking / VLAN etc.
13:44:02 <bh526r> #action Kaspars to prepare a deep dive of hardware topology diagram, and how it describes Intel lab topology.
13:45:12 <bh526r> #info Georg asked how to handle missing features, such as DPDK, and provide input to upstream Airship community
13:51:26 <bh526r> #info Bin shared how IPv6 and Doctor did in the past regarding providing new features to upstream (OpenStack)
13:52:48 <bh526r> #info The 1st step is to document all gaps between current Airship features and CNTT specs
13:56:10 <bh526r> #info Then we bring the gaps to upstream Airship, start communication and coordination
13:59:18 <bh526r> #info If Airship can commit to some features in a timely manner, great.
14:00:36 <bh526r> #info If not, we may start to work on those features in parallel to meet CNTT needs, then eventually upstream our patch to Airship community. This is because of our "upstream first" principle in OPNFV
14:01:35 <bh526r> #info Georg agreed it is a good approach, and also indicated that communication and collaboration is extremely important
14:02:08 <bh526r> #action Georg happily agree to take the action of gap analysis once CNTT spec is stable
14:03:40 <bh526r> #info Sridhar asked if we need description document before CNTT reference mode
14:04:22 <bh526r> #info Bin answered that once CNTT specs is ready, we need to translate it into machine-readable format, which is the YAML consumed by Airship
14:05:22 <bh526r> #info All are excited.
14:05:30 <bh526r> #topic AOB
14:06:50 <bh526r> #info We will resume in 2 weeks and give project update
14:06:56 <bh526r> #info Meeting adjourned
14:07:00 <bh526r> #endmeeting