13:00:16 <mbeierl> #startmeeting OPNFV TSC Meeting 2019-10-08
13:00:16 <collabot_> Meeting started Tue Oct  8 13:00:16 2019 UTC.  The chair is mbeierl. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:16 <collabot_> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:16 <collabot_> The meeting name has been set to 'opnfv_tsc_meeting_2019_10_08'
13:00:22 <mbeierl> #chair bh526r
13:00:22 <collabot_> Current chairs: bh526r mbeierl
13:01:21 <mbeierl> #topic Roll Call
13:01:33 <bh526r> #info Bin Hu
13:02:14 <trevor_intel> #info Trevor Cooper
13:02:32 <mbuil> #info Manuel Buil
13:02:38 <georgk> #info Georg Kunz (IRC only)
13:03:25 <bh526r> #info Mark Beierl
13:03:41 <mbeierl> Thanks Bin, I guess I forgot to info myself!
13:03:54 <bh526r> :)
13:05:15 <pkaralis> #info Panagiotis Karalis (IRC only)
13:06:13 <bh526r> #info Frank Brockners
13:06:20 <mbeierl> For those who are IRC only, I will be acting as the minute taker.  Let me know if I need to clarify anything as we move along
13:06:40 <mbeierl> #topic Antitrust Policy Notice
13:06:53 <mbeierl> #info Jim presented the policy
13:07:01 <mbeierl> #topic Approval of previous minutes
13:07:39 <bh526r> #info Cedric Ollivier
13:07:51 <mbeierl> #link http://meetbot.opnfv.org/meetings/opnfv-meeting/2019/opnfv-meeting.2019-10-01-13.04.html
13:08:04 <mbeierl> #info any comments on the previous meeting minutes?
13:08:12 <mbeierl> #info Minutes are approved
13:08:14 <frankbrockners> #info Frank Brockners
13:08:27 <mbeierl> #topic Agenda Bashing
13:08:46 <mbeierl> #link https://wiki.opnfv.org/display/meetings/TSC#TSC-October8,2019
13:09:31 <mbeierl> #info Bin reads out the proposed agenda from the link above
13:09:41 <mbeierl> #info no chair report today
13:10:09 <mbeierl> #info if anyone on IRC wants to add to agenda, please  let me know
13:11:43 <mbeierl> #info mbeierl would like to discuss the recording of zoom meetings
13:13:23 <mbeierl> #info Cedric mentions there is also an email thread on IRC only
13:13:45 <mbeierl> #info discussion - if Zoom recording does not pass, and IRC only does not pass, then we would keep status quo
13:15:58 <mbeierl> #info mbeierl suggests that the recording of audio/video or IRC only should serve the community to provide more transparency to the discussions
13:16:11 <mbeierl> #info that is why the two proposals are being tied together
13:16:16 <mbeierl> #info agenda is approved
13:16:26 <mbeierl> #topic Python 3 status
13:17:19 <mbeierl> #info Cedric checked, there are 2/3 projects that are missing python 3 support
13:17:43 <mbeierl> #info tempest is in Python 2
13:18:32 <mbeierl> #info Cedric believes there should be no impact to OPNFV committing to Python 3 completely
13:18:56 <mbeierl> #info Cedric will double check with OSLO and Swift to confirm
13:19:24 <mbeierl> #info Cedric confirms Jan 1 2020 is EOL for Python 2 and it is clear to all that this is a hard date
13:20:56 <mbeierl> #info ollivier suggests we can also run the python2 checker to ensure we are completely moved over
13:21:29 <mbeierl> #info ollivier says even Linux find command can be used to search
13:22:05 <mbeierl> #info ollivier also states a heavy approach could be to remove python2 from the build infrastructure
13:22:22 <mbeierl> #info dmcbride asks ollivier to send an email with the search methods
13:22:37 <mbeierl> #action ollivier will send out email about how to check for python2
13:22:50 <mbeierl> #topic Next DDF/Plugfest update
13:23:09 <mbeierl> #info Jim states there are different locations being investigated
13:23:18 <mbeierl> #info Decision should come this week
13:23:32 <mbeierl> #info sites are Warsaw, Prague, Budapest and Singapore
13:23:46 <mbeierl> #info Board embraced the idea of LF sponsored events
13:24:15 <mbeierl> #info shift will allow us to set dates in advance
13:24:58 <mbeierl> #info Panama did not receive quorum for decision, so the opportunity is gone
13:25:02 <mbeierl> #topic Role, Responsibility and Expectation of LFN Infra Support for Issues in Community Labs
13:25:43 <mbeierl> #info trevor_intel: As CNTT activities are ramping up, we want to use our community labs
13:26:07 <mbeierl> #info trevor_intel: as new members are starting to use resources, this is becoming more important
13:26:24 <mbeierl> #info trevor_intel: we used to have infra working group and pharos, which are no longer operating
13:26:51 <mbeierl> #info trevor_intel: an example - issues in Intel lab have been going around between LF helpdesk and others, with no owner
13:27:14 <mbeierl> #info trevor_intel: where do users go for support - JIRA, mailing list, helpdesk email
13:27:29 <mbeierl> #info  trevor_intel: this is going to get worse as CNTT ramps up
13:28:25 <mbeierl> #info trevor_intel: as Jack Morgan no longer works for Intel, and he was one of the primary resources, the remaining resources are not in a position to provide that level of support
13:28:55 <mbeierl> #info trevor_intel: we seem to have lost some visibility into the community labs, and we should try to revitalize the infra community
13:29:32 <mbeierl> #info Jim: labs are critical to success, Mark Cotrell suggest federating labs
13:30:13 <mbeierl> #info trevor_intel: 1) have a clear understanding of communication mechanisms, requesting support,
13:30:32 <mbeierl> #info trevor_intel: 2) what level of support can LFN support provide for community labs
13:31:04 <mbeierl> #info ollivier: question - how can the community help with the infra support
13:32:10 <mbeierl> #info trevor_intel: have someone step up to lead the infra working group / combined pharos+infra with regular calls and work through the issues and make recommendations
13:32:29 <mbeierl> #info Jim: we are defining the problem space
13:32:47 <mbeierl> #info trevor_intel: agrees, but how do we go about tackling this
13:33:01 <mbeierl> #info bh526r: start email thread and discuss in weekly tech call
13:33:14 <mbeierl> #info ollivier: maybe question for community role should be asked at TAC level
13:33:43 <mbeierl> #info Mike Fix: Heather volunteered to look into health of labs
13:34:04 <mbeierl> #info Mike Fix will cycle back with her to where that is at
13:34:35 <mbeierl> #info bh526r: comments status of labs is unknown (there are 18 or more of them)
13:35:05 <mbeierl> #info ollivier: there are a few Jenkins slave that are down, which is an indication that the community lab is also down
13:35:55 <mbeierl> #info Mike Fix: clarifies his action is to follow up with Heather to see if she is still available to volunteer
13:36:08 <mbeierl> #info Jim Baker: can we have a TSC volunteer to drive this
13:36:39 <mbeierl> #info trevor_intel: suggests we follow bh526r's suggestion of email and weekly tech call follow up to find leader
13:37:24 <mbeierl> #info bh526r suggests two actions: 1) Mike to follow up with Heather, 2) discuss in Monday weekly tech calls
13:38:16 <mbeierl> #info any other comments?
13:38:21 <mbeierl> #topic SPC Update
13:38:51 <mbeierl> #info trevor_intel: SPC is working on asks from Board after the strategy presentation in Antwerp
13:39:26 <mbeierl> #info trevor_intel: board requested info on end user input and KPIs and metrics relating to the objectives
13:39:57 <mbeierl> #info trevor_intel: SPC is getting input from EUAG.  Vodafone is chair and is providing info
13:40:06 <mbeierl> #info any questions?
13:40:20 <mbeierl> #topic CNTT in OPNFV Update
13:40:47 <bh526r> #info Qiao Fu
13:41:26 <mbeierl> #info Mike: coming out of Antwerp, we aligned on needing to secure a lab, extract requirements from RI, and define installer requirements
13:41:30 <bh526r> #info Al Morton
13:41:39 <mbeierl> #info Mike: we are going to work through the next steps to get RA deployed
13:41:57 <mbeierl> #info Mike: working with trevor_intel on securing a lab
13:42:11 <mbeierl> #info any questions?
13:43:07 <mbeierl> #info trevor_intel: re CNTT-RI project, do we have regular meetings?
13:43:26 <mbeierl> #info trevor_intel: are we waiting for definition from CNTT?
13:43:37 <mbeierl> #info Mike: plan is to start weekly meetings next week
13:43:59 <mbeierl> #info Mike: the RA is available in terms of requirements, now to translate that to an installer and test project
13:45:12 <mbeierl> #info trevor_intel: what is confusing to trevor_intel is the structure: we have reference implementation, we are going from available requirements, now we have CNTT RI in OPNFV, then what is the work of the RI within the CNTT?  As opposed to CNTT-RI in OPNFV?
13:46:02 <mbeierl> #info Ravi?: CNTT is temporary, so OPNFV CNTT-RI is a mirror of the workstream RI in CNTT, so when CNTT disappears, CNTT-RI lives on
13:46:10 <mbeierl> #undo
13:46:10 <collabot_> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x23232d0>
13:46:21 <mbeierl> #info Rabi: CNTT is temporary, so OPNFV CNTT-RI is a mirror of the workstream RI in CNTT, so when CNTT disappears, CNTT-RI lives on
13:46:38 <mbeierl> #info trevor_intel: will there be CNTT RI meetings as well as OPNFV CNTT-RI meetings?
13:46:42 <mbeierl> #info Rabi: No
13:47:03 <mbeierl> #info JIm: CNTT-RI is the implementation of the CNTT task force
13:47:27 <mbeierl> #info Mike: this was started in OPNFV with the purpose of OPNFV being the delivery vehicle
13:48:18 <mbeierl> #info Rabi: work was started in GSMA to create a reference model, so the same thing is expected from OPNFV: CNTT does the definition, OPNFV implements it and the RI lives on there
13:48:51 <mbeierl> #info Jonathan Beltran: resources come from CNTT, and continue collaboratively under the umbrella of OPNFV
13:49:22 <mbeierl> #info Al Morton: Mike, can we do a doodle poll for the time slot of CNTT-RI weekly meeting?
13:49:28 <mbeierl> #info Mike agrees
13:49:56 <mbeierl> #info Mike: would love ideas on CNTT as a group - rotating schedule to accommodate international hours
13:50:10 <mbeierl> #undo
13:50:10 <collabot_> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c89810>
13:50:28 <mbeierl> #info Jonathan: would love ideas on CNTT as a group - rotating schedule to accommodate international hours
13:51:12 <mbeierl> #info Al: confirms it can be successful, and has not been successful on other projects, but hopes it will work for CNTT-RI to have rotating times
13:51:38 <mbeierl> #info Jim: asks about 10 concurrent RI - is our toolchain ready to handle that?
13:51:53 <mbeierl> #info Jim: ask if there is anyone who wants to engage on this project?
13:52:18 <mbeierl> #info Jim: we have contracting resources, but need clear deliverable and objectives
13:52:24 <mbeierl> #info Jim: is anyone interested?
13:52:30 <mbeierl> #info Jim received no reply
13:52:32 <mbeierl> #topic Iruya Release Update
13:52:45 <mbeierl> #info dmcbride: has been out for a few weeks
13:52:56 <mbeierl> #info dmcbride: Milestone 1 was September 30
13:53:06 <mbeierl> #info dmcbride: as of that date, 14 projects expressed intent
13:53:12 <mbeierl> #info dmcbride:part of MS1 is release plan
13:53:36 <mbeierl> #info dmcbride:we have 50% compliance with release plans, and is following up with the PTLs
13:53:42 <mbeierl> #info dmcbride:MS2 is OpenStack integration
13:53:58 <mbeierl> #info dmcbride: reminder this is a compressed schedule, dates are coming up fast
13:54:23 <mbeierl> #info dmcbride: MS2 is mainly for installers, which is only FUEL and Airship
13:54:26 <mbeierl> #info any questions?
13:55:11 <mbeierl> #info ollivier: reminds that email about releng participating in the release, would like clarification
13:55:33 <mbeierl> #info bramwelt: releng is participating due to releng-xci
13:55:52 <mbeierl> #info bramwelt: releng participates due to historical support
13:56:14 <mbeierl> #info: ollivier should clarify releng vs releng-xci
13:56:39 <mbeierl> #info dmcbride: suggests breaking projects out into projects types, including support projects like releng and opnfvdocs
13:57:08 <mbeierl> #info dmcbride: once we move to the new process, we should have more clarification
13:57:20 <mbeierl> #topic LF IT/Infra update
13:57:25 <mbeierl> #info no update
13:59:17 <mbeierl> #Topic IRC and Zoom recording
13:59:27 <ollivier> #link https://lists.opnfv.org/g/opnfv-tsc/topic/32967803#5484
14:00:53 <mbeierl> #info mbeierl questions - is this a TSC decision, a community decision, or should we just ask the LFN to decide for us?
14:01:53 <ollivier> #link https://lists.opnfv.org/g/opnfv-tsc/message/5492
14:02:10 <mbeierl> #info: it's not time to vote as we need to know what the community wants
14:02:31 <mbeierl> #info Jim: let's start an actual poll
14:02:38 <mbeierl> #info: will discuss next week
14:02:47 <mbeierl> #action mbeierl to send email and start poll
14:05:21 <mbeierl> #info we are past the hour
14:07:14 <mbeierl> #info any further questions, comments from IRC?
14:07:26 <mbeierl> #info ending meeting in 3, 2, 1....
14:07:33 <mbeierl> #endmeeting