13:00:19 <bh526r> #startmeeting Weekly Technical Discussion 154
13:00:19 <collabot> Meeting started Mon Oct 14 13:00:19 2019 UTC.  The chair is bh526r. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:19 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:19 <collabot> The meeting name has been set to 'weekly_technical_discussion_154'
13:00:28 <bh526r> #topic Roll Call
13:00:48 <bh526r> #info Liang Chen
13:01:25 <bh526r> #info Qiao Fu
13:01:34 <bh526r> #info Hongli Zhang
13:01:40 <bh526r> #info Bin Hu
13:02:08 <bh526r> #info Denver Williams
13:02:16 <bh526r> #info Jack Morgan
13:02:56 <bh526r> #info Cedric Ollivier
13:07:01 <bh526r> #info Watson W
13:07:08 <bh526r> #info Trevor Cooper
13:07:16 <bh526r> #info Trevor Bramwell
13:07:21 <ollivier> #info Cédric Ollivier
13:07:50 <bh526r> #topic Role, Responsibility and Expectation of LFN Infra Support for Issues in Community Labs by Trevor Cooper
13:08:34 <bh526r> #info Trevor Cooper described the issue that was discussed in TSC meeting on 10/08.
13:09:34 <bh526r> #info e.g. when there was an issue in community lab (e.g. Intel lab), there wasn't a forum to discuss how to resolve the issue.
13:11:18 <bh526r> #info This was because the lab admin usually doesn't participate in community, and they usually just are responsible for hardware configuration. When an issue becomes more complex, there isn't a place to discussion and resolve related issues.
13:12:34 <bh526r> #info So we need a consolidated forum, e.g. Pharos + Infra Forum, to help resolve the issues
13:13:52 <bh526r> #info Cedric Ollivier indicated that even if he has the skillset to help, e.g. set up Jenkins slave, he doesn't have access permission to do it.
13:15:18 <bh526r> #info Jack Morgan summarized (1) Lab support issue (who will do what) (2) Current community lab status (3) Lab assignment (e.g. when CNTT joins us) (4) open credentials (e.g. Jenkins slave) to community
13:17:06 <bh526r> #undo
13:17:06 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x212dfd0>
13:18:45 <bh526r> #info Jack Morgan summarized (1) Lab support issue (who will do what) (2) Current community lab status (3) Feature of Community Labs (e.g. Infra evolution, other features change to the lab when CNTT joins us, etc.) (4) open credentials (e.g. Jenkins slave) to community
13:19:08 <bh526r> #undo
13:19:08 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x22c6290>
13:19:29 <bh526r> #info Jack Morgan summarized (1) Lab support issue (who will do what) (2) Current community lab status (3) Future of Community Labs (e.g. Infra evolution, other features change to the lab when CNTT joins us, etc.) (4) open credentials (e.g. Jenkins slave) to community
13:20:00 <bh526r> #info Discussing (1) Lab support issue (who will do what)
13:20:42 <trevor_intel> #info Support process to be clarified
13:21:43 <bh526r> #info Ticket support through Jira service desk
13:22:10 <bh526r> #link https://support.linuxfoundation.org
13:23:02 <bh526r> #info Al Morton
13:24:18 <bh526r> #info Cedric indicated that although there is a resource pool for every project, but 2 resources are budgeted and dedicated to OPNFV, so we should get quicker support
13:25:49 <bh526r> #info Trevor Bramwell indicated that if support is needed from LF staff, it should go to https://support.linuxfoundation.org
13:26:24 <bh526r> #info Exception is that if there is issue related to OPNFV Community Lab, it should go to OPNFV Jira: https://jira.opnfv.org
13:26:40 <bramwelt> #link https://jira.linuxfoundation.org/servicedesk/customer/portal/2
13:26:44 <bramwelt> #link support.linuxfoundation.org
13:27:36 <acmacm> #info Al Morton
13:28:14 <bh526r> #info e.g. if issue related to Jenkins master or connection to Jenkins slave, it should go to LF support: support.linuxfoundation.org
13:28:52 <bh526r> #info Trevor Bramwell will organize a training session to community
13:29:15 <bh526r> #action Trevor Bramwell will organize a training session for community
13:33:00 <bh526r> #info Mark Shostak
13:35:34 <bh526r> #info Trevor Cooper gave an example: a VM wasn't working on a pod, and lab admin had no clue why we need the VM, and why it stopped working
13:36:12 <bh526r> #info Jack Morgan indicated the gap of Lab admin wasn't aware anything of OPNFV.
13:38:50 <bh526r> #info Infra WG needs to document those, i.e. gaps and proposed process of where to escalate, and who will do what
13:40:07 <bh526r> #action Jack Morgan and Trevor Bramwell to revive Infra WG meeting to take care of above task
13:40:47 <jentoio> #link https://wiki.opnfv.org/display/pharos/Community+Labs
13:41:18 <bh526r> #info Infra WG will also take the task of assessing current lab status so that above information will be up to date
13:41:43 <bh526r> #undo
13:41:43 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x22fdcd0>
13:42:00 <bh526r> #info Pharos Project will also take the task of assessing current lab status so that above information will be up to date
13:47:17 <bh526r> #info (3) Future Lab
13:49:13 <bh526r> #info e.g infra evolution, TAC Infra WG etc.
13:49:51 <bh526r> #info Trevor Bramwell have been representing OPNFV in TAC Infra WG
13:54:33 <bh526r> #info Both Jack Morgan and Trevor Bramwell will represent OPNFV in Infra WG of TAC. They will bring back the guidelines from TAC, clarity of decisions that OPNFV TSC needs to make in terms of CI evolution, cloud-based CI/CD etc.
13:55:14 <bh526r> #info Cedric indicated that FuncTest has successfully experimented Traverse CI etc.
13:55:44 <bh526r> #info Nothing has been decided in TSC level
13:55:44 <ollivier> travis-ci
13:58:23 <bh526r> #info We need to experiment, get lessons and experience, and bring the topic to TSC regarding what recommendation and decision TSC needs to make.
13:58:35 <bh526r> #info (4) Open credentials to community
13:59:43 <bh526r> #info Cedric raised the topic in TSC last week, and email to mailing list, and waiting for feedback/response
14:00:12 <bh526r> #action Trevor Bramwell set up meeting of Infra WG
14:04:46 <bh526r> #info Jack Morgan and Trevor Bramwell will bring the topic of "open credential to community" in TAC Infra WG meeting on Friday, because it involves other communities such as ODL and ONAP
14:06:45 <bh526r> #info All 4 issues will be taken care of in details in OPNFV Infra WG (issue 1), Pharos Project (issue 2), and TAC Infra WG represented by Jack and Trevor on behalf of OPNFV (issue 3 and 4).
14:07:37 <bh526r> #info We will see how it goes, and if still gaps (possible) and how to solve it in future meetings
14:07:53 <bh526r> #topic AOB
14:07:59 <bh526r> #info Meeting adjourned
14:08:03 <bh526r> #endmeeting