13:02:23 <mdgray> #startmeeting Weekly Open vSwitch for NFV meeting (17th August 2015)
13:02:23 <collabot> Meeting started Mon Aug 17 13:02:23 2015 UTC.  The chair is mdgray. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:23 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:02:23 <collabot> The meeting name has been set to 'weekly_open_vswitch_for_nfv_meeting__17th_august_2015_'
13:02:28 <mdgray> #info mdgray
13:02:36 <mdgray> #info Mike Lynch
13:02:47 <mdgray> #topic Roll Call
13:02:51 <mdgray> #info mdgray
13:03:03 <mdgray> #info Mike Lynch
13:03:32 <tfherbert> Good morning
13:04:44 <mdgray> #info Gabor
13:04:54 <tfherbert> #info therbert
13:05:12 <mdgray> #topic Agenda Items
13:05:37 <mdgray> #info Release Planning
13:05:56 <mdgray> #info Instructions to add package to an installer
13:06:25 <mdgray> #info SFC
13:06:42 <tfherbert> #info and NSH
13:07:03 <mdgray> #topic Release Planning
13:07:22 <mdgray> #info ppt was sent out to Debra Scott
13:08:44 <tfherbert> #info sounds right
13:09:05 <mdgray> #info May need to update due to a dependency on Openstack Liberty
13:10:30 <mdgray> #info There is a risk that Brahmaputra will not have Openstack Liberty
13:11:19 <mdgray> #info There may be a dependency on Openstack Liberty for SFC/NSH
13:12:43 <mdgray> #undo
13:12:43 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2af9990>
13:13:17 <tfherbert> #info SFC requires NSH aware openvswitch. If we are deploying user space accelerated openvswitch, that would need to be NSH aware as well.
13:17:49 <mdgray> #info Both userspace and kernel space patches for NSH will be released together and will be based on the original Cisco code
13:18:22 <mdgray> #action Mark to update ppt to reflect these dependencies
13:20:05 <mdgray> #info We will also need more detail in the plan which we can do at a later stage when we have more information.
13:20:29 <mdgray> #info Gabor asks if there are any specific hardware dependencies?
13:20:38 <mdgray> #undo
13:20:38 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2afd5d0>
13:20:52 <mdgray> #info Gabor asks if we have any hardware for this project
13:22:05 <mdgray> #info Mike Lynch: There will be access to the Intel OPNFV lab or the LF lab.
13:23:15 <mdgray> #info Follow the HW requirements of Pharos
13:24:48 <mdgray> #info We may need to book time on lab infrastrucure in order to run tests.
13:26:09 <mdgray> #action Mike Lynch to check the procedure for reserving lab infrastructure.
13:27:47 <mdgray> #info Gabor: What are the supported NICs in the userspace datapath with DPDK?
13:28:23 <mdgray> #info There is a baseline specification for Pharos servers. Inclusing NICs. Those are all DPDK-supported.
13:29:10 <mdgray> #info Gabor: Memory and hugepages are not an issue either.
13:29:28 <mdgray> #topic  Instructions to add package to an installer
13:29:56 <mdgray> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-August/004178.html
13:32:04 <mlynch> #info: there is a link to the current Pharos HW Specification
13:32:11 <mlynch> #link https://wiki.opnfv.org/pharos/pharos_specification
13:33:16 <mdgray> #info There are few options for installers
13:34:44 <mdgray> #info Mark suggests Fuel is a good option as the documentation, support from the mailing list, it also supports checkboxes for different builds, it also supports a virtual deployment
13:34:57 <mdgray> #info Gabor +1
13:35:28 <mdgray> #info Robin: Is RDO another option?
13:36:31 <mdgray> #info therbert: Franck Brockner gave the exact methodology for doing what we need to do.
13:37:42 <mdgray> #info It might be Michal. The following link outlines this.
13:37:47 <mdgray> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-August/004185.html
13:37:50 <mlynch> #info Fuel +1
13:38:35 <mdgray> #info We only need to support one.
13:39:20 <mdgray> #agreed We will target Fuel as the first installer.
13:41:00 <mdgray> #info We need to take the list of tasks highlighted in the above e-mail thread into Jira to indicate what we need to do to complete an integration of userspace ovs into OPNFV
13:43:31 <mdgray> #action Tom will build a description of the work we need to do using the info in this e-mail and populate into Jira. The first purpose of this is really to help direct work so that people can contribute.
13:44:43 <tfherbert> #info mailing list with [ovsnfv] tag, individual email or this chat channel for comms
13:45:09 <mdgray> #info Gabor wants to know how to contact this group in general during the week?
13:45:33 <mdgray> #info Let's use e-mail as there is a record of it.
13:46:05 <mdgray> #info Tom we are in different timezones so email is probably better
13:46:11 <mdgray> #topic SFC and NSH
13:46:42 <mdgray> #info SFC requires NSH-aware Open vSwitch
13:47:27 <mdgray> #info This is the first example of a NFV requirement that we need pushed into upstream.
13:49:25 <mdgray> #topic Actions
13:49:57 <mdgray> #info Tom to arrange presentation from someone on Genesis team on integration - Closed via the email chain http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-August/004178.html
13:50:48 <mdgray> #topic Other topics
13:51:01 <mdgray> #info Tom: Where do we put the package?
13:52:07 <mdgray> #info Needs to be somewhere accessible by CI
13:52:18 <tfherbert> #info +1
13:52:21 <mdgray> #info artifacts is a possibility
13:52:42 <mdgray> #info Mike: How do we formalize the userspace ovs as part of the CI
13:54:03 <mdgray> #action Mike to talk to Octopus project to understand how to do this.
13:55:30 <mdgray> #endmeeting