23:28:14 <mdgray> #startmeeting 2015 Design Summit Breakout Meeting
23:28:14 <collabot> Meeting started Mon Nov  9 23:28:14 2015 UTC.  The chair is mdgray. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:28:14 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
23:28:14 <collabot> The meeting name has been set to '2015_design_summit_breakout_meeting'
23:29:24 <mdgray> #topic agenda bashing
23:30:06 <mdgray> #info Strategy for dealing with out of tree patches
23:30:08 <mdgray> #info RDO
23:30:11 <mdgray> #info CI
23:30:17 <mdgray> #info Phase 2
23:31:23 <mdgray> #info System Performance Tuning
23:34:48 <mdgray> #topic Phase 2
23:39:12 <mdgray> #info Can a feature be implemented just in userspace and not in kernel space?
23:39:31 <mdgray> #info Might be worth bringup up at the OVS summit
23:40:58 <mdgray> #info This introduces a dependency between kernel space and userspace datapath
23:44:07 <mdgray> #info How do we deal with new requirements.
23:44:46 <mdgray> #info i.e. What is the process?
23:46:00 <mdgray> #info What are the tools we should use?
23:49:58 <mdgray> #info Options: Jira, Git, Etherpad
23:51:53 <mdgray> #info Mark to look into process in order to promote Gabor as a committer
23:54:54 <mdgray> #info Suggested process is that we get requirements in various ways (for example via email), and then input them into git/gerrit for review and refinement followed by moving them to Jira when we are in the implementation phase.
23:55:36 <mdgray> #action Mark to document this process on the wiki and to test the workflow
00:03:24 <mdgray> #agreed To send out a request to opnfv community in order to get vswitch requirements
00:03:40 <mdgray> #info we will do this after the OVS summit
00:06:33 <mdgray> #info Gabor: We can get performance requirements from the VSPERF community.
00:10:08 <mdgray> #topic Strategy for dealing with out of tree patches
00:12:13 <mdgray> #info Discussion about leveraging RHs rpms
00:12:40 <mdgray> #info What about ubuntu???
00:12:48 <mdgray> #info they probably follow the same process
00:17:48 <mdgray> #info A lot of effort to maintain out of tree patches
00:23:59 <mdgray> #info Should we maintain an OVS repo for OPNFV so all opnfv projects can pull from this directly and merge their code into before it gets pushed upstream?
00:24:22 <mdgray> #info Openstack in OPNFV always uses upstream?
00:32:28 <mdgray> #info Thomas: We aren't resourced to maintain a fork, we are forced to always work upstream.
00:32:54 <mdgray> #info Lets work pure upstream for a while and see how it goes.
00:34:23 <mdgray> #info There is a risk that there will be duplication of effort across OPNFV projects
00:40:09 <mdgray> #info There is value to maintaining a list of requirements as it serves as a central database of work that needs to be done
00:41:23 <mdgray> #agreed For the moment we will only work upstream and won't maintain any kind of OPNFV fork
00:41:33 <mdgray> #info We might revisit this in the future
00:50:23 <mdgray> #topic RDO
00:50:42 <mdgray> #infpo We need to engage with Dan Radez in Apex in order to work with Apex
00:50:48 <mdgray> #undo
00:50:48 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x315de90>
00:50:58 <mdgray> #info We need to engage with Dan Radez in Apex in order to work with Apex
00:55:06 <mdgray> #info Question about can we run user and kernel datapath in same binary
01:06:58 <mdgray> #endmeeting