13:02:51 <mdgray> #startmeeting Weekly Open vSwitch for NFV meeting (December 7th 2015)
13:02:51 <collabot> Meeting started Mon Dec  7 13:02:51 2015 UTC.  The chair is mdgray. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:51 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:02:51 <collabot> The meeting name has been set to 'weekly_open_vswitch_for_nfv_meeting__december_7th_2015_'
13:03:06 <mdgray> #topic Roll Call
13:03:11 <mdgray> #info mdgray
13:03:15 <anac1> #info Ana Cunha
13:03:16 <gdunne> #info gdunne
13:03:22 <z0d> #info Peter Barabas
13:03:23 <billyoma> #info Billy O'Mahony
13:04:48 <mdgray> #topic Agenda Bashing
13:04:59 <mdgray> #info Do we want to enforce a policy JIRA tag on all commits?
13:04:59 <Simona_> #info Simona
13:05:12 <mdgray> #info Select someone to go to the functest meetings.
13:05:23 <mdgray> #info  Gabor promoted to committer. Congratulations!
13:05:34 <mdgray> #info Development Update
13:05:47 <mdgray> #info Review of e-mail to be sent to list regarding requirements.
13:07:36 <billyoma> https://etherpad.opnfv.org/p/fuel@opnfv-meet  etherpad for agenda.
13:07:53 <mdgray> #link https://etherpad.opnfv.org/p/fuel@opnfv-meet
13:08:46 <mdgray> #topic Do we want to enforce a policy JIRA tag on all commits?
13:09:02 <mdgray> #info Some projects have this. Does this project need it?
13:10:47 <mdgray> #agreed We will leave the flexibility that we have at the moment ad revisit at a later date
13:10:48 <mdgray> #undo
13:10:48 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x2d4d0d0>
13:10:57 <mdgray> #agreed We will leave the flexibility that we have at the moment and revisit at a later date
13:11:15 <mdgray> #topic Select someone to go to the functest meetings.
13:11:39 <mdgray> #info we have been registered with functest
13:11:54 <mdgray> #info It runs at Thursdays at 4pm GMT
13:12:32 <mdgray> #info Ana clarifies that this is the general testing meeting
13:12:58 <mdgray> #info We will treat functest as a regression test
13:13:23 <mdgray> #info Initially, we will not add any specific tests for this project.
13:14:17 <mdgray> #info This would just be Robot and Tempest
13:15:03 <mdgray> #info We will need to do additional testing with Yardstick and vsperf
13:17:57 <mdgray> #info Functest meeting is at an awkward time for most attendees
13:18:15 <mdgray> #agreed Simona and/or Gillian can monitor offline and report any key issues on this call
13:22:02 <mdgray> #info There will be a discussion at the release meeting tomorrow in which testing will be discussed. We need an attendee at this call tomorrow.
13:23:04 <mdgray> #topic Gabor promoted to committer. Congratulations!
13:24:27 <mdgray> #topic Review of e-mail to be sent to list regarding requirements.
13:25:12 <mdgray> #link https://etherpad.opnfv.org/p/ovsnfv-meet
13:25:25 <mdgray> #info In above link
13:25:38 <mdgray> #info In section 5
13:27:44 <mdgray> #info Billy suggests sending to all of opnfv-tech-discuss
13:28:13 <mdgray> #action Mark to send out email with request to opnfv-tech-discuss
13:28:21 <mdgray> #topic Development Update
13:28:49 <mdgray> #info 1. Fuel Plugin Development
13:29:01 <mdgray> #info support from Fuel team and Montreal Pod
13:29:25 <mdgray> #info Moved to Fuel 7 and now plugin is recognised by Fuel
13:30:53 <billyoma> https://github.com/billyom/fuel-plugin-billy
13:31:28 <mdgray> #link https://github.com/billyom/fuel-plugin-billy
13:31:28 <mdgray> #info Still some issues. "Nailgun" is dying.
13:31:51 <mdgray> #info Some issues with underlay network configuration
13:32:10 <mdgray> #info Long test, debug, deploy cycle
13:32:21 <mdgray> #info deply is taking 1-1.5 hours
13:32:24 <mdgray> #undo
13:32:24 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x31492d0>
13:32:35 <mdgray> #info deploy is taking 1-1.5 hours
13:33:26 <mdgray> #info Gillian has got a virtual deployment of 7 up but it is not deploying Billy's plugin.
13:34:49 <mdgray> #info 2. DPDK packages
13:34:58 <mdgray> #info Sync with SFC project
13:35:06 <mdgray> #undo
13:35:06 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x3149bd0>
13:35:19 <mdgray> #info Billy synced with the SFC project
13:36:08 <mdgray> #info SFC has binary deb packages for Native OVS (kernel) for Ubuntu 14.04
13:37:06 <mdgray> #info Source packages would be better to compile on the node to give better performance. However, at this stage anything would be great! :)
13:37:56 <mdgray> #info There was an email about project dependencies.
13:38:05 <mdgray> #info For OVSNFV, the following were highlighted
13:38:13 <mdgray> #info Qemu 2.1.0+
13:38:32 <mdgray> #info Openstack - Kilo
13:38:52 <mdgray> #info ODL - Berryllium
13:39:28 <mdgray> #info The ODL dependency wont be met as it arrives after Brahmaputra
13:39:47 <mdgray> #info There *should* be no specific kernel dependency
13:40:20 <mdgray> #info We are tied to Ubuntu because Fuel is for Ubuntu only
13:45:22 <mdgray> #action Mark to confirm what DPDK version is needed.
13:46:36 <mdgray> #info Should be possible to build a debian package using the "dist" Makefile target. Someone should check this.
13:48:04 <mdgray> #link https://github.com/openvswitch/ovs/tree/master/rhel
13:48:11 <mdgray> #link https://github.com/openvswitch/ovs/tree/master/debian
13:48:52 <mdgray> #link https://github.com/openvswitch/ovs/blob/master/INSTALL.Debian.md
13:49:01 <mdgray> #info The above link could be useful.
13:50:39 <mdgray> #info Fuel deploys Ubuntu 14.04 for Brahmaputra. This is an LTS release.
13:50:50 <mdgray> #info OVSNFV has a dependency on this version.
13:51:33 <mdgray> #info SFC can build a kernel space package but cant build userspace one
13:53:52 <mdgray> #topic Others
13:53:55 <mdgray> #info qemu --enable-num required for huge-pages, is set on qemu for rel-B.
13:55:35 <mdgray> #info Is this a compile-time or run-time parameter?
13:56:17 <mdgray> #info effects of various opnfv major deployment options - KVM/QEMU, Neutron w. VLAN/Tunelling(VXLAN/GRE via Fuel CLI).The networking equipment must support VXLAN segmentation. This option supports millions of tenant data networks.
13:56:58 <mdgray> #info This is a comment on the test effort. The number of combinations and permutations is growing ...
13:57:52 <mdgray> #info This is a general issue across OPNFV
13:58:49 <mdgray> #info OVSNFV will need to be very specific about what versions we are compatible with to narrow the scope.
13:59:28 <mdgray> #info There may be a way to limit this in Fuel
13:59:52 <mdgray> #endmeeting