12:59:28 <mdgray> #startmeeting Weekly Open vSwitch for NFV meeting (December 14th 2015)
12:59:28 <collabot`> Meeting started Mon Dec 14 12:59:28 2015 UTC.  The chair is mdgray. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:59:28 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:59:28 <collabot`> The meeting name has been set to 'weekly_open_vswitch_for_nfv_meeting__december_14th_2015_'
13:02:38 <mdgray> #topic Roll Call
13:02:43 <mdgray> #info Mark Gray
13:03:26 <gdunne> #info gdunne
13:03:29 <tfherbert> #info Tom Herbert
13:04:41 <mdgray> #link https://etherpad.opnfv.org/p/ovsnfv-meet
13:04:58 <mdgray> #topic Agenda
13:05:08 <mdgray> #info Agenda can be found at https://etherpad.opnfv.org/p/ovsnfv-meet
13:05:42 <mdgray> #info Welcome New Contributers
13:06:00 <mdgray> #info Jira/Gerrit Policy
13:06:15 <mdgray> #info Dev Updates: Fuel
13:06:21 <mdgray> #info Dev updates: RPMs
13:06:29 <mdgray> #info Dev updates: Debs
13:06:36 <mdgray> #info Dev Updates: CI
13:06:46 <mdgray> #info Requirements
13:07:03 <mdgray> #topic Welcome New Contributers
13:08:02 <mdgray> #info Paul Kangil Choi (ETRI, forerunner@etri.re.kr) Yuki Kasuya (KDDI R&D Laboratories, yu-kasuya@kddilabs.jp)
13:08:16 <mdgray> #info Welcome on board!
13:08:30 <mdgray> #topic Jira/Gerrit Policy
13:09:17 <mdgray> #info Not necessary to have a Jira tag for every commit.
13:10:49 <mdgray> #info We need to update instructions for committing code to our repo.
13:11:50 <mdgray> #action Mark has some instructions to show how to make git commits to our repo.
13:16:42 <mdgray> #info Gerrit allows us to review patches
13:17:00 <mdgray> #link https://gerrit.opnfv.org/gerrit/#/q/project:ovsnfv
13:17:12 <mdgray> #info These are the list of patches that have been submitted.
13:18:48 <mdgray> #info We need to decide on a policy as to when we can push changes to our repository
13:20:12 <mdgray> #action Tom will see if it is possible to add a group of users for review (e.g. OVSNFV committers)
13:20:39 <mdgray> #topic Dev Updates: Fuel
13:21:03 <mdgray> #info Deadline for Fuel code freeze 18th December
13:21:21 <mdgray> #info There might be leeway on that (middle of next week)
13:22:04 <mdgray> #info There is a similar Fuel plugin being developed by the SFC team
13:22:25 <mdgray> #info We are trying to align as much as possible with that.
13:25:46 <mdgray> #info Idea end state would be one plugin. This is a goal
13:26:23 <mdgray> #info OVSNFV plugin is working in Ericsson Montreal Pod (hardware environment) but not in a virtual environment
13:28:13 <mdgray> #info We have a daily meeting at 9am (Dublin Time) with Fuel@OVSNFV to work through these problems. They are giving great support!
13:28:29 <mdgray> #info If anyone wants to attend, let me know
13:28:41 <mdgray> #topic Dev updates: RPMs
13:29:58 <mdgray> #info Goal is to build RPM from the master tree (native OVS). This will provide a framework to do this for userspace OVS
13:30:39 <mdgray> #info Next step is an analogous step for Apex.
13:31:15 <mdgray> #info Tom plans to get help from Tim and Dan to achieve this.
13:32:27 <tfherbert> #info we currently are supporting fuel installer.
13:33:28 <mdgray> #info Currently rpms are stored locally but plan is to put them into artifacts.
13:34:06 <mdgray> #info Plan would be that Apex would then pull that rpm
13:35:31 <tfherbert> #info tfherbert is working on preparing rpms for apex installer for now.
13:35:38 <tfherbert> #info other installers will come later.
13:38:50 <mdgray> #info 18th December deadline is that the fuel plugin is code complete
13:40:41 <mdgray> #info When we are doing an Apex and a Fuel build, we will probably need to use two servers as one will have centos and one will have unbuntu
13:41:41 <mdgray> #undo
13:41:41 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1aabe90>
13:41:52 <mdgray> #info When we are doing an Apex and a Fuel build, we will probably need to use two servers as one will have centos and one will have ubuntu
13:47:02 <mdgray> #info We can use build.sh to be our entry point which calls other build scripts
13:47:39 <mdgray> #topic Dev updates: Debs
13:47:58 <mdgray> #info We can build debian packages using upstream code
13:50:02 <mdgray> #info We still need to decide how we will do this. There are a few potential methodologies.
13:51:21 <mdgray> #info Dev Updates: CI
13:51:38 <mdgray> #info We have covered that in previous topics
13:51:54 <mdgray> #undo
13:51:54 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1baa450>
13:51:56 <mdgray> #undo
13:51:56 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1baa3d0>
13:52:06 <mdgray> #topic  Dev Updates: CI
13:52:14 <mdgray> #info We have covered that in previous topics on this call
13:52:34 <mdgray> #topic Requirements
13:53:32 <mdgray> #info Sent out e-mail polling for requirements
13:56:34 <mdgray> #endmeeting