13:03:26 <mdgray> #startmeeting Weekly Open vSwitch for NFV meeting (December 21st 2015)
13:03:26 <collabot`> Meeting started Mon Dec 21 13:03:26 2015 UTC.  The chair is mdgray. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:26 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:03:26 <collabot`> The meeting name has been set to 'weekly_open_vswitch_for_nfv_meeting__december_21st_2015_'
13:03:34 <mdgray> #info Mark Gray
13:04:05 <mdgray> #topic Roll Call
13:04:08 <tfherbert> #info Tom Herbert
13:04:09 <mdgray> #info Mark Gray
13:04:10 <gdunne> #info gdunne
13:04:14 <ljlamers_> #info Larry Lamers
13:04:21 <tfherbert> #info Tom Herbert
13:04:23 <Simonac> #info Simona Coppola
13:04:25 <yuki_> #info yuki kasuya
13:04:30 <mdgray> #topic Agenda
13:04:30 <billyoma> #info Billy O'Mahony
13:04:35 <mdgray> #link https://etherpad.opnfv.org/p/ovsnfv-meet
13:05:32 <mdgray> #topic Christmas Schedule
13:06:06 <mdgray> #action Billy to cancel 28th Meeting. Next meeting will be on the 4th of January
13:06:30 <mdgray> #topic Dev Update - Fuel
13:07:10 <mdgray> #info "Hello world" plugin was deployed using Fuel. It deployed a Debian package.
13:07:57 <mdgray> #info Then it was decided to change plugin to deploy and compile on the node.
13:08:06 <mdgray> #info Tom: What was the reason for it?
13:08:39 <mdgray> #info Convenience was one reason. Opportunity to use puppet manifests that were already available.
13:09:03 <mdgray> #info Also, the performance will be better as we can turn on optimizations.
13:10:15 <mdgray> #info Perhaps in the future we could install a Debian.
13:10:55 <mdgray> #link https://github.com/mrmarkgray/fuel-plugin-ovsnfv
13:11:17 <mdgray> #info Current plugin is in this link
13:11:32 <mdgray> #info There is a "stable" branch
13:12:22 <mdgray> #info Fuel guys don't want to maintain the plugin. They will clone the plugin source. They will build it and then package it into the ISO.
13:13:15 <mdgray> #info Currently we need a final location for this plugin.
13:13:28 <mdgray> #info Probably put this in the ovsnfv repo.
13:17:13 <mdgray> #info We have made fuel's WP2 but it is not fully functional/
13:17:17 <mdgray> #undo
13:17:17 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ba1c50>
13:17:51 <mdgray> #info We have made Fuel's WP2 but it is not fully functional. Openstack integration needs a bit of work.
13:18:45 <mdgray> #info Fuel is targeting Liberty for Brahmaputra.
13:20:01 <mdgray> #info Tom: How are you dealing with original goal of an alternate build?
13:21:24 <mdgray> #info There is a tickbox on the UI or a command line parameter to enable it.
13:21:38 <mdgray> #info We will need documentation and/or a video to show it.
13:21:53 <mdgray> #topic Dev Update - RPM
13:23:12 <mdgray> #info First step is to build a native binary using upstream code.
13:23:31 <mdgray> #info There are some nuances to running in OVSNFV context.
13:23:44 <mdgray> #info Built and worked locally and then pushed upstream.
13:24:10 <mdgray> #info "releng" was not doing ovsnfv builds
13:24:29 <mdgray> #info Trying to get rpm pushed to the artifactory.
13:25:46 <mdgray> #info "releng" didn't like that we were producing artifacts as part of verify.
13:26:53 <mdgray> #info There are some rpms up there already "http://artifacts.opnfv.org/ovsnfv/opnfv-2015-12-18-openvswitch-2.5.90-1.x86_64.rpm"
13:29:00 <mdgray> #info Fatih only wants to build package daily.
13:29:19 * fdegir gets notification from irccloud client
13:29:36 <fdegir> clarification; it is not because releng don't like stuff
13:29:47 <fdegir> it is because we have to do things properly
13:30:01 <mdgray> ok i will update :)
13:30:04 <mdgray> #undo
13:30:04 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ba2150>
13:30:25 <fdegir> the artifacts can be produced from merge and daily jobs and placed together for others to consume, this is up to you
13:30:47 <fdegir> but we can not put artifacts produced by verify jobs due to reasons explained in the mail
13:31:34 <mdgray> #info Artifacts should be part of merge and daily jobs and placed together for others to consume.
13:31:41 <fdegir> meaning verify artifacts can not be put together with merge and daily artifacts
13:31:55 <mdgray> #info Tom will work with Fatih on this.
13:42:53 <tfherbert> #info http://artifacts.opnfv.org/ovsnfv/opnfv-2015-12-18-openvswitch-2.5.90-1.x86_64.rpm
13:44:00 <tfherbert> #info https://gerrit.opnfv.org/gerrit/#/c/4907/
13:45:54 <mdgray> #info Discussion about forking again :)
13:46:02 <mdgray> #info SFC is an example
13:47:12 <mdgray> #info One suggestion is that we don't fork but we make sure our packaging and testing has the option to apply patches sometime before deploy.
13:49:27 <mdgray> #info Then other projects could maintain their changes. They could potentially reuse our packaging and build infrastrucutre
13:50:31 <mdgray> #undo
13:50:31 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1dea390>
13:50:44 <mdgray> Then other projects could maintain their changes. They could potentially reuse our packaging and build infrastructure
13:53:58 <mdgray> #topic Requirements
13:54:57 <mdgray> #info Two requirements so far:
13:55:00 <mdgray> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-December/007268.html
13:55:24 <mdgray> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-December/007266.html
13:56:39 <tfherbert> #info, I understand what you are saying about vsperf. But does vsperf test against specific perf requirements?
14:02:57 <mdgray> #info I don't think it has any requirements yet. It just measures and reports.
14:03:21 <mdgray> #endmeeting