13:01:14 <mdgray> #startmeeting Weekly Open vSwitch for NFV meeting (March 7th 2016)
13:01:15 <collabot`> Meeting started Mon Mar  7 13:01:14 2016 UTC.  The chair is mdgray. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:15 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:15 <collabot`> The meeting name has been set to 'weekly_open_vswitch_for_nfv_meeting__march_7th_2016_'
13:01:21 <mdgray> #topic Roll Call
13:01:24 <mdgray> #info Mark Gray
13:01:39 <billyoma> #info Billy O'Mahony
13:01:48 <Simona_> #info Simona Coppola
13:02:55 <Paul_> # info paul kangil Choi
13:04:49 <tfherbert> Where is the meeting?
13:04:53 <mdgray> Its here
13:05:14 <mdgray> #topic Agenda
13:05:16 <mdgray> #link https://etherpad.opnfv.org/p/ovsnfv-meet
13:06:20 <mdgray> #topic C-Release Planning
13:08:43 <mdgray> #info Draft C-Release backlog is on Wiki
13:09:50 <mdgray> #info Simon will send out an e-mail with the details
13:09:59 <mdgray> #undo
13:09:59 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2feed50>
13:10:08 <mdgray> #info Simona will send out an e-mail with the details
13:10:51 <mdgray> #action Everyone: Review the backlog to give any feedback.
13:11:21 <mdgray> #action Tom: Update the Apex feature list with key backlog items and to fix any mistakes.
13:12:40 <tfherbert> #info Tom Herbert
13:15:11 <tfherbert> apex integration is a requirement. sfc enablement is a priority too.
13:15:48 <mdgray> #info Release C milestone 1 is tomorrow
13:16:23 <mdgray> #info Simona will drive this with feedback from committers
13:16:34 <tfherbert> Also functest passing.
13:17:34 <mdgray> #info .. and contributers
13:18:14 <mdgray> #info Debra Scott has left Linux Foundation and OPNFV - may change a few things around release planning.
13:18:39 <mdgray> #topic Priority Path through OVS based on Requirements (Lead: Al Morton - 45 minutes)
13:18:41 <tfherbert> #info sorry to see Debra go.
13:19:24 <tfherbert> Al, please send link to slides after meeting.
13:20:01 <mdgray> #info Al presenting slides. Mark will put them up on the wiki.
13:26:46 <mdgray> #link https://wiki.opnfv.org/_media/qos_mechanisms.pdf
13:27:29 <mdgray> #info Al is outlining the current standards related to QoS
13:27:48 <mdgray> #info This highlights the need for QoS
13:28:31 <mdgray> #info Many of the requirements are for service quality i.e. end-to-end
13:30:09 <mdgray> #info The eventual allocation to a virtual switch would depend on other equipment in the path, speed of light, etc
13:38:21 <mdgray> #info Two class prioritization should make sense initially
13:39:03 <mdgray> #info Initial implementation should focus on this.
13:39:18 <mdgray> #info Further work could expand on this
13:40:23 <mdgray> #info We can assume that traffic is already marked
13:41:31 <mdgray> #info We need flexibility as to which field in the packet contains the priority information
13:42:50 <mdgray> #info This could be programmed in a protocol oblivious way
13:43:30 <mdgray> #info Need to map this to a priority as handled by the switch
13:47:06 <mdgray> #info Tom noted that other vswitches have this type of functionality
13:49:25 <mdgray> #info OVS architecture will make this tricky
13:49:37 <mdgray> #info Al has outlined some observations previously made
13:54:40 <mdgray> #info Is OpenFlow control required?
13:54:56 <mdgray> #info Perhaps we should do a smaller prototype first?
13:57:28 <mdgray> #info Similar control interface in OpenFlow for Packet_In messages
14:00:53 <mdgray> #info Plan to follow up on this discussion at Hackfest (look for Al, Billy and Tom having heated discussion in front of a whiteboard!)
14:01:56 <mdgray> #info This needs to be formally documented. If no one else volunteers, Mark can do this.
14:02:13 <mdgray> #info Need vsperf tests to show the benefit of this
14:02:28 <mdgray> #endmeeting