16:19:59 <billyoma> #startmeeting opnfv hackfest breakout
16:19:59 <collabot`> Meeting started Tue Mar 15 16:19:59 2016 UTC.  The chair is billyoma. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:19:59 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:19:59 <collabot`> The meeting name has been set to 'opnfv_hackfest_breakout'
16:20:14 <billyoma> #info Billy, Al, Tom, Larry
16:21:15 <billyoma> Tom talks about priority based on vlan pcp
16:27:51 <billyoma> Al suggests using multiple interfaces to the guest as a way of prioritizing traffic to the guest
16:28:37 <billyoma> Tom mentions the performance improvemnt to the guest by using vhost-multiqueue.
16:29:41 <billyoma> vhost-multiqueue does not reorder packets on the guest i/f.
16:32:36 <billyoma> Al tcp re-order of adjacent packets is acceptable. It is only when reorder is 3 pkts or more wide that TCP alg. causes issues.
16:43:20 <billyoma> Billy points out the OF pipeline actions/routing are all combined into a single entry in the mini/megaflow OVS lookup.
16:43:44 <billyoma> Billy suggests using NIC multiqueue as the prioritization mechanism.
16:47:35 <billyoma> #question do the NIC queues show up as separate pcie devices?  This would require several pmd threads for each queue.
16:49:50 <billyoma> #info Al mentions new OF feature - auxilarry controllers. Want to know about directing priorit packets to auxillary controllers.
16:56:43 <billyoma> #info Al points out that we need to prioritize important traffic both when we know how to deal iwth it (emc...OF hit) and when we do not - packet_out req to controller.
17:41:03 <billyoma> #topic REview of Rel C priority list
17:41:06 <billyoma> #info https://wiki.opnfv.org/release_c_planning/priority_list
17:55:11 <billyoma> #info https://wiki.opnfv.org/release_c_planning/priority_list
18:13:25 <billyoma> #topic Apex Feature List
18:14:14 <billyoma> #info NSH VxLAN based on Pritesh patches
18:14:30 <billyoma> for both ovs-dpdk and kernel dp.
18:22:04 <billyoma> #info Waiting for kernel patches to upstream: Linux VxLAN and LWT (light weight tunnels)
18:31:03 <billyoma> #info pritesh patches only work for kernel 3.12? to 3.17 and need to be rebased to latest kernel
18:32:44 <billyoma> #help
18:32:48 <billyoma> #erase
18:32:51 <billyoma> #delete
18:34:49 <billyoma> #undo
18:34:49 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Help object at 0x2bf7990>
18:34:56 <billyoma> #undo
18:34:56 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2d2c9d0>
18:36:42 <billyoma> #info pritesh patches to OVS are now abandoned and to be replaced by same functionality in the pending kernel patches.
18:39:44 <billyoma> #topic MPLS over GRE
18:41:20 <billyoma> #info Simon Hormon is working on this. Again there are two sets of patches for this. Kernel and OVS.
18:41:50 <billyoma> #info It's not certain that it will make it in time for Rel -C.
18:42:11 <billyoma> #info Latest info from Simon Horman regarding MPLSoGRE: “At this stage I'm trying to shake out how the vport support for the datapath will look[1] as that will effect both the kernel and user-space implementation of L3 GRE. I would wait for that to be resolved before exercising the code.
18:42:11 <billyoma> 18:25 <MarkusMagnusson> [1] https://www.mail-archive.com/dev@openvswitch.org/msg56967.html
18:42:24 <billyoma> #info  https://www.mail-archive.com/dev@openvswitch.org/msg56967.html
18:47:38 <billyoma> #topic 100G, Virtio Container requirement
18:47:55 <billyoma> #info no details on page for these requirements
18:48:06 <billyoma> #topic port placement on cores
18:48:35 <billyoma> #info no details on page for this req - but some work in ongoing for NUMA aware pmd and VM placement
18:48:44 <billyoma> #topic JOID features
18:51:00 <billyoma> #info very little detail or discussion on these items.
18:52:11 <billyoma> #info Some updates to the wiki have been made during this discussion.
18:52:22 <billyoma> #action Billy to forward flipchart photos.
18:52:40 <billyoma> #endmeeting