14:03:24 <mdgray_> #startmeeting Weekly Open vSwitch for NFV meeting (11th July 2016)
14:03:24 <collabot> Meeting started Mon Jul 11 14:03:24 2016 UTC.  The chair is mdgray_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:24 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:03:24 <collabot> The meeting name has been set to 'weekly_open_vswitch_for_nfv_meeting__11th_july_2016_'
14:03:33 <mdgray_> #topic Roll Call
14:03:41 <mdgray_> #info Mark Gray
14:03:41 <lch> #info Chunghan Lee
14:04:09 <mdgray_> #agenda https://etherpad.opnfv.org/p/ovsnfv-meet
14:04:27 <mdgray_> #undo
14:04:27 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2da5890>
14:04:31 <mdgray_> #topic Agenda
14:04:32 <billyo> #info Billy O'Mahony
14:04:35 <mdgray_> #link https://etherpad.opnfv.org/p/ovsnfv-meet
14:06:08 <mdgray_> #topic Fuel Demo
14:07:27 <mdgray_> #info Billy presents demo slides
14:07:40 <mdgray_> #info outlines goal of brahmaputra release
14:09:15 <mdgray_> #info Billy ran tests using two versions of OPNFV. One with the Fuel plugin for OVS/DPDK and one without OVS/DPDK
14:10:03 <mdgray_> #info Some benchmarks have been done with OVS in an isolated manner. These tests are more "realistic" as they are run in a real deployment.
14:11:04 <mdgray_> #info Demo results show the difference bettwen the two
14:11:41 <mdgray_> #info Initial results are good: Throughput x 2 and latency / 3
14:11:47 <mdgray_> #undo
14:11:47 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2cd7f90>
14:11:59 <mdgray_> #info Initial results are good: Throughput x 3 and latency / 5
14:12:10 <mdgray_> #info Tests are netperf UDP tests
14:13:51 <mdgray_> #info OVS/DPDK latency is very smooth but there are latency spikes in longer time intervals
14:14:21 <tfherbert> #info Tom Herbert
14:14:44 <tfherbert> #info Sorry I am late. Are tests published?
14:14:48 <mdgray_> #info In Rel-B test there are about 10-15 tests
14:14:54 <mdgray_> #undo
14:14:54 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2c6dcd0>
14:15:16 <mdgray_> #info In Rel-B test there are about 10-15 tests in the CI
14:15:25 <mdgray_> #info There are about 40 tests in Yardstick
14:15:36 <mdgray_> #info Don't know if that will change for Colorado
14:16:36 <mdgray_> #info Billy has run all tests but the results are not published yet
14:18:23 <mdgray_> #info He will do a more formal analysis this week and aim to present results next week.
14:18:45 <mdgray_> #info For Brahmaputra all tests seem to pass
14:19:05 <mdgray_> #info For Colorado goal, all tests should pass.
14:19:29 <mdgray_> #info Need to enable tests for CI-pipeline.
14:20:49 <mdgray_> #info Functest tests seem to pass but need to confirm. This could be a future readout at this forum.
14:20:52 <tfherbert> #info x3 wrt what?
14:21:17 <mdgray_> x3 the vanilla ovs results
14:21:27 <mdgray_> #info Next steps are ..
14:21:30 <mdgray_> #undo
14:21:30 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2da5c90>
14:21:32 <tfherbert> OK
14:21:53 <mdgray_> thats with netperf in a openstack environment
14:22:28 <mdgray_> #info Yardstick tests uses ubunto cloud image that is modified for yardstick
14:22:58 <mdgray_> #info image uploaded to glance
14:23:06 <mdgray_> #info heat used to run tests
14:23:13 <mdgray_> #info Grafana to display the results.
14:23:33 <mdgray_> #info Same methodology should work with Apex
14:23:58 <mdgray_> #info Billy showing live output from montreal pod
14:27:02 <mdgray_> #info Billy presents possible demo and yardstick next steps
14:27:45 <mdgray_> Any further questions on this topic?
14:29:45 <mdgray_> #info Chunghan asks if there is any background traffic
14:30:33 <mdgray_> #info There isnt, this is sending traffic between VMs on the same host. It is one the Yardstick testcases
14:32:03 <mdgray_> #info These tests are UDP tests
14:32:23 <mdgray_> #topic Fuel Update
14:33:01 <mdgray_> #info Yardstick and Functest tests will be run and the results will be documented to determine gaps
14:33:10 <mdgray_> #info Focus on Brahmaputra
14:33:17 <mdgray_> #undo
14:33:17 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2cd7410>
14:33:54 <mdgray_> #info Focus on Brahmaputra for performance as we have confidence that Brahmputra works correctly
14:34:09 <mdgray_> #info Same for functest
14:35:54 <mdgray_> #action Billy: Check if our scenario will be run nightly against C-release
14:37:29 <mdgray_> #info Colorado will need to be setup and tested to ensure it still functions correctly
14:38:51 <mdgray_> #info Manual test would be more efficient to do this before CI is set up. This will help expose any gotchas such as cabling, issues with installing the fuel iso
14:39:06 <mdgray_> #topic Documentation
14:40:54 <mdgray_> #info General OPNFV installation document could have been better. For colorado, each scenario would have its own installation guide.
14:41:23 <mdgray_> #info This would be based off a template installation guide for the os-nosdn-nofeature-ha scenario
14:41:39 <mdgray_> #info We are waiting on this template from the documentation project.
14:42:13 <mdgray_> #topic Project Milestones update
14:42:28 <mdgray_> #info David Mc Bride is looking for project milestone updates
14:42:43 <mdgray_> #link https://wiki.opnfv.org/display/SWREL/Releases+Colorado+Projects
14:43:14 <mdgray_> #action Mark to update project milestones
14:44:41 <mdgray_> #action Mark to check the scenario dependencies to ensure that our scenario is dependent on the ovs-nsh plugin with a particular configuration (instead of the deprecated ovs plugin)
14:45:05 <mdgray_> #info Billy will also highlight this to the fuel team but we might need to inform Fatih
14:45:50 <mdgray_> #info Apex updates
14:46:17 <mdgray_> #info Tom will provide updates offline.
14:46:35 <mdgray_> #info We are passed feature freeze. Has it been deployed/
14:46:42 <mdgray_> #info It would be nice to get a demo.
14:47:12 <mdgray_> #topic Feature development
14:47:17 <mdgray_> #info Thanks for the comments
14:47:24 <mdgray_> #info Mark needs to update based on the comments.
14:47:57 <mdgray_> #info Mark got some other comments in private via email so I will update based on them aswell
14:48:49 <mdgray_> #topic Other topics
14:49:10 <mdgray_> #info Is there a link for good general OPNFV documentation
14:49:50 <billyo> #link https://www.opnfv.org/opnfv-brahmaputra-fuel-users
14:50:19 <billyo> or for other installer https://www.opnfv.org/software/download
14:50:31 <mdgray_> thanks Billy
14:51:43 <mdgray_> #info Full installation required a lot of infrastructure
14:51:50 <mdgray_> #undo
14:51:50 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b591d0>
14:52:08 <mdgray_> #info Full installation required a lot of infrastructure for bare metal
14:52:33 <mdgray_> #info Virtual install needs to be tested for OVSNFV with colorado release.
14:52:45 <mdgray_> #endmeeting