14:02:59 <mdgray_> #startmeeting Weekly Open vSwitch for NFV meeting (18th July 2016)
14:02:59 <collabot> Meeting started Mon Jul 18 14:02:59 2016 UTC.  The chair is mdgray_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:59 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:59 <collabot> The meeting name has been set to 'weekly_open_vswitch_for_nfv_meeting__18th_july_2016_'
14:03:08 <mdgray_> #topic Roll Call
14:03:12 <mdgray_> #info Mark Gray
14:03:18 <tfherbert1> #info Tom Herbert
14:03:22 <lch> #info Chunghan Lee
14:04:23 <mdgray_> .#topic Agenda
14:04:37 <billyo> #info Billy O'Mahony
14:05:19 <mdgray_> #info Yardstick Results for OVSNFV with Fuel
14:05:24 <mdgray_> #info Fuel Update
14:05:31 <mdgray_> #info Apex Update
14:05:51 <mdgray_> #info Spec review
14:06:02 <mdgray_> #topic Yardstick Results for OVSNFV with Fuel
14:08:11 <mdgray_> #info Billy has tested Fuel with and without OVSNFV plugin against yardstick and functest
14:08:20 <mdgray_> #info This is for Rel B
14:08:27 <mdgray_> #info Functest passes
14:09:52 <mdgray_> #info There at least 37 testcases but only 7 were enabled for CI in Brahmaputra
14:10:43 <mdgray_> #action Billy will follow-up with Yardstick team to understand what tests will be enabled for Colorado.
14:12:32 <mdgray_> #info TC002 ping test shows 4-times lower latency for ovsnfv plugin
14:14:48 <mdgray_> #info TC005 File IO test shows broadly similar results.
14:15:19 <mdgray_> #info TC010 memory latency test shows broadly similar results.
14:15:56 <mdgray_> #info TC011 Packet delay variation test shows eerily similar results.
14:19:56 <mdgray_> #info TC012 Mem r/w show better throughput. Unsure why this would be the case?
14:21:17 <mdgray_> #info TC014 CPU Speed test shows better result for OVS over OVSNFV.
14:24:38 <mdgray_> #info Many of the tests are run several times and the results don't change considerably between test runs.
14:25:52 <mdgray_> #info TC037 Pktgen test is showing x10 (2 flows) and x55 (1M flows) improvement for OVSNFV
14:29:20 <mdgray_> #info This test runs "standard" (i.e. non-dpdk) pktgen in the guest and sends traffic VM-VM using standard linux networking interface.
14:35:45 <mdgray_> #info General consensus is that the result look good. Better performance for the networking tests. Other tests show drops which may be due to differences in Qemu version and configuration.
14:36:08 <mdgray_> #topic Fuel Update
14:36:25 <mdgray_> #info We are a little behind with our CI
14:37:19 <mdgray_> #info Virtual deployment is work in progress
14:37:30 <mdgray_> #info Migration to Intel POD has started today.
14:38:15 <mdgray_> #info Fuel plugin feature has been delivered but not tested.
14:38:29 <mdgray_> #info No documentation so far.
14:40:15 <mdgray_> #topic Apex update
14:42:16 <mdgray_> #info Request from SFC project for ovsnfv to provide Apex plugin with ovs with NSH
14:42:36 <mdgray_> #undo
14:42:36 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2b656d0>
14:42:53 <mdgray_> #info Request from SFC project for ovsnfv to provide Apex plugin with ovs with NSH (interim patch - not merged upstream)
14:43:13 <mdgray_> #info RPM will be built by CI and placed in artifacts
14:43:34 <mdgray_> #info Will not have DPDK support and labelled clearly (no dpdk and experimental)
14:44:37 <mdgray_> #info When do we merge master branch to experimental branch?
14:45:03 <mdgray_> #info Suggestion is August 22nd - not sure on this.
14:46:09 <mdgray_> #info After dates, bug fixes can be cherry-picked after that point. CI will then swap to the stable branch.
14:47:03 <mdgray_> #info Fuel plugin will also support NSH patches.
14:48:16 <mdgray_> #info Clarification, Apex will install OVS with DPDK aswell (but not with NSH)
14:48:34 <mdgray_> #info Should work with virtual and bare-metal deployments.
14:49:10 <mdgray_> #info Yardstick should run but no results yet.
14:49:42 <mdgray_> #action Tom: If results are available for Yardstick, it would be god to compare with the Fuel results.
14:49:59 <mdgray_> #info Tom asks where are the results stored.
14:50:14 <mdgray_> #info Billy clarifies that he achieved his results manually.
14:51:34 <mdgray_> #info Comparable results will give us a good feeling that things are running correctly.
14:57:37 <mdgray_> #endmeeting