15:02:12 <trevor_intel> #startmeeting OPNFV Pharos
15:02:12 <collabot> Meeting started Wed Sep 16 15:02:12 2015 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:12 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:12 <collabot> The meeting name has been set to 'opnfv_pharos'
15:02:24 <ChrisPriceAB> #info Chris Price
15:02:48 <trevor_intel> #info trevor_intel
15:02:48 <fdegir> #info Fatih Degirmenci
15:03:00 * fdegir is in 2 meetings and might be slow responding
15:03:54 <ChrisPriceAB> All foo fdegir, I'm lurking there and focusing here.
15:03:56 <VikramDham> #info VikramDham
15:03:57 <trevor_intel> fdegir: Hi Fatih ... can you help drive please I am in aother F2F meeting
15:03:58 <trevor_intel> Topics?
15:03:58 <trevor_intel> 1. Milestones
15:04:07 <iMSWynne> #info Michael Wynne
15:04:34 <ChrisPriceAB> Pharos stories for Brahmaputra?
15:04:35 <fdegir> trevor_intel: can try but I'm also having Arno meeting
15:04:35 * ChrisPriceAB isn't feeling epic today
15:04:42 <trevor_intel> Lets see how it goes
15:04:52 <fdegir> ok
15:05:09 <fdegir> other topics could be
15:05:10 <trevor_intel> ChrisPriceAB: ha ha
15:05:17 <fdegir> 2. Pharos backlog in Jira
15:05:24 <fdegir> 3. MAAS Prototype
15:05:43 <fdegir> 4. Update regarding potential additions to CI server pool
15:06:19 <trevor_intel> fdegir: Good list ... lets start with MAAS
15:06:20 * ChrisPriceAB thinks it would be wirth Pharos members who are working on labs could pound in with the lab reference too...
15:07:26 <ChrisPriceAB> (wirth == worth it if) dyslexia strikes
15:07:32 <trevor_intel> ChrisPriceAB: good idea
15:07:37 <trevor_intel> #info INTEL LAB trevor_intel
15:08:16 <trevor_intel> #topic MAAS
15:08:38 <trevor_intel> arturt: Can you update please?
15:08:57 <iMSWynne> #info INTEL LAB Michael Wynne
15:09:32 <iben> #info Iben Rodriguez
15:09:55 <trevor_intel> iMSWynne: can you give the update for MAAS?
15:10:27 <fdegir> pinged narindergupta on another channel
15:10:33 <iben> i’m here
15:10:37 <fdegir> I'm not sure if he sees it
15:10:46 <trevor_intel> iben: Hi Iben
15:10:55 <iben> i will ask a question but expect to get the answer later
15:11:06 <iben> we have tasks for the MaaS POC - is that the topic under discussion?
15:11:15 <trevor_intel> iben: yes
15:11:18 <iben> we have machines setup for both cluster and region controllers
15:11:31 <fdegir> narindergupta says he is in another meeting
15:11:40 <iben> these machines have network connectivity and are in the process of application installation
15:11:45 <iben> iben is working with narindergupta so far
15:11:53 <iben> we also have access to the intel lab
15:12:04 <iben> the quesiton is - we need an orientation to get started there
15:12:09 <iMSWynne> I've been in communication with Narinder, and am working on getting a server or VM set up as a cluster controller.
15:12:14 <iben> so who can spend some minutes with me
15:12:17 <iben> um
15:12:43 <iben> okay - we should work on this as a team - not indiviuals
15:12:54 <iben> i will follow up with narindergupta on this - he may be a one man army situation
15:13:11 <iben> so i guess there are maybe three of us working “together” on this maas poc project
15:13:18 <narindergupta> iben, i am working on it and hope to finish soon
15:13:20 <iben> hello iMSWynne - nice to meet you!
15:13:42 <iben> that’s the status so far - we will need to coordinate internally
15:14:03 <iMSWynne> I'm going to talk to the lab network admin about how quickly we can get that completed, going to try to complete by end of week, but may depend on his schedule.
15:14:07 <fdegir> iben: internally?
15:14:21 <iMSWynne> Hi iben, nice to meet you as well.
15:14:24 <fdegir> can we have the progress reflected to jira etc if it's not done so
15:14:26 <iben> ha ha - irk?  i meant between the members of the maas poc team
15:14:31 <fdegir> so we can also follow
15:14:36 <iben> so i don’t waste your time
15:14:47 <fdegir> it's not about waste
15:14:47 <iben> we were having many jira permission issues
15:14:53 <iMSWynne> I am also in twwo meetings and a little distracted.
15:14:59 <iben> what is the url for the maas poc jira issue?
15:15:07 <fdegir> there is 1 epic
15:15:14 <fdegir> and 4 stories under it
15:15:20 <iben> we tried to use joid project but they said it is not part of their scope
15:15:29 <fdegir> 5 epics
15:15:30 <fdegir> https://jira.opnfv.org/browse/PHAROS-27
15:15:52 <fdegir> and tbh we (or I personally) couldn't get the answer to my question
15:16:00 <fdegir> Identify the objective and scope of MAAS Proof of Concept
15:16:10 <iben> question?
15:16:11 <fdegir> which is: https://jira.opnfv.org/browse/PHAROS-49
15:16:14 <VikramDham> we would like to try maas in Dell Lab, Is there any url for instructions to use MAAS?
15:16:30 <iben> VikramDham: I can help you - you will need a public ip address
15:16:54 <fdegir> iben: if you take a look at that epic and stories under it, it would be good
15:16:54 <ChrisPriceAB> iben, maybe we should get the PoC done and have a read-out before we try and scale out too much.. ?
15:16:55 <iben> fdegir: i still have the same permissions issue
15:16:55 <iben> can’t update jira
15:17:08 <fdegir> you can comment under it
15:17:08 <iben> ChrisPriceAB: exactly - that’s what we’re doing
15:17:23 <fdegir> so we can keep the history there
15:17:24 <VikramDham> thanks Iben
15:17:32 <iben> fdegir: i’ll wait until it is assigned to someone who owns it and can edit it
15:17:39 <iben> I’m happy to help
15:17:57 <iben> but due dates and other tracking tasks require the ability to edit the issue
15:18:00 <fdegir> trevor_intel: can you assign MAAS Epic and stories to narindergupta perhaps?
15:18:10 <fdegir> we don't use due date
15:18:11 <iben> we can ‘take’ assignment
15:18:12 <iben> that’s not an issue
15:18:18 <fdegir> and i usually use asap as due date
15:18:24 <fdegir> implicitly
15:18:40 <iben> anyone can login to trello and click “assign to me”
15:18:41 <iben> i can do that too
15:18:42 <iben> but i still can’t edit the issue
15:18:50 <fdegir> can you comment an issue on jira?
15:18:56 <iben> i can comment
15:19:05 <fdegir> then that's good enough to start with
15:19:07 <iben> but if i’m doing work on something i will own it
15:19:12 <fdegir> wile waiting the permission issues sorted out
15:19:15 <trevor_intel> fdegir: Yes I will assign ownership
15:19:56 <fdegir> iben: please comment on which MAAS task you would like to work
15:19:57 <fdegir> so trevor_intel can perhaps assign it
15:20:10 <iben> i cna assign it - that’s not the issue
15:20:13 <narindergupta> VikramDham, do you want a standalone maas or maas cluster connected to regional controller in psirent lab?
15:21:06 <fdegir> iben: whatr do you mean "own" it then?
15:21:16 <fdegir> donät get it
15:21:25 <iben> it’s a jira permissions issue - ability to edit a JIRA issue
15:21:31 <fdegir> the question I asked was: can we get a bit more visibility to what's happening with MAAS
15:21:37 <fdegir> rather than internal status updates
15:21:43 <iben> look to the trello - https://trello.com/c/lZStwC4I
15:21:51 <iben> it is public
15:21:51 <fdegir> OPNFV uses jira
15:22:06 <iben> we create sub-tasks and assing work to other teams outside opnfv
15:22:32 <iben> only people with LF id and correct permissions can use JIRA
15:22:37 <iben> i’m happy to help and cross post status there
15:23:21 <iben> let’s move forward - in the interest of time - I have another meeting starting in 6 minutes to get ipv6 addresses setup for these machines
15:23:28 <iben> i can chat more this afternoon too
15:23:32 <trevor_intel> iben: Permission issues are easy to fix ... send a request to help desk
15:23:42 <fdegir> only thing I asked is to get some information regarding whatäs happening
15:24:04 <iben> narindergupta: iMSWynne VikramDham can we sync up on the MaaS POC later today?
15:24:06 <fdegir> anyway, we can move on
15:24:27 <iben> we have 3 machines up and running
15:24:27 <iben> when I get the status I’ll add a comment to the jira
15:24:32 <trevor_intel> #topic CI server pool
15:24:32 <iben> https://jira.opnfv.org/browse/PHAROS-27
15:24:41 <narindergupta> iben, sure we will sync
15:25:05 <fdegir> #info Thanks to trevor_intel and iMSWynne, we are getting 5 additional/standalone servers to use for CI
15:25:12 <iMSWynne> Yes, agreeable to sync
15:25:59 <fdegir> #info The servers will be provided from Intel lab and build, virt deploys, and other CI activities will be done on them
15:26:33 <trevor_intel> fdegir: What additional help or info needed?
15:26:34 <fdegir> I'm not sure if iMSWynne wants to add anything regarding this
15:27:02 <fdegir> trevor_intel: I don't think no extra help is needed at the moment
15:27:16 <trevor_intel> iMSWynne: anything more?
15:27:20 <fdegir> I provided some basic reqs to iMSWynne and some names to be allowed to login
15:27:29 <iMSWynne> Target for having this ready is this week.
15:28:03 <trevor_intel> #topic Pharos backlog
15:29:31 <fdegir> #info Pharos Brahmaputra backlog is available via below link/query
15:29:32 <trevor_intel> How do we get to tasks and assign ownership from stories
15:29:33 <fdegir> #link https://jira.opnfv.org/issues/?filter=10513
15:30:12 <fdegir> trevor_intel: I think we can create 1 task per lab and assign tasks  to lab owners
15:30:15 <fdegir> if we know who they are
15:30:58 <fdegir> we also need templates created which I'm not sure who can do it
15:31:32 <fdegir> trevor_intel: you already created those subtasks so just assigning them to correct people
15:32:39 <fdegir> I can go through existing lab documents and find out who created them
15:32:59 <fdegir> and ask them directly under jira tickets to see what they say
15:33:26 <trevor_intel> fdegir: sounds good
15:33:47 <fdegir> trevor_intel: but they will ask what they need to do
15:34:57 <fdegir> and for that we need some input
15:34:57 <trevor_intel> fdegir: So we need tasks
15:35:00 <fdegir> trevor_intel: you already created them
15:35:03 <fdegir> trevor_intel: like "XYZ Lab specification"
15:35:06 <fdegir> they'll ask "how to create it or based on what etc"
15:35:06 <trevor_intel> fdegir: I mean more granular level
15:36:12 <trevor_intel> fdegir: So we need to provide an example
15:36:13 <fdegir> trevor_intel: yes
15:38:30 <fdegir> I was bugging morgan_orange on another channel - he seems to be here as well
15:38:30 <morgan_orange> hi pharos team
15:38:34 <morgan_orange> cyril was there at the beginning of the meeting but he had to leave
15:38:38 <fdegir> the thing I asked to morgan_orange was that if we can get help from his colleagues with templates
15:38:39 <fdegir> and also with orange lab spec
15:38:41 <fdegir> so it can be used as example
15:38:47 <morgan_orange> We need to do it anyway, so i assume we can take the point for the templates
15:39:02 <fdegir> trevor_intel: we have a victim
15:39:15 <fdegir> https://jira.opnfv.org/browse/PHAROS-28
15:39:17 <fdegir> https://jira.opnfv.org/browse/PHAROS-30
15:39:33 <fdegir> https://jira.opnfv.org/browse/PHAROS-59
15:39:40 <fdegir> https://jira.opnfv.org/browse/PHAROS-58
15:39:46 <morgan_orange> I tried to assign some Jira to cyril but he was not declared neither in JIRA nor as commiter
15:40:06 <morgan_orange> I added them in the INFO file that I push in gerrit for review and action
15:40:37 <fdegir> morgan_orange: I think he needs to login to JIRA first
15:40:41 <VikramDham> @iben yes we can sync
15:40:41 <collabot> VikramDham: Error: "iben" is not a valid command.
15:40:51 <fdegir> and then his name will appear in the possible assignees
15:41:00 <ChrisPriceAB> People have to log into Jira for the LDAP to sync them into groups.
15:41:10 <morgan_orange> OK I will tell them
15:41:19 <fdegir> ok
15:41:21 <ChrisPriceAB> Tell all yur project memnbers to log in or you can't assign them tasks.
15:41:22 <fdegir> thanks morgan_orange
15:41:33 <fdegir> infoing this in
15:42:07 <fdegir> #info Some Pharos Jira issues could be taken by Orange contributors
15:42:14 <fdegir> #link https://jira.opnfv.org/browse/PHAROS-28
15:42:18 <fdegir> #link https://jira.opnfv.org/browse/PHAROS-30
15:42:19 <fdegir> #link https://jira.opnfv.org/browse/PHAROS-59
15:42:22 <fdegir> #link https://jira.opnfv.org/browse/PHAROS-58
15:42:52 <fdegir> #info morgan_orange will talk to cyril-orange to login to Jira so issues can be assigned
15:43:30 <fdegir> if we can get these done, it will help us a lot to push other issues forward
15:43:58 <fdegir> trevor_intel: I'm not sure what else we should talk about the Pharos backlog
15:44:09 <morgan_orange> #action morgan_orange will talk to cyril-orange to login to Jira so issues can be assigned
15:44:30 <trevor_intel> fdegir: I will assign to Orange
15:44:46 <fdegir> trevor_intel: cyril-orange needs to login to jira first
15:44:54 <fdegir> then it can be assigned
15:44:54 <morgan_orange> but they need to login to jira first
15:45:25 <trevor_intel> fdegir: got it
15:45:41 <morgan_orange> and you should also declare them as contributor if you want them to commit some rst files in Pharos repo
15:45:56 <fdegir> morgan_orange: if they signed CLA
15:46:08 <fdegir> they can send patches without any extra step
15:50:16 <morgan_orange> ok
15:50:34 <trevor_intel> Can we move to milestones?
15:50:35 <fdegir> yes
15:50:35 <trevor_intel> #topic Rls B milestones
15:50:40 <trevor_intel> I am not sure how to enter milestones
15:50:42 <fdegir> me neither
15:50:42 <fdegir> perhaps we can list them on wiki as milestones
15:50:42 <fdegir> and talk about it during B-release/Debra meeting
15:50:43 <ChrisPriceAB> what do we mean by entering milestones?
15:50:45 <trevor_intel> ChrisPriceAB: using Jira
15:50:49 <ChrisPriceAB> So as I understand it.  (and I am known to be misunderstood)
15:50:50 <ChrisPriceAB> Milestones will be passed based on Jira content, not necesarily entered in Jira.
15:50:50 <fdegir> then we will pass the milestone C
15:50:52 <ChrisPriceAB> For Milestone C, we need Jira stories and items in place and planned for the release content targetted.
15:50:53 <ChrisPriceAB> The planned is the hard part...
15:51:03 <fdegir> #info For Milestone C, we need Jira stories and items in place and planned for the release content targeted.
15:51:19 * ChrisPriceAB is feeling sorry for collabot, he seems like he needs coffee
15:51:25 <fdegir> I think we can at least prioritize them some way
15:51:49 <ChrisPriceAB> Yeah, and provide some indicative planning on what we think we will get done based on the # of people we have in place.
15:51:54 <fdegir> and highlight the importance of them and put some target
15:52:18 <fdegir> ChrisPriceAB: yes
15:52:24 * ChrisPriceAB will address the board around areas for additional resourcing if we have gaps on what we think we can get done and what we want to get done.
15:52:35 <fdegir> we might need to take some of the backlog items out of scope perhaps
15:53:01 <ChrisPriceAB> yeah show the probable scope, but also show the R2 scope that we "want to do" as well. within reason of course. :)
15:53:02 <fdegir> given the popularity of pharos :(
15:53:27 <fdegir> I think we should focus more on getting labs out from docs and show them as we market them
15:53:32 <fdegir> "federated labs ..."
15:53:42 <fdegir> "used by CI and developers ..."
15:54:10 <fdegir> the theme we thought of having was: Connected community labs with visible capability and deployment/usage monitoring.
15:54:45 <fdegir> just infoing milestone status
15:55:22 <fdegir> #info Pharos Jira backlog has been populated and it is important to prioritize the items in the backlog to have realistic scope
15:55:42 <fdegir> #info Based on Milestone-C definition, Pharos will probably fulfil the Milestone-C criteria
15:55:54 <trevor_intel> fdegir: Do we need a workign session focussed on prioritizing and scope?
15:56:00 <fdegir> #link https://wiki.opnfv.org/releases/brahmaputra/release_plan#milestone_definitions
15:56:36 <fdegir> trevor_intel: I think we should do that
15:56:38 <trevor_intel> I will have to drop off soon
15:56:43 <fdegir> and decide/discuss that
15:56:57 <fdegir> ok
15:57:17 <trevor_intel> fdegir: I will setup a meeting, ok?
15:57:25 <fdegir> ok - but I'm away/off next week
15:57:35 <ChrisPriceAB> I think we shoud look at which epic's we can deliver, and which are under risk (or not possible)
15:58:16 <ChrisPriceAB> https://jira.opnfv.org/browse/PHAROS-61?filter=10513&jql=project%20%3D%20PHAROS%20AND%20issuetype%20%3D%20Epic%20AND%20labels%20%3D%20R2
15:58:16 <fdegir> I can perhaps write some stuff on to etherpad and provide my input
15:58:16 <trevor_intel> ChrisPriceAB: I can take a pass and send on mailing list for comment?
15:58:19 <ChrisPriceAB> sounds like a plan.
15:58:26 <trevor_intel> fdegir: Please start on Ehterpad and we go form there
15:58:30 <fdegir> ChrisPriceAB: https://jira.opnfv.org/secure/Dashboard.jspa?selectPageId=10500
15:58:33 <fdegir> trevor_intel: will do
15:58:42 <fdegir> ChrisPriceAB: there are 6 epics for pharos
15:59:02 <trevor_intel> fdegir: thank you!
15:59:18 <fdegir> trevor_intel: np
15:59:28 <trevor_intel> #endmeeting