15:01:35 <trevor_intel> #startmeeting OPNFV Pharos
15:01:35 <collabot> Meeting started Wed Sep 23 15:01:35 2015 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:35 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:35 <collabot> The meeting name has been set to 'opnfv_pharos'
15:01:50 <trevor_intel> #info Trevor Cooper
15:01:57 <iMSWynne> #info Michael Wynne
15:01:58 <ChrisPriceAB> #info Chris Price
15:02:10 <bin_> #info Bin Hu
15:02:17 <trevor_intel> #info Agenda proposal ...
15:02:44 <trevor_intel> #info 1. Status of current activities
15:02:55 <trevor_intel> #info a) MAAS PoC
15:03:04 <trevor_intel> #info b) CI resources
15:03:17 <trevor_intel> #info c) Creating template examples
15:03:30 <trevor_intel> #info 2. Milestones
15:03:48 <trevor_intel> #info 3. Rls C plans
15:03:57 <trevor_intel> #info a) Project dependencies
15:04:06 <JoeKidder> quick question: is there an audio track for this meeting or is it all in IRC? thanks.
15:04:21 <trevor_intel> #info b) Readiness of first activities/sprints
15:04:35 <trevor_intel> #info c) Issues and risks
15:04:53 <iben> JoeKidder: not really
15:05:05 <trevor_intel> #info Comments / questions on agenda please
15:05:26 <iben> we can set one if for those that can’t IRC and we can help them bridge questions into IRC
15:05:32 <iben> but it’s some small effort
15:05:57 <trevor_intel> we can't use teh GTM since other meetings are happening now
15:06:05 <JoeKidder> nope - IRC is fine - I just wasn't sure if I was missing a great soundtrack - I'll just watch;)
15:06:25 <iben> yeah!  MaaS POC is first on the agenda - !!! i’m happy about that -
15:06:39 <iben> agenda looks good to me - no comments
15:06:56 <trevor_intel> #topic MAAS PoC
15:07:10 <trevor_intel> Who can give a readout ... Iben?
15:07:18 <trevor_intel> Nrinder?
15:07:23 <iben> is narindergupta here?
15:07:25 <trevor_intel> Narinder (sorry)
15:07:32 <iben> we have some progress
15:07:45 <iben> the rc and cc machines are setup
15:07:51 <narindergupta> iben: yes i am here
15:08:16 <iben> now waiting on some “pod” machines to be built out - expect eta this week or early next - this is issue on the spirent side
15:08:21 <narindergupta> right now waiting for jump host so we can register
15:08:52 <trevor_intel> Is this in Spirent or Intel lab (or both)?
15:08:53 <iben> also need to get the pod 3 setup in intel lab - narindergupta - any news on that?
15:08:58 <narindergupta> its both
15:09:05 <iben> spirnet lab from my update
15:09:26 <narindergupta> for intel lab i got the new pod access pod6 yesterday for MAAS POC
15:09:27 <trevor_intel> Question ... what is the differnce beteen PoC in Spirent and Intel lab or is it a duplicate activity?
15:09:32 <iben> we had preliminary meeting with dell lab and they are hoping to get in on the poc too but have some requirements
15:09:37 <iMSWynne> For my part I owe Narinder a lab spec for POD6.
15:09:44 <iben> our goal for poc is to show multisite capability for maas
15:10:02 <iben> so we need to have more than one and less than five labs
15:10:08 <iben> centally controlled
15:10:13 <narindergupta> correct
15:10:21 <trevor_intel> yes but haev to start with one and then built it out?
15:10:30 <iben> that plus the ability to recycle a pod from one config to next in less than an hour
15:10:52 <iben> we already have this runnign in the intel pod 5 - but not centrally to other remote labs
15:11:03 <iben> the issue with intel lab is the lack of public ip addresses
15:11:20 <trevor_intel> So focus should be central (LF) part .... yes?
15:11:26 <iben> iMSWynne: so we will use intel pod 6 for maas poc - not intel pod 3?
15:11:38 <iMSWynne> iben: correct
15:11:45 <trevor_intel> INtel POD 3 is VSPERF
15:11:55 <iben> trevor_intel: focus is any central server - can start in spirent or somewhere “easy” then move to other location when ready
15:12:24 <iben> it’s not easy for us to get servers and network changes in the LF lab - plus - that is for prodution purpose - not POC e xperiemnt - right?
15:12:32 <iMSWynne> Narinder: did the firewall rules work, or do we still have an issue?
15:12:34 <iben> sorry for typos...
15:12:40 <trevor_intel> iben: so which lab is the central one for first phase of teh PoC?
15:12:45 <iben> spirent
15:13:08 <trevor_intel> Intel is the slave and Spirent is central?
15:13:19 <narindergupta> regional control is on spirent
15:13:46 <narindergupta> and mutiple cluster controller spready across spirent and intel will have cluster controllers
15:13:47 <trevor_intel> Ok and tehn you plan to migrate to LF lab?
15:14:05 <narindergupta> correct then regional controller will get migrated to linux foundation
15:14:09 <iben> slaves in both intel and spirent - not slave but we call them cluster controllers - a cc can control multiple pods
15:14:11 <trevor_intel> goti it
15:14:21 <iben> so many cc in many labs
15:14:34 <iben> governed by one master rc or regional controller
15:14:53 <trevor_intel> This is our first milestone:     MAAS PoC  complete with recommendations re. infrastructure management system
15:14:58 <iben> once we get the rc working will with one or more cc we will move the rc to lf after a demo review by the community
15:15:08 <trevor_intel> Comments on first milestone?
15:15:23 <iben> another aspect of the poc is authentication - we need to have some sort of integration evaluated
15:15:35 <iben> we are doing research on ldap type auth now
15:16:01 <iben> soon we will need to start thinking abotu federated identity with all these labs and people sharing resources
15:16:05 <trevor_intel> When will we reach first milestone?
15:17:11 <trevor_intel> narindergupta: Is first milestone stated correctly? MAAS PoC  complete with recommendations re. infrastructure management system
15:17:35 <trevor_intel> narindergupta: What is target for completion?
15:17:44 <iben> good question - it depends on the resources and lab setup velocity - i’m shooting for next week - but narindergupta might know more
15:18:04 <narindergupta> trevor_intel: we are trying if we have maas cc controller in labs then most likely next week
15:18:25 <narindergupta> iben correct
15:18:39 <trevor_intel> narindergupta: all complete ... including recommendations documented? That seems incredibly agressive
15:19:05 <trevor_intel> I haven't seen any diagrams explaining scope yet
15:19:22 <iben> there is some documentation on the setup - but the recommendations might be simple bullet list of what to do
15:19:53 <narindergupta> trevor_intel: we have diagram let mw share with you
15:19:54 <trevor_intel> "Come up with a one/ two pager      for the POC and a drawing of what the end to end setup looks like"
15:20:32 <narindergupta> trevor_intel: https://wiki.opnfv.org/get_started/lflab_maaspoc
15:21:07 <trevor_intel> We need trackign in Jira ... will make it easy to follow progress (I think all permission issues are solved?)
15:21:11 <iben> the concept is written already - now we “prove” it - right? POC?
15:21:26 <iben> yes - JIRA permissions are working better now - thanks!
15:21:38 <narindergupta> yes it is
15:21:54 <iben> i’m certain we can reproduce the initial MaaS and JOID setup for this POC - the risk for me is the extra things we want to accomplish
15:22:01 <iben> like authentication
15:23:02 <trevor_intel> like resource reservation
15:23:59 <trevor_intel> like deploying fuel/foreman through MAAS and fuel/foreman successfully deploy Arno release using the topology created by MAAS.
15:24:27 <trevor_intel> like defining minimum resources needed in LF for MAAS to "work" across 10 (say) labs ... need to reserve hardware or can we live with a VM (with bridges on existing controller)?
15:24:30 <iben> is fuel foreman part of milestone 1?
15:24:43 <narindergupta> deploying  fuel/foreman through MAAS we can demostrate
15:24:44 <trevor_intel> Jira says 2 topologies
15:24:58 <trevor_intel> I think that means 2 deploers?
15:25:02 <trevor_intel> deployers
15:25:03 <iben> yes - today we have 2 - odl controller and contrail controller
15:25:27 <iben> these are the 2 topologies we will deliver next week in multi-site setup
15:25:29 <trevor_intel> What deployers?
15:25:51 <iben> er? maas is today running joid
15:26:03 <narindergupta> we can do it with joid definetely but for fuel and foreman only Arno images
15:26:04 <iben> so for this POC a assume we will continue with that
15:26:22 <iben> expanding this to other installers has not been done but can be added as milestone 2
15:26:31 <iben> would that be okay?
15:27:14 <trevor_intel> If you can expand the one/two pager to explain these details it will go a long way IMO
15:27:47 <trevor_intel> I think that scope is still not clear to those of us who are not doing the work :)
15:27:58 <iben> okay - thanks! this is good feedback
15:28:08 <trevor_intel> Also please comment on all the realted Jira epics
15:28:31 <trevor_intel> Thanks all MASS contributors!
15:28:35 <iben> i’m still learning too - so just passing on MY understanding - the proof is in the pudding - i am expecting we can pull it off - we shall see.
15:28:36 <trevor_intel> MAAS
15:28:48 <trevor_intel> lets move on
15:29:07 <trevor_intel> #topic CI resources
15:29:27 <trevor_intel> iMSWynne: anything to report?
15:29:47 <trevor_intel> or anybody else?
15:30:14 <iMSWynne> Yes, the systems are ready in POD4. Received the connections strings from Aric.
15:30:26 <iMSWynne> Installing todayy.
15:30:54 <trevor_intel> iMSWynne: great!
15:31:16 <trevor_intel> Looks like we can move to next topic :)
15:31:34 <trevor_intel> #topic Template examples
15:31:46 <trevor_intel> Is there anybody from orange?
15:31:52 <trevor_intel> Orange
15:32:33 <trevor_intel> I still couldn't assign tasks ... Cyril, Olivier, Bertrand have not logged into Jira yet.
15:32:55 <trevor_intel> I will follow up with them
15:33:01 <trevor_intel> next topic ...
15:33:23 <trevor_intel> #topic Milestone planning
15:33:51 <trevor_intel> #link https://etherpad.opnfv.org/p/pharos_brahmaputra
15:34:15 <trevor_intel> Look at bottom of Etherpad
15:35:02 <trevor_intel> I need help/input to get the miletones in shape ... and some dates
15:35:19 <trevor_intel> How can we do this?
15:35:35 <trevor_intel> We can go through each one now?
15:35:42 <trevor_intel> and get comments
15:35:50 <trevor_intel> ... lets try that ...
15:35:53 <trevor_intel> ok?
15:36:13 <trevor_intel> Or other ideas?
15:36:34 <iMSWynne> ok, I have to drop in a few minutes for another meeting though
15:38:09 <trevor_intel> #info 1. MAAS PoC  complete with recommendations re.     infrastructure management system
15:38:21 <trevor_intel> I think we covered that
15:38:36 <trevor_intel> #info . Templates created
15:38:47 <trevor_intel> #undo
15:38:47 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2fef910>
15:39:01 <trevor_intel> #info 2. Templates created
15:39:37 <trevor_intel> These are Lab specs, complinace checklist for dev and CI labs, lab access and user guides
15:41:10 <trevor_intel> #info 3. Management system setup and documented
15:42:15 <trevor_intel> #info 4. Establish community lab model for CI with goal to support CI Pipeline for all Rls B installers and include a testing scheme
15:42:41 <trevor_intel> #info 5. CI lab model implemented in one community lab with documentation
15:43:19 <iMSWynne> we have a template for the lab spec, right? Has anything else been done with #2? I'd like to know how much time I have
15:44:50 <trevor_intel> iMSWynne: Teh spec we have was thron together for Rls A
15:44:53 <trevor_intel> thrown
15:45:16 <trevor_intel> We need a "proper" spec with templates for each community lab to fill
15:45:25 <iMSWynne> ok, good.
15:45:35 <trevor_intel> Orange has been assigned to create an example template
15:46:03 <trevor_intel> #info 6. Establish community lab model for Dev with goal to support dev and test projects include a testing scheme
15:46:16 <trevor_intel> #info 7. Lab spec templates filled by participating community labs
15:46:18 <iben> i see some people in the etherpad but they are not “named”
15:46:22 <iben> they are annoymous
15:46:31 <trevor_intel> #info 8. Dev lab model implemented in  one community lab with documentation
15:46:53 <VikramDham> Where can I find templates
15:47:16 <trevor_intel> VikramDham: Our job is to create them
15:47:40 <trevor_intel> And we need owners for the tasks
15:47:46 <iMSWynne> I like to know what others have in mind for the timeline on #7
15:47:51 <trevor_intel> Otherwise it will not happen
15:48:09 <VikramDham> ok
15:48:50 <trevor_intel> iMSWynne: We should ask Orange who are assigned initial task of creating example templates
15:49:38 <trevor_intel> Names are not assigned in Jira yet because assignees haev not logged into Jira (last time I checked)
15:50:25 <trevor_intel> oops I have to drop in 10 min
15:50:54 <trevor_intel> #info Trevor requests input on milestones documented on Ehterpad https://etherpad.opnfv.org/p/pharos_brahmaputra
15:51:59 <trevor_intel> #action ALL pharos committers and lab owners are assigned task to review milestones and update/edit/comment (ASAP please)
15:52:17 <trevor_intel> I will enter it as a task in Jira
15:52:37 <trevor_intel> what is the IRC command for assigning ARs?
15:53:08 <trevor_intel> #topic Rls C plans
15:53:32 <trevor_intel> I am not too clear on dependencies
15:53:42 <trevor_intel> Ci has a dependency on Pharos
15:53:55 <trevor_intel> What about projects Pharos is dependent on?
15:54:34 <trevor_intel> Also need niput on risks?
15:54:42 <trevor_intel> inpput
15:55:03 <trevor_intel> What are the top issues?
15:55:26 <bin_> #info quick question: how much will the Pharos B Release be different from Arno release http://artifacts.opnfv.org/arno.2015.1.0/docs/pharos-spec.arno.2015.1.0.pdf?
15:56:46 <bin_> In another word, if we start to build a lab based on Pharos in Arno, how much new effort shall we anticipate?
15:57:22 <trevor_intel> bin_: expanded scope ... there will be two models 1) CI lab model 2) Dev lab model
15:57:45 <trevor_intel> sorry I have a hard stop
15:57:55 <bin_> I assume Arno Pharos is CI Lab model, right?
15:58:20 <bin_> No problem, and we can continue to discuss on mailing list
15:58:29 <trevor_intel> bin_: no it was for dev ... all CI resources were in LF lab
15:59:05 <bin_> I see. Let me write an email to you to further discuss it.
15:59:15 <trevor_intel> I will fill out Rls milestone C repoort and assign Jira tasks to review and comment on milestones etc.
15:59:56 <trevor_intel> bin_: I can respond next week ... I am on crital path of an intenal release and swamped
16:00:01 <trevor_intel> sorry
16:00:06 <trevor_intel> #endmeeting