15:00:43 <trevor_intel> #startmeeting OPNFV Pharos
15:00:43 <collabot> Meeting started Wed Oct  7 15:00:43 2015 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:43 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:43 <collabot> The meeting name has been set to 'opnfv_pharos'
15:01:09 <iMSWynne> #info Michael Wynne
15:01:34 <trevor_intel> Lab reps  please record attendance and lab represented ... #info LABNAME my-name
15:01:53 <iMSWynne> #info Intel Michael Wynne
15:01:55 <fdegir> #info Fatih Degirmenci
15:02:09 <ulik> #Info uli
15:02:19 <trevor_intel> #topic Agenda bashing
15:03:14 <trevor_intel> #info 1. Current activities
15:03:28 <trevor_intel> #info MAAS PoC
15:03:50 <trevor_intel> #info templates
15:04:03 <trevor_intel> #info 2. CI resources
15:04:15 <ChrisPriceAB> #info Chris Price (late as usual)
15:04:20 <lmcdasm> #info Daniel Smith
15:04:43 <trevor_intel> #info 3. Jira task assignments
15:04:52 <lmcdasm> #info Ericsson Lab - Daniel Smith
15:05:05 <ChrisPriceAB> #info We might discuss additional infra in the LF lab based on yesterdays agreement on TSC and Brahmaputra meetings,.
15:05:11 <trevor_intel> Input, comments on agenda?
15:05:37 <trevor_intel> ChrisPriceAB: yes we can put that under CI resources
15:05:48 <lmcdasm> perhaps a bit of discussion on how we deal with labs not in Pharos spec (custom labs, laptops, etc)?  Just wondering how we handle that stuff
15:06:24 <lmcdasm> if we have time.
15:06:36 <trevor_intel> lmcdasm: yes ok
15:07:15 <trevor_intel> Lets start with the current activites and then talk CI reources ... then see what time is
15:07:31 <trevor_intel> #topic MAAS PoC
15:07:46 <trevor_intel> narinder can you start?
15:08:11 <trevor_intel> Is status reflected in Jira?
15:08:19 <fdegir> narindergupta: ping
15:08:42 <lmcdasm> i see "discon" message about narinder it other chat windows... maybe he has connection issues?
15:08:50 <narindergupta> fdegir, hi
15:08:53 <lmcdasm> :)
15:09:08 <fdegir> narindergupta: the topic is MAAS
15:09:16 <trevor_intel> narindergupta: Please give status
15:09:51 <narindergupta> fdegir, yeah we were able to configure mutiple labs and pods to MAAS. But seeing performance issue where regional controller act as proxy and dns
15:10:13 <trevor_intel> In Jira one task is in progress others are open
15:10:25 <fdegir> what does "configure multiple labs and pods to MAAS" mean?
15:10:36 <narindergupta> fdegir, Iben still need to work on clarifying
15:11:18 <narindergupta> fdegir, for maintaining the mutiple community labs from single controller
15:11:19 <trevor_intel> This task is still in progress  ...  Identify the objective and scope of MAAS Proof of Concept
15:12:23 <fdegir> narindergupta: again if I go back to first issue regarding community labs; reservation and status visibility
15:12:33 <fdegir> does "maintaining" mean this?
15:12:44 <fdegir> can I see the booked/free labs/pods via MAAS?
15:12:54 <fdegir> can I book a free pod?
15:12:56 <narindergupta> fdegir, yes status visibility and deploy the jumphost node
15:13:08 <narindergupta> fdegir, yes you can do that
15:13:21 <narindergupta> fdegir, you can assign nodes if those are free
15:13:32 <lmcdasm> Narinder - just a question for you -
15:13:39 <narindergupta> lmcdasm, sure
15:13:49 <lmcdasm> when you are deploying, are you having MAAS deploy the FOREMAN/FUEL VM to the jumphost and then do a OSTACK deployment from there
15:14:05 <lmcdasm> or are you deploying MAAS to the Jumphost (so its under control of the reginoal) and then doing a Ubuntu/MAAS openstack deployment?
15:14:15 <narindergupta> lmcdasm, correct forman / fuel /joid all three options are there
15:14:21 <lmcdasm> thx
15:14:23 <fdegir> narindergupta: when I say "can I do this or do that"
15:14:37 <fdegir> I ask if the POC reached the point or not
15:14:42 <narindergupta> fdegir, yeah through cli or gui you can do that
15:14:47 <fdegir> not if MAAS can do that or not; we know it can do
15:15:24 <fdegir> narindergupta: can we reflect the status to jira or wiki or whatever you document the POC progress?
15:15:43 <narindergupta> sure i will update the JIRA on the progress today
15:15:44 <trevor_intel> narindergupta: are you ready to do a demo for teh community?
15:16:16 <narindergupta> trevor_intel, yes we can do that may be week after next week
15:16:41 <narindergupta> trevor_intel, as we are traveling to seatle next week
15:17:08 <fdegir> #info narindergupta says that they're able to configure mutiple labs and pods to MAAS. But seeing performance issue where regional controller act as proxy and dns
15:17:21 <lmcdasm> sorry narinder - one more question - is there a requirements document, or something that outlines what you need in terms of connectivity from the regional controller into labs (for example if i want to add some of our labs to your controller or others?).
15:17:35 <trevor_intel> narindergupta: waht forum to do this, we need a GTM, how much time?
15:17:36 <fdegir> #info Iben still has work to do to clarify the aim of the POC
15:18:26 <fdegir> #info narindergupta says MAAS POC reached to the point that one can see the visibility of the PODs and reserve them
15:18:30 <narindergupta> trevor_intel, i think in technical meeting on thursday we can do
15:19:25 <narindergupta> trevor_intel, fot GTM dates still needs to finalize as we are trying to solve performance issue
15:20:04 <trevor_intel> narindergupta: thinking to use teh T&P meeting on Thursday
15:20:32 <narindergupta> trevor_intel, this thursday?
15:20:53 <trevor_intel> narindergupta: clarification ... are you using the LF lab for regional controller yet ... or just Spirent lab?
15:20:59 <ulik> We could also use Bin's meeting.
15:21:05 <trevor_intel> narindergupta: no in 2 weeks
15:21:10 <narindergupta> trevor_intel, currently spirent lab only
15:21:17 <ulik> Not very busy these days...
15:21:18 <narindergupta> trevor_intel, ok sounds good in two weeks
15:21:29 <trevor_intel> narindergupta: so teh performance issues could be related to Spirent?
15:22:24 <narindergupta> trevor_intel, no its not Spirent issue its an issue with MAAS architecture currently as proxy and dns always lies to regional controller
15:22:24 <trevor_intel> ulik: hmmm ... narinder can only demo in 2 weeks
15:22:45 <narindergupta> and cluster controller uses the same proxy
15:23:29 <narindergupta> other solution is use the regional controller per lab. And add another scrips who do the syncs from all regional controller through MAAS aPI.
15:23:30 <trevor_intel> #action Trevor to schedule demo of MAAS PoC in 2 weeks
15:23:38 <lmcdasm> any chance, we can help setup what you ahve in Spirent and see if we can help with the performance issues (i have some blades available). :)
15:23:45 <narindergupta> i am working with MAAS team to see what can be done
15:24:02 <lmcdasm> cool.. if you need some help Narinder. i have some bandwidth this and next week
15:24:15 <narindergupta> lmcdasm, sure i will let you know
15:24:57 <trevor_intel> anythign else for MAAS today?
15:25:37 <trevor_intel> I am still unlcear on status of https://jira.opnfv.org/browse/PHAROS-49
15:25:47 <trevor_intel> Identify the objective and scope of MAAS Proof of Concept
15:26:12 <narindergupta> trevor_intel, Iben has to work on this and will see if Iben can help me here this week.
15:26:22 <trevor_intel> narindergupta: ok
15:26:29 <trevor_intel> lets move on
15:26:42 <trevor_intel> #topic Templates
15:27:38 <fdegir> the orange guys have taken over the template stories last week
15:27:39 <trevor_intel> #info Jira tasks were assigned to Orange lab owners
15:27:51 <fdegir> they're not around atm
15:27:56 <trevor_intel> fdegir: thanks great
15:28:23 <trevor_intel> #info task owners not available to give statsu update
15:28:41 <trevor_intel> can we move on to CI?
15:28:54 <fdegir> yes
15:29:06 <trevor_intel> #topic CI resources and plan
15:29:32 <fdegir> #info The current status with CI resources have been captured on below link
15:29:35 <fdegir> #link https://wiki.opnfv.org/pharos/hw_resource_allocation
15:30:05 <fdegir> as you see there; we only have 2 PODs which one of them is currently being reconfigured
15:30:20 <fdegir> and only 1 proper server; ericsson-build
15:30:21 <ChrisPriceAB> So the question for me is if, when and how we might need to adjust these plans based on availability of additional infra.  :)  And the effort involved to make the changes.
15:30:37 <trevor_intel> So there is alot of unknown as to what CI will get from community labs
15:30:56 <fdegir> trevor_intel: except intel and ericson labs
15:31:01 <fdegir> the rest is kind of unknown
15:31:23 <fdegir> ChrisPriceAB: that's why I asked the question about stopping the POD1 reconfig
15:31:29 <fdegir> after getting 5 servers from intel
15:31:40 <fdegir> since rebuilding POD might be harder then destroying it
15:31:57 <ChrisPriceAB> Yeah, not sure when we might have the extra equipment though...  chickens and eggs.
15:32:10 <fdegir> but it is probably too late now since pbandzi is already halfway through
15:32:13 <ChrisPriceAB> Oh, you mean build infra from the Intel lab?
15:32:31 <fdegir> nope; rebuilding back the POD1 in case if we get 4 servers into LF
15:32:42 <ChrisPriceAB> Ah OK.
15:32:47 <fdegir> but this is all speculation until they're in the lab
15:33:09 <fdegir> some more updates regarding resource situataion
15:33:13 <ChrisPriceAB> That's why I wonder about the effort.  We might end up running in CM circles if we speculate too much or don't plan well.
15:33:31 <fdegir> #info 5 servers from intel have been connected to Jenkins and need to be configured
15:33:49 <fdegir> #info Contacted Tim Rozet regarding configuring them for apex
15:33:53 <lmcdasm> so trevor_intel.. you are looking for more labs?  If we are not so concerned about following the reference architecture, i can provide some more rigth away
15:34:39 <fdegir> #info Tim Rozet has action from octopus meeting to connect intel pod4 to jenkins; increasing no of pods
15:34:47 <trevor_intel> lmcdasm: I think we are tryign to find out first what we really have and what we will have from all the labs
15:34:54 <fdegir> #info 1 new server will come from ericsson for virtual deployments
15:35:14 <lmcdasm> thx trevor.. maybe i can take a second here to ask about this.
15:35:26 <fdegir> #info So the final picture will be; 13 standalone servers (2 ericsson, 5 intel, 6 lf)
15:35:26 <trevor_intel> lmcdasm: sure please do
15:35:35 <fdegir> #info 2 PODs (1 intel, 1 LF)
15:35:54 <lmcdasm> we see alot of people coming with setting up labs (CI and otherwise), but we see alot of hacking around (since they dont match the reference arch - for example the NUS's that Bryan Sullivan setup)..  im just wondering how much enforcement we want to make for this as well
15:36:34 <lmcdasm> since if we are more flexible (and thus provide time to hack togethers peoples labs) we have more labs resources sure, but they dont match our stated arch.  so im wondering how strict we want to be
15:37:12 <lmcdasm> fdegir - we have "more" if you need as well
15:37:21 <fdegir> lmcdasm: I know
15:37:36 <fdegir> but we shouldn't beat the same guys all the times :)
15:37:48 <fdegir> we have lots of labs/resources listed on wiki
15:38:02 <fdegir> and this perhaps brings us to the next topic; contacting lab owners
15:38:25 <fdegir> and collecting more info regarding lab availability, purpose, plans
15:39:08 <trevor_intel> fdegir: agree we need visibility to see "reality" at a glance ... should be reflected by Jenkins
15:39:26 <fdegir> yep
15:39:46 <trevor_intel> fdegir: I think we do need to set a "bar"
15:40:05 <lmcdasm> should we add a Primary Contact field in the table on the page you sent out Trevor?
15:40:06 <trevor_intel> otherwise we can't plan
15:40:12 <lmcdasm> and then have the labs resp fill that in?
15:40:21 <fdegir> agree; we allowed everyone to come to jenkins thinking they will provide those resources
15:40:31 <fdegir> but we were perhaps a bit ambitious
15:40:34 <fdegir> so
15:40:54 <fdegir> we will contact lab owners and let them know that we might need to remove their labs from OPNFV Jenkins
15:41:02 <fdegir> if they don't fulfil CI reqs
15:41:20 <fdegir> since this confuses people; seeing lots of labs connected to jenkins
15:41:21 <trevor_intel> fdegir: can you create a list of things we need to know?
15:41:36 <lmcdasm> ok - do we have clear CI requirements (for CI labs)? using the page taht we came up with a couple weeks ago defining the different bewteen a Developer Lab and a CI lab?
15:41:46 <ulik> .. and also remove them from pharos wiki
15:41:50 <fdegir> trevor_intel: will do that using what ulik  provided
15:41:55 <lmcdasm> maybe thats a starting point - and pointing to our reference architecture.
15:42:00 <fdegir> lmcdasm: the first step is to get a high level info
15:42:10 <fdegir> why all those labs are listed on pharos webpage
15:42:13 <fdegir> and connected to jenkins
15:42:17 <fdegir> who uses them
15:42:25 <fdegir> and what are the plans of lab owners
15:42:32 <fdegir> if they say "we will give this to ci"
15:42:37 <lmcdasm> sounds like a good plan - do some clean up - and see who "answers" when they see its being removed
15:42:40 <fdegir> and then we can point to the requirements
15:42:48 <lmcdasm> and then give them the CI reqs and see (check again) if they can participate
15:42:49 <fdegir> will you be able to fulfil them or not
15:42:56 <fdegir> and similar for developer resources
15:43:06 <fdegir> "do you have clear guidelines/contacts for developers"
15:43:07 <fdegir> and so on
15:43:26 <fdegir> and based on the result
15:43:29 <lmcdasm> do we want to include developers labs - or just say that anything that doesnt met CI reqs, is a Dev Lab and then they are on their own?
15:43:38 <fdegir> both jenkins and pharos page could be cleaned up a bit
15:43:39 <trevor_intel> #action Fatih to create a list of information for lab owners to provide (based on CI requirements) ... send this to all lab owners
15:43:51 <lmcdasm> not on their own, but not managed by Pharos i mean / captured in this setup
15:44:03 <fdegir> lmcdasm: we have 2 parts; CI resources which helps us to cleanup jenkins
15:44:12 <fdegir> and the rest; helps us to cleanup pharos page
15:44:50 <lmcdasm> ahh.. thx for explain'
15:44:52 <fdegir> so saying "anything that doesn't meet CI reqs" is not enough
15:45:03 <fdegir> since we only have 1 lab that matches to CI reqs; LF Lab
15:45:12 <fdegir> but this doesn't mean the rest can be used for dev
15:45:28 <fdegir> we don't know; that's our problem if you ask me
15:46:07 <fdegir> and then once we have this list; MAAS or whatever infra management we will have can hook in to those labs
15:46:39 <fdegir> a question to trevor_intel and ulik
15:46:42 <trevor_intel> Ok I suggest that we let Fatih create the list as next step
15:46:57 <fdegir> should we give a heads up regarding our intentions to TSC?
15:47:18 <fdegir> (we already have an action from TSC to contact lab owners)
15:47:51 <fdegir> so we kind of answer to the action item by talking about our short term plan
15:47:57 <fdegir> and see what they say
15:48:22 * ChrisPriceAB likes that plan.
15:49:05 <trevor_intel> fdegir: No issue IMO
15:49:29 <fdegir> can one of you please take this as an action to bring to TSC?
15:49:57 <trevor_intel> fdegir: lets gather information first?
15:50:21 <trevor_intel> then we haev some data to give to TSC
15:50:29 <ulik> I will keep TSC informed about progress
15:50:32 <fdegir> ok
15:51:12 <trevor_intel> fdegir: So you have teh first action, agree?
15:51:22 <fdegir> trevor_intel: agreed
15:51:26 <fdegir> will have the page tomorrow
15:51:45 <fdegir> and send for review to pharos attendees before contacting the lab owners
15:51:57 <trevor_intel> fdegir: fast as usual :)
15:52:09 <fdegir> :)
15:54:05 <trevor_intel> Do we still need to dsicuss this ... We might discuss additional infra in the LF lab based on yesterdays agreement on TSC and Brahmaputra meetings?
15:54:58 <trevor_intel> Is the conclusion that this is not a short term solution?
15:55:28 <trevor_intel> And we don't yet know what the community will pony up?
15:55:48 <fdegir> yes
15:56:01 <trevor_intel> Are there any decsions / actions around this for us?
15:56:20 <fdegir> about additional servers into LF lab you mean?
15:56:26 <trevor_intel> yes
15:56:28 <fdegir> ChrisPriceAB already triggered that
15:56:36 <fdegir> so we wait and see
15:56:42 <lmcdasm> what sort of timeline are you looking for trevor?
15:56:49 <trevor_intel> ChrisPriceAB: ok so nothign for us to decide or act on now?
15:56:52 <lmcdasm> can we use the example of the time it took to stage the LF POD1 and get it integrated as a timeline?
15:57:08 <ChrisPriceAB> not yet, waiting on the BoM, quote and budget approval
15:57:11 <trevor_intel> lmcdasm: yesterday
15:57:13 <lmcdasm> hehe.
15:57:20 <lmcdasm> ok - well.. lets talk turkey -
15:57:34 <lmcdasm> sourcing and paper to get the stuff will take how long (estimate 1 week Chris?).
15:57:36 <ChrisPriceAB> Once we act it should likely be a 4-5 week window according to aric
15:57:53 <fdegir> lmcdasm: but these new servers won't become POD
15:57:56 <ChrisPriceAB> I think, so nothing until Nov for sure.
15:57:56 <lmcdasm> cool - so we are talking about earliest 1st week of December before you have a new lab
15:58:05 <fdegir> if I'm not mistaken
15:58:16 <ChrisPriceAB> the plan is to get some additional servers to use for build etc...
15:58:24 <lmcdasm> sorry Fdegir.. can you explain a bit
15:58:24 <fdegir> since we will get 4 servers
15:58:38 <lmcdasm> ok - but that doesnt match our reference architecture for Pharos
15:58:40 <fdegir> lmcdasm: it seems there is some free space in the rack in LF lab
15:58:45 <fdegir> for 4 servers
15:58:54 <lmcdasm> our archiecture as published requires 5 servers
15:58:55 <fdegir> so we requested to fill those spaces
15:59:00 <lmcdasm> (if you are talking about Baremetal)
15:59:02 <fdegir> as for build/virt deploy servers
15:59:13 <fdegir> and then we will see again
15:59:16 <lmcdasm> so going back to my asking - these new servers will be build machines then? not for deploments?
15:59:24 <lmcdasm> ok
15:59:26 <fdegir> lmcdasm: build + virt deploys
15:59:45 <fdegir> and having a full POD is the question we have been asking
15:59:48 <lmcdasm> fair enough - just so we are clear that addingthe hardware still only leaves us with two labs (LF POD1 and POD2) that actually match what we say
15:59:55 <fdegir> lmcdasm: nope
16:00:03 <fdegir> lmcdasm: LF POD1 is not a POD anymore
16:00:14 <fdegir> this leaves us with 1 POD
16:00:17 <fdegir> +
16:00:20 <lmcdasm> we have not updated our docs to include Virtualization as a lab and this is a bad idea - since we are suppossed to be working on Carrier grade ( I would think for our CI we shoudl have some baremetal being used somewhere)
16:00:23 <fdegir> imaginary community PODs
16:00:44 <lmcdasm> hmm.
16:00:48 <lmcdasm> seems we have some issues then
16:01:08 <lmcdasm> and if we open up the can of worms to all virtualization deployments, we are going to be in real trouble.
16:01:12 <fdegir> lmcdasm: virtualization is good for having increased CI scope
16:01:24 <lmcdasm> except that we can never use the measurements
16:01:25 <fdegir> but we will still need CI on metal as well
16:01:38 <lmcdasm> at some point people are going to start to put VNF's on these things
16:01:41 <fdegir> and use them more cleverly
16:01:59 <fdegir> not like each and every build on metal directly - have weekly stable releases
16:02:05 <fdegir> that get tested on metal
16:02:23 <fdegir> or daily or more frequently depending on how many metal pods we have
16:02:25 <lmcdasm> and want to see HA, Migration and all that good stuff - we have three + installers to handle on one single BM POD - we need to, i think, reset ourselves and verify if our goals for testinga nd CI are valid still
16:02:41 <lmcdasm> fair enough - if we only care that the BUILD and DEPLOY but a test works great.
16:02:58 <lmcdasm> however, its not really carrier grade and we never test any of the items in the CI that a real DC would need to deploy into production.
16:03:01 <fdegir> lmcdasm: when I say daily/weekly CI, it includes tests
16:03:01 <lmcdasm> (security for one :P)
16:03:11 <fdegir> and on virt
16:03:17 <fdegir> we can do sanity type of testing
16:03:24 <fdegir> to check the quality of the development work
16:03:27 <lmcdasm> agreed.. lots of things can be done virtaully
16:03:32 <fdegir> but platform testing is something else
16:03:47 <fdegir> which is what you described above
16:03:49 <trevor_intel> One otehr quick topic please?
16:03:50 <lmcdasm> i guess im wondering how we say to someone " this is tested in our CI pipeline and is ready for operational deployment)
16:03:55 <lmcdasm> maybe not somethign we care abou tnow
16:04:04 <lmcdasm> go for it Trevor (im done chatting :P).
16:04:10 <trevor_intel> Orange contributors added to INFO file under Contributors heading https://gerrit.opnfv.org/gerrit/1512
16:04:45 <trevor_intel> From Morgan : the idea is to add them as committer (at least to create rst and template) not as contributor. I had a look at functest and releng, there is no contributor section in INFO file
16:05:06 <trevor_intel> What to do about this?
16:05:07 <lmcdasm> i thought the INFO file is what Aric used to put all the perms into JIRA for each group
16:05:18 <fdegir> trevor_intel: I kind of disagree what morgan does there
16:05:30 <ulik> Me too.
16:05:33 <fdegir> you don't have to make people committer in order to make them contribute to the project
16:05:37 <fdegir> they should contribute first
16:05:45 <lmcdasm> im sorry - i have another meeting to run too (also i think its backwares, you want contributers, but commiters shoudl be a smaller list i think).
16:05:53 <fdegir> and then become committers by showing they add some value
16:05:56 <ulik> INFO file is committers
16:06:09 <fdegir> so
16:06:18 <ulik> Anybody can becomw contributor
16:06:25 <trevor_intel> ok seems to be concensus here ... I will talk to Morgan about it
16:06:40 <fdegir> yep, they can send changes to gerrit
16:06:47 <fdegir> and committers review/submit them
16:06:56 <ulik> You need a vote for committer promotion
16:07:09 <ulik> Charter!
16:07:16 <fdegir> except the project is newly forming
16:07:21 <trevor_intel> ok so we can say once they contribute we are happy to do a vote?
16:07:57 <fdegir> it should be that way in my opinion
16:07:59 <trevor_intel> So as not to set a precedence for future which may be more difficult for us to handle
16:08:15 <trevor_intel> I am fine with that too
16:08:17 <ulik> Keep the number of committer low.
16:08:45 <ulik> Hard to get a vote if you have 20 committers
16:08:49 <fdegir> :)
16:09:01 <trevor_intel> will end the meeting now
16:09:11 <trevor_intel> anything else?
16:09:18 <fdegir> not from me
16:09:29 <trevor_intel> #endmeeting