15:00:42 <trevor_intel> #startmeeting OPNFV Pharos
15:00:42 <collabot> Meeting started Wed Oct 14 15:00:42 2015 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:42 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:42 <collabot> The meeting name has been set to 'opnfv_pharos'
15:00:56 <fdegir> #info Fatih Degirmenci
15:01:20 <trevor_intel> #info INTEL LAB Trevor Cooper
15:01:35 <trevor_intel> thansk for attending Fatih!!
15:01:39 <trevor_intel> thanks
15:01:41 <iMSWynne> #info Intel Lab Michael Wynne
15:01:42 <fdegir> np
15:02:43 <trevor_intel> #info Agenda proposed: 1) MAAS 2) Templates 3) Lab resource allocation 4) Requirements of Pharos lab
15:02:53 <trevor_intel> Comments on agenda?
15:03:22 <fdegir> looks good
15:03:23 <trevor_intel> We can wait a minute for others to arrive
15:04:11 <trevor_intel> Please record your attendance and if you are a lab owners which lab ... e.g. #info INTEL LAB Trevor Cooper
15:04:47 <trevor_intel> #topic MAAS PoC
15:05:01 <nahad> #info DELL LAB Nauman Ahad (representing Wenjing and VIkram today)
15:05:02 <trevor_intel> narindergupta: can you give status?
15:05:35 <trevor_intel> nahad: welcome
15:05:49 <narindergupta> trevor_intel: iben has to work on clearing the definition.
15:05:49 <wshao> #info HUAWEI LAB Weidong Shao
15:06:04 <iben> #info Spirent - Iben Rodriguez
15:06:15 <iben> #undo
15:06:23 <narindergupta> trevor_intel: and POC we have have integreted two labs with regional controller and ready to demo next week
15:06:39 <iben> #info Spirent VCT Lab - Iben Rodriguez - https://wiki.opnfv.org/pharos/spirentvctlab
15:06:51 <fdegir> #info iben will work on clearing the MAAS POC definition
15:07:22 <trevor_intel> narindergupta: is the progress reflected on Jira?
15:07:27 <fdegir> #info 2 labs have been integrated to MAAS POC with regional controller and ready to demo next week
15:07:53 <iben> #info narindergupta: and iben have not been able to communicate too much on status updates or update JIRA - but we have made updates to planning and getting started guide on wiki - link to follow
15:07:55 <trevor_intel> narindergupta: how long do you need for teh demo?
15:07:56 <narindergupta> trevor_intel: unfortunately i am on travel this week so did not got time to update JIRA. I will be back on Friday then update.
15:08:14 <narindergupta> 30 minutes should be ok for full deployment
15:08:23 <iben> #link https://wiki.opnfv.org/pharos/maas_getting_started_guide
15:08:28 <fdegir> narindergupta: deployment of?
15:08:46 <narindergupta> fdegir: deployment of jump host through regional controller
15:08:50 <iben> we can show using maas-rc to conenct to maas-cc in remote lab and deploy opnfv
15:08:52 <trevor_intel> narindergupta: ok I have added to the agenda of Test & Performance meeting
15:09:01 <narindergupta> trevor_intel: thanks
15:09:05 <fdegir> ok
15:09:17 <fdegir> deployment of jumphost and deployment of opnfv
15:09:25 <iben> right
15:09:48 <fdegir> which one is the focus?
15:10:01 <fdegir> sorry for going back to my repeating question
15:10:08 <narindergupta> fdegir:  deployment of jump host with opnfv release
15:10:23 <trevor_intel> narindergupta: means Arno?
15:10:31 <narindergupta> correct
15:10:36 <fdegir> but...
15:11:00 <fdegir> you already know my view on this
15:11:08 <trevor_intel> narindergupta: you will use INtel POD and Spirent POD for the demo?
15:11:25 <narindergupta> we have two intel pods pod5 and pod6
15:11:40 <narindergupta> spirent lab has regional controller
15:11:57 <trevor_intel> fdegir: means?
15:12:06 <fdegir> if we're going to demo this and if people ask "what is the benefit of having MAAS?"
15:12:22 <fdegir> is the answer "you can deploy OPNFV."
15:12:48 <trevor_intel> fdegir: IMO that is not a good answer
15:12:56 <fdegir> and I'll be one of the users who won't see the benefit of this
15:13:12 <narindergupta> fdegir: no we will discuss other benefit like single view of all the labs and deploy from single tool
15:13:28 <fdegir> narindergupta: I like to hear that
15:13:40 <fdegir> will you have demo for that use case as well?
15:13:41 <narindergupta> fdegir: also users can choose the lab and assign it and get it work on it
15:13:49 <narindergupta> fdegir: yes
15:14:00 <fdegir> narindergupta: now I'm ambitious
15:14:07 <fdegir> looking forward to the demo
15:14:42 <narindergupta> fdegir: cool thats the whole idea to integrete the labs who wants to take participate in CI of OPNFV tests can be integreted.
15:14:48 <fdegir> yes
15:14:48 <trevor_intel> narindergupta: I request that Jira is fully updated before the demo ... I will send out a link to jira epics so that people can look ahead and understand before seeing the demo
15:15:12 <narindergupta> trevor_intel: sure i will work on this by this weekend and finish it.
15:15:19 <fdegir> my dream is to use MAAS API so CI can book the resources if the resources are shared between CI and development work
15:15:24 <trevor_intel> narindergupta: thansk!
15:15:49 <fdegir> and noone else can book it while it's in use by CI or developers
15:16:22 <trevor_intel> More on MAAS today?
15:16:27 <narindergupta> fdegir: yes user can book the resource if they see it free
15:16:39 <narindergupta> no we are good
15:16:40 <fdegir> I'm pretty happy with what I heard
15:17:13 <trevor_intel> #topic Templates
15:17:39 <trevor_intel> Any updated from Cyril or other Orange guys?
15:17:57 <fdegir> haven't seen/heard anything yet
15:18:42 <trevor_intel> Its been a while
15:19:05 <trevor_intel> I will ping them off-line and talk to Morgan if no response
15:19:18 <fdegir> ok
15:19:59 <trevor_intel> #topic Allocation of lab resource
15:20:15 <trevor_intel> fdegir: Can you give status update on teh lab survey
15:20:31 <fdegir> #info A questionnaire was sent last week to 10 lab responsibles
15:20:48 <fdegir> #info Out of 10 labs, 6 of them answered
15:21:01 <fdegir> #info Labs that hasn't answered as of yet are
15:21:21 <fdegir> #info Cable Labs, Dell, Huawei, Orange
15:21:49 <fdegir> #info Will send out the link to responses tomorrow to Pharos people
15:22:08 <wshao> Huawei will get the info by Thursday China time
15:22:09 <fdegir> nahad: wshao: ping
15:22:15 <nahad> We are working on drafting our answers for the survey and will send them by today
15:22:17 <fdegir> thanks wshao
15:22:18 <trevor_intel> fdegir: great, I will ping the owners of those labs today
15:22:37 <fdegir> thanks trevor_intel
15:22:46 <trevor_intel> nahad: for which lab?
15:22:48 <trevor_intel> Dell?
15:22:49 <nahad> Dell
15:22:51 <nahad> yes
15:22:57 <fdegir> I can perhaps type the next steps so everyone knows what are we trying to do
15:22:59 <trevor_intel> nahad: thanks
15:23:09 <trevor_intel> fdegir: please do
15:23:10 <fdegir> #infi Steps are
15:23:18 <fdegir> #info Steps are
15:23:38 <fdegir> #info Get lab availability from lab reps - waiting for survey results
15:24:02 <fdegir> #info Get project hw/sw requirements from community - Debra sent out the mail to collect the info
15:24:12 <fdegir> #info Get LF POD1 servers
15:24:25 <fdegir> #info Match resources to requirements to do the allocation
15:24:43 <fdegir> #info Report/document the outcome and act on it
15:25:10 <fdegir> my hope is that the survey will help us to identify high level capability of the labs
15:25:17 <trevor_intel> So far only Storperf has filled out the project survey
15:25:25 <fdegir> some labs will not make into the CI and freed for dev purposes
15:26:04 <fdegir> we also have requirements for kvm in a seperate mail
15:26:23 <fdegir> will talk to Jiang so he puts reqs to wiki
15:26:34 <trevor_intel> We have an action re. LF lab ... Usage of LF lab ( defined and  documented)
15:26:57 <trevor_intel> fdegir: Is it clear yet how LF labs will be used?
15:27:16 <trevor_intel> I mean PODs
15:27:21 <fdegir> trevor_intel: I'm not happy with the current situation of LF labs
15:27:38 <fdegir> they're opened for broad acces
15:27:45 <fdegir> and some development work is done on them
15:27:58 <fdegir> on top of CI
15:28:06 <fdegir> to me, it should be hands off lab
15:28:15 <trevor_intel> fdegir: But until the usage is defined and documented we cannot control it!
15:28:16 <fdegir> and only CI and troubleshooting should be allowed
15:28:18 <wshao> sorry, where is LF Lab physically hosted?
15:28:29 <fdegir> wshao: portland
15:28:40 <fdegir> trevor_intel: agree to that
15:28:54 <fdegir> I can come up with very high list of activities
15:29:04 <fdegir> and review it together and ask TSC to approve it
15:29:16 <fdegir> and then clean up the access to the LF infra
15:30:08 <fdegir> trevor_intel: how does this sound?
15:30:21 <trevor_intel> fdegir: very good ... lets start to put on Wiki ... I will make a page and send you the link after this ... to start the list. Then its available for others to give feedback
15:30:35 <trevor_intel> fdegir: Sounds very good, thanks
15:30:42 <fdegir> ok
15:30:51 <fdegir> asking aricg to provide the list of people
15:30:59 <fdegir> so we can check what they are doing there
15:31:21 <trevor_intel> fdegir: we can put that on the Wiki too
15:31:53 <fdegir> will do that once you create the page and once aricg comes up with the list
15:32:07 <trevor_intel> fdegir: ok
15:32:25 <trevor_intel> Anythign else on lab resource planning for now?
15:32:48 <fdegir> that's all from me
15:33:09 <trevor_intel> #topic  Requirements of Pharos labs
15:33:31 <trevor_intel> #info     Requirements of Pharos labs ... https://wiki.opnfv.org/pharos_rls_b_spec
15:34:32 <trevor_intel> I sent an email about the topic of a lab "ready label" ... this was somethign raised by OPNFV board
15:35:04 <fdegir> thanks for that mail
15:35:07 <trevor_intel> There were a few responses but we need more input
15:35:11 <fdegir> I have a question
15:35:20 <fdegir> we say dev resources/labs
15:35:59 <fdegir> I don't think it is not realistic and good to have all the labs providing resources for all the projects
15:36:14 <fdegir> so the labs can be purposes for different dev activities
15:36:20 <fdegir> purposed
15:36:30 <fdegir> if this is the case
15:36:39 <trevor_intel> fdegir: correct
15:36:41 <fdegir> can we still label the labs as "ready"?
15:36:56 <fdegir> it doesn't serve for everything
15:37:16 <trevor_intel> fdegir: that is why I am stuggling with the "ready label"
15:37:17 <fdegir> But it serves some projects
15:38:06 <fdegir> I think/hope the Debra's form on wiki and your mail will give some answers
15:38:17 <trevor_intel> If I make a virtual deployment usign one server available to the internet ... does that mean I am an OPNFV "lab"???
15:38:35 <fdegir> and then we can perhaps define minimum for getting "ready" label
15:38:57 <fdegir> trevor_intel: that's my question :)
15:39:03 <fdegir> what's the minimum?
15:39:19 <trevor_intel> fdegir: indeed!
15:39:44 <fdegir> the guidelines, contacts, etc are in the list by default
15:39:54 <fdegir> but what they offer is the tricky part
15:40:59 <fdegir> trevor_intel: should we postpone this discussion to next week?
15:40:59 <trevor_intel> I updated the spec page to try and make at least the terminology clear between 1) Community lab 2) Dev lab 3) CI lab
15:41:15 <fdegir> once more answers come to your mail
15:41:28 <trevor_intel> Please look and see if you agree (update/edit/comment)
15:41:34 <fdegir> will do
15:41:37 <trevor_intel> fdegir: yes I agree
15:42:04 <trevor_intel> Only thing is the officers are impatient :)
15:42:12 <fdegir> officers?
15:42:42 <trevor_intel> OPNFV officials :)
15:42:50 <fdegir> I can understand
15:42:55 <fdegir> just before pharos meeting
15:43:06 <fdegir> Chris, Prodip, and Eric were on the stage
15:43:18 <fdegir> talking about pharos to hundred people
15:43:20 <fdegir> :)
15:43:46 <trevor_intel> :)
15:43:54 <fdegir> we're moving, we're not fast but moving some way
15:43:54 <trevor_intel> High expectations
15:44:10 <fdegir> yes
15:45:18 <joekidder> may I ask a couple of questions? (about pharos in general, so I can wait)
15:45:33 <trevor_intel> Ok I will try to answer the quesions as best I can ... can we aim to give a recommendation (from Pharos community) as to defintion of "ready" next week?
15:45:33 <joekidder> meaning I don't want to interrupt the current discussion
15:45:51 <trevor_intel> joekidder: lets just wrap this first
15:45:56 <joekidder> yep
15:46:04 <fdegir> trevor_intel: we can try
15:46:32 <fdegir> on the wiki perhaps
15:46:44 <fdegir> and see where we end up
15:47:33 <trevor_intel> #action All Pharos community reps to think about defintion of "lab ready" (see email sent by trevor yesterday on this topic) ... respod with comments and/or attend next weeks meeting to close on this.
15:48:11 <trevor_intel> Is "#action" correct?
15:48:16 <fdegir> yes
15:49:26 <trevor_intel> fdegir: You mean start to consolidate/capture feedback on Wiki?
15:49:37 <trevor_intel> trevor_intel: I can do that
15:49:58 <trevor_intel> So that next meetin we have something to work on
15:49:59 <fdegir> trevor_intel: yep
15:50:22 <fdegir> we can then associate reqs to lab classes
15:50:35 <fdegir> on that page you already created
15:50:52 <fdegir> https://wiki.opnfv.org/pharos_rls_b_spec
15:50:54 <trevor_intel> #action Trevor to create Wiki page on "ready label" and consolidate input on this question
15:50:56 <fdegir> as a draft
15:51:06 <fdegir> and then move to its final location
15:51:24 <trevor_intel> Yes I see that page as the portal for Pharos spec stuff
15:51:26 <fdegir> since we will have some references to community, dev, ci labs in the ready label stuff
15:51:37 <fdegir> we can cross reference
15:51:57 <trevor_intel> ok
15:52:18 <trevor_intel> Any further comments / questions on "lab ready" (for today)?
15:52:23 <fdegir> nope
15:52:35 <trevor_intel> joekidder: fire away
15:53:24 <joekidder> thanks.  First question: do all the 5 servers in a pod have to be the same configuration? mainly compute and controller might be different
15:54:44 <trevor_intel> joekidder: also there is a "jumphost" that can be different
15:55:34 <joekidder> yes, we expect that could be different.
15:55:35 <iMSWynne> joekidder: I prefer them to be the same, but there is no strict requirement that the HW be identical.
15:55:36 <trevor_intel> trevor_intel: I don't think the Pharos spec says all servers need to be the same
15:56:03 <joekidder> ok. that's the first.  thanks.
15:57:23 <nahad> I was a bit confued over some of the questions in the survey.  Should i ask them now or discuss later on the email thread?
15:57:36 <nahad> considering the time for the meeting is about to end
15:57:50 <joekidder> The second question is what if I'm loading ubuntu on all servers...
15:57:55 <trevor_intel> nahad: try now maybe we can answer
15:58:10 <nahad> Oh sorry. Joekidder sorry to interrupt
15:58:15 <joekidder> ...but the servers might have different kernels/drivers because they're different SoCs (if mixed arm servers)
15:58:20 <trevor_intel> nahad: its ok keep going
15:58:29 <nahad> The question related to CI:
15:58:38 <joekidder> or it might be ARM and x86 (e.g. arm compute and x86 control)
15:58:52 <nahad> Baremetal servers available 24/7 vs POD available 24/7 for CI
15:58:57 <fdegir> joekidder: wouldn't it make harder to troubleshoot stuff
15:58:58 <nahad> I was a bit confused over this.
15:59:11 <nahad> By POD we mean the POD is deployed and is just integrated to CI?
15:59:21 <fdegir> if we can get past the potential problems having different kernels/drivers
15:59:36 <nahad> and with Baremetals available for CI, we have the jumpserver provisioned and connected to CI, not the other servers?
15:59:42 <trevor_intel> joekidder: that would be a good thing ... shows diversity, right?
16:00:00 <fdegir> nahad: POD=5+jumphost
16:00:11 <fdegir> nahad: jumphost connected to CI
16:00:22 <fdegir> where we initiate the deployment/testing from
16:00:40 <fdegir> all the 6 servers up &running 24/7
16:00:46 <joekidder> fdegir: assuming that each node is fine/stable with its kernel/drivers.  More a question of whether this would confuse the heck out of the installer or whether the linux repo, if mixed, could support it.
16:00:47 <nahad> but in both cases, isn't the jumphost connected to CI?
16:00:48 <fdegir> and noone else but CI can use them
16:01:02 <fdegir> for standalone servers
16:01:08 <nahad> ok
16:01:14 <fdegir> I wouldn't call jumphost
16:01:31 <trevor_intel> nahad: That is for CI resources
16:01:33 <fdegir> it's general purpose server for CI builds/test etc
16:01:53 <fdegir> joekidder: that was what I was trying to ask
16:02:05 <fdegir> if installers have trouble due to this
16:02:46 <fdegir> nahad: which question was it?
16:02:50 <trevor_intel> fdegir: Do you agree that for Dev resources there is not the same requirement to connect to LF? BUT we do need connectivity requirement (is it defined yet?)
16:02:54 <joekidder> fdegir - I'm hoping that it might not be a problem. My original thought was that for each type of server, we might have the installer point to a different repo
16:03:14 <nahad> fdegir: Q8
16:03:16 <fdegir> q8?
16:03:18 <nahad> yes
16:03:18 <fdegir> yep
16:03:31 <fdegir> POD is the pharos POD spec
16:03:40 <nahad> ok
16:03:44 <fdegir> 5+1
16:03:54 <fdegir> the other one is as I said, general purpose servers
16:04:06 <fdegir> but only CI is allowed to use
16:04:08 <nahad> So right now we have a jump server connected to CI. That jump server deployed foreman on 5 servers
16:04:15 <nahad> oh ok
16:04:28 <nahad> so by the POD we mean, only CI is allowed to use the rest of the 5 servers
16:04:31 <joekidder> fdegir: but I looked a little at some repos and they might have an arrangement that would support multiple architectures. Potentially.
16:04:45 <fdegir> nahad: yes in q8 context
16:05:06 <nahad> ok. Thanks
16:05:09 <fdegir> np
16:05:33 <fdegir> joekidder: I think you asked this question on mailing list as well
16:05:34 <nahad> and the first answer CI for baremetal servers 24/7
16:06:07 <joekidder> fdegir: yes, same question.  I figured I'd ask it here...not sure it would get answered in email:)
16:06:07 <fdegir> and as you pointed there, genesis could be the forum where you could get satisfying answer
16:06:31 <joekidder> fdegir: good point/advice.  I'll follow up with them!
16:06:37 <fdegir> for pharos, as trevor_says, it provides diversity
16:06:44 <fdegir> but if we can make it work
16:06:48 <joekidder> fdegir: but pharos doesn't care.  Which is excellent.
16:07:12 <fdegir> I don't remember if pharos spec has this much details
16:07:16 <nahad> would this be something to do with MAAS? That CI could  provision servers to install OPNFV? I mean i was a bit confused that if we later use MAAS, it would deploy jumphost. But Jumphost should be connected to CI
16:07:38 <fdegir> trevor_intel is the one who can clarify this if and how much pharos cares
16:08:33 <fdegir> nahad: that's the same question I've been trying to get the answer from MAAS POC
16:08:49 <fdegir> I propose not to mix MAAS into this as of yet
16:08:58 <fdegir> until we see the demo and the outcome of the POC
16:08:59 <nahad> oh ok. Thanks fdegir
16:09:12 <fdegir> the question is: can you dedicate CI resources
16:09:26 <fdegir> if so, what type; full POD or just 1 or 2 servers
16:09:43 <nahad> Oh thanks. That really makes it clear :)
16:09:57 <fdegir> MAAS could be useful if we have resource outage and need to share the resources between ci and dev
16:10:15 <fdegir> so we can offload ci work to shared resources when the demand peaks using maas as booking system
16:10:36 <nahad> ok
16:11:53 <fdegir> I suppose we're done for the day
16:12:08 <trevor_intel> joekidder: : I think we care to the extent that 1) follows the baseline Pharos spec AND 2) it "works". There are many implementation details are up to the lab owners
16:13:07 <joekidder> trevor_intel: thanks!
16:13:21 <joekidder> bye, all.
16:13:28 <trevor_intel> fdegir: yes
16:13:32 <trevor_intel> thansk all!
16:13:37 <nahad> Thank you everyone. Bye!
16:13:41 <trevor_intel> #endmeeting