15:00:49 <trevor_intel> #startmeeting OPNFV Pharos
15:00:50 <collabot> Meeting started Wed Oct 21 15:00:49 2015 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:50 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:50 <collabot> The meeting name has been set to 'opnfv_pharos'
15:01:16 <trevor_intel> #info Trevor (Intel lab)
15:01:20 <fdegir> #info Fatih Degirmenci
15:01:24 <narindergupta> #info Narinder Gupta
15:01:45 <iMSWynne> #info Michael Wynne - Intel Lab
15:02:09 <trevor_intel> #Agenda  1) MAAS 2) Templates 3) LF lab 4) Allocation and mapping of lab resources
15:02:27 <trevor_intel> Agenda comments?
15:02:42 <trevor_intel> #info Agenda  1) MAAS 2) Templates 3) LF lab 4) Allocation and mapping of lab resources
15:03:43 <trevor_intel> #topic MAAS
15:03:58 <narindergupta> regarding MAAS i have clear the MAAS description in JIRA for POC. And we have mutiple regional controllers now in different labs.
15:04:11 <trevor_intel> narindergupta: CAn you give an update, ready for the demo tomorrow?
15:04:32 <narindergupta> yes we are ready for demo tomorrow.
15:04:40 <trevor_intel> narindergupta: ok great
15:04:56 <narindergupta> i am doing last minute scription to consolidated view of regional controller though.
15:05:27 <trevor_intel> narindergupta: Will you present some slides ... it will be teh first time some people hear about MAAS
15:05:28 <narindergupta> what we will demo is mentioned in the jira MAAS POC description.
15:06:01 <fdegir> narindergupta: is it possible to record the demo and publish it somewhere?
15:06:09 * fdegir will miss the demo due to travel
15:06:10 <trevor_intel> narindergupta: I think you need to start with high level description of what MAAS is and objectives of teh PoC
15:06:12 <narindergupta> yes i will prepare some slides about maas and present it. But i need to put on ubuntudemo.com as webex does not do well
15:06:15 <narindergupta> on ubuntu
15:06:40 <trevor_intel> narindergupta: Yes I can record it and publish on OPNFV Youtube channel ... please remind me at teh beginning
15:06:50 <narindergupta> fdegir: if someone can help me in recording then yes we can do that
15:07:00 <trevor_intel> fdegir: that is too bad
15:07:32 <trevor_intel> narindergupta: We use GoTo meeting
15:07:39 <fdegir> I might watch from my phone in the airport
15:07:52 <fdegir> I think gotomeeting meetings can be recorded
15:08:10 <trevor_intel> fdegir: yes they can I know how to do it
15:08:19 <narindergupta> fdegir: goto meeting also have issue in sharing my desktop with ubuntu
15:08:19 <fdegir> thx trevor_intel
15:08:53 <fdegir> that's also true; gotomeeting linux client is limited in functionality
15:08:55 <narindergupta> trevor_intel: can u send me meeting invite so i can test it before hand and let you know
15:09:27 <narindergupta> i can show my desktop using http://demoubuntu.com/narindergupta
15:09:36 <VikramDham> Where I can get GTM info?
15:09:49 <trevor_intel> narindergupta: I just sent it
15:09:53 <VikramDham> I don't see dialing info in meeting invite or pharos meeting page
15:09:55 <narindergupta> thanks
15:10:29 <trevor_intel> #info meeting logistics https://wiki.opnfv.org/meetings/test
15:11:16 <trevor_intel> Anything to disuss about MAAS today?
15:12:12 <trevor_intel> Will take that as no ... so we will wait for the demo :)
15:12:29 <trevor_intel> #topic Templates
15:12:49 <trevor_intel> #Info Is there anyone from Orange who can update on templates?
15:13:37 <trevor_intel> #Info Nobody available
15:14:50 <trevor_intel> I will ping Morgan again to see if he has latest
15:15:14 <trevor_intel> #topic Allocation of lab resources
15:16:13 <trevor_intel> Thansk to fdegir we have a good set of data from labs
15:16:32 <trevor_intel> fdegir: How did Cable labs respond?
15:16:46 <trevor_intel> Are they going to proivde resources?
15:16:48 <fdegir> trevor_intel: they answered the survey
15:16:56 <fdegir> and they say they have the resources
15:17:13 <fdegir> but I'm not sure what it means when they say they have resources
15:17:21 <fdegir> I haven't heard anyone using cable labs resources
15:17:42 <fdegir> they plan to provide more
15:17:58 <fdegir> but again, we need to see what current resources they claim to have
15:18:09 <trevor_intel> I think we need to put up detailed information about each lab on teh Wiki to make it clear ... agree?
15:18:14 <fdegir> yes
15:18:37 <fdegir> no/type of current and future resources
15:18:39 <trevor_intel> fdegir: Can you send me the detailed responses?
15:18:41 <fdegir> current allocation
15:19:26 <fdegir> it is here: https://www.surveymonkey.com/results/SM-CYC35WH2/
15:19:44 <fdegir> if you click individual responses, you will see the details answers
15:19:51 <fdegir> detailed
15:20:08 <trevor_intel> fdegir: Hmm I tried that already ... maybe I was doign it wrong
15:20:17 <fdegir> do you see it now?
15:20:22 <trevor_intel> trying now
15:21:34 <trevor_intel> E.g. Q2 ... I can't see which labs answered yes, only that 8 did
15:22:34 <fdegir> but you can see individual responses?
15:22:59 <fdegir> you need to go through individual responses to see which labs answered yes for Q2
15:23:02 <trevor_intel> No ... only where they wrote text
15:23:54 <fdegir> do you see this link: https://www.surveymonkey.com/results/SM-CYC35WH2/browse/
15:24:26 <trevor_intel> Yes I can see that
15:25:02 <trevor_intel> Ok I see the issue ... sorry I am slow
15:25:03 <fdegir> that's the one we need to go through to see who answered yes to which question
15:25:08 <fdegir> np
15:25:26 <fdegir> this is due to using free account
15:25:44 <trevor_intel> Yes I was clicking on responses in the summary
15:26:16 <trevor_intel> Ok ... next step is to put up a detaled status of each lab on Wiki (with current usage)
15:26:23 <fdegir> yep
15:26:23 <trevor_intel> Agree?
15:26:29 <fdegir> +1
15:26:53 <trevor_intel> I will do it. I have been sick this week :(
15:27:36 <fdegir> me too
15:27:41 <fdegir> working from home
15:27:45 <trevor_intel> me too
15:28:40 <trevor_intel> #action Trevor update https://wiki.opnfv.org/pharos_rls_b_labs with detiled status of community labs
15:29:05 <trevor_intel> #info Requirements for Phaors labs https://wiki.opnfv.org/pharos_rls_b_spec?&#test_lab_requirements
15:29:33 <trevor_intel> Please review the page if not already and edit/comments
15:30:22 <fdegir> I think I did that
15:30:29 <fdegir> will take a look at it again
15:31:01 <trevor_intel> Planning for release testing is an issue ... LF will not be able to handle all teh features
15:31:55 <trevor_intel> This means community labs will have to be part of testing for the release
15:32:31 <trevor_intel> I think certain labs will have to be "certified" for testing the release
15:33:52 <fdegir> yes
15:33:53 <trevor_intel> #info Cross Matrix Test projects versus Pharos labs https://wiki.opnfv.org/feature_test_project_matrix
15:34:02 <fdegir> about that table
15:34:15 <trevor_intel> yes needs to be build out
15:34:16 <fdegir> standalone servers and full pods mixed on the table
15:34:32 <trevor_intel> agree its a start ...
15:34:35 <fdegir> yes
15:34:52 <fdegir> so we can perhaps classify testing in 2 categories
15:35:17 <fdegir> the first one could be "OPNFV Reference Platform Testing" running against OPNFV deployed on a pharos compliant lab/pod
15:35:25 <trevor_intel> Was thinking we need to map FEATURES against test resources
15:35:25 <fdegir> 1 table for this
15:35:45 <trevor_intel> ok and 2nd?
15:36:05 <fdegir> the 2nd is mixed between standalone testing activities and perhaps the feature type of testing
15:36:38 <fdegir> cause the projects first need to do their testing in limited scope for development purposes
15:36:52 <fdegir> and once they get integrated to OPNFV and installed during the deployment
15:36:57 <fdegir> then they can be tested in that scope
15:37:48 <fdegir> what I'm trying to say is
15:37:53 <trevor_intel> For 2nd ... isn't that up to the project ... do we need to track it? They will test in their Dev environment?
15:37:55 <fdegir> we need to have default configuration
15:38:03 <fdegir> like what we had for arno
15:38:08 <fdegir> openstack + odl
15:38:20 <fdegir> and once onos becomes ready
15:38:34 <fdegir> openstack + onos is another combination to test
15:38:51 <fdegir> about the 2nd
15:39:11 <fdegir> if I'm not mistaken, I've seen project specific testing activities in that test table
15:39:21 <trevor_intel> Agree for each combination we need reference environments and map features to be tested against that
15:40:03 <fdegir> but if we go back to your original question
15:40:18 <fdegir> "certified" labs for testing
15:40:30 <fdegir> we definitely need to do that
15:40:49 <trevor_intel> Table one is Rls B features against "certified" test resources
15:41:25 <trevor_intel> Each feature should have pass/fail criteria
15:41:45 <fdegir> yes
15:41:52 <trevor_intel> For release to happen all features shoudl report success
15:41:54 <fdegir> like KVM is tested using yardstick on intel lab
15:41:58 <fdegir> we miss that mapping
15:42:08 <fdegir> we map yardstick to intel and kvm to yardstick
15:42:18 <fdegir> it is not missing
15:42:23 <fdegir> but needs 2 hops
15:42:33 <trevor_intel> ok got it I think
15:42:58 <trevor_intel> But that is table one. What aout table two?
15:43:43 <fdegir> that is a bit confusing tbh
15:43:52 <trevor_intel> ... the 2nd is mixed between standalone testing activities and perhaps the feature type of testing
15:43:56 <fdegir> yes
15:44:01 <fdegir> that's what I was going to ask
15:44:23 <fdegir> because we have feature projects and test projects there together
15:46:13 <trevor_intel> The seond table could be project vs lab resources for Dev?
15:46:36 <trevor_intel> Dev and standalone testing
15:47:37 <fdegir> yes
15:47:54 <trevor_intel> We need all the project survey responses for tabel 2
15:48:33 <fdegir> 8 projects responded
15:49:30 <trevor_intel> We need more
15:49:52 <trevor_intel> Will have to keep pushing
15:50:37 <fdegir> have you seen my mail regarding creating tasks for all projects in jira?
15:51:33 <trevor_intel> For lab resources? Today?
15:52:17 <trevor_intel> Just foudn it
15:52:22 <trevor_intel> found it
15:52:59 <trevor_intel> fdegir: looks good I will rspond today
15:53:17 <trevor_intel> #topic LF resources
15:53:36 <trevor_intel> fdegir: Thansk for creating the page on LF usage
15:54:01 <fdegir> np
15:54:04 <trevor_intel> #info LF lab usage https://wiki.opnfv.org/pharos/lf_lab
15:55:16 <fdegir> should we ask those people what they do on LF lab?
15:55:34 <trevor_intel> yes what I was about to say too
15:56:06 <trevor_intel> I will ask, haven't done it yet
15:56:11 <fdegir> ok
15:57:07 <trevor_intel> I have a hard stop now
15:57:26 <trevor_intel> Will have to end the meeting
15:58:02 <trevor_intel> #endmeeting