16:00:08 <trevor_intel> #startmeeting OPNFV Pharos
16:00:08 <collabot`> Meeting started Wed Nov 18 16:00:08 2015 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:08 <collabot`> The meeting name has been set to 'opnfv_pharos'
16:00:27 <trevor_intel> #info Trevor Cooper (Intel lab)
16:00:28 <fdegir> #info Fatih Degirmenci
16:00:50 <lmcdasm> #info Daniel Smith
16:00:53 <narindergupta> #info Narinder Gupta
16:02:22 <trevor_intel> Can we start with allocation of resources and then do status updates after?
16:03:50 <trevor_intel> #topic Lab resources
16:04:19 <trevor_intel> First lets update on LF and then move to project needs
16:04:47 <trevor_intel> fdegir: Sounds like the 4 extra servers are being used now?
16:05:01 <fdegir> trevor_intel: not yet unfortunately
16:05:19 <trevor_intel> I need to update teh Wiki to reflect usage of LF resources
16:05:27 <fdegir> aricg, pbandzi and me sat down last week during the summit to configure the resources
16:05:37 <trevor_intel> fdegir: but do we know how they will be used?
16:05:50 <fdegir> trevor_intel: yes
16:05:53 <fdegir> infoing in
16:06:04 <fdegir> #info rebuild LF POD1 to use for bare metal deployments
16:06:20 <fdegir> #info LF POD2 will continue to be used for bare metal deployments
16:06:31 <fdegir> #info 2 of the 4 new blades will be used for nested deployments
16:06:38 <fdegir> #info remaining 2 will be used as build resources
16:07:03 <fdegir> #info the delay is due to a potential disk issue with one of the blades - investigation is ongoing
16:07:23 <trevor_intel> Ok so we get one full-metal POD back
16:07:29 <fdegir> that's correct
16:07:48 <trevor_intel> Are tehy dedicated to 2 of teh installers ... Fuel and Apex?
16:08:14 <fdegir> yes, at the moment
16:08:20 <fdegir> but this hopefully will change coming weeks
16:08:34 <fdegir> as long as we can put cleanup/reconfig scripts in place
16:08:43 <trevor_intel> yes ok
16:08:49 <fdegir> we only have pbandzi who can do ucs stuff
16:09:06 <fdegir> so that's kind of a problem - when he is off or busy, we get stuck
16:09:11 <trevor_intel> I will update the Wiki to reflect this
16:09:21 <fdegir> ok
16:09:23 <trevor_intel> LF lab support is still an issue
16:09:32 <fdegir> yes
16:09:39 <fdegir> aric was interested in learning ucs stuff
16:09:46 <fdegir> but I don't know if he works for beer
16:09:50 <trevor_intel> We had talked about training some extra prople and seems that is urgent
16:09:54 <trevor_intel> :)
16:10:02 <fdegir> I want to learn as well
16:10:07 <fdegir> and had a quick crash session
16:10:09 <trevor_intel> I am gonig to raise it to TSC and get some action on this
16:10:21 <fdegir> pbandzi has ucs simulator which we asked him to make it publicly available
16:10:25 <fdegir> so this can help
16:10:39 <trevor_intel> Ahh interesting ... ok my AR
16:10:53 <fdegir> #info A UCS simulator is available and needs to be made available by pbandzi
16:11:05 <trevor_intel> #action Trevor to escalate issue of LF support and get training
16:11:09 <fdegir> #action fdegir to talk to pbandzi regarding making UCS simulator publicly available
16:11:39 <trevor_intel> We also need to update Wiki re. CI resources
16:11:46 <trevor_intel> https://wiki.opnfv.org/pharos/hw_resource_allocation
16:11:58 <fdegir> yes
16:12:10 <fdegir> I kind of started working on intel machines
16:12:15 <fdegir> and ericsson ones
16:12:27 <fdegir> will move on to LF ones once they're ready
16:12:32 <fdegir> and then the community ones
16:12:39 <fdegir> and will try to keep the page up to date
16:13:29 <trevor_intel> What about the Huawei CI production POD?
16:13:37 <fdegir> that's the thing
16:13:42 <fdegir> it looks like it's in production
16:13:53 <fdegir> so we should talk to people so they update the page
16:13:58 <fdegir> or
16:14:08 <fdegir> I'm not sure if you like the idea of moving that page to gerrit
16:14:13 <fdegir> so people update it in gerrit
16:14:25 <fdegir> and it gets reviewed by looking at actual status on jenkins
16:14:43 <fdegir> rather than anyone updating the page - even though we have history there
16:14:46 <trevor_intel> Interesting idea
16:15:05 <fdegir> ok, I'll move the page to gerrit into pharos repo
16:15:07 <trevor_intel> The Wiki page is very visible ...
16:15:11 <fdegir> and send it to you for review
16:15:17 <trevor_intel> hang on ...
16:15:18 <fdegir> we can scrape the page to wiki automatically
16:15:29 <fdegir> so it can be visible on the wiki as well
16:15:32 <trevor_intel> I think we should get the Wiki cleaned up and in shape and accurate first
16:15:37 <fdegir> or
16:15:52 <fdegir> we should capture the initial status first
16:15:57 <fdegir> your call
16:16:22 <trevor_intel> Lets capture the initial status first ... then move to gerrit ( I think its a great idea)
16:16:31 <fdegir> this is the initial status
16:16:34 <fdegir> whatever is there
16:16:49 <fdegir> and we update and reflect the current status
16:17:05 <trevor_intel> There is https://wiki.opnfv.org/pharos/hw_resource_allocation for LF
16:17:22 <fdegir> yes
16:17:29 <trevor_intel> https://wiki.opnfv.org/pharos_rls_b_labs for community labs
16:17:56 <fdegir> the 2nd link is mixed with CI and dev resources
16:18:08 <trevor_intel> Well its a differnt view
16:18:19 <trevor_intel> Its how community labs are used
16:18:31 <fdegir> right
16:18:38 <trevor_intel> and some are bing used for CI
16:18:53 <trevor_intel> Can we move to project resources?
16:19:11 <fdegir> yes
16:19:23 <trevor_intel> #topic Project resouce allocation
16:19:42 <trevor_intel> There are some projects that need lab resources ... I will list them ...
16:20:16 <trevor_intel> IPv6 needs a full POD wtih IPv6 support
16:20:36 <trevor_intel> OVSNFV need a full POD with traffic generator
16:21:06 <trevor_intel> kvm4nfv needs x2 dedcicated machines (no installers) and a traffic genrator
16:21:35 <trevor_intel> Bottleneck needs some dev and proj CI but not clear yet on details
16:22:00 <trevor_intel> STORPERF same as Bottleneck
16:22:26 <trevor_intel> That is all I am aware of as far as current gaps
16:23:08 <fdegir> 2 POD + 2 servers
16:23:16 <fdegir> the ones that are obvious
16:23:21 <trevor_intel> Pretty much yes
16:23:35 <trevor_intel> Should I allocate from Intel lab?
16:23:57 <fdegir> do you know if these 2 PODs + 2 servers are for dev or for CI?
16:23:58 <trevor_intel> The other issue is with traffic genrators
16:24:16 <fdegir> cause for example for kvm
16:24:21 <fdegir> they need to run some tests through CI
16:24:33 <fdegir> I'm not sure if they already have dev resources
16:24:39 <trevor_intel> Tehy don't
16:24:50 <fdegir> then it might be 4 servers for kvm
16:25:20 <fdegir> or 1 + 1
16:25:31 <trevor_intel> but they say they only need standalone with no installer ... so why do they need CI?
16:25:40 <fdegir> they patch the kernel
16:25:51 <fdegir> and we build it in CI when their patch comes to gerrit
16:25:59 <fdegir> and then that kernel needs to be applied to a machine
16:26:17 <fdegir> and the machine booted and cyclictest(?) and perhaps some other tests need to be run
16:26:32 <trevor_intel> so they need build and it should be contolled by jenkins central
16:26:38 <fdegir> yes
16:26:46 <fdegir> they need build + test via jenkins
16:26:52 <fdegir> apart from their dev work
16:27:06 <trevor_intel> but the machines they run tests on can be the same as dev I think
16:27:15 <fdegir> nope
16:27:30 <fdegir> because machine goes down when the kernel is applied
16:27:36 <fdegir> so if they do this during dev work
16:27:42 <fdegir> it makes is useless for CI
16:27:44 <fdegir> and vice versa
16:27:51 <fdegir> so it must be dedicated
16:28:00 <fdegir> and it can't even be shared with other CI or dev purposes
16:28:14 <fdegir> because you never know when they send a patch to gerrit or do the development locally
16:28:30 <fdegir> let me find the etherpad
16:28:42 <trevor_intel> Ok so I need to clarify this with them ... will do that. If we gave them a full POD in Intel it should be enough?
16:28:54 <fdegir> https://etherpad.opnfv.org/p/nfv-kvm-test
16:29:10 <fdegir> there are 5 servers in a POD?
16:29:22 <trevor_intel> yes
16:29:24 <fdegir> ok
16:29:30 <fdegir> CI can take 2 of them
16:29:34 <fdegir> and the rest can be for dev
16:29:42 <trevor_intel> Ether pad is really good!
16:30:14 <fdegir> this is the crucial sentence: The built-out kernel can be booted on both host and guest.
16:30:16 <trevor_intel> So it may be the same with OVSNFV?
16:30:22 <fdegir> probably
16:30:32 <fdegir> so if they mess up the kernel
16:30:43 <fdegir> the machine might not be possible to boot unless fixed manually
16:30:57 <fdegir> kvmfornfv is really good project btw
16:31:22 <fdegir> just to add another update for kvm
16:31:47 <fdegir> i submitted a patch to enable builds for kvm: https://gerrit.opnfv.org/gerrit/#/c/3369/
16:31:52 <trevor_intel> So I could allocate one POD each in Intel lab
16:31:56 <fdegir> and once this gets merged, we will move on to tests
16:32:09 <fdegir> so it would be good if you can allocate pods whenever you have time
16:33:00 <fdegir> ovsnfv is a bit behind comparing kvmfornfv
16:33:04 <fdegir> I need to bug them again
16:33:07 <trevor_intel> FYI Dan Smith did update the Wiki re Ericsson dev resources https://wiki.opnfv.org/pharos_rls_b_labs
16:33:10 <fdegir> from CI point of view
16:33:32 <fdegir> yep, saw that
16:33:56 <fdegir> pod2 will be configured coming days or so
16:34:05 <fdegir> and might be available 2 weeks perhaps
16:34:20 <fdegir> pod1 is online
16:34:24 <trevor_intel> We had said to allocate POD 7 to Fuel  and 8 to Compass
16:34:29 <fdegir> and used by yardstick
16:34:47 <trevor_intel> You are talkign Ericsson PODs?
16:34:50 <fdegir> right, POD7
16:35:03 <fdegir> yes - we might bring up an additional pod
16:35:05 <fdegir> but
16:35:17 <fdegir> please do not change your pod7 allocation as of yet
16:35:38 <fdegir> if I get hold onto an ericsson pod for fuel, I can come back to you and we release pod7
16:35:39 <trevor_intel> Can I cahnge POD 8 and 9?
16:36:04 <trevor_intel> to give to teh two projects
16:36:14 <fdegir> what will happen to compass?
16:36:37 <trevor_intel> Its supportedin Huawei lab
16:36:54 <fdegir> ok
16:37:18 <trevor_intel> I think in Intel lab when we said Compass it means a test environment
16:37:28 <trevor_intel> I will check with Huawei to make sure
16:38:08 <trevor_intel> Ok so I don't know about IPv6 and also need more clarification from Bottleneck and STORPERF
16:38:33 <trevor_intel> Do you have any opnions on allocation for these projects?
16:39:00 <fdegir> unfortunately not
16:39:16 <trevor_intel> ok np I will dig
16:39:41 <trevor_intel> #topic MAAS
16:39:52 <trevor_intel> narindergupta: hi
16:40:29 <narindergupta> trevor_intel, hi
16:40:53 <narindergupta> trevor_intel, yeah i was looking into JIRA issues but i do not permisson to mark it resolved
16:41:16 <trevor_intel> Do you mean MAAS PoC?
16:41:26 <narindergupta> trevor_intel, yes
16:41:58 <trevor_intel> I see Fatih added "Pilot" to the Epic ... but perhaps we should start a new one?
16:42:00 <narindergupta> trevor_intel, also looking for next action item decided in OPNFV summit. what needs to done next?
16:42:29 <trevor_intel> narindergupta: Kick off the pilot and plan it
16:42:33 <fdegir> I was supposed to create 3 stories
16:42:39 <narindergupta> trevor_intel, i think yes we should start a new one would be better and close the existing one.
16:42:41 <fdegir> that's why changed the epic
16:43:13 <narindergupta> ok
16:43:21 <trevor_intel> fdegir: but the pilot is a new Epic?
16:43:31 <fdegir> yep
16:43:39 <fdegir> changed back the poc epic
16:43:53 <fdegir> and we need a new epic for pilot as you say
16:43:59 <narindergupta> +1
16:44:03 <fdegir> and 3 stories
16:44:15 <trevor_intel> ok who will create teh new epic and 3 stories?
16:44:22 <fdegir> can do that
16:44:27 <fdegir> and you fix it afterwards
16:44:33 <trevor_intel> fdegir: go for it :)
16:44:41 <narindergupta> sounds good
16:44:41 <fdegir> writing here to record it in the minutes
16:44:49 <fdegir> #info Epics: MAAS Pilot
16:45:05 <fdegir> #info Story 1: Use MAAS for lab booking and status visualization
16:45:31 <fdegir> #info Story 2: Use MAAS and MAAS APIS for configuring jumphost automatically from Jenkins
16:45:56 <fdegir> #info Story 3: Use MAAS for deployment of OPNFV
16:46:07 <trevor_intel> We need to get into using Jira and keeping it updated (this is a requirement by our release manager)
16:46:18 <fdegir> need to add detailed info to stories and DOD/acceptance criteria
16:46:20 <trevor_intel> I need to lead by example!
16:46:30 <fdegir> +1 to that :)
16:47:05 <trevor_intel> So I will do my best to get that habit going
16:47:43 <trevor_intel> There will be a demo of "rebar" tomorrow in the T&P meeting
16:47:50 <fdegir> rebar?
16:48:26 <trevor_intel> This is like an orchestrator / workflow engine for lab infrastructure if I understand it
16:48:43 <trevor_intel> Chris Price introduced me to the company last week
16:48:54 <fdegir> can you record it?
16:48:55 <trevor_intel> "RackN"
16:49:00 <fdegir> I have 3 meetings at the same time
16:49:01 <trevor_intel> I will
16:49:05 <trevor_intel> Only 3?
16:49:07 <fdegir> and need to skip t&p unfortunately
16:49:20 <fdegir> + 2 not accepted :)
16:49:23 <trevor_intel> You can get one extra monitor?
16:49:43 <fdegir> and 2 extra pair of ears
16:50:29 <trevor_intel> narindergupta: So you are the man for the pilot
16:51:22 <trevor_intel> fdegir: true
16:51:32 <narindergupta> trevor_intel, sounds good lets do it
16:51:47 <trevor_intel> #topic Templates
16:51:50 <fdegir> narindergupta: I have a question
16:51:55 <narindergupta> fdegir, sure
16:52:04 <trevor_intel> cyril_auboin_ora: hi
16:52:13 <fdegir> narindergupta: quick one: about story 2, configuring jumphost
16:52:18 <fdegir> that's I know
16:52:26 <fdegir> like install specified OS + packages
16:52:33 <fdegir> what about switch etc configuration
16:52:36 <fdegir> can maas do that?
16:52:42 <trevor_intel> cyril_auboin_ora: do you have any update today on the templates?
16:53:25 <narindergupta> fdegir, no maas can not do switch confoiguration
16:53:46 <fdegir> narindergupta: ok
16:54:03 <narindergupta> fdegir, but if you have scripts which can do that then we can always run during commisoning time
16:54:26 <narindergupta> fdegir, in maas you can upload the scripts and that will be sxecuted while discovering the device.
16:54:31 <fdegir> narindergupta: right
16:54:36 <fdegir> this is actually a requirement on labs
16:54:45 <fdegir> to provide automatic reconfiguration scripts for their lab
16:54:54 <fdegir> who know when we can have them
16:55:09 <narindergupta> fdegir, :)
16:55:31 <trevor_intel> I have a hard stop in a few min and will drop off
16:55:39 <fdegir> but anyway, narindergupta if we can start this pilot asap
16:55:42 <fdegir> like right now :)
16:55:45 <fdegir> it would be good
16:56:03 <fdegir> ok trevor_intel
16:56:11 <narindergupta> fdegir, lets define it and i will talk to Artur and we can start
16:56:20 <fdegir> ok narindergupta
16:56:29 <fdegir> btw trevor_intel, it was good seeing you last week in sf
16:56:47 <fdegir> and was good that you brough all lab reps together
16:57:41 <trevor_intel> fdegir: yes it was good to spend some time just to focus on this. I wish we sould do F2F more often.
16:58:06 <trevor_intel> Now to get back to chasing lab reps remotely :)
16:58:13 <trevor_intel> bye all
16:58:16 <fdegir> bye
16:58:21 <trevor_intel> #endmeeting