16:00:36 <trevor_intel> #startmeeting Pharos
16:00:37 <collabot> Meeting started Wed Nov 25 16:00:36 2015 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:37 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:37 <collabot> The meeting name has been set to 'pharos'
16:01:07 <trevor_intel> #info Trevor Cooper (Intel lab)
16:01:10 <fdegir> #info Fatih Degirmenci
16:01:38 <narindergupta> #info Narinder Gupta
16:02:43 <trevor_intel> Hi guys
16:02:51 <fdegir> hi
16:02:56 <narindergupta> hi
16:04:54 <trevor_intel> I am behind (was away) ... what updates?
16:05:26 <fdegir> I have updates for
16:05:27 <fdegir> MAAS Pilot, POD Config in pharos repo, Intel lab resources
16:05:36 <narindergupta> i saw fdegir put a jira for MAAS PILOT.
16:05:43 <lmcdasm> #info Daniel Smith
16:06:10 <narindergupta> trevor_intel, is it ok for you to send an email to community on the labs wants to take participate in MAAS Pilot
16:06:12 <narindergupta> ?
16:06:13 <trevor_intel> We have a new person who will help out on Intel side
16:06:29 <trevor_intel> #topic MAAS Pilot
16:06:45 <narindergupta> trevor_intel, is it ok for you to send an email to community on the labs wants to take participate in MAAS Pilot?
16:07:06 <trevor_intel> Ok can we set some objectives about that?
16:07:06 <narindergupta> we talk to few labs and they mentioned they need a format request to join MAAS Pilot.
16:07:13 <fdegir> trevor_intel can #action himself :)
16:07:25 <trevor_intel> Yes can do that :)
16:07:30 <narindergupta> thanks
16:07:49 <trevor_intel> How many PODs /labs is your objective?
16:07:52 <narindergupta> for the objective yes i will setup some objective in jits
16:08:27 <trevor_intel> As I understand these will be "live" PODs
16:08:31 <narindergupta> i think thinking minimum 5-8 labs so that we have better control
16:09:23 <trevor_intel> We only have 10 labs total
16:09:33 <trevor_intel> Do you mean 5 - 8 PODs?
16:09:41 <narindergupta> yes
16:09:59 <trevor_intel> across how many labs ... e.g. 3?
16:10:06 <narindergupta> 3 or 4
16:10:12 <narindergupta> would do
16:10:24 <trevor_intel> ok ... Intel can be one :)
16:10:47 <trevor_intel> What about Dell as one?
16:10:47 <narindergupta> yes +1 always
16:11:25 <trevor_intel> Ericsson?
16:11:33 <trevor_intel> Orange?
16:11:41 <narindergupta> i am ok with any lab who wants to participate.
16:12:20 <trevor_intel> #action Trevor send email to lab owners requesting to join MAAS Pilot
16:12:32 <narindergupta> thanks
16:13:28 <trevor_intel> I will do it right after this meeting
16:13:28 <lmcdasm> Ericsson has 2 PODs that are dynamic depending on needs
16:13:56 <lmcdasm> basically 28 blades that can be configured in various sized PODs
16:14:49 <narindergupta> lmcdasm, +1
16:14:55 <lmcdasm> i think that Fatih is already including our Lab's configuration in there (to answer your questino Trevor)
16:15:04 <lmcdasm> our = Ericsson
16:15:10 <trevor_intel> Ok great
16:15:11 <fdegir> lmcdasm: where? :)
16:15:25 <trevor_intel> MAAS pilot
16:16:12 <lmcdasm> ahh.. i misunderstood - sorry- i thought this was referring to the Lab configuration into the pharos repo, not the maas only.. apologies.
16:16:21 <fdegir> np
16:16:23 <lmcdasm> I saw POD config in pahros repo
16:16:31 <lmcdasm> above and thought that was the chain.. not MAAS.. :)
16:17:37 <trevor_intel> fdegir: thanks for creating MAAS jira stories!
16:17:47 <fdegir> np
16:18:55 <fdegir> I suppose all POC stories/epic can be closed
16:18:57 <trevor_intel> I also didn't see the YAML templates proposal form Jonas
16:18:58 <iben> here
16:19:20 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/3583/
16:19:37 <fdegir> the file named: 	common/config/pod_config.yaml
16:20:16 <trevor_intel> fdegir: yes I need to do that (update Jira)
16:20:42 <fdegir> narindergupta: trevor_intel: lmcdasm: iben: please check MAAS Pilot epic/stories to see if they make sense
16:21:02 <fdegir> https://jira.opnfv.org/browse/PHAROS-80
16:21:03 <fdegir> https://jira.opnfv.org/browse/PHAROS-81
16:21:05 <fdegir> https://jira.opnfv.org/browse/PHAROS-82
16:21:10 <trevor_intel> With the new Intel guy helping it should improve for me
16:21:42 <trevor_intel> His name is Jack Morgan FYI ... I will send an email to the mailing to introduce
16:21:53 <iben> nice!
16:21:58 <narindergupta> thanks
16:22:00 <iben> big welcome to Jack!
16:22:09 <narindergupta> Welcome Jack
16:22:38 * lmcdasm waves hello to Jack
16:22:47 <fdegir> good to have more comrades!
16:23:08 <trevor_intel> What else on the MAAS pilot?
16:23:38 <fdegir> the first one is basically visibility of available resources and ability of booking them
16:23:58 <fdegir> second thing is ability of reconfiguring certain resource using MAAS API from Jenkins
16:24:01 <fdegir> this could be jumphost
16:24:03 <fdegir> or
16:24:13 <fdegir> servers used for kvm testing for example
16:25:01 <fdegir> only 2 stories to begin with
16:25:13 <iben> right
16:25:20 <narindergupta> sounds good
16:25:40 <iben> Narinder - David Duffey mentioned there would be some sort of dashboard to report on all the maas sites
16:25:52 <trevor_intel> narindergupta: they make sense to me
16:25:53 <iben> that will be for JIRA first use case
16:26:24 <iben> for second ask we need an example jenkins job to tell maas to do something - like reset a machine then build it with an os
16:26:39 <fdegir> iben: can do that
16:27:02 <fdegir> as long as we can access to MAAS master/or whatever from one of the servers connected to jenkins
16:27:24 <fdegir> I can create a pharos job with a dummy shell script
16:27:40 <fdegir> which narindergupta and you can take over
16:27:44 <fdegir> and fix the script part of it
16:27:54 <narindergupta> fdegir, yes that sounds good
16:28:05 <trevor_intel> fdegir: Will the pilot use the second instance of Jenkins?
16:28:18 <iben> i made a drawing for discusison - https://wiki.opnfv.org/joid/get_started
16:28:20 <fdegir> if we can get aricg to set it up
16:28:43 <iben> i can update it with both master jenkins servers
16:28:50 <fdegir> just asked him
16:29:01 <iben> at the summit aric was looking at the existing jenkins vm which is running on gce
16:29:13 <iben> to see if it had sufficient resources (CPU, RAM, etc)
16:29:17 <fdegir> yep
16:29:24 <fdegir> let's see what he says
16:29:27 <fdegir> about the drawing
16:29:43 <iben> the idea was he’d simply add a second service to the existing jenkins that would run on new tcp ports
16:29:50 <iben> yes? re drawing?
16:29:55 <fdegir> will we have a separate host in labs which jenkins will connect?
16:30:13 <iben> the drawing shows three models
16:30:15 <fdegir> or can we directly connect to RC(regional controller?)?
16:30:29 <iben> for 3 kinds of labs - depending on the network available and resources too
16:30:30 <fdegir> yes
16:30:37 <fdegir> now I saw the difference
16:31:03 <iben> for example - private ip addresses only - require jenkins slave inside lab to handle outbound connection to jenkins master
16:31:21 <fdegir> about this example
16:31:34 <iben> but if a lab can provide a public ip address to the maas then an external jenkins (or anyone really) can connect to it
16:31:37 <fdegir> can maas rc reach to the jenkins master directly?
16:32:01 <fdegir> or is there any security/other types of reasons for needing to have a separate host just for jenkins connection?
16:32:13 <iben> maybe the maas can reach out to jenkins - from a network connectivity perspactive - sure - but that’s not how maas works
16:32:28 <fdegir> ok
16:32:40 <iben> someone needs to connect to maas to tell it what to do or perform a query
16:32:51 <iben> let’s dive deep to use case 1? for the dashboard
16:32:58 <fdegir> yes
16:33:16 <iben> the dashboard server will be connecting to each maas in each lab to ask it for a current inventory status
16:33:38 <iben> if the maas in the lab cannot be with public ip then who will do this query?
16:33:56 <iben> why not the jenkins slave in the lab to tell maas to report it’s status to the dashboard
16:34:08 <fdegir> that would work
16:34:34 <iben> that’s an idea so far - but we should scrum this with the cannonical team who is building this dashboard
16:34:36 <fdegir> via maas rc -> slave in lab -> jenkins master -> dashboard
16:35:20 <fdegir> maybe this is another improvement for maas
16:35:27 <iben> once the maas in the lab gets the command to report its status then the maas could just run a job to send a blob anywhere
16:35:35 <fdegir> instead of maas controller connecting to maas rcs
16:35:49 <fdegir> can maas rcs connect to the controller in LF lab?
16:35:50 <iben> or maybe it’s the jenkins slave that gets the blob of inventory data and sends it somewhere
16:35:56 <narindergupta> iben, fdegir maas has rest api and this common tool implements it
16:36:03 <iben> right
16:36:08 <fdegir> like how we connect slaves to the jenkins to skip all this security stuff
16:36:15 <iben> but the common rool won’t have access to each maas directly
16:36:47 <iben> this common tool will need to be waiting to collect the data from each lab’s maas controller when they report in with inventory data
16:36:53 <narindergupta> if jenkins jobs can collect data from maas and then pass it to dashboard should be ok
16:37:07 <iben> k
16:37:23 <iben> narindergupta: can you find out who we speak with abotu this tool?
16:37:34 <iben> and when we can expect to discuss its operation?
16:37:48 <fdegir> just asking my question again as a MAAS illiterate
16:37:59 <fdegir> we have maas rc in each lab
16:38:05 <narindergupta> yes
16:38:09 <fdegir> and we have maas master controller or whatever in lf
16:38:17 <fdegir> which all the maas rcs are supposed to connect to
16:38:22 <iben> no wait
16:38:26 <fdegir> is this right up till this pont?
16:38:35 <iben> there is no maas controller in LF anymore
16:38:46 <iben> that was determined to be a bottle neck
16:38:49 <narindergupta> lf will contain the script will collect the data from each regional controller
16:38:53 <fdegir> there is on the diagram :)
16:39:16 <iben> that “maas controller” is the dashboard data collector
16:39:40 <iben> as far as I know it is a ‘read only” controller
16:39:45 <narindergupta> lf just needs to run the scripted tool to get data from each regional controller and display in single dashboard
16:40:07 <iben> running commands on maas controllers for each lab will be a role for jenkins jobs
16:40:12 <narindergupta> iben, correct which will display the controller and nodes connected to each cluster
16:41:12 <iben> lf master jenkins —>  lab slave jenkins —> lab maas —> lf controller
16:41:37 <iben> that’s the data flow (I think) but we need to confirm
16:41:44 <fdegir> ok
16:42:12 <narindergupta> lf controller shold have access to lab maas to get the data as it will be using the rest api from lab maas
16:43:28 <narindergupta> unless lab slave jenkins can sends the data back to master jenkins in lf and then lf controller can consume that?
16:44:12 <fdegir> narindergupta: we can do some nasty magic for this
16:44:26 <fdegir> but I prefer not doing it until we fail with other possible ways
16:44:27 <narindergupta> fdegir, :)
16:44:36 <narindergupta> fdegir, ok
16:45:20 <fdegir> if we go back to basics: how to move this forward?
16:45:26 <fdegir> who works on this?
16:45:37 <trevor_intel> narindergupta: Let me know if you need help in Intel lab for experimenting
16:45:40 <fdegir> how we can have a chat without wasting pharos meeting time
16:45:44 <narindergupta> fdegir, i will work with lab admin to have maas deployed on each lab
16:45:52 <fdegir> ok
16:46:15 <narindergupta> i need help on jenkins setup though
16:46:26 <trevor_intel> narindergupta: So for me right now only thing is to get 2 (or 3 more labs) to volunteer?
16:46:50 <narindergupta> correct
16:46:51 <fdegir> narindergupta: just ping me with whatever jenkins stuff you need
16:46:56 <trevor_intel> narindergupta: ok thanks
16:47:46 <iben> where are we tracking the labs for this?
16:48:07 <trevor_intel> iben: what do you mean?
16:48:09 <iben> we already have a list
16:48:10 <iben> dell, orange, 2 at intel, huawei
16:48:13 <narindergupta> trevor_intel, will send email to all lab
16:48:21 <iben> trevor_intel: we don’t need to ask for more labs
16:48:27 <iben> there are already many labs signe dup
16:48:32 <narindergupta> admin and then jira will get updated
16:48:47 <iben> we should get it working in the exising maas poc labs then after that we can look to expand it
16:48:49 <iben> ?
16:49:13 <narindergupta> iben, as part of pilot we can have more labs
16:50:01 <trevor_intel> The pilot is supposed to have "real" users ... i.e. people who are not part of working on the MAAS
16:50:04 <iben> okay - but still - we need a wiki page with existing labs and what their current setup status is - dont’ want to plan this out via email and irc only - which wiki page will we use to track this progress?
16:50:23 <fdegir> 1 task per lab under the jira story
16:50:26 <fdegir> assigned to lab owner
16:50:39 <trevor_intel> yes agree with Fatih
16:50:41 <iben> what wiki page is showign current POC status?  If we close out the POC and move to Pilot we should depreciate that old page and use a new one?
16:51:46 <trevor_intel> Can we just update the PoC wiki page? Either way is ok to me
16:52:21 <trevor_intel> Wiki gives background info ... the Jira epics will track uo-to-date status
16:52:40 <iben> perfect - me too - jsut want to track our current progress - narindergupta can you help me update teh POC wiki page with current status?
16:53:20 <trevor_intel> fdegir: POD Config in pharos repo?
16:53:30 <iben> the issue I have is we still only have a “proposed maas poc” page with nothing showing current status
16:53:39 <trevor_intel> fdegir: also .. Intel lab resources?
16:53:40 <narindergupta> iben, sure will work on it
16:53:43 <iben> we have to improve our communication before we expand this https://wiki.opnfv.org/pharos/maas_getting_started_guide?s[]=maas&s[]=poc#proposed_maas_poc
16:53:52 <iben> it looks messy and unorganized right now
16:53:58 <fdegir> trevor_intel: POD config will come to the pharos repo
16:54:13 <fdegir> Jonas put it into genesis for the timebeing to keep installer and pod config files together
16:54:17 <fdegir> to have some kind of context
16:54:27 <fdegir> once we all review and give comments
16:54:42 <fdegir> we can move it to pharos repo and ask lab owners to provide config files for their pods
16:54:46 <narindergupta> i will work with iben and fdegir to setup wiki with status
16:55:14 <fdegir> so, it is us who can move the pod config further and faster
16:56:31 <trevor_intel> fdegir: ok
16:56:32 <fdegir> trevor_intel: is this ok for pod config?
16:56:34 <fdegir> ok
16:56:41 <fdegir> intel resources are currently being verified
16:56:55 <fdegir> will talk to Tim as well - right now actually
16:57:02 <fdegir> apart from that
16:57:13 <fdegir> have you had chance to talk to kvm and ovs guys regarding their needs?
16:57:15 <trevor_intel> fdegir: I think its ok ... I will review with Jack to get him up to speed
16:57:38 <trevor_intel> fdegir: yes
16:57:59 <fdegir> ok - so we're getting something for them to use for their ci
16:59:42 <trevor_intel> I talked to them last week ... I will send an email
16:59:47 <fdegir> ok
16:59:55 <fdegir> I don't have anything else to add
17:00:10 <fdegir> narindergupta: iben: please keep me in the loop regarding MAAS pilot
17:00:13 <trevor_intel> fdegir: ok thanks
17:00:18 <fdegir> I'm pretty interested in it
17:00:36 <narindergupta> fdegir, sure
17:00:52 <fdegir> thx
17:01:25 <trevor_intel> FYI rest of this week most people in US are out
17:02:27 <trevor_intel> One more quick thing ...
17:02:43 <fdegir> yes
17:02:53 <trevor_intel> I want to get the "lab as a service" project going
17:03:04 <trevor_intel> who is interested in that?
17:03:16 <fdegir> is that a new project?
17:03:23 <fdegir> or will that be?
17:03:42 <trevor_intel> Well I think we keep it in Pharos
17:03:47 <fdegir> ok
17:03:49 <fdegir> I'm interested
17:04:31 <trevor_intel> Ok I will start a Wiki page and ask for help to update it
17:04:42 <fdegir> ok
17:04:59 <trevor_intel> #endmeeting