14:06:42 <fdegir> #startmeeting OpenStack 3rd Party CI
14:06:42 <collabot> Meeting started Wed Sep 14 14:06:42 2016 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:42 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:06:42 <collabot> The meeting name has been set to 'openstack_3rd_party_ci'
14:06:42 <jmorgan1> sorry for going over
14:06:46 <fdegir> np
14:06:58 <fdegir> #topic Roll Call
14:07:02 <jmorgan1> #info Jack Morgan
14:07:08 <Julien-zte> #info Julien
14:07:13 <qiliang> #info qiliang
14:07:14 <fdegir> #info Fatih Degirmenci
14:07:24 <fdegir> #chair jmorgan1 Julien-zte
14:07:24 <collabot> Current chairs: Julien-zte fdegir jmorgan1
14:07:32 <fdegir> #chair yolanda hwoarang
14:07:32 <collabot> Current chairs: Julien-zte fdegir hwoarang jmorgan1 yolanda
14:07:39 <yolanda> hi
14:07:44 <fdegir> his
14:07:45 <fdegir> hi
14:07:48 <hwoarang> hello
14:08:00 <jmorgan1> hey
14:08:05 <fdegir> good we have everyone around
14:08:09 <fdegir> let's start with
14:08:15 <fdegir> #topic Status Update
14:08:31 <fdegir> anyone wants to give update?
14:08:46 <hwoarang> i will start with suse
14:08:54 <fdegir> please
14:09:20 <hwoarang> so stephanie submitted opensuse patches for upstream bifrost. i commented on them but overall they are fine.
14:09:36 <hwoarang> i have a couple of other patches pending review upstream
14:09:46 <hwoarang> and suse host support should be done
14:09:50 <fdegir> #info OpenSuSe patches have been submitted to openstack/bifrost. They are fine.
14:10:05 <fdegir> #info Couple of other patches are pending reviews.
14:10:18 <fdegir> hwoarang: so when they get submitted, we will be able to use suse hosts
14:10:41 <hwoarang> yes. there are some fixes for the opensuse Leap regarding to rabbitmq-server that must go into the opensuse repos
14:10:52 <fdegir> #info Once the pending patches are submitted, we will be able to use SuSe hosts
14:11:00 <hwoarang> but yeah we are pretty close
14:11:11 <hwoarang> then we can hookup the suse host to jenkins i suppose
14:11:16 <fdegir> #info Some fixes need to go to opensuse repos to fix rabbitmq-server stuff for OpenSuSe Leap
14:11:28 <fdegir> jmorgan1: and then we will lost hwoarang's machine as well
14:11:31 <fdegir> lose
14:11:59 <fdegir> if nothing more hwoarang, we can perhaps hear from yolanda
14:12:07 <hwoarang> yeah but that's bifrost. i still need to check puppet
14:12:27 <yolanda> ok so for infra cloud
14:12:33 <yolanda> i got it running on vms on centos finally
14:12:40 <fdegir> #info Work with puppet-infracloud for SuSe is pending
14:12:43 <yolanda> fixed all the problems with bridges and glean on systemd
14:13:36 <fdegir> yolanda: just to make sure; both bifrost and puppet-infracloud work fine on Centos using VMs?
14:13:37 <yolanda> and also refactored the test-bifrost-deployment script and the playbook , to make it more flexible and accept env vars, to define distros, elements...
14:13:46 <yolanda> yes they do
14:13:57 <fdegir> #info Both bifrost and puppet-infracloud work fine on Centos using VMs
14:14:07 <Julien-zte> good news
14:14:12 <fdegir> #info Problems with bridges and glean on systemd have been fixed
14:14:27 <yolanda> i have not yet started progress on baremetal, no time
14:14:32 <fdegir> #info test-bifrost-deployment script and the playbook have been fixed to make it more flexible and accept env vars, to define distros, elements
14:14:52 <fdegir> #info Work on baremetal will start soon
14:14:53 <fdegir> :)
14:15:27 <jmorgan1> so looks like we are supporting centos and suse, what about ubuntu?
14:15:33 <fdegir> I suggest us to try following steps yolanda documented in readmes on centos to see how it looks
14:15:34 <yolanda> fdegir, now we can create some jobs, the same you did for trusty, but on centos, to automate the tests
14:15:51 <fdegir> #action fdegir to create centos jobs on opnfv jenkins
14:15:59 <yolanda> ubuntu was always supported, as it was the primary OS for infra
14:16:01 <fdegir> jmorgan1: ubuntu is there already
14:16:10 <fdegir> trusty to be more precise
14:16:14 <jmorgan1> suse needs to be added to opnfv as well
14:16:17 <yolanda> yes, cannot tell about xenial
14:16:32 <fdegir> jmorgan1: I think we now need your help
14:16:44 <fdegir> given that both machiens used by yolanda and hwoarang will be tied to jenkins
14:16:51 <fdegir> and patches might come to upstream any time
14:16:59 <fdegir> wiping out ongoing development work
14:17:20 <fdegir> jmorgan1: can you take a look at your drawer to see if you have some machines lying in it?
14:17:25 <qiliang> fdegir: trusty is already run on opnfv jenkins ?
14:17:36 <Julien-zte> qiliang, yes
14:17:36 <fdegir> qiliang: yes
14:17:50 <qiliang> i test trusty on local blade but faild
14:17:53 <jmorgan1> fdegir: i'm planning on moving the Intel lab after the colorado 1.0 release
14:17:57 <fdegir> #action fdegir and jmorgan1 to have chat regarding resource availability
14:17:59 <qiliang> that's great
14:18:06 <jmorgan1> fdegir: i'll pull together a pod for this effort
14:18:12 <Julien-zte> qiliang, actually I also find many issues for trusty
14:18:14 <qiliang> i'll go to check the jjb
14:18:22 <jmorgan1> fdegir: in the intel lab
14:18:35 <fdegir> jmorgan1: we also need standalone machines as well
14:18:48 <jmorgan1> fdegir: i mean independant of intel pod 4
14:18:57 <fdegir> jmorgan1: right
14:19:02 <jmorgan1> fdegir: we can call it intel pod 10
14:19:06 <fdegir> jmorgan1: we already used all in pod4
14:19:28 <jmorgan1> fdegir: right, so let's move this effort out of intel pod 4 to its own pod (intel pod 10)
14:19:53 <qiliang> Julien-zte: ok, i'll do more detail check and send out deatil issues we find.
14:19:55 <Julien-zte> besides blades, working for baremetal in pod10?
14:19:55 <jmorgan1> fdegir: i will commit to make this happen afer the move
14:20:07 <fdegir> jmorgan1: what do you mean moving this out of pod4?
14:20:19 <fdegir> jmorgan1: pod4 is used for provisioning and installation of VMs
14:20:25 <jmorgan1> fdegir: i mean no use hardware resouce in intel pod 4
14:20:35 <fdegir> jmorgan1: ok, get additional resources
14:20:44 <fdegir> that's what I am happy to hear
14:20:50 <jmorgan1> fdegir: right, add a new pod (inel pod 10)
14:21:04 <fdegir> ok
14:21:10 <fdegir> I suppose that's all from you yolanda
14:21:11 <jmorgan1> fdegir: i want to free up systems in intel pod 4 by moving our effort to its own pod
14:21:20 <Julien-zte> #info jmorgan1 will add a new intel-pod10 for bifrost
14:21:35 <fdegir> some updates from me then
14:21:51 <fdegir> #info We enabled 3rd party CI by hooking OPNFV Jenkins to OpenStack Gerrit
14:21:55 <yolanda> fdegir, yes, no more updates
14:22:02 <yolanda> i want to put work on baremetal this week
14:22:21 <fdegir> #info OPNFV Jenkins is now subscribed to OpenStack Gerrit event stream
14:22:40 <fdegir> #link https://wiki.openstack.org/wiki/ThirdPartySystems/OPNFV_CI
14:22:58 <Julien-zte> triggered by event or periodly?
14:23:07 <fdegir> #info A job has been created to watch changes coming to openstack/bifrost to verify if proposed upstream changes cause issues for OPNFV
14:23:12 <fdegir> Julien-zte: via evennt
14:23:31 <fdegir> #link https://build.opnfv.org/ci/view/3rd%20Party%20CI/job/openstack-bifrost-verify-trusty-master/
14:23:44 <fdegir> #info Thanks to aricg and bramwelt for fixing OPNFV side of things
14:23:52 <Julien-zte> maybe lots of resources will be consumed
14:24:15 <fdegir> #info This will help us gain some experience operating 3rd party ci even though it's not voting
14:24:35 <fdegir> Julien-zte: openstack/bifrost has been quiet lately but you never know
14:24:57 <fdegir> #info Similar setup will be done for openstack/puppet-infracloud repo as well once that part is automated
14:25:08 <fdegir> #info In the end, we should be able to verify upstream patches locally
14:25:51 <fdegir> #info Jobs for centos and suse will be enabled as well and any remaining issues need to be fixed as trusty job failed last time
14:26:06 <fdegir> that's all from me
14:26:17 <Julien-zte> updates from me:
14:26:18 <Julien-zte> I'm still working on the first item about setting up the CI in our lab. almost done, it tooks too much time use another user not root. I will submit some patches for issues happened in the lab.
14:26:20 <fdegir> Julien-zte: you want to mention anything?
14:26:50 <Julien-zte> not digger into other tasks
14:26:59 <fdegir> #info Julien-zte is working on setting up CI in ZTE lab. There have been issues due to use of non-root user. Patches will be send.
14:27:32 <fdegir> Julien-zte: can you tell us the relation of setting up CI in ZTE lab?
14:27:38 <fdegir> Julien-zte: or what it is exactly?
14:27:57 <Julien-zte> that will be easier for me to test before sumbit the patch
14:28:14 <fdegir> Julien-zte: to openstack/bifrost and opnfv/bifrost?
14:28:40 <Julien-zte> the infrastructure is not same as opnfv for the slaves will be destroyed after CI runs failure
14:28:53 <Julien-zte> openstack/bifrost
14:29:08 <Julien-zte> more accurate opnfv/bifrost
14:29:08 <fdegir> Julien-zte: can't you use what we set up already instead of struglling with these issues?
14:29:30 <Julien-zte> yes, just our infra is not the same
14:29:37 <fdegir> Julien-zte: there will be jobs for opnfv/bifrost on OPNFV Jenkins to verify patches coming to opnfv/bifrost and opnfv/puppet-infracloud as well
14:29:46 <Julien-zte> good news is almost fixed
14:29:53 <fdegir> Julien-zte: good
14:30:12 <Julien-zte> that's all for me
14:30:24 <fdegir> jmorgan1: your turn :)
14:31:01 <jmorgan1> i've been mostly focusing on opnfv release tasks, otherwise i've been looking into the code and projects to get ramped up
14:31:20 <jmorgan1> i'll look to set up a testing envornment in the intel lab for myself next
14:31:34 <fdegir> good to hear
14:31:39 <jmorgan1> that is it
14:31:45 <fdegir> thx
14:31:59 <fdegir> qiliang: have you started looking into what we have been doing?
14:32:17 <qiliang> fdegir: i checked https://build.opnfv.org/ci/view/3rd%20Party%20CI/job/openstack-bifrost-verify-trusty-master it seems all test failed. so not all trusty opnfv/bifrost and opnfv/puppet-infracloud is auto run by opnfv ci?
14:32:30 <qiliang> fdegir: yes
14:32:40 <fdegir> qiliang: that job is supposed to run patchset verificaiton for bifrost only
14:32:46 <fdegir> qiliang: but for some reason it's failing
14:32:52 <qiliang> opnfv/bifrost is successfull runned
14:33:05 <fdegir> qiliang: I'll check that again to see why it is behaving that way
14:33:13 <qiliang> on my blad, but opnfv/puppet-infracloud  faild
14:33:22 <qiliang> thanks
14:33:37 <fdegir> qiliang: do you have log or something from opnfv/puppet-infracloud?
14:34:28 <fdegir> qiliang: you can perhaps save the logs on http://hastebin.com/ and send it to here next time you try and if it fails again
14:34:29 <qiliang> yes
14:34:48 <qiliang> puppet apply manifests/site.pp --modulepath=/etc/puppet/modules:/opt/releng/prototypes/puppet-infracloud/modules
14:34:53 <qiliang> failed
14:35:00 <jmorgan1> qiliang: we are here all the time ;)
14:35:53 <fdegir> qiliang: just put the link to logs and give some explanation such as which node it failed and so on
14:36:01 <fdegir> qiliang: so we can take a look at it
14:36:08 <Julien-zte> fdegir I don't see any list in opnfv/bifrost
14:36:26 <Julien-zte> "no jobs in this section"
14:36:37 <qiliang> fdegir: ok, thanks.
14:36:50 <qiliang> i'm getting the log now :)
14:37:04 <fdegir> Julien-zte: my plan is to collect jobs on this view: https://build.opnfv.org/ci/view/3rd%20Party%20CI/
14:37:22 <fdegir> Julien-zte: where are you looking at?
14:37:30 <Julien-zte> yes, the same page
14:37:50 <fdegir> Julien-zte: ok, you mean you don't see any opnfv/bifrost verification job there
14:37:59 <Julien-zte> yes, actually
14:37:59 <fdegir> Julien-zte: if so, they are yet to be created
14:38:01 <hwoarang> is the meeting over? because i need to bug yolanda a bit ;p
14:38:21 <fdegir> ending the meeting so we can cross-chat :)
14:38:29 <fdegir> thanks everyone and keep trying
14:38:32 <yolanda> ok bug me :)
14:38:33 <Julien-zte> thanks
14:38:34 <fdegir> #endmeeting