14:02:54 <fdegir> #startmeeting 3rd Party CI
14:02:54 <collabot> Meeting started Wed Dec 14 14:02:54 2016 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:54 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:54 <collabot> The meeting name has been set to '3rd_party_ci'
14:03:13 <fdegir> so, can we do tool based updates this week
14:03:20 <fdegir> starting with bifrost and openstack-ansible
14:03:25 <fdegir> and anything else later on?
14:03:49 <fdegir> I take this as yes
14:03:51 <hwoarang> fine by me
14:03:51 <fdegir> #topic Bifrost Status
14:04:00 <fdegir> who has update regarding bifrost?
14:04:18 <hwoarang> well not so much an update, but latest diskimage-builder changes broke the suse job
14:04:38 <hwoarang> so i posted a patch but until it's accepted the job will remain broken
14:05:01 <fdegir> that was what I was going to ask
14:05:04 <yolanda> sorry, no time in the latest weeks to work on it
14:05:15 <fdegir> but apart from that, bifrost seems pretty stable comparing to last month for example
14:05:21 <hwoarang> yes!
14:05:37 <fdegir> a question to you all
14:05:53 <fdegir> should we set up 3 daily jobs against baremetal, running ubuntu, centos, and suse?
14:06:07 <fdegir> so we can get some feeling regarding baremetal provisioning as well
14:06:26 <Julien-zte> If we have resources, a good choice
14:06:27 <yolanda> it will provide valuable info, as the behaviour of bifrost can be different on baremetal
14:06:39 <yolanda> yep, if there are resources to dedicate, sounds very good
14:06:59 <fdegir> I'll check this
14:07:14 <fdegir> yolanda: you were talking about Julia implementing multiple network (?) support for bifrost
14:07:17 <fdegir> any update about that?
14:07:37 <yolanda> fdegir, last news i had, is that bifrost already offers support to pass custom network data info
14:07:47 <yolanda> so we could generate by our own, and pass it to bifrost
14:07:59 <yolanda> but i hadn't have time to play with that, i have been very involved in downstream job
14:08:23 <fdegir> ok, so we just need to verify it
14:08:47 <fdegir> anyone else wants to add anything about bifrost?
14:08:56 <Julien-zte> I hope I can try bifrost on centos when my ci system runs well.
14:08:59 <fdegir> Julien-zte: hw_wutianwei: have you tried bifrost in your lab?
14:09:02 <fdegir> :)
14:09:07 <fdegir> just asked and got the answer
14:09:07 <hwoarang> i was wondering if we can make the CI a voting one for openstack?
14:09:12 <hwoarang> would that be valuable?
14:09:13 <Julien-zte> I have tested ubuntu, it is ok
14:09:32 <fdegir> hwoarang: well, that was kind of not a popular thing for puppet-infracloud
14:09:38 <fdegir> hwoarang: but Julia was positive to this
14:09:46 <fdegir> hwoarang: I'll ping her right now
14:09:49 <Julien-zte> I'd try it in baremetal
14:10:14 <hwoarang> well for bifrost, i believe we provide a good feedback. i got the impression that the upstream one doesn't do a full VM provision
14:10:19 <yolanda> i think we cannot make it voting
14:10:25 <yolanda> as it's thid party ci
14:10:33 <yolanda> you can provide +1 or -1 but it won't block changes for landing
14:10:42 <hwoarang> yeah sorry i meant +/-1
14:10:46 <yolanda> ah ok
14:10:51 <hwoarang> my bad
14:10:59 <hwoarang> just to make it more visible that "look you broke something"
14:11:37 <fdegir> chatting with Julia
14:11:41 <fdegir> will post the answer here
14:12:08 <hwoarang> ok thanks
14:12:49 <fdegir> she says ok and I asked her to add opnfvci user to the appropriate group
14:12:59 <hwoarang> good news
14:13:39 <fdegir> she wants me to put it into the agenda of next ironic meeting
14:14:24 <fdegir> thanks for reminder hwoarang
14:14:33 <hwoarang> sounds reasonable. lets see!
14:14:45 <fdegir> this will be a good reference for other infra projects going forward
14:15:00 <fdegir> I think we can move to openstack-ansible
14:15:09 <fdegir> #topic openstack-ansible status
14:15:14 <yolanda> fdegir, i use this feedback we provided from opnfv heavily on the bifrost reviews
14:15:31 <yolanda> i helped to caught failures on patches, specially on distros that are not xenial
14:15:47 <fdegir> I'm wondering what others are feeling - non-opnfv/openstack people
14:15:49 <yolanda> like the selinux issues, package naming mismatch, etc
14:15:55 <fdegir> do you have any inside?
14:16:00 <fdegir> do they look at our results?
14:16:10 <hwoarang> Julia does
14:16:16 <yolanda> i bet Julia does yes
14:16:26 <fdegir> good, then we are not just a noise for them
14:16:40 <hwoarang> she also alsed to update teh logs on artifacts.opnfv.org
14:16:52 <hwoarang> a while ago but never got around to actually see how to do that...
14:16:57 <hwoarang> *asked
14:17:08 <fdegir> then we need to improve that
14:17:21 <fdegir> #action hwoarang to fix bifrost logs on artifacts.opnfv.org
14:17:23 <fdegir> hehe
14:17:29 <hwoarang> oh busted
14:17:40 <fdegir> first action ever!
14:17:56 <fdegir> so, openstack-ansible?
14:17:58 <fdegir> anyone?
14:17:59 <hwoarang> sadly no o-ansible progress on my end. very busy with internal stuff
14:18:10 <hw_wutianwei> i use the openstack-ansible to deploy the production environment of openstack, but there are some problem in network configuration.
14:19:18 <fdegir> hw_wutianwei: you can perhaps share more details regarding what type of network config problems you are having
14:19:46 <fdegir> in case if someone else had the issue and knows something about it
14:19:56 <fdegir> or if someone else experiences them while they work with it
14:20:13 <hw_wutianwei> the openstack instance cann't get ip by dhcp
14:21:22 <yolanda> do you use for baremetal or for containers?
14:21:45 <hw_wutianwei> I use for VM
14:22:19 <hw_wutianwei> 3 infra nodes +2 compute nodes
14:23:43 <hwoarang> not sure what the deployment is but could it be that cloud-init or glean is not running or something?
14:24:08 <hw_wutianwei> the network configuration is too much to send here, so i will send a link tomorrow
14:24:55 <fdegir> that would be good hw_wutianwei
14:25:06 <fdegir> I think that's all for openstack-ansible
14:25:16 <Julien-zte> hw_wutianwei, next time, we can use http://paste.ubuntu.com/ to use the log
14:25:34 <hw_wutianwei> Julien-zte: ok
14:25:39 <fdegir> anyone wants to add anything?
14:25:40 <Julien-zte> fdegir, need resources to try openstack-ansible?
14:25:50 <fdegir> Julien-zte: you need resources?
14:26:03 <Julien-zte> people resources?
14:26:12 <Julien-zte> maybe I will pay some time in openstack-ansible
14:26:16 <fdegir> Julien-zte: of course
14:26:22 <fdegir> Julien-zte: any help is appreciated
14:26:49 <Julien-zte> from what we discussed previously, bifrost is stable now?
14:26:54 <fdegir> Julien-zte: yes
14:27:03 <Julien-zte> can it be used in baremetal and VM?
14:27:04 <fdegir> at least for provisioning virtual machines
14:27:26 <fdegir> and it works for baremetal as well but as yolanda mentioned above, there might be different suprises on baremetal
14:27:41 <Julien-zte> that's a good result.
14:27:45 <fdegir> you can see the build history on our jenkins
14:28:11 <fdegir> they are pretty stable - except some usual issues due to development of other components, such as diskimage-builder
14:28:12 <Julien-zte> I will try and  discuss with daisy team to use bifrost to deploy vm:)
14:28:22 <fdegir> https://build.opnfv.org/ci/view/3rd%20Party%20CI/
14:28:26 <Julien-zte> good
14:28:28 <fdegir> Julien-zte: +1!!!
14:28:37 <fdegir> so I have 2 things to add
14:28:47 <fdegir> jmorgan1 will migrate intel labs and this might impact us
14:29:02 <fdegir> it remains to be seen how much and when this impact will be
14:29:04 <Julien-zte> thanks fgedir, I received the daily ci log just has no time to check
14:29:17 <fdegir> we might lose all our ci and development resources that are located in intel-pod4
14:29:25 <fdegir> or jmorgan1 can have an exception for us
14:29:26 <Julien-zte> I hope our labs will be on hand as soon as possible
14:29:37 <fdegir> second item is next meeting
14:29:43 <fdegir> I'll be away on december 28th
14:29:57 <fdegir> and if you will be around, you don't need me to have the meeting
14:30:15 <fdegir> but I will probably schedule another one for january 4th just in case
14:30:20 <yolanda> i'm on holiday until 7th january
14:30:40 <fdegir> anyone else having vacation?
14:30:46 <Julien-zte> In China, only 1st-3rd is holiday
14:30:55 <hwoarang> yeah i am back on the 3rd
14:31:07 <fdegir> ok
14:31:12 <fdegir> then we keep the regular schedule
14:31:44 <fdegir> and for the ones that are taking vacation, the next meeting will be on january 11th
14:32:05 <fdegir> Julien-zte: please have the meeting if you need one on 28th of december but we won't be around
14:32:23 <fdegir> with that
14:32:31 <Julien-zte> get it
14:32:35 <fdegir> I wish all of you Merry Christmas and Happy New Year
14:32:44 <Julien-zte> good to you all
14:32:49 <fdegir> thank you all for the work and effort you put
14:32:52 <yolanda> have a nice christmas!
14:32:55 <fdegir> and I think we made ourselves visible
14:33:20 <fdegir> I think we can do more and we will do more
14:33:35 <fdegir> take care until the next time
14:33:38 <fdegir> #endmeeting