14:00:37 <fdegir> #startmeeting OPNFV Cross Community CI (XCI) Meeting
14:00:37 <collabot`> Meeting started Wed Mar  8 14:00:37 2017 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:37 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:37 <collabot`> The meeting name has been set to 'opnfv_cross_community_ci__xci__meeting'
14:00:44 <fdegir> #topic Rollcall
14:00:56 <fdegir> anyone around for quick status update and some additional topics?
14:01:29 <fdegir> yolanda: hwoarang
14:01:36 <fdegir> jmorgan1: Julien-zte
14:01:42 <fdegir> ping all
14:01:52 <yolanda> o/
14:02:24 <fdegir> thx yolanda, I was afraid to be left alone, again
14:02:28 <NikoHermannsEric> #info nikolas
14:02:43 <fdegir> hi NikoHermannsEric
14:03:04 <NikoHermannsEric> fdegir: hey
14:03:09 <yolanda> fdegir, just chaining meetings :)
14:03:13 <fdegir> jmorgan1: said he will join and wants to discuss some resource stuff (vPOD, hw)
14:03:26 <fdegir> I'm having another one in parallel as well
14:03:34 <fdegir> anyway, we start and finish this quickly
14:03:52 <Julien-zte> pong dgedir
14:03:58 <fdegir> #topic OpenStack Cross Community CI status (Bifrost, OpenStack Ansible)
14:04:01 <Julien-zte> fdegir, hi
14:04:05 <fdegir> hi Julien-zte
14:04:20 <fdegir> as you might have noticed discussions around openstack-ansible
14:04:37 <fdegir> there were some issues on stable/ocata which was fixed a day or two ago
14:04:53 <fdegir> so, stable/ocata works fine now
14:04:57 <fdegir> but master fails
14:05:01 <Julien-zte> that's great
14:05:12 <fdegir> anyone wants to add anything
14:05:15 <fdegir> yolanda?
14:05:19 <yolanda> master doesn't seem to be very reliable, never had the chance to make it pass
14:05:28 <yolanda> right now they seem to have problem with packages
14:05:30 <Julien-zte> recently days, in China, git hub access is very difficult
14:05:41 <Julien-zte> docker hub instead of git hub
14:05:42 <Julien-zte> sorry
14:06:05 <yolanda> so i wonder if we shall pin to latest stable version with OSA, but then it won't fit our goal of "deploying the latest OpenStack"
14:06:12 <fdegir> +1
14:06:16 <fdegir> I think it fits
14:06:23 <fdegir> we can have 2 type of jobs
14:06:34 <fdegir> one continuously pull latest and attempts deployment
14:06:45 <fdegir> if it succeeds, we move to/pin that version
14:06:48 <Julien-zte> agree
14:07:04 <fdegir> if not, we stay with already pinned one for the jobs used by the community
14:07:15 <fdegir> so if something goes wrong in this 2nd type of jobs
14:07:22 <Julien-zte> seems to daily-weekly jobs
14:07:24 <fdegir> we would have less trouble to identify issue
14:08:02 <fdegir> Julien-zte: yes, some kind of promotion
14:08:02 <yolanda> fdegir, you mean pinning to some commit in OSA?
14:08:09 <fdegir> yolanda: yes
14:08:09 <Julien-zte> we can give the response quickly while get a runable version
14:08:23 <yolanda> i wonder how that will work with the dependencies
14:08:37 <fdegir> don't they lock versions of dependencies there as well?
14:08:47 <yolanda> i think OSA also pins all the dependencies per commit, so it shall work
14:08:59 <yolanda> but for things that are pip related, for example, we may have issues
14:09:03 <fdegir> yep
14:09:45 <yolanda> i mean, requirements are not normally >= ... if some new version comes , that breaks master, it may get fixed on the latest master, but not in our pin
14:09:54 <yolanda> but is something we'd need to find out
14:10:03 <fdegir> yep
14:10:11 <fdegir> and this brings us to next topic about osa
14:10:24 <fdegir> should we merge Tianwei's patch
14:10:41 <fdegir> and start working on creating periodical jobs for bifrost/osa?
14:10:46 <yolanda> ++
14:10:59 <yolanda> in the latest tries i did, with the right memory and disk, it worked
14:11:12 <fdegir> yep
14:11:21 <fdegir> this is about osa patch only
14:11:22 <fdegir> https://gerrit.opnfv.org/gerrit/#/c/28189/
14:11:24 <fdegir> to be precise
14:11:37 <fdegir> the other one touching bifrost perhaps needs to be looked into again
14:12:47 <yolanda> do we want to keep the ones for puppet-infracloud or we switch totally to osa? the bifrost patches were mostly fitting the infracloud needs
14:12:47 <fdegir> so please review above patch and +1/+2
14:12:47 <fdegir> and we submit it
14:12:57 <fdegir> yolanda: I think we can switch to osa as the puppet-infracloud stuff will be in history
14:13:08 <fdegir> so we can go back and look or revert them if needed
14:13:21 <Julien-zte> for 28189?
14:13:25 <yolanda> ok then also the bifrost job bits shouldn't be that bad
14:13:27 <fdegir> Julien-zte: yes
14:13:42 <Julien-zte> shall we adandon puppet?
14:13:47 <fdegir> yolanda: the 2nd patch only touches scripts so it should be fine
14:14:11 <fdegir> yolanda: but if fails on verify so something is wrong with it
14:14:19 <yolanda> ok
14:14:20 <fdegir> so I put agree
14:14:40 <fdegir> #agree The patch https://gerrit.opnfv.org/gerrit/#/c/28189/ will be submitted so we can start working on setting up periodics jobs
14:15:01 <fdegir> #action To all, please review https://gerrit.opnfv.org/gerrit/#/c/28189/ and https://gerrit.opnfv.org/gerrit/#/c/28171/
14:15:20 <fdegir> anything else about bifrost/osa?
14:15:49 <fdegir> moving to next topic
14:15:52 <fdegir> #topic ODL Cross Community CI status
14:16:31 <fdegir> last thing I heard about this is that Jamo/Jose were looking into bringing ODL CSIT tests to OPNFV
14:16:39 <fdegir> and this is still going on
14:16:48 <fdegir> NikoHermannsEric: do you know more about the status?
14:17:18 <fdegir> I suppose not
14:17:20 <yolanda> Jose shall be on PTO these days or i'd expect, as he was getting married. I talked with him at the PTG
14:17:27 <fdegir> yep
14:17:32 <fdegir> but he still sends mails :/
14:17:39 <yolanda> so bad :)
14:17:49 <fdegir> I told him but he doesn't listen
14:18:17 <fdegir> just to summarize ODL stuff
14:18:38 <fdegir> it is now possible to bring up opesntack quickly using snapshots provided by apex
14:18:43 <fdegir> and install netvirt on it
14:19:01 <fdegir> the last piece in the puzzle is the test cases which is the thing I mentioned above
14:19:17 <fdegir> ODL guys are involved in this and I hope this will be resolved soon
14:19:21 <NikoHermannsEric> fdegir: I am not sure about the status right now. The ball is at the moment still on trozet
14:19:41 <fdegir> NikoHermannsEric: yep, trozet kicked the ball to Jamo and others
14:19:51 <fdegir> as he finished his parts
14:20:04 <fdegir> moving on to the last part
14:20:06 <fdegir> #topic AoB
14:20:22 <fdegir> I think it is time now to send meeting call to whole community
14:20:25 <trozet> NikoHermannsEric: I think though in parallel we can switch to your deploy tool in python
14:20:42 <fdegir> so from next meeting and onwards, more people can hopefully join
14:20:45 <trozet> NikoHermannsEric: if you want to try that and test it out, we also need to add some support in the introspection tool for VPP
14:20:53 <fdegir> any objections?
14:21:00 <fdegir> yolanda: Julien-zte: NikoHermannsEric; ?
14:21:20 <Julien-zte> no
14:21:31 <yolanda> ++
14:22:05 <NikoHermannsEric> trozet: ok, however I think that is only a add on not a must. The amount of triggers from odl is small anyway
14:22:05 <fdegir> so please try to keep attending meetings like you have been doing
14:22:05 <NikoHermannsEric> fdegir: +1
14:22:05 <fdegir> since I expect people want to try this out
14:22:05 <fdegir> and bring questions
14:22:10 <fdegir> #action Send XCI Meeting call to tech-discuss
14:22:13 <fdegir> #undo
14:22:13 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1f0d310>
14:22:20 <fdegir> #action fdegir to send XCI Meeting call to tech-discuss
14:22:32 <fdegir> anyone else wants to add anything?
14:22:36 <fdegir> jmorgan1: ping?
14:23:17 <fdegir> then that's all for the day
14:23:24 <fdegir> thanks for joining and talk to you later
14:23:26 <fdegir> #endmeeting