09:36:07 <fdegir> #startmeeting OPNFV Hackfest Infra Day1
09:36:07 <collabot> Meeting started Mon Apr 24 09:36:07 2017 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:36:07 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:36:07 <collabot> The meeting name has been set to 'opnfv_hackfest_infra_day1'
09:36:20 <fdegir> #topic Infra Roadmap
09:36:50 <fdegir> #info We need to create JIRA tickets for creating PDFs for PODs located in Intel, Ericsson, Huawei, LF
09:37:06 <fdegir> #action fdegir to create Jira tickets for LF and Ericsson labs
09:37:25 <fdegir> #action jmorgan1 to create Jira tickets for Intel and Huawei labs
09:38:19 <fdegir> #action fdegir to create Jira tickets for POD converter, 1 per installer
10:04:31 <fdegir> #action jmorgan1 to commit the patch for network settings to gerrit/pharos for review
11:23:27 <fdegir> #topic Moving installers to VMs on Jumphost
11:23:51 <fdegir> #info We will need jumphost cleanup and setup scripts in order to remove/create bridges, vms
11:48:43 <fdegir> #chair uli-k
11:48:43 <collabot> Current chairs: fdegir uli-k
11:49:33 <uli-k> #info There can be multiple network setting files that would work with a POD.
11:50:19 <uli-k> #info the PDF contains a list of NSF (network setting files) that can be used with the POD.
11:51:01 <uli-k> #info PDF and NSF are stored in secured lab repo
12:09:42 <uli-k> #info multiple PODs can use the same network setting file(s).
12:15:19 <uli-k> #info Releng will parse SDF, PDF, NSF to find the right resource for a scenario.
12:17:08 <uli-k> #info the translator tool might be not necessary (if the installers directly move to parsing PDF)
12:27:48 <uli-k> #info we will define new requirement for OPNFV Community Labs: Provide PDF, Can be booked via Pharos dashboard, Document on wiki.
12:28:04 <uli-k> #info Labs that don't provide that will be deleted from the list.
12:33:21 <fdegir> #info The directory structure will be
12:33:48 <fdegir> #info securedlab/<lab_name>/<podX>.yaml, for example
12:34:07 <fdegir> #info securedlab/zte/pod1.yaml, securedlab/lf/pod3.yaml
12:38:50 <uli-k> #info securedlab/zte/nsf.yaml, securedlab/zte/nsfdpdk.yaml
12:39:57 <fdegir> #info In order to make it possible to run installers on any OS, it is important to pick the right machine type in libvirt VM xml file and link the qemu executable in right place
12:40:09 <fdegir> #info Align how the OSes are statated in SDF and PDF
12:40:33 <fdegir> #info Decide how to state the OSes (trusy/xenial or 14.04/16.04)
12:41:18 <uli-k> #info releng will write analyser scripts
12:44:48 <fdegir> #info Apex creates VMs using virsh which use prebuilt images from Triple-O and then starts the installer VM
12:45:03 <fdegir> #info Joid can pull down ubuntu cloud images and applies metadata
12:45:13 <fdegir> #info Fuel installs centos from scratch
12:45:22 <fdegir> #info Compass and Daisy need to be checked
12:45:31 <fdegir> #info XCI uses diskimage builder to build VM images
13:24:07 <fdegir> https://hastebin.com/qiposovusi.hs
13:34:22 <fdegir> aricg: ^
13:34:28 <fdegir> aricg: bifrost inventory
13:53:58 <uli-k> #info SDF should be available at MS2 and finalized at MS5 (starting with F release)
13:57:24 <uli-k> #info Octopus will plan creation of SDF converter
13:59:59 <uli-k> #info testcase selection is impacted. All test information is in test db, not in SDF. But test team is affected since the scenario naming scheme changes.
14:05:51 <uli-k> #info #info need a jira task for adjustments for jenkins jobs tosupport dynamic allocation
14:11:23 <fdegir> #info Test projects use below script to fetch openstack credentials
14:11:25 <fdegir> #link https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=blob;f=utils/fetch_os_creds.sh
07:28:03 <fdegir> #endmeeting