#opnfv-pharos: Cross Community CI

Meeting started by hwoarang at 13:00:40 UTC (full logs).

Meeting summary

  1. Rollcall (hwoarang, 13:00:53)
    1. Uli (uli-k, 13:00:57)
    2. Thaj (thaj, 13:01:07)
    3. Juan Vidal (jvidal, 13:01:11)
    4. Tinawei Wu (hw_wutianwei, 13:01:22)
    5. Bob Monkman (bobmon01, 13:01:27)
    6. David Blaisonneau (David_Orange, 13:01:58)
    7. https://etherpad.opnfv.org/p/xci-meetings (hwoarang, 13:02:31)

  2. XCI (hwoarang, 13:04:37)
    1. Alexandru Avadanii (Enea) (AlexAvadanii, 13:04:49)
    2. Matt Spencer (m5p3nc3r, 13:04:55)
    3. Cristina Pauna (Enea) (CristinaPauna, 13:05:03)
    4. Yolanda Robla (yolanda, 13:05:22)
    5. Tim Irnich (timirnich, 13:05:31)
    6. layout for releng-xci proposed by Fatih on https://gerrit.opnfv.org/gerrit/#/c/36587/ (hwoarang, 13:05:54)
    7. Manuel Buil (mbuil, 13:06:18)
    8. Tina Tsou (Tina, 13:06:23)
    9. Dimitris Markou (mardim, 13:06:44)
    10. David McBride (dmcbride, 13:08:37)
    11. David_Orange suggests to use pdf as source (hwoarang, 13:09:43)
    12. David_Orange suggests to simplify user-visible configuration (hwoarang, 13:11:05)
    13. our goal is to understand how we can participate (bobmon01, 13:11:52)
    14. we wish to have process, docs, servers for AR testing (bobmon01, 13:12:07)
    15. ARM testing (bobmon01, 13:12:18)
    16. we need to know what we need to do to support the project (bobmon01, 13:12:35)
    17. Alex and Cristina here can coment on how we support bare metals pods (bobmon01, 13:13:03)
    18. ARM will only support bare metal pods in XCI for th forseeable future (bobmon01, 13:13:23)
    19. Cristina: I assume we can try this on Armband Pharos lab perhaps? (bobmon01, 13:14:51)
    20. Trinath Somanchi (trinaths, 13:15:32)
    21. we do not yet know what is "in" XCI that is different from what we do today with Fuel on that same OS (bobmon01, 13:16:09)
    22. Trinath Somanchi (NXP) (trinaths, 13:16:43)
    23. hworang: OK, but my question will be if bare metals pods can be supporte dby us in XCI in future (bobmon01, 13:19:15)
    24. baremetal support is in the TODO list (hwoarang, 13:19:40)
    25. +1 (bobmon01, 13:19:51)
    26. Daniel Farrell (dfarrell07, 13:23:59)
    27. testing community considered XCI to avoid installer dependencies. (hwoarang, 13:26:41)
    28. Uli mentioned that end result is the same despite the installer that was used (hwoarang, 13:30:09)
    29. jose raised the point of limited hardware, time and human resources (hwoarang, 13:30:21)
    30. Jose raised the issue of not having stable XCI branches (hwoarang, 13:31:13)
    31. stable brances are in the TODO (hwoarang, 13:31:19)

  3. General status for OSA (hwoarang, 13:32:53)
    1. ACTION: hw_wutianwei to try to have a look on jenkins jobs (hwoarang, 13:34:50)
    2. yolanda is working on certificates and openrc improvements (hwoarang, 13:36:14)
    3. https://gerrit.opnfv.org/gerrit/#/c/36587/ (hwoarang, 13:37:05)
    4. orange pod1 is installed with bifrost + osa using ^ patch (David_Orange, 13:37:36)
    5. 5 nodes baremetal (David_Orange, 13:37:46)
    6. this is still beta and install can be erratic but all was green on las t install (David_Orange, 13:38:34)
    7. the 36587 patch is just FYI, it does not plan to replace xci scripts, just a way for me to learn on bifrost and osa (David_Orange, 13:39:24)
    8. almost all roles have gained support for SUSE excpet nova and ceph (hwoarang, 13:40:32)
    9. AIO is on TODO (hwoarang, 13:41:10)
    10. https://jira.opnfv.org/browse/RELENG-266 (hwoarang, 13:41:47)
    11. yolanda found out that there were problems consuming the cloud (hwoarang, 13:42:17)
    12. https issues. certificates not trusted (hwoarang, 13:42:29)
    13. https://gerrit.opnfv.org/gerrit/37619 (yolanda, 13:42:43)

  4. General status for Bifrost (hwoarang, 13:43:45)
    1. https://review.openstack.org/483998 (yolanda, 13:44:22)
    2. ACTION: hwoarang to have a look on enabling periodic jobs for bifrost (hwoarang, 13:45:51)

  5. Feature Status (hwoarang, 13:46:21)
    1. https://review.openstack.org/#/c/480128/ (hwoarang, 13:47:03)
    2. ODL integration pending upstream review (hwoarang, 13:47:30)
    3. L3 has a bug in ODL carbon and network-odl. Should be ok in the pike release (hwoarang, 13:49:13)
    4. https://review.openstack.org/#/c/356839/ (hwoarang, 13:50:03)
    5. https://review.openstack.org/#/c/482873/ (hwoarang, 13:50:39)
    6. openstack-infra created the tacker role repository (hwoarang, 13:51:05)
    7. https://review.openstack.org/#/c/476121/ (hwoarang, 13:52:10)
    8. ovs-nsh packages created for ubuntu, centos, suse (hwoarang, 13:53:24)
    9. ovs networking issues - under investigation (hwoarang, 13:54:31)

  6. Scenario Status (hwoarang, 13:57:30)


Meeting ended at 13:59:25 UTC (full logs).

Action items

  1. hw_wutianwei to try to have a look on jenkins jobs
  2. hwoarang to have a look on enabling periodic jobs for bifrost


Action items, by person

  1. hw_wutianwei
    1. hw_wutianwei to try to have a look on jenkins jobs
  2. hwoarang
    1. hwoarang to have a look on enabling periodic jobs for bifrost


People present (lines said)

  1. hwoarang (117)
  2. jose_lausuch (33)
  3. yolanda (16)
  4. bobmon01 (14)
  5. David_Orange (13)
  6. mardim (11)
  7. uli-k (9)
  8. hw_wutianwei (9)
  9. mbuil (9)
  10. jvidal (7)
  11. AlexAvadanii (5)
  12. trinaths (4)
  13. dmcbride (4)
  14. Tina (3)
  15. collabot (3)
  16. CristinaPauna (2)
  17. m5p3nc3r (1)
  18. dfarrell07 (1)
  19. timirnich (1)
  20. thaj (1)


Generated by MeetBot 0.1.4.