13:00:27 <fdegir> #startmeeting Cross Community CI
13:00:27 <collabot> Meeting started Wed Aug 30 13:00:27 2017 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:27 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:27 <collabot> The meeting name has been set to 'cross_community_ci'
13:00:33 <fdegir> #topic Rollcall
13:00:42 <fdegir> please type in your name if you are joining the meeting
13:01:10 <yolanda> #yolanda
13:01:10 <David_Orange> #info David Blaisonneau
13:01:17 <yolanda> #info Yolanda
13:01:18 <hw_wutianwei> #info Tianwei
13:01:24 <mbuil> #info Manuel Buil
13:01:29 <georgk> #info Georg Kunz
13:01:54 <epalper> #info epalper Peri
13:02:01 <mbuil> yolanda: sorry, I was having lunch, let's talk after the meeting about your patch and openrc :P
13:02:08 <thaj> #info Thaj
13:02:19 <fdegir> lets start
13:02:20 <fdegir> #topic General XCI Framework status
13:02:41 <fdegir> the patch yolanda sent is open for reviews
13:02:50 <fdegir> anyone tried that?
13:02:55 <fdegir> mbuil perhaps...
13:03:08 <mardim> #info Dimitris Markou
13:03:39 <fdegir> #info The patch to generate and use self signed certificates for OSA is open
13:03:45 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/39435/
13:04:01 <mbuil> mbuil: yes! The SSL problem I was seeing when triggering functest tests is gone when adding the insecure variable to openrc, however, I think that should be automatically included in openrc when I read Yolanda's patch so I think there might be a bug there
13:04:26 <fdegir> mbuil: yolanda: do we still need to use OS_INSECURE=true if we use yolanda's patch?
13:04:36 <yolanda> fdegir, yes, because we use self signed certs
13:04:43 <fdegir> ok
13:04:59 <yolanda> a next step could be use certs from an external provider we trust, or build our own CA and trust it
13:05:05 <fdegir> #info OS_INSECURE=true should be set in openrc while using self signed certificates
13:05:10 <yolanda> but i think it can go on next steps
13:05:23 <hw_wutianwei> yolanda:  can we export the certs in openrc?
13:05:26 <fdegir> #info Next step could be to use certs from an external provider we trust, or build our own CA and trust it but what we have is good enough now
13:05:44 <mbuil> yolanda, fdegir: but as far as I understood the openrc in the utility container should be this one ==> https://hastebin.com/ekukikurac.bash or?
13:05:48 <uli-k> #info Uli
13:05:58 <yolanda> mbuil yes
13:06:04 <yolanda> if it's not like that, there is a bug
13:06:32 <mbuil> yolanda: I am getting this one ==> https://hastebin.com/osudabuvan.bash
13:06:37 <fdegir> since mbuil is alrady trying yolanda's patch I action mbuil
13:07:01 <mbuil> yolanda, fdegir: I thought that with those aliases,  OS_INSECURE=true is not needed anymore
13:07:06 <yolanda> mbuil so the openrc is on the opnfv host and on the build host. Can you see if both have the same content?
13:07:27 <yolanda> mbuil yep, that's wrong content for openrc, i expect the aliases to be there
13:07:59 <mbuil> yolanda: ok, let's discuss it after the meeting :)
13:08:11 <fdegir> #action mbuil to report findings on the patch and update README.rst with necessary information
13:08:15 <fdegir> thanks, moving on
13:08:24 <fdegir> David_Orange: any update?
13:08:31 <David_Orange> fdegir: yes
13:08:35 <fdegir> #info The PDF for lf-pod4 has been merged
13:09:02 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/38283/
13:09:06 <fdegir> please go ahead David_Orange
13:09:06 <David_Orange> #info Baremetal install is still under debug: i have an issue linking openstack router to extnet
13:09:32 <David_Orange> #info VM to VM is OK, VM to router is OK, but router to ext gateway is failing
13:10:02 <David_Orange> #info i am checking topology and hosts config, but i can not found where it is failing
13:10:48 <David_Orange> #info as i am on an interface with multi vlan and multi bridge, i am deploying with a new network topology with a single vlan for br-vlan
13:11:25 <hw_wutianwei> David_Orange:  do you have the topology?
13:11:51 <hw_wutianwei> David_Orange: can you send to us? so we can check.
13:11:54 <David_Orange> #info yes, i can share it, maybe after the meeting
13:12:12 <fdegir> thanks hw_wutianwei!
13:12:25 <David_Orange> #info thanks hw_wutianwei
13:12:34 <fdegir> David_Orange: I've been having issues with ha after latest bump
13:12:43 <fdegir> David_Orange: what do you deploy?
13:12:47 <David_Orange> #info working in parallel on pdf, and moving actual j2 files to this new config source
13:13:02 <hw_wutianwei> fdegir: the issue about keepalived, I ask in irc openstack-ansible channel, they have fixed this problem. and I am testing
13:13:17 <David_Orange> fdegir: ha, but it has never worked, and the install was 1 month ago
13:13:36 <mbuil> David_Orange: can you check if you are using --provider:network_type=flat when creating the public network (or something similar)?
13:13:54 <David_Orange> fdegir: hw_wutianwei: in my install the keepalive between routers were working
13:14:03 <mbuil> David_Orange: when using OVS + ODL, that is needed, otherwise we have the same problem you describe
13:14:10 <fdegir> David_Orange: ok, for me it was failing there
13:14:39 <David_Orange> mbuil: as i just change the infra topology, i can not check now.
13:14:52 <hw_wutianwei> fdegir: me too
13:15:10 <David_Orange> mbuil: fdegir: i will reinstall with last topo version and check that
13:15:26 <fdegir> David_Orange: so we have some progress and challenges bt you have hw_wutianwei and mbuil there to help you as needed
13:15:34 <fdegir> so moving on to keepalived issue
13:15:51 <fdegir> #info After bumping to pike dated august 15th, keepalived playbook started failing
13:15:56 <fdegir> #link https://hastebin.com/oyigeqoqax.md
13:16:02 <David_Orange> #info i will check with mbuil and hw_wutianwei, thanks to them, feel free to send me your ssh keys if you want access
13:16:14 <fdegir> #info hw_wutianwei reported the issue to osa and they fixed it
13:16:21 <fdegir> hw_wutianwei: do you have link to the fix?
13:16:29 <hw_wutianwei> keepalived is caused by the python version
13:16:50 <fdegir> #info keepalived issue is caused by the python version
13:17:00 <fdegir> #info because of this, ha flavor is disabled at the moment
13:17:50 <fdegir> moving on...
13:17:50 <hw_wutianwei> 下午2:41:54 - cloudnull: […] If  you have py3
13:17:50 <hw_wutianwei> 下午2:42:05 - cloudnull: i wonder if you have an old version of the keepalived role ?
13:17:50 <hw_wutianwei> 下午2:42:06 - cloudnull: https://github.com/evrardjp/ansible-keepalived/commit/2553ddffd948f3e8e8196cd017d27716b396554a
13:17:50 <hw_wutianwei> 下午2:42:21 - cloudnull: I got a change in that role a while back to address the py3 issue cloudnull: https://github.com/openstack/openstack-ansible/blob/master/ansible-role-requirements.yml#L29-L32
13:18:28 <fdegir> thx hw_wutianwei, I'll probably ping you later, perhaps tomorrow to get more details
13:18:45 <hw_wutianwei> fdegir: ok
13:18:55 <fdegir> #info We finalized migration to releng-xci repo and settling the structure there
13:19:10 <fdegir> #topic Scenario/Feature status
13:19:24 <fdegir> #info os-nosdn-nofeature works
13:19:36 <fdegir> epalper: what about os-odl-nofeature?
13:19:49 <epalper> reviews are in: https://gerrit.opnfv.org/gerrit/#/c/39239/, https://review.openstack.org/#/c/496583/ and https://review.openstack.org/#/c/496583/
13:20:04 <fdegir> #info Patches for odl are under review
13:20:10 <epalper> testing is in progress.
13:20:11 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/39239/
13:20:18 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/496583/
13:20:27 <fdegir> #info Testing is in progress
13:20:37 <fdegir> epalper: you are working against master, isn't it?
13:20:43 <fdegir> not ocata I hope...
13:20:58 <epalper> #info yes
13:21:08 <fdegir> #info The work with odl is done against master
13:21:19 <fdegir> thanks epalper!
13:21:29 <fdegir> mbuil: your turn
13:21:46 <mbuil> epalper, fdegir: as far as I know, ODL Nitrogen does not work correctly with Pike yet, so don't get paranoid if tests fail :P
13:22:03 <fdegir> mbuil: I won't but you should :)
13:22:25 <fdegir> mbuil: how sfc is doing?
13:22:35 <mbuil> I am waiting for reviews to my two patches ==> https://gerrit.opnfv.org/gerrit/#/c/39517/ https://gerrit.opnfv.org/gerrit/#/c/39511/
13:22:50 <fdegir> #info SFC patches are waiting for reviews
13:22:56 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/39517/
13:23:02 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/39511/
13:23:04 <mbuil> Those patches complete the os-odl-sfc scenario
13:23:19 <fdegir> #info The patches complete the os-odl-sfc scenario
13:23:20 <mbuil> Then, I am waiting for reviews on this patch ==> https://gerrit.opnfv.org/gerrit/#/c/40595/
13:23:24 <fdegir> how is the testing going on?
13:23:39 <mbuil> That patch is required to make functest working with XCI
13:23:43 <fdegir> #info The patch to functest is also open
13:23:49 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/40595/
13:23:58 <fdegir> you tried it manually, isn't it?
13:24:12 <fdegir> and what was the result?
13:24:26 * fdegir heard rumours that it looked good...
13:24:29 <mbuil> The testing is completed. Try this private branch which has releng-xci master + Yolanda's patch + those two patches. Deployment is successful
13:24:29 <mbuil> v
13:24:33 <mbuil> https://github.com/manuelbuil/releng-xci/tree/integration-test-certificates
13:25:14 <epalper> #info we also need to get this review to be merged for ODL clustering to work: https://git.opendaylight.org/gerrit/#/c/61945/
13:25:37 <mbuil> fdegir, epalper: Something interesting for epalper. The current ODL role does not work with ODL Nitrogen. This patch needs to be merged ==> https://git.opendaylight.org/gerrit/#/c/62323/
13:25:45 <fdegir> I see dfarrell07 is there so I'm sure it will be done soon
13:26:27 <fdegir> #info For odl role to work with nitrogen, the patch needs to go in https://git.opendaylight.org/gerrit/#/c/62323/
13:26:28 <mbuil> epalper: what is your email, I can add you as reviewer?
13:26:29 <fdegir> dfarrell07: ^
13:27:14 <mardim> fdegir, : I am the owner of this patch https://git.opendaylight.org/gerrit/#/c/61945/
13:27:17 <fdegir> while we are on sfc, any update regarding ovs nsh?
13:27:18 <dfarrell07> mbuil, fdegir <blunt honestly> getting packages shipping for Nitrogen and Oxygen is a higher prio than anything related to ansible-odl
13:27:41 <mardim> fdegir, I want to update it but I din't find the tim
13:27:46 <mardim> time*
13:28:03 <fdegir> dfarrell07: we consider this as warning
13:28:04 <dfarrell07> few more TODOs to get Oxygen working for frankbrockners
13:28:10 <fdegir> dfarrell07: but any help is appreciated :)
13:28:32 <epalper> mbuil: periyasamy.palanisamy@ericsson.com
13:28:52 <mardim> fdegir: So ovs-nsh updates
13:28:55 <fdegir> mardim: you mean ovs nsh
13:29:01 <fdegir> yes, please go ahead
13:29:26 <mardim> So as we told to the latest hangout that we had with you guys
13:29:49 <mardim> mbuil integrate my private neutron role to the xci relneg
13:30:05 <mardim> and we are not gonna push upstream the changes for the ovs-nsh
13:30:22 <fdegir> #info mbuild integrated the private role for ovs nsh to neutron
13:30:22 <mardim> because we are gonna have support for the nsh in OVS 2.8 right ?
13:30:43 <mardim> So I think the part for ovs-nsh is done right ?
13:30:48 <mardim> what do you think
13:30:49 <mardim> ?
13:30:56 <fdegir> mardim: if you think it's not worth the effort and assuming ovs 2.8 is soon, it sounds logical
13:31:31 <mardim> Yes I think that for now we can go with the releng-xci as we have it now
13:31:40 <fdegir> mardim: whenever we get ovs with what you need, we bump whatever is needed to take that in
13:31:52 <fdegir> beauty of chasing master
13:32:05 <mardim> fdegir, Can tyou explain that please
13:32:11 <mardim> I din't understand it
13:32:15 <mardim> sorry
13:32:27 <fdegir> mardim: I mean we do not have any constraints when it comes to what to bring in from upstream
13:32:55 <fdegir> mardim: as XCI needs to be on the latest of whatever we bring in from upstream
13:32:59 <mardim> fdegir, So you think that we can close thos jira tickets or ?
13:33:07 <fdegir> mardim: not yet
13:33:07 <mardim> https://jira.opnfv.org/browse/RELENG-228
13:33:18 <mardim> https://jira.opnfv.org/browse/SFC-96
13:33:22 <fdegir> mardim: we can discuss this later after the meeting
13:33:30 <mardim> fdegir sure
13:33:35 <fdegir> thanks mardim
13:33:48 <fdegir> I think scenario/feature topic is done
13:33:53 <fdegir> moving to testing
13:33:57 <fdegir> #topic Testing
13:34:11 <fdegir> #info Trials with functest alpine based containers started
13:34:23 <fdegir> #info It will be integrated to osa-periodic jobs as first step
13:34:48 <fdegir> mbuil: since you updated the progress you had with testing, I skip sfc tests here
13:35:21 <fdegir> #info snaps enabled patches verification for their patches against a pre-deployed pike based system
13:35:41 <fdegir> #info We have a real user and we have to take good care of them
13:36:00 <fdegir> #info See the job https://build.opnfv.org/ci/view/snaps/job/snaps-verify-master/
13:36:22 <fdegir> #info The information about this is available on https://wiki.opnfv.org/display/INF/Improving+CI+for+Test+Projects#ImprovingCIforTestProjects-SNAPSPoC
13:36:46 <fdegir> and the task about stress test support is on David_Orange if I'm not mistaken
13:37:00 <fdegir> and it depends on what David_Orange already is working on; baremetal
13:37:19 <David_Orange> fdegir: you're not
13:37:34 <fdegir> #info the task about stress test support is on David_Orange and it depends on/related to what he is already doing with baremetal
13:37:40 <fdegir> thx David_Orange !
13:37:49 <David_Orange> fdegir: you're welcome
13:38:01 <fdegir> next topic is
13:38:05 <fdegir> #topic Distro Support
13:38:29 <fdegir> #info The last I heard from hwoarang was that he was thinking of finishing SUSE support by last friday
13:38:52 <fdegir> #info He started publishing patches for XCI multi-distro support so things are progressing there as well
13:39:04 <fdegir> but we had issues with bifrost on centos
13:39:08 <fdegir> yolanda: any updates?
13:39:23 <yolanda> fdegir, i could fix the log publish from vms, in centos and on suse
13:39:36 <yolanda> but we are still hitting issues on centos jobs , related with selinux
13:40:00 <yolanda> still under investigation
13:40:05 <fdegir> this is the patch you are trying, isn't it?
13:40:05 <fdegir> https://review.openstack.org/#/c/497814/
13:40:26 <yolanda> yep, but that's not a proper fix although it works :)
13:40:45 <fdegir> #info We are still hitting issues with centos jobs for bifrost and this is related to selinux
13:40:46 <yolanda> there seems to be a problem with serving images via nginx, because they don't have the right selinux type
13:41:06 <fdegir> #info There seems to be a problem with serving images via nginx, because they don't have the right selinux type
13:41:29 <ttallgren> I have been working on CentOS also but I seem to have a different problem
13:41:36 <fdegir> yolanda: I have no doubts about it being resolved since you are on top of it
13:41:49 <yolanda> fdegir, but as always, i could not focus on it
13:42:06 <fdegir> yolanda: I know but we will try our best
13:42:18 <fdegir> ttallgren: do you have logs?
13:42:27 <ttallgren> Yes
13:42:44 <fdegir> ttallgren: you can maybe share it so we can take a look at it after the meeting
13:43:05 <ttallgren> ipmitool is not able to reboot the opnfv VM, for some reason
13:43:29 <yolanda> mm, i have not arrived that long, as our jobs fail on provision the vms
13:44:48 <fdegir> ok, moving on to get through the agenda
13:45:06 <fdegir> yolanda: one last question: did we switch to centos minimal?
13:45:51 <yolanda> mm, i don't remember about it
13:46:58 <fdegir> yolanda: it seems we did for bifrost jobs
13:47:32 <fdegir> #info We switched to centos-minimal for bifrost-verify jobs
13:47:35 <fdegir> #link https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=blob;f=jjb/xci/bifrost-verify-jobs.yml;h=ef604fcfc7c0e550ac199e5d6d3385effbdd7e31;hb=HEAD#l29
13:47:45 <fdegir> #info ttallgren is having trouble with rebooting the opnfv VM
13:47:54 <yolanda> ah yep, i was looking at some logs from my patch now
13:47:59 <fdegir> next topic
13:48:09 <fdegir> #topic Extending CI
13:48:11 <yolanda> we may run with setenforce 0 because it passes there
13:48:25 <fdegir> yolanda: can you send a quick patch there?
13:48:33 <fdegir> I mean to releng?
13:48:49 <yolanda> for what?
13:48:57 <fdegir> yolanda: setenforce 0 thing you said
13:49:01 <yolanda> centos jobs in releng work
13:49:09 <yolanda> but i talk about the bifrost jobs themselves
13:49:17 <fdegir> ok
13:49:20 <ttallgren> bifrost is setting setenforce to 0
13:50:04 <fdegir> #info We started setting up periodic jobs
13:50:23 <fdegir> #info We will have jobs for bifrost and osa to test master to find a working version to pin
13:50:45 <fdegir> #info Skeleton for osa-periodic job is merged and execute shell part is in progress
13:51:03 <fdegir> and the last topic
13:51:07 <fdegir> #topic AoB
13:51:26 <fdegir> #info We presented the progress and short term plans to TSC yesterday
13:51:45 <fdegir> #info Presentation is available on https://wiki.opnfv.org/download/attachments/8687635/XCI_TSC_Report_August2017.pdf?api=v2
13:51:53 <fdegir> my feeling was good
13:52:14 <fdegir> at least we didn't get same questions again which I call a progress
13:52:25 <ttallgren> Did you discuss how this will affect the release model?
13:52:46 <fdegir> ttallgren: we haven't since I'm still trying to address dmcbride's questions
13:52:54 <ttallgren> Ok
13:53:05 <fdegir> ttallgren: and we intend to share the etherpad in a day or two
13:53:23 <fdegir> ttallgren: taking your comment into account regarding CD friendly release model
13:53:33 <fdegir> drawing an ascii art...
13:54:23 <fdegir> #info Next step is to clarify the impacts on release model and have a proposal regarding how it can be adjusted
13:55:01 <fdegir> #info We also need to document guides regarding how projects can be onboarded to XCI and get feedback from it
13:55:26 <fdegir> #info Documentation for XCI also started and will be on docs.opnfv.org under infrastructure
13:55:33 <fdegir> and one last announcement
13:55:54 <fdegir> #info Linux Foundation published XCI Solution Brief as well: https://www.opnfv.org/wp-content/uploads/sites/12/2017/08/OPNFV_SolutionBrief_XCI_080617.pdf
13:56:03 <ttallgren> Congratulations!
13:56:10 <fdegir> thanks ttallgren!
13:56:12 <yolanda> nice!
13:56:22 <mardim> great yes :)
13:56:32 <fdegir> thanks to you all
13:56:48 <David_Orange> great :)
13:56:52 <fdegir> I think we have great progress in such a short time and I believe we will have even more things
13:57:19 <fdegir> so I want to thank all of you for good work
13:57:26 <fdegir> and people expect more, just so you know...
13:57:48 <fdegir> closing the meeting if noone wants to bring anything else?
13:58:04 <fdegir> #endmeeting