13:00:16 <fdegir> #startmeeting Cross Community CI
13:00:16 <collabot> Meeting started Wed Sep 20 13:00:16 2017 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:16 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:16 <collabot> The meeting name has been set to 'cross_community_ci'
13:00:22 <fdegir> hi everyone
13:00:31 <ttallgren> hi
13:00:34 <acm> #info Al Morton
13:00:45 <fdegir> please type in your name if you are joining the xci meeting
13:00:56 <liangqi> #info qiliang
13:00:58 <David_Orange> #info David Blaisonneau
13:01:01 <ttallgren> #info Tapio Tallgren
13:01:03 <David_Orange> Hi everyone
13:01:04 <hw_wutianwei> #info Tianwei Wu
13:01:04 <jmorgan1> #info Jack Morgan
13:01:05 <fdegir> while we do that, I can put the link to the agenda as a reminder
13:01:08 <jmorgan1> hey David_Orange
13:01:11 <fdegir> #link https://etherpad.opnfv.org/p/xci-meetings
13:01:48 <fdegir> lets start and others can join on the way
13:02:03 <fdegir> the first topic for today is an issue we met today
13:02:12 <David_Orange> jmorgan1: hi
13:02:18 <fdegir> #topic Issues with diskimage-builder
13:02:25 <s3wong> hello
13:02:36 <fdegir> both me and hwoarang faced issues with bifrost provisioning today
13:02:42 <jmorgan1> David_Orange: sorry for not getting to your patches yet, I will today
13:02:55 <David_Orange> jmorgan1: np :)
13:02:56 <fdegir> some of you might have issues if you attempt using xci on ubuntu today
13:03:13 <fdegir> hwoarang: yolanda: can you give a quick summary about dib issue we have?
13:03:31 <hwoarang> #info Markos Chandras
13:03:33 <durschatz> fdegir: Students are happy learning on their XCI deployed OpenStack!
13:03:43 <fdegir> durschatz: happy to hear!
13:03:54 <hwoarang> fdegir: yeah basically root=LABEL=foobar doesn't work anymore on ubuntu for unknown reason
13:03:56 <durschatz> info# Dave Urschatz
13:04:06 <hwoarang> actually i think the reason is that the dib doesn't inject an initrd on the ubuntu image
13:04:12 <s3wong> #info Stephen Wong
13:04:12 <fdegir> #info root=LABEL=foobar doesn't work anymore on ubuntu for unknown reason
13:04:14 <hwoarang> i don't know why maybe something changed in the upstream packages
13:04:29 <fdegir> #info the reason might be that the dib doesn't inject an initrd on the ubuntu image
13:04:31 <yolanda> so, not able to make the meeting today...
13:04:40 <fdegir> yolanda: no worries
13:05:00 <fdegir> so the CI is broken due to this issue as well since we clean the images for each run
13:05:15 <fdegir> which results in jenkins giving -1
13:05:31 <hwoarang> i want to use dracut to rebuild an initrd but the element doesn't play well if you don't already have an initrd present
13:05:32 <fdegir> the beauty of living on the edge
13:05:57 <hwoarang> #link https://bugs.launchpad.net/diskimage-builder/+bug/1718415
13:05:59 <hwoarang> upstream report^
13:06:22 <Guest88084> Then let me reconnect
13:06:46 <fdegir> hwoarang: can we assume that you will not give up on ubuntu yet and will continue trying to fix it?
13:06:55 <hwoarang> it's a risky assumption
13:07:00 <hwoarang> ;p
13:07:08 <fdegir> #action hwoarang to fix dib issues on ubuntu
13:07:10 <fdegir> thx hwoarang
13:07:14 <fdegir> moving on
13:07:22 <fdegir> #topic Multi-distro support
13:07:31 <jmorgan1> hwoarang: is it missing some driver support?
13:07:32 <fdegir> hwoarang: I think you have some news regarding SUSE
13:07:53 <hwoarang> jmorgan1: i don't know what initrd is missing still investigating. the fact that initrd is missing is worrying enough
13:08:05 <jmorgan1> hwoarang: agreed
13:08:11 <hwoarang> fdegir: yes suse support merged, makes it all the way to OSA but had to kill it so i can fix ubuntu
13:08:31 <hwoarang> i mean, networking plugging etc works so that's good enough. if something fails then that's an OSA thing
13:08:35 <fdegir> #info SUSE support has been merged but the work is put on hold while troubleshooting dib issues on ubuntu
13:08:50 <hwoarang> i still have a few patches to send but i am waiting for jenkins to be green again
13:09:02 <fdegir> #info If something goes wrong with SUSE, it is probably due to OSA which needs to be fixed as well
13:09:24 <fdegir> #info Few more patches are pending to be sent but we need CI before doing that
13:09:37 <hwoarang> that's it
13:09:40 <fdegir> I think we are getting there
13:09:41 <fdegir> hwoarang: thx!
13:09:45 <fdegir> ttallgren: how about centos?
13:10:20 <ttallgren> I can run the virtual deployment with noha on Centos
13:10:25 <hwoarang> ttallgren: are you building ontop of the suse stuff which added multi distro support to roles? i guess the thing that needs fixing is just the networking bits with vlans etc?
13:10:39 <fdegir> #info The virtual deployment with noha flavor runs on Centos
13:10:50 <ttallgren> Yes, that is already in master
13:10:55 <hwoarang> ok that's good
13:11:13 <fdegir> ttallgren: have you had chance to try using the osa version I passed?
13:11:19 <fdegir> so you can progress further perhaps
13:11:48 <ttallgren> Nope. For some reason the role haproxy_endpoints is not loaded
13:11:56 <fdegir> ok
13:12:19 <fdegir> as I mentioned, it might be safer to use the version we pinned since that version didn't have the issue you had
13:12:30 <fdegir> at least you can see if the problem you had is specific to centos or not
13:12:48 <fdegir> so centos is progressing as well
13:12:50 <fdegir> thx ttallgren!
13:12:57 <fdegir> we already talked about ubuntu
13:13:04 <fdegir> it's been fine until today and then dib happened
13:13:13 <fdegir> next topic is
13:13:16 <fdegir> #topic Testing
13:13:36 <fdegir> #info The work to enable functest for xci-verify and osa-periodic is progressing slowly
13:14:03 <fdegir> I took over the patch from mbuil
13:14:04 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/42069/
13:14:14 <fdegir> which I'll try to finish asap
13:14:39 <fdegir> #info Once the healthcheck is enabled and confirmed working, we can enable testing for sfc scenario once the scenario gets merged
13:14:49 <fdegir> that's all for the testing
13:15:02 <fdegir> #topic Release Readiness
13:15:12 <fdegir> some of you might know that we will release XCI as part of Euphrates
13:15:28 <fdegir> and in order for us to do that, we need to ensure CI exists/up & running
13:15:35 <fdegir> we need documentation
13:15:36 <fdegir> and so on
13:16:00 <fdegir> #info the CI parts is progressing and the documentation will soon be moved to docs.opnfv.org
13:16:18 <fdegir> I'll send few patches for documentation and add everyone as reviewers
13:16:31 <fdegir> please review them as they will be used by our users, like durschatz
13:16:36 <fdegir> and we need to treat our users well :)
13:16:48 <durschatz> :-)
13:17:02 <fdegir> that's all for the release for the timebeing
13:17:15 <fdegir> moving to the scenarios
13:17:29 <fdegir> #topic Scenario/Feature Status: os-odl-nofeature
13:17:34 <fdegir> epalper: are you with us?
13:17:45 <jmorgan1> fdegir: link for docs please
13:18:14 <fdegir> jmorgan1: http://docs.opnfv.org/en/latest/#infrastructure
13:18:22 <fdegir> jmorgan1: it's empty as the patches are not merged
13:18:48 <fdegir> https://gerrit.opnfv.org/gerrit/#/c/40329/
13:18:51 <jmorgan1> fdegir: this is your patch 40329
13:18:53 <fdegir> https://gerrit.opnfv.org/gerrit/#/c/40533/
13:18:53 <jmorgan1> right
13:19:01 <jmorgan1> thanks
13:19:10 <fdegir> I'll submit 40329 to see how it looks on docs.opnfv.org
13:19:29 <fdegir> epalper doesn't seem to be around so I give an update
13:19:29 <jmorgan1> i will provide review today
13:19:44 <jmorgan1> but don't have to wait for me
13:20:01 <fdegir> #info epalper's patch for os-odl-nofeature is under review
13:20:03 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/39239/
13:20:20 <fdegir> #info But we need to decide how to move forward with handling scenarios first before merging that patch
13:20:27 <fdegir> #info Which will happen soon
13:21:01 <fdegir> #topic Scenario/Feature Status: os-odl-sfc
13:21:06 <fdegir> mbuil: mardim: any updates?
13:21:47 <mbuil> fdegir: This week not many. You took over the xci-functest patch and we agreed on a way forward to connect scenarios to xci
13:21:56 <mbuil> fdegir: I need to move my pending patch to the sfc repo
13:22:16 <fdegir> #info The agreed way forward with scenarios need to be applied to sfc
13:22:26 <mbuil> fdegir: but I am currently very busy fixing ODL, so I am not sure if I will manage to do that before october
13:22:27 <fdegir> #info The sfc scenario needs to be moved to sfc repo
13:22:44 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/39517/
13:22:55 <fdegir> mbuil: that's fine
13:23:04 <mbuil> fdegir: and also the tacker patch
13:23:18 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/39511/
13:23:18 <mbuil> https://gerrit.opnfv.org/gerrit/#/c/39511/
13:23:35 <fdegir> fyi for everyone
13:23:53 <fdegir> what we are trying to do with odl and sfc scenarios is actually finding a sustainable way forward with scenarios
13:24:00 <fdegir> by pushing scenarios to project repos
13:24:26 <fdegir> you can read the details about this on https://wiki.opnfv.org/pages/viewpage.action?pageId=12390152
13:24:33 <fdegir> #link https://wiki.opnfv.org/pages/viewpage.action?pageId=12390152
13:24:49 <fdegir> the first attempt will be a bit messy and we will fix it properly once we get the first scenarios running
13:24:54 <fdegir> thx mbuil
13:25:11 <mbuil> yeah, and we will create a proper documentation once that is done
13:25:19 <mbuil> fdegir: you are welcome
13:25:24 <fdegir> #topic Kubernetes in XCI
13:25:34 <fdegir> before I pass the word to s3wong, let me introduce him
13:25:45 <fdegir> Stephen joined us to work with k8s in XCI
13:26:01 <fdegir> and we will start a prototype to bring k8s in
13:26:09 <fdegir> s3wong: stage is yours
13:26:19 <s3wong> fdegir: Thanks
13:26:36 <fdegir> welcome s3wong!
13:26:38 <fdegir> any updates?
13:26:55 <hwoarang> welcome s3wong
13:27:07 <s3wong> I am currently looking at some playbooks from kubespray
13:27:22 <s3wong> Personally I normally set up k8s cluster using kubeadm
13:27:46 <s3wong> hwoarang: Thanks
13:27:52 <fdegir> #info s3wong is looking into kubespray for the existing playbooks
13:28:06 <durschatz> CNI for networking?
13:28:34 <s3wong> durschatz: Yes, with either Calico and Canal for CNI plugin
13:28:43 <durschatz> :-)
13:29:23 <s3wong> As Calico (especially) and Canal are well supported and basically are defaults now for k8s networking
13:29:50 <fdegir> #info For networking, either Calico and Canal for CNI plugin will be looked into
13:30:25 <s3wong> Will first try to do AIO with ubuntu as OS
13:30:42 <fdegir> #info First try will be on ubuntu with the flavor aio
13:31:18 <durschatz> I would like to try if you have anything working down the road.
13:31:28 <s3wong> durschatz: certainly
13:32:02 <fdegir> s3wong: anything else?
13:32:09 <David_Orange> s3wong: i have to look at k8s for ONAP needs, so i will test it too
13:32:24 <David_Orange> s3wong: (and Welcome :))
13:32:48 <s3wong> David_Orange: yes, I noticed from a link you provided last week
13:32:53 <fdegir> let me put the link to the etherpad again
13:32:53 <s3wong> David_Orange: Thanks
13:32:59 <fdegir> #link https://etherpad.opnfv.org/p/xci-k8s
13:33:09 <fdegir> and highlight some key points/our ambition level
13:33:17 <durschatz> I'm also interested in what is going on with XCI and ONAP
13:33:19 <s3wong> fdegir: that's all for now, will update progress (and the etherpad content) as I move forward
13:33:22 <epalper> fdegir: sorry, got into some other task. thanks for giving an update !
13:33:43 <fdegir> #info With k8s, we have similar approach as openstack
13:33:52 <fdegir> #info multi-distro support; ubuntu, suse, centos
13:34:08 <fdegir> #info consume k8s from master - probably using the weekly releases done by k8s community
13:34:26 <fdegir> #info bring up a prototype which is what s3wong has been working on
13:34:48 <fdegir> #info reach out to k8s community and present what we are trying to achieve based on real stuff
13:35:13 <fdegir> like how we did with openstack community (bifrost & osa)
13:35:21 <fdegir> thanks for the update s3wong
13:35:32 <s3wong> fdegir: Thanks!
13:35:34 <fdegir> #topic Congress in XCI
13:35:42 <fdegir> Taseer: are you around?
13:35:52 <Taseer> fdegir: Yes
13:36:03 <fdegir> Taseer: please give us an update regarding congress
13:36:17 <Taseer> #link https://review.openstack.org/#/c/499066/
13:36:31 <Taseer> Blue print has been accepted by the OSA community
13:36:53 <fdegir> #info Blueprint for congress has been accepted & merged by the OSA community
13:36:59 <Taseer> #link https://github.com/Taseer94/os_congress/
13:37:22 <Taseer> creating a role from scratch since there is none upstream
13:37:46 <fdegir> #info Taseer is creating the role for congress from scratch since it doesn't exist in the upstream
13:38:07 <Taseer> #link https://review.openstack.org/#/c/503971/
13:38:15 <Taseer> integration patch in progress as well
13:38:31 <fdegir> #info Integrating the role to osa is in progress as well
13:38:43 <fdegir> Taseer: I suppose you had a look at bryan_att's ansible playbook for congress
13:38:44 <Taseer> That's from me
13:38:57 <Taseer> fdegir: Yes
13:39:05 <fdegir> thx Taseer
13:39:15 <Taseer> fdegir: you are welcome
13:39:17 <fdegir> #topic Extending CI
13:39:39 <fdegir> as we discussed at the beginning of the meeting, CI is currently blocked due to dib issues
13:39:56 <fdegir> apart from that we are working on extending it
13:40:06 <hwoarang> jmorgan1: pm now?
13:40:17 <jmorgan1> hwoarang: yup
13:40:28 <fdegir> #info osa-periodic jobs will be enabled soon and they will have the usual mini deployment together with functest healthcheck to chase the osa master
13:40:48 <fdegir> #info Apart from having the basic jobs, we will enable CI for all the distros we support; ubuntu, centos, and suse
13:41:07 <fdegir> jmorgan1 might have a present for us soon...
13:41:49 <fdegir> #info Once the basic jobs are in place, jobs for the scenarios will be created following what is explained in CI Evolution
13:42:11 <fdegir> #info No more (re)running things if things don't change and instead take them to more extensive testing
13:42:38 <fdegir> that's all for CI parts
13:42:45 <fdegir> #topic XCI on Baremetal
13:42:51 <fdegir> David_Orange: any updates?
13:42:57 <David_Orange> fdegir: yes
13:43:12 <David_Orange> #info i just pushed my baremetal proto
13:43:22 <fdegir> link or it didn't happen... :)
13:43:53 <David_Orange> #link https://gerrit.opnfv.org/gerrit/#/c/42267/
13:44:29 <David_Orange> #info as previous version, the idea is only to have the upstream bifrost+osa installation
13:44:45 <David_Orange> #info this version is based on PDF and its actual evolutions
13:45:18 <David_Orange> now everyone is welcome to review, ans test it
13:45:28 <fdegir> David_Orange: a question
13:45:58 <David_Orange> fdegir: yes
13:46:02 <fdegir> David_Orange: if we have pdf for one of the xci pods, I assume and hope we don't need to change too much and this should just work automagically?
13:46:09 <fdegir> David_Orange: since I see you templated stuff and so on
13:46:46 <David_Orange> fdegir: yes it should... i test it on another pod tomorrow
13:47:02 <fdegir> David_Orange: let me know if you want to give a try on one of the xci pods
13:47:05 <David_Orange> as intel pod18 is not available
13:47:28 <jmorgan1> i will make pdf for all intel pod
13:47:29 <David_Orange> fdegir: sure, we can plan a test next week
13:47:35 <jmorgan1> before end of month
13:47:38 <fdegir> David_Orange: ok, I'll contact you offline
13:47:45 <David_Orange> jmorgan1: thanks
13:47:51 <David_Orange> fdegir: thanks
13:47:57 <fdegir> thx David_Orange
13:48:01 <fdegir> thx jmorgan1
13:48:02 <jmorgan1> thanks David_Orange
13:48:08 <fdegir> so the last topic is
13:48:11 <fdegir> #topic AoB
13:48:12 <jmorgan1> fdegir: your most welcome!
13:48:30 <fdegir> #info XCI has been presented to ETSI last week and I think it was good
13:48:32 <durschatz> AoB?
13:48:40 <fdegir> durschatz: any other business
13:48:46 <durschatz> :-)
13:49:19 <fdegir> #info We also had conversations with OpenStack QA thanks to yolanda and talked about what we aim to achieve with XCI
13:49:48 <fdegir> #info I think we have lots of (new) opportunities to collaborate further with OpenStack community around XCI
13:50:05 <fdegir> that was all from me for AoB
13:50:11 <fdegir> anyone else wants to add anything?
13:50:32 <durschatz> When will ONAP be part of XCI?
13:50:32 <fdegir> hw_wutianwei: I see you have some patches to xci
13:50:39 <hw_wutianwei> fdegir: integrating ceph are in progress
13:50:55 <fdegir> #info hw_wutianwei is working on integrating ceph
13:51:01 <hw_wutianwei> and some bug need to be fixed
13:51:10 <fdegir> hw_wutianwei: bug in osa or in xci?
13:51:26 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/42503/
13:51:32 <hw_wutianwei> in xci configuration
13:51:42 <fdegir> is this the one: https://gerrit.opnfv.org/gerrit/#/c/41517/
13:51:46 <fdegir> hw_wutianwei: ^
13:52:03 <hw_wutianwei> fdegir: https://gerrit.opnfv.org/gerrit/#/c/41517/
13:52:32 <fdegir> #info A fix has been issued for the bug in xci configuration
13:52:37 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/41517/
13:52:44 <fdegir> thx hw_wutianwei
13:53:01 <fdegir> durschatz: making ONAP part of XCI is in our roadmap
13:53:11 <hw_wutianwei> fdegir: you are welcome
13:53:23 <jmorgan1> but want to get it working fist, no
13:53:24 <fdegir> durschatz: we have been discussing this and things will hopefully start happening soon
13:53:48 <fdegir> durschatz: at least on a more detailed level
13:54:01 <fdegir> durschatz: when things start happening for real depends on our progress
13:54:01 <durschatz> I have a student who will be interested in ONAP.  So may want him to understand what is being done so far in XCI
13:54:15 <durschatz> thx
13:54:50 <fdegir> durschatz: then I'll bug you further
13:54:57 <durschatz> :-)
13:55:13 <fdegir> any other updates from anyone?
13:55:16 <fdegir> comments/questions?
13:55:38 <fdegir> jmorgan1: did you mean we should get ONAP working first?
13:55:43 <fdegir> cause xci works perfectly...
13:55:52 <jmorgan1> fdegir: no xci working first
13:55:53 <durschatz> No. Just want to know status.
13:56:18 <fdegir> jmorgan1: we will make it work
13:56:21 <durschatz> The student may get ONAP working here and could leverage anything already being done.
13:56:43 <fdegir> durschatz: we had some conversations around LaaS/XCI and ONAP
13:56:44 <durschatz> Also provide feedback.  But TBD also
13:57:00 <fdegir> these are TBD as well
13:57:30 <durschatz> :-)
13:57:35 <jmorgan1> sounds good
13:57:43 <fdegir> just a final note; as you noticed, we have the XCI meetings on a weekly basis moving forward
13:57:56 <fdegir> #info XCI meetings will be held on a weekly basis from now on
13:58:06 <fdegir> thank you all for joining!
13:58:13 <hwoarang> with pleasure
13:58:15 <jmorgan1> thanks
13:58:19 <fdegir> and thanks for the great work
13:58:22 <s3wong> thanks
13:58:25 <durschatz> Thanks all!
13:58:34 <David_Orange> thanks all
13:58:38 <fdegir> you should know that it is appreciated by many and we are on our way to change things
13:58:40 <fdegir> just saying...
13:58:45 <fdegir> #endmeeting