13:00:04 <fdegir> #startmeeting Cross Community CI
13:00:04 <collabot`> Meeting started Wed Sep 27 13:00:04 2017 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:04 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:04 <collabot`> The meeting name has been set to 'cross_community_ci'
13:00:10 <fdegir> hi everyone
13:00:23 <fdegir> please type in your name if you are joining the XCI meeting
13:00:24 <jmorgan1> hey
13:00:26 <fdegir> #topic Rollcall
13:00:29 <s3wong> hello
13:00:33 <jmorgan1> #info Jack Morgan
13:00:37 <hw_wutianwei1> hi
13:00:39 <s3wong> #info Stephen Wong
13:00:51 <fdegir> the agenda is in its usual place: https://etherpad.opnfv.org/p/xci-meetings
13:00:53 <hw_wutianwei1> #info Tianwei Wu
13:01:46 <liangqi> #info qiliang
13:01:49 <fdegir> let's start and others can join us on the way
13:01:53 <fdegir> first topic is
13:02:02 <fdegir> #topic Multi-distro Support
13:02:25 <fdegir> #info Ubuntu has been working fine already
13:02:42 <hwoarang> #info Markos Chandras
13:02:46 <fdegir> #info Support for OpenSUSE has been introduced recently
13:02:55 <fdegir> hwoarang: anything to add for OpenSUSE?
13:03:03 <hwoarang> it should JustWork(tm)
13:03:15 <David_Orange> #info David Blaisonneau
13:03:30 <fdegir> hwoarang: no worries, we will see it ourselves soon :)
13:03:50 <fdegir> Tapio doesn't seem to be online so infoing it for him
13:03:59 <fdegir> #info Tapio is looking into Centos
13:04:26 <hwoarang> might worth getting whatever he has on gerrit so we can get some CI feedback
13:04:51 <mbuil> #info mbuil
13:04:57 <fdegir> #info It would be good to get what Tapio did for Centos to Gerrit so we get CI feedback
13:04:57 <jmorgan1> i don't see any patches for him in gerrit
13:05:05 <mbuil> is this meeting weekly or biweekly? :P
13:05:07 <jmorgan1> right
13:05:13 <fdegir> mbuil: it's been weekly since last week
13:05:21 <fdegir> #info Apart from general distro support, we also introduced xci-verify jobs for all 3 distros (like 5 minutes ago..)
13:05:29 <fdegir> #link https://build.opnfv.org/ci/view/OPNFV%20XCI/
13:05:31 <mbuil> fdegir: I see, thanks. mardim, you were right :P
13:05:45 <hwoarang> which also happens inside a VM built from scratch on every run
13:05:48 <fdegir> #info See section xci verify master
13:06:01 <hwoarang> so that should eliminate problems due to stale artifacts from previous builds
13:06:21 <jmorgan1> ttallgren: we were just talking about centos, any update?
13:06:39 <fdegir> #info On top of enabling jobs, we now run verification in clean VMs to ensure leftovers of previous runs don't cause issues
13:06:48 <ttallgren> I reinstalled my CentOS box and got new problems
13:06:58 <fdegir> #info Whenever a new patch comes in, a new VM gets created for each 3 distros
13:07:28 <ttallgren> Besides /etc/ssl/certs, glean is acting up in CentOS guest VM
13:07:31 <fdegir> ttallgren: we now enabled jobs for centos so you will get feedback from CI
13:07:42 <ttallgren> ok, I will check thos
13:07:44 <hwoarang> ttallgren: can you post  any of your patches on gerrit so jenkins can test them (jenkins can run on centos too now) and perhaps help you share the work?
13:07:55 <mbuil> what you try in those VMs? to run aio flavor?
13:08:01 <fdegir> mbuil: mini
13:08:12 <fdegir> #info verify jobs use mini flavor
13:08:25 <mbuil> but there is not healthcheck or tempest, right? You only check that the deployment is successfully deployed, right?
13:08:28 <ttallgren> aio looked tricky, so I am just using noha
13:08:33 <fdegir> #info We run 2 verify jobs on single slave so VM stuff helped us with resource shortage as well
13:08:40 <fdegir> mbuil: that's coming up
13:08:55 <mbuil> fdegir: ok thanks :)
13:09:25 <fdegir> #info One final note about verify jobs is that, only xci-verify-ubuntu votes. Voting for other distro jobs will be enabled once we are sure we fixed the framework/jobs themselves
13:09:34 <mbuil> and if it fails in one distro, can we merge it?
13:09:44 <fdegir> mbuil: depends on the nature of the failure
13:09:45 <mbuil> fdegir: ok, you replied to my question :)
13:10:00 <mbuil> fdegir: only ubuntu votes
13:10:14 <fdegir> mbuil: you can merge it "technically" but it would be good to fix it if you know the fix already
13:10:21 <fdegir> if not, then yes, merge is possible
13:10:39 <fdegir> this was verify jobs
13:11:01 <fdegir> #info We need similar jobs for osa-periodic and the new way of running stuff will make things much easier for osa-periodic jobs as well
13:11:19 <fdegir> #info These jobs will be created soon once the basics with verify jobs/VM stuff is settled
13:11:32 <fdegir> moving to testing...
13:11:38 <fdegir> #topic Testing
13:11:50 <fdegir> #info The change that prepares the deployment for functest has been merged
13:12:04 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/42069/
13:12:28 <fdegir> #info Next step is to integrate healthcheck into xci-verify/osa-periodic - it will start its life as none-voting for verify jobs
13:12:49 <fdegir> mbuil: do you want to talk about sfc testing now or as part of scenario status update?
13:13:40 <fdegir> moving on to 2 really important topics
13:13:41 <mbuil> fdegir: better with the scenario update. I have not a lot of news
13:13:45 <fdegir> #topic Documentation
13:14:07 <fdegir> #info We are getting closer to release date and we must have documentation ready no matter what we get working
13:14:36 <fdegir> #info Reviews will be coming to your way and please read them as they will be used by our users and they must be clear
13:15:02 <fdegir> #info I appreciate if anyone wants to help out
13:15:23 <fdegir> #topic Release Readiness
13:15:36 <fdegir> this is tricky
13:15:44 <fdegir> anyone wants to speak up?
13:15:57 <fdegir> about multi-distro support or scenario support?
13:16:11 <hwoarang> for multidistro i think we may not have centos ready in time
13:16:28 <hwoarang> at least not all of it
13:16:31 <fdegir> ttallgren: what do you think?
13:16:45 <fdegir> ttallgren: you will be asked this as part of your euphrates interviews
13:16:52 <fdegir> ttallgren: it is better you get it working :)
13:16:54 <ttallgren> I would agree
13:17:12 <ttallgren> not being able to promise that it will work
13:17:40 <ttallgren> I already have nightmares about journalists asking me about CentOS support :-)
13:17:41 <fdegir> I think the best thing to do at this point is to get your patches to gerrit ttallgren
13:17:53 <fdegir> and we see what it breaks
13:18:29 <fdegir> I need to give yet another heads up regarding centos then
13:18:42 <ttallgren> I am running my testing with a simple script that sets a few variables and uses screen to display all kinds of information
13:19:26 <ttallgren> I have two patches in Gerrit that I also use, and I delete the exit -1. Thats all
13:19:42 <ttallgren> I have this issue now: https://bugs.launchpad.net/bifrost/+bug/1719864
13:19:49 <hwoarang> ttallgren: you can mimic what the CI will do for centos by simply running ./xci/scripts/vm/start-new-vm.sh centos
13:20:03 <hwoarang> this will createa a brand new VM for centos7 and run xci-deploy.sh in it
13:20:32 <hwoarang> maybe that helps instead of having your own wrappers. might make it easier to compare your results with the CI
13:21:03 <jmorgan1> for release we are only talking about VM deployemnts, not baremetal?
13:21:04 <ttallgren> Yes, I saw that. However, the glean stuff now fails everywhere, both host and guest
13:21:10 <fdegir> jmorgan1: that's right
13:21:16 <jmorgan1> ok
13:21:29 <fdegir> jmorgan1: guess why - all because of PDF!!! :P
13:21:50 <fdegir> thx ttallgren hwoarang
13:21:51 <jmorgan1> fdegir: better to get it right forst time then redue later
13:21:59 <fdegir> jmorgan1: +1
13:22:16 <fdegir> #topic Scenario/Feature Status: os-nosdn-nofeature
13:22:33 <fdegir> #info This is the scenario we are running everywhere and no need to talk about it in detail
13:22:53 <fdegir> #info It simply works - if upstream doesn't mess something up...
13:23:07 <fdegir> #topic Scenario/Feature Status: os-odl-nofeature
13:23:12 <fdegir> epalper: any update?
13:23:46 <fdegir> I suppose not
13:24:00 <fdegir> #info No update for os-odl-nofeature
13:24:02 <fdegir> #topic Scenario/Feature Status: os-odl-sfc
13:24:06 <fdegir> mbuil: now your turn
13:24:08 <mbuil> fdegir: I already started working on the patch that moves the SFC scenario code to the SFC repo: https://gerrit.opnfv.org/gerrit/#/c/43165/ but I haven't had much time to invest on it due to bugs in SFC testing
13:24:28 <fdegir> #info mbuil started moving sfc scenario to sfc repo
13:24:38 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/43165/
13:24:58 <mbuil> fdegir: And yesterday evening I found an issue with the functest <--> xci integration. The quotes in the ip of the env.j2 template brings problems
13:25:14 <fdegir> mbuil: ok - will you send a patch for it?
13:25:17 <mbuil> fdegir: I don't know why I did not experience it before though
13:25:22 <mbuil> fdegir: yeah, I can do it
13:25:27 <fdegir> mbuil: thx
13:25:55 <fdegir> #info mbuil identified an issue with functest-prepare role with env.j2 (having quotes in ip) - he will send a patch for it
13:26:03 <fdegir> mbuil: and testing?
13:26:32 <OPNFV-Gerrit-Bot> Guillermo Herrero proposed pharos: Updated fuel adapter (vlan1000, interfaces format)  https://gerrit.opnfv.org/gerrit/43307
13:26:34 <mbuil> fdegir: manual testing of SFC in a xci-deployed environment is working
13:26:52 <fdegir> #info Manuel testing of SFC in xci works - it needs to be automated asap
13:27:09 <mbuil> fdegir: when I say manual I mean there a few steps in the deployment which are not yet automated but the test was done through functest alpine container
13:27:42 <fdegir> #info Testing is done using alpine based containers for functest
13:27:52 <fdegir> #info There are few things that need to be automated as well
13:27:56 <mbuil> fdegir: those few steps are needed because of bugs in some of our integrated projects (tacker, OVS, ODL...). They are workarounds to avoid those problems
13:28:10 <fdegir> mbuil: will you add them to your sfc role?
13:28:26 <mbuil> fdegir: yes
13:28:39 <fdegir> ok, so they will be automated
13:28:56 <fdegir> thx Manuel!
13:29:15 <epalper> fdegir: os-odl-nofeature: merge is pending for https://gerrit.opnfv.org/gerrit/#/c/39239/ and https://review.openstack.org/#/c/496580/
13:29:17 <fdegir> I want to bring everyone's attention to what Manuel is doing with the move of sfc role to sfc repo
13:29:33 <fdegir> this is crucial for XCI in order to push scenarios to where they belong; project repos
13:29:56 <fdegir> please take extra look and ensure review anything related to this so we can put good foundation in place
13:30:03 <epalper> Please take a look and give your review comments
13:30:20 <fdegir> epalper: thanks
13:30:31 <fdegir> epalper: this is also realted to what Manuel is doing for sfc
13:30:53 <fdegir> epalper: we need to find a good way to position scenarios so we can consume them no matter where they are stored
13:31:14 <fdegir> moving to the next topic
13:31:28 <epalper> one more thing
13:31:33 <fdegir> #topic Scenario/Feature Status: k8s-nosdn-nofeature
13:31:37 <fdegir> s3wong: any update
13:32:02 <fdegir> epalper: sorry epalper - missed that
13:32:05 <epalper> shall i also look into os-nosdn-ovs scenario ?
13:32:10 <fdegir> epalper: can we take it in AoB please?
13:32:18 <s3wong> I spent most of the week try to make the kubespray + kubeadm support working in my setup as reference
13:32:41 <s3wong> The kubeadm support was merged about two weeks ago:  https://github.com/kubernetes-incubator/kubespray/commit/6744726089245c724b6927d419064a84551931e2
13:32:44 <fdegir> #info s3wong tried to make the kubespray + kubeadm support working in my setup as reference
13:32:54 <fdegir> #info The kubeadm support was merged about two weeks ago:  https://github.com/kubernetes-incubator/kubespray/commit/6744726089245c724b6927d419064a84551931e2
13:33:42 <fdegir> s3wong: anything you can send to gerrit so we can take a look at?
13:33:58 <s3wong> As mentioned last week the goal is to get k8s-nosdn-nofeature working for aio
13:34:06 <fdegir> s3wong: yes
13:34:31 <fdegir> others, such as David_Orange, are interested in k8s so it would be good to share whatever you have
13:34:47 <fdegir> so people can take a look at them, trying them out or at least giving feedback
13:34:47 <David_Orange> fdegir: s3wong: +1 :)
13:35:22 <s3wong> fdegir: I will try to post something soon --- please note that I will be on PTO next week, so hopefully I can get a WIP patch out soon
13:35:22 <fdegir> cause, there is no update on etherpad or gerrit so it is difficult to see the progress
13:35:27 <fdegir> and possible share the load
13:35:38 <fdegir> that would be good s3wong
13:35:40 <fdegir> thx a lot
13:35:58 <fdegir> moving to Congress
13:36:07 <fdegir> #topic Scenario/Feature Status: Congress
13:36:13 <fdegir> Taseer: are you with us?
13:37:02 <fdegir> I suppose not
13:37:07 <fdegir> #info No update for congress
13:37:18 <fdegir> #topic Scenario/Feature Status: Ceph
13:37:28 <fdegir> hw_wutianwei: anything you want to share?
13:37:42 <hw_wutianwei> I have  submit the patch, https://gerrit.opnfv.org/gerrit/#/c/42503/
13:38:14 <hw_wutianwei> it failed in verify, but manual deploying was fine
13:38:30 <fdegir> #info hw_wutianwei's patch works manually but failed on CI
13:38:37 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/42503/
13:38:38 <hw_wutianwei> maybe I missed something,
13:38:40 <jmorgan1> fdegir: do we have etherpad link for conress? if not, can we ask to create one for visability?
13:38:55 <fdegir> hw_wutianwei: I think the jobs will hopefully be more stable moving forward
13:39:19 <fdegir> hw_wutianwei: due to use of clean VMs so we can take a look at any failures from now on and try to find out if anything else needs to be done
13:39:47 <hw_wutianwei> fdegir: agree
13:39:53 <fdegir> jmorgan1: https://jira.opnfv.org/browse/RELENG-247
13:40:13 <fdegir> Taseer: can you please put the links to blueprint and any other patches you might have to the Jira issue above?
13:40:35 <hw_wutianwei> and I will try to fix this
13:40:39 <fdegir> #action Taseer to put the links to blueprint and any other patches to https://jira.opnfv.org/browse/RELENG-247 for better visibility
13:40:56 <fdegir> thx hw_wutianwei
13:41:17 <fdegir> #topic Baremetal Status
13:41:28 <hw_wutianwei> fdegir: you are welcome
13:41:29 <Taseer> fdegir: I am here.
13:41:32 <fdegir> David_Orange: your turn
13:41:37 <David_Orange> yes
13:42:05 <David_Orange> about baremetal i updated all yaml files, playbooks and config after a yamllint check
13:42:25 <David_Orange> and now testing it on ONAP Orange openlab
13:43:06 <David_Orange> this platform is freshly plugged so i have to debug a fex things (like pxe interfaces)
13:43:28 <fdegir> #info All yaml files, playbooks and config are updated after a yamllint check
13:43:37 <fdegir> #info It is now being tested in ONAP Orange OpenLab
13:43:44 <David_Orange> the hardware is DELL, and pod1 is HP, so for the bifrost part it would validate the playbooks
13:44:18 <David_Orange> and i am still open to reviews :)
13:44:29 <fdegir> David_Orange: yep
13:44:41 <fdegir> David_Orange: I think the release stuff is taking everyone's attention
13:44:43 <David_Orange> but no pression, main release first :)
13:44:53 <fdegir> David_Orange: I hope things will improve soon once we push this out
13:44:58 <David_Orange> np
13:45:12 <fdegir> thx a lot for the effor David_Orange and especially with PDF work
13:45:31 <jmorgan1> thanks David_Orange
13:45:39 <fdegir> #topic AoB
13:45:50 <fdegir> epalper: coming back to os-nosdn-ovs scenarios
13:46:01 <fdegir> epalper: can you summarize it please?
13:46:16 <David_Orange> your welcome, now AlexAvadanii is doing a big part of the job
13:46:20 <epalper> There is request to install OVS without odl
13:46:48 <epalper> like os with linux bridges
13:46:51 <fdegir> epalper: I suppose this means switching to ovs as default instead of linux bridges
13:47:03 <epalper> yes fdegir
13:47:45 <fdegir> #info epalper is working introducing ovs into osa
13:48:24 <fdegir> epalper: a question
13:48:24 <epalper> but still need to figure out how tunnels between OVS can be configured without ODL
13:48:32 <fdegir> to mardim as well perhaps
13:48:44 <fdegir> epalper: mardim: ovs nsh stuff will be part of upstream ovs
13:49:06 <fdegir> epalper: mardim: so epalper doing this will also help that as well
13:49:10 <epalper> right now "no"
13:49:18 <fdegir> ok
13:49:30 <mardim> fdegir, I think yes it wil be part in 2.
13:49:34 <mardim> 2.8*
13:49:54 <fdegir> so it will enable taking that in at least - some way/form
13:50:14 <s3wong> Various different forms of NSH patches had been under OVS review for the past 2+ years...
13:50:53 <fdegir> I think that was one of the difficulties for OPNFV for quite a while
13:51:01 <hwoarang> nsh is in 2.8.0 already
13:51:25 <hwoarang> but the kernel part is missing unless you use the out-of-tree ovs module which i am not sure which distros provide it right now
13:51:32 <fdegir> which version of ovs you will be integrating epalper ?
13:52:06 <epalper> shouldn't it be ovs 2.6 ? this is the version being used across deployments
13:52:20 <mardim> hwoarang, I din't know that so ok
13:53:02 <fdegir> I can't say much about ovs so my question was for capturing the info
13:53:19 <fdegir> #info ovs 2.6 will be integrated at first phase
13:53:39 <fdegir> thx epalper
13:53:50 <fdegir> jmorgan1: I see you added a note to etherpad
13:53:59 <jmorgan1> fdegir: yup
13:54:05 <fdegir> jmorgan1: do you want to info that in yourself so we get the written confirmation?
13:54:29 <fdegir> so I can use it against you...
13:54:41 <jmorgan1> #info a second POD will be provided ready this week in the Intel Pharos lab
13:55:06 <fdegir> thanks a lot Jack!
13:55:21 <jmorgan1> #info Intel Pharos lab has a firewall issue blocking jenkins so wil be unusable until fixed
13:55:21 <fdegir> I think this will help a lot, especially with the multi-distro enablement
13:55:52 <fdegir> #info The plan for the pod20 is that it will continue to serve as development pod
13:56:29 <jmorgan1> at some point I will upgrade POD19-24 to latest hardware platform (next month or two)
13:56:41 <fdegir> #info The machines in new pod will become jenkins slaves, running all kinds of virtual deployments (bifrost-verify, bifrost-periodic, osa-verify, osa-periodic, xci-verify)
13:56:42 <jmorgan1> do POD20 wil be impacted then
13:57:13 <fdegir> #info Intel PODs 19-24 will be refreshed in coming months - we need to prepare when the time appraoches
13:57:31 <fdegir> thx again jmorgan1
13:57:38 <fdegir> did we miss anyone?
13:57:58 <fdegir> or anyone wants to bring any last minute topic?
13:58:10 <jmorgan1> yes
13:58:19 <fdegir> go ahead jmorgan1
13:58:40 <jmorgan1> we have some folks on my intel team who are interested in bringing kolla support to xCI
13:59:00 <fdegir> #info Intel team is interested in bringing kolla support to XCI
13:59:01 <jmorgan1> they are currently evaluating how to do it and understanding xCI more
13:59:19 <fdegir> #info They are currently evaluating how to do it and understanding XCI more
13:59:45 <fdegir> jmorgan1: can we have them in one of the upcoming meetings?
14:00:20 <jmorgan1> fdegir: sure, we might ask for GTM first so you answer questions i can not
14:00:37 <fdegir> jmorgan1: ok - then we schedule a separate meeting
14:00:44 <jmorgan1> fdegir: yup, thanks
14:00:58 <fdegir> #action fdegir to coordinate with jmorgan1 to have a GTM meeting b/w XCI and Intel Kolla team
14:01:04 <fdegir> thanks everyone
14:01:08 <fdegir> #endmeeting