#opnfv-pharos: Cross Community CI

Meeting started by fdegir at 13:00:12 UTC (full logs).

Meeting summary

    1. Manuel Buil (mbuil, 13:02:00)
    2. https://etherpad.opnfv.org/p/xci-meetings (fdegir, 13:03:01)
    3. Periyasamy Palanisamy (epalper, 13:03:07)
    4. Taseer (Taseer, 13:03:17)
    5. Markos Chandras (hwoarang, 13:03:28)

  1. Multi-distro support (fdegir, 13:03:37)
    1. Ubuntu and OpenSUSE work fine and work with CentOS is progressing (fdegir, 13:03:59)
    2. Dave Urschatz (durschatz, 13:04:16)

  2. CI for XCI (fdegir, 13:04:47)
    1. Tina Tsou (tinatsou, 13:05:00)
    2. xci-verify got some cool stuff thanks to hwoarang (fdegir, 13:05:04)
    3. Tapio Tallgren (ttallgren, 13:05:05)
    4. The jobs run in clean VMs to ensure we don't get strange results (fdegir, 13:05:22)
    5. David Blaisonneau (David_Orange, 13:05:22)
    6. Ubuntu and OpenSUSE jobs are voting (fdegir, 13:05:33)
    7. ttallgren is working on network configuration for Centos (fdegir, 13:06:59)
    8. Tim Irnich (timirnich, 13:10:16)
    9. A patch is waiting to be reviewed which uses pre-built OS for the clean VM instead of building new images on every run, cuttine the time by 10 minutes (fdegir, 13:13:55)
    10. https://gerrit.opnfv.org/gerrit/#/c/44049/ (fdegir, 13:14:03)

  3. Testing (fdegir, 13:14:08)
    1. prepare-functest role has been merged (fdegir, 13:14:18)
    2. A new playbook is currently being written for running tests; starting with functest (fdegir, 13:15:00)
    3. The patch fixes a missing dependency and ready for review (fdegir, 13:15:12)
    4. The 2nd patch sets everything up for functest and runs the functest container (fdegir, 13:16:14)
    5. https://gerrit.opnfv.org/gerrit/#/c/43635/ (fdegir, 13:16:20)
    6. We will run the testing using docker CLI to ensure we can make what went wrong visible and upload the test logs (fdegir, 13:17:28)

  4. Documentation (fdegir, 13:18:58)
    1. Started moving documentation to docs.opnfv.org (fdegir, 13:19:09)
    2. User guide is available: docs.opnfv.org/en/latest/submodules/releng-xci/docs/xci-user-guide.html (fdegir, 13:19:23)
    3. Work with Overview, Developer Guide, and XCI way of working is in progress (fdegir, 13:19:53)
    4. You can test your doc patches locally and the guide below explains how it can be done (fdegir, 13:21:36)
    5. http://docs.opnfv.org/en/latest/how-to-use-docs/include-documentation.html#testing-build-documentation-locally (fdegir, 13:21:38)
    6. Also, jenkins posts comments to the change pointing the generated documents such as "Patch Set 2: (fdegir, 13:22:16)

  5. Bifrost jobs status (fdegir, 13:23:28)
    1. ACTION: hwoarang to remove opnfv-bifrost-* jobs, update openstack-bifrost-* jobs to use clean-VM approach and enable them when we have the machines (fdegir, 13:27:23)

  6. Release Readiness (fdegir, 13:28:01)
    1. Release has been delayed by 2 weeks so skipping the topic (fdegir, 13:28:09)

  7. Scenario/Feature Status: os-odl-nofeature (fdegir, 13:28:56)
    1. https://git.opendaylight.org/gerrit/#/c/63938/ (epalper, 13:29:38)
    2. epalper moved changes related to the scenario from releng-xci into ansible-opendaylight repo (fdegir, 13:29:58)
    3. https://gerrit.opnfv.org/gerrit/#/c/43469/ (epalper, 13:30:14)

  8. #topic Scenario/Feature Status: os-odl-sfc (fdegir, 13:32:26)
    1. First sfc scenario patch is merged: https://gerrit.opnfv.org/gerrit/#/c/43165/ (fdegir, 13:33:36)
    2. Work with another patch is going on: https://gerrit.opnfv.org/gerrit/#/c/44031/ (fdegir, 13:34:50)

  9. Scenario/Feature Status: os-nosdn-ovs (fdegir, 13:36:20)
    1. A change has been sent for review and currently being tested locally: https://gerrit.opnfv.org/gerrit/#/c/43447/ (fdegir, 13:37:24)

  10. Scenario/Feature Status: k8s-nosdn-nofeature (fdegir, 13:38:46)
    1. s3wong is evaluating kubespray to see what needs to be done to setup a simple k8s cluster using it (fdegir, 13:39:32)
    2. He added some details to the etherpad https://etherpad.opnfv.org/p/xci-k8s (fdegir, 13:39:57)
    3. Patches will be sent once he is back from holiday and done with first steps (fdegir, 13:40:26)

  11. Scenario/Feature Status: Congress (fdegir, 13:42:58)
    1. Taseer is able to setup a congress container, and run through the pip install path (fdegir, 13:44:16)
    2. Failure while adding the service to keystone - investigation ongoing (fdegir, 13:45:45)

  12. Scenario/Feature Status: Ceph (fdegir, 13:46:46)
    1. Tianwei is working on integrating ceph: https://gerrit.opnfv.org/gerrit/#/c/42503/ (fdegir, 13:47:35)

  13. Baremetal status (fdegir, 13:47:48)
    1. David_Orange is testing it on ONAP OpenLab (fdegir, 13:48:24)
    2. Playbook runs are all green but glance can not write on nfs mount point due to local rights (770 on this pod, 777 on pod1). Debug is ongoing (fdegir, 13:48:40)
    3. The code is being cleaned up and roles will be created (fdegir, 13:49:43)
    4. A new deployment is planed on Orange Pod2 community lab (PDF/IDF writting is ongoing) (fdegir, 13:49:51)
    5. Testing it on Orange POD2 will give chance to check the issue happening in ONAP OpenLab (fdegir, 13:50:39)
    6. https://wiki.opnfv.org/display/AUTO (tinatsou, 13:52:32)
    7. Different flavors for baremetal will be available similar to the ones with virtual machines (fdegir, 13:53:50)

  14. AoB (fdegir, 13:54:54)
    1. We are waiting for new machines to become available (fdegir, 13:55:03)
    2. Workaround for Jenkins slave connection from Intel lab works fine and it will be used until the firewall is configured by Intel corp IT (fdegir, 13:55:40)
    3. Bifrost and OSA shas might be bumped soon (fdegir, 13:58:59)


Meeting ended at 13:59:12 UTC (full logs).

Action items

  1. hwoarang to remove opnfv-bifrost-* jobs, update openstack-bifrost-* jobs to use clean-VM approach and enable them when we have the machines


Action items, by person

  1. hwoarang
    1. hwoarang to remove opnfv-bifrost-* jobs, update openstack-bifrost-* jobs to use clean-VM approach and enable them when we have the machines


People present (lines said)

  1. fdegir (150)
  2. hwoarang (33)
  3. David_Orange (19)
  4. mbuil (17)
  5. epalper (12)
  6. durschatz (10)
  7. ttallgren (9)
  8. Taseer (4)
  9. collabot (4)
  10. tinatsou (2)
  11. OPNFV-Gerrit-Bot (2)
  12. timirnich (1)


Generated by MeetBot 0.1.4.