13:30:52 <fdegir> #startmeeting Cross Community CI
13:30:52 <collabot> Meeting started Wed Nov  1 13:30:52 2017 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:30:52 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:30:52 <collabot> The meeting name has been set to 'cross_community_ci'
13:30:56 <fdegir> #topic Rollcall
13:31:04 <fdegir> please type in your name if you are joining the meeting
13:31:36 <hw_wutianwei> #info Tianwei Wu
13:31:46 <s3wong> #info Stephen Wong
13:32:47 <fdegir> the agenda is on etherpad
13:32:49 <fdegir> #link https://etherpad.opnfv.org/p/xci-meetings
13:33:03 <fdegir> and as usual, we start with scenario status
13:33:19 <fdegir> #topic Scenario/Feature Status: k8-nosdn-nofeature
13:33:27 <fdegir> s3wong: did you get any reviews?
13:33:45 <liangqi> #info qiliang
13:34:09 <s3wong> fdegir: no --- FYI, the patch is here:  https://gerrit.opnfv.org/gerrit/46153
13:34:17 <fdegir> #info s3wong sent the first patch for k8s integration
13:34:20 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/46153/
13:34:28 <electrocucaracha> #info Victor Morales
13:34:38 <fdegir> s3wong: I suppose it is fine for people to review it even though it says WIP
13:34:46 <s3wong> It is WIP, probably why no one is looking. And it is under development, so expect changes
13:35:18 <s3wong> fdegir: agreed. At least please give feedback if the general direction of the implementation matches what folks expect
13:35:33 <fdegir> s3wong: will do
13:35:44 <hw_wutianwei> s3wong: we will do
13:36:08 <fdegir> s3wong: one thing I want to highlight is that we intend to place scenario stuff into https://gerrit.opnfv.org/gerrit/gitweb?p=releng-xci.git;a=tree;f=xci/scenarios
13:36:14 <fdegir> s3wong: for generic scenarios
13:36:26 <s3wong> I do want to say that at this point, kubespray isn't too consistently stable... at the very least, I kept on bumping into timing out (for the first time) during the wait time for control plane to come up (during kubeadm init part of the playbook)
13:36:45 <fdegir> s3wong: you can also take a look at sfc scenario in sfc repo to see how mbuild did that and adjust it for k8s
13:37:08 <s3wong> fdegir: sure --- I noticed. Will move my stuff over
13:37:23 <fdegir> s3wong: that's one of the purposes of this activity; evaluate kubespray and if you find out it is not stable enough, we can look at other options
13:37:46 <s3wong> fdegir: absolutely
13:38:09 <fdegir> s3wong: a related question
13:38:23 <fdegir> s3wong: clover project got approved yesterday so how do you see its relation to xci?
13:38:43 <fdegir> there were few references to xci so it would be good to get an indication regarding intentions
13:38:51 <fdegir> and congrats for the project btw
13:39:27 <s3wong> fdegir: we do intend to use xci-k8s for our installation --- we have no intention to implement k8s installation automation in Clover
13:39:36 <s3wong> fdegir: thanks
13:39:49 <fdegir> s3wong: so you have to fix the scenario :)
13:39:54 <fdegir> good to hear
13:40:00 <s3wong> fdegir: yes, I do :-)
13:40:07 <fdegir> anything else you want to add?
13:40:16 <s3wong> fdegir: that's it for me
13:40:21 <fdegir> thx s3wong
13:40:28 <fdegir> moving to ceph
13:40:34 <fdegir> #topic ceph in xci
13:40:45 <fdegir> hw_wutianwei: so the change is waiting few more reviews
13:40:55 <hw_wutianwei> fdegir: yep
13:41:04 <fdegir> #info xci ceph integration has been completed and the change is waiting for more review
13:41:15 <hw_wutianwei> Integrating ceph has finished.
13:41:25 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/42503/
13:41:36 <hw_wutianwei> other people can give more suggestions
13:41:50 <fdegir> #info the change will be submitted by the end of week so it is your chance to look at it and provide comments
13:42:24 <fdegir> great work hw_wutianwei !
13:42:38 <fdegir> especially the perseverance
13:42:56 <fdegir> and thx for getting it done
13:43:04 <hw_wutianwei> fdegir: after finishing ceph, I can spend some time to other scenarios
13:43:15 <fdegir> that would be good
13:43:24 <fdegir> perhaps helping out with ovs
13:43:25 <hw_wutianwei> fdegir: such as ovs or k8s
13:43:28 <fdegir> and followed by dpdk
13:43:35 <hw_wutianwei> fdegir: yep
13:43:38 <fdegir> moving to ovs then
13:43:45 <fdegir> #topic ovs in xci
13:43:55 <fdegir> #info epalper has a patch for review for ovs integration
13:44:25 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/43447/
13:45:02 <fdegir> #info This type of features require us to adjust the xci itself which is what hwoarang also mentioned
13:45:33 <fdegir> no matter what, hw_wutianwei you can perhaps take a look at the patch to see how it looks
13:45:46 <hw_wutianwei> fdegir: yep
13:45:46 <electrocucaracha> fdegir: what kind of adjustments?
13:46:08 <hw_wutianwei> fdegir: I will try to do
13:46:18 <fdegir> electrocucaracha: the thing is, we want to keep whatever deployed using in releng-xci/xci by default as same as the upstream osa
13:46:27 <fdegir> electrocucaracha: which doesn't have ovs and/or ceph
13:46:40 <electrocucaracha> :O
13:46:54 <fdegir> electrocucaracha: and instead push the default stuff set/used by opnfv to a specific scenario
13:47:07 <fdegir> such as os-nosdn-nofeature which should have ceph and ovs
13:47:34 <fdegir> this is important for upstream patch verification since if we verify patches with ceph + ovs, upstream might say that is not valid
13:48:02 <fdegir> I hope I'm making sense
13:48:17 <electrocucaracha> yes, it is... thanks
13:48:22 <fdegir> good
13:48:26 <fdegir> moving to Taseer
13:48:29 <fdegir> #topic congress in xci
13:48:37 <Taseer> Yes
13:48:47 <fdegir> I know you have good news
13:48:58 <Taseer> I think the conrgress role is close to completion
13:49:09 <mardim> Can someone please paste the agenda ?
13:49:17 <mardim> the etherpad link ?
13:49:27 <mardim> #info Dimitrios Markou
13:49:41 <Taseer> OSA PTL told me he has put the request for inclusion of role into OSA
13:50:13 <Taseer> So it is a matter of time,
13:50:17 <fdegir> #info The congress integration is close to completion
13:50:19 <fdegir> #link https://review.openstack.org/#/c/503971/
13:50:26 <fdegir> mardim: https://etherpad.opnfv.org/p/xci-meetings
13:50:33 <mardim> fdegir, thanks :)
13:50:37 <Taseer> when the OpenStack TC approve
13:51:14 <fdegir> Taseer: thank you for this
13:51:26 <Taseer> fdegir: It it my pleasure !
13:51:32 <fdegir> congress is another feature we might need to push to os-nosdn-nofeature scenario
13:51:40 <fdegir> this obviously depends on upstream as well
13:52:04 <fdegir> if upstream osa makes congress part of their gate, we can keep it by default as well
13:52:06 <fdegir> we'll see
13:52:39 <fdegir> #topic os-odl-sfc
13:52:48 <fdegir> mardim: do you know the status of sfc?
13:53:04 <mardim> I can speak more for the status of ovs-nsh if you want
13:53:05 <mardim> ?
13:53:08 <mardim> fdegir
13:53:18 <mardim> fdegir ^ *
13:53:28 <fdegir> I'll have it as next topic
13:53:34 <fdegir> let me add few words about sfc first
13:53:49 <mardim> ok lets skip this because manuel is the expert fot the odl-sfc topic
13:53:56 <mardim> ok sure
13:53:58 <fdegir> #info sfc scenario is committed in sfc repo but it needs 2 things before we get it finalized
13:54:23 <fdegir> #info first thing is similar to ovs itself, we need the groundwork finalized - the overall structure of things and scenario support
13:54:36 <fdegir> #info the external/child scenario support has been merged recently
13:55:15 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/q/topic:add-role-hooks+(status:open+OR+status:merged)
13:55:40 <fdegir> #info And the second issue was about mbuil needing to have a later version of osa for a certain bugfix (if I am not mistaken)
13:56:00 <fdegir> #topic ovs-nsh
13:56:04 <fdegir> mardim: go ahead
13:56:25 <mardim> ok so the blueprint that I had for the ovs-nsh suport
13:56:28 <mardim> is merged
13:56:32 <mardim> https://review.openstack.org/#/c/476121/
13:56:48 <mardim> and we are planning to upstream the ovs-nsh os neutron changes
13:56:54 <fdegir> #info Blueprint for ovs-nsh has been merged
13:56:58 <mardim> that we have currently to a private repo
13:57:05 <fdegir> #link https://review.openstack.org/#/c/476121/
13:57:19 <mardim> Al;so we are palnning to create the ovs-nsh packages fro suse and redhat
13:57:32 <mardim> Also*
13:57:37 <mardim> for*
13:57:42 <fdegir> #info ovs-nsh changes will be done in upstream
13:57:45 <mardim> That's all
13:57:53 <mardim> fdegir, thanks
13:57:56 <fdegir> #info Packages for suse and redhat will be made available
13:58:05 <fdegir> this is also very good
13:58:09 <fdegir> thanks mardim
13:58:13 <mardim> :)
13:58:17 <fdegir> mardim: an extra question
13:58:28 <fdegir> the default ovs scenario will use 2.6 (?)
13:58:35 <fdegir> and the sfc will use 2.? ?
13:59:02 <mardim> sfc will use 2.6 ovs with yiyang's NSH patches
13:59:16 <mardim> 2.6.1 actually
13:59:18 <fdegir> mardim: I thought those patches were accpeted upstream
13:59:49 <mardim> fdegir, I am not sure but I think they support nsh upstream for userspace only
14:00:13 <mardim> fdegir, We need also kernelspace NSH support
14:00:21 <fdegir> mardim: ok
14:00:25 <fdegir> thanks for the clarification
14:00:34 <mardim> fdegir, I think I remember correct on this
14:00:38 <mardim> no problem :)
14:00:54 <fdegir> so, the next topuc is
14:00:57 <fdegir> #topic Baremetal status
14:01:17 <fdegir> #info David already got it working on Orange POD and it will be done on Nokia POD for long duration testing
14:01:25 <fdegir> #undo
14:01:25 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2dec210>
14:01:44 <fdegir> #info David Blaisonneau already got it working on Orange POD and it will be done on Nokia POD for long duration testing
14:02:13 <fdegir> #info But his approach is a bit different from how we are thinking of doing things (to be more precise, how I was envisioning)
14:02:52 <fdegir> #info This is also related to how to structure things
14:02:54 <fdegir> #link https://etherpad.opnfv.org/p/xci-structure
14:03:15 <fdegir> #info The discussion is going on and we will continue once David is back from his vacation
14:03:22 <durschatz> #info Dave Urschatz
14:03:42 <ttallgren> #info Tapio Tallgren
14:03:51 <fdegir> welcome ttallgren durschatz
14:04:10 <fdegir> it seems we had some mixup due to winter time change so sorry for that
14:04:22 <durschatz> np
14:04:33 <fdegir> ttallgren: your turn :)
14:04:38 <fdegir> #topic Centos support
14:04:59 <fdegir> ttallgren: any luck with it?
14:05:05 <ttallgren> Yes, wait¨
14:05:53 <ttallgren> It crashes on one of the openstack-ansible modules
14:06:27 <fdegir> #info The installation fails during one of the osa modules
14:07:25 <ttallgren> role is repobuild-prepare or something like that that
14:07:55 <ttallgren> It is one of the modules that the script pulls in from github.com so it is not so easy for me to fix
14:08:06 <fdegir> ttallgren: can you perhaps post the log to hastebin/pastebin if you see it again so we can ask hwoarang to chase upstream
14:08:34 <fdegir> #info The failing role is repobuild-prepare (or something like that)
14:08:45 <ttallgren> Yes, I can do that but not right now (I am not connected to the lab machine at the moment)
14:10:06 <fdegir> whenever you have time
14:10:36 <fdegir> ttallgren: also, it would be good to record the osa sha and perhaps the sha of the role so we know what version you are having trouble with
14:10:58 <ttallgren> I copied the shas from releng-xci
14:11:09 <fdegir> I just had a look at osa centos gate jobs and the ones I looked either failed or timed out so upstream centos doesn't look healthy either
14:11:24 <ttallgren> Good :-)
14:11:31 <fdegir> we need to check with hwoarang and others to get the latest status info
14:11:46 <fdegir> #action fdegir to check status of centos support upstream with hwoarang
14:11:56 <fdegir> ttallgren: I assume bifrost works just fine?
14:12:23 <ttallgren> Yes
14:12:42 <fdegir> #info Bifrost on Centos looks good
14:12:54 <fdegir> thx ttallgren
14:13:11 <fdegir> moving to the next topic
14:13:16 <fdegir> #topic Improving stability
14:13:32 <fdegir> #info We have got some reports from users about the issues they are experiencing
14:13:59 <fdegir> #info The issues are mainly related to not using a clean installation
14:14:24 <fdegir> #info We need to ensure that we isolate ourselves as much as possible from the machine so we don't require users to reinstall their machines
14:15:14 <fdegir> #info This will be achieved by pushing everything into opnfv vm; bifrost installation, node provisioning/deployment, scenario installation and so on so the only requirement we will have on the host machine will be default ansible and libvirt stuff
14:15:50 <fdegir> #info This is also related to Dynamic CI and LaaS so what will be done has more uses
14:16:06 <fdegir> anyone has any questions/comments about this?
14:16:32 <fdegir> durschatz: maybe you since you are one of the imprtant and valued users of the XCI
14:17:05 <durschatz> yes. I totally agree.  I ended having to redeploy OS on BM many times
14:17:18 <durschatz> and that did fix issues
14:17:19 <fdegir> :)
14:17:21 <electrocucaracha> +1
14:17:21 <fdegir> sorry for that
14:17:27 <durschatz> :-)
14:17:30 <fdegir> just want to say this has highest prio for us atm
14:17:40 <durschatz> wonderful!
14:17:41 <fdegir> and first thing is getting PDF for vPODs created
14:18:02 <fdegir> #info PDF for vPOD is under review
14:18:15 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/46493/
14:18:40 <fdegir> #info Once that change gets merged, PDFs for other flavors will be created
14:18:58 <fdegir> AlexAvadanii: ^
14:19:05 <fdegir> the last topic is about
14:19:12 <fdegir> #topic Bumping OSA SHA
14:20:19 <fdegir> #info hwoarang is working on moving us to a newer SHA which will have pre-queens
14:20:47 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/46431/
14:21:02 <fdegir> #topic AoB
14:21:13 <fdegir> anyone wants to bring up anything?
14:21:21 <ttallgren> ANyone going to Sydney?
14:21:39 <fdegir> ttallgren: I am
14:21:43 <hw_wutianwei> I won't
14:21:44 <fdegir> have an xci talk :)
14:21:49 <fdegir> OpenStack loves xci
14:22:06 <ttallgren> Great, see you there!
14:22:07 <durschatz> not me
14:22:17 <electrocucaracha> fdegir: well I'm still struggling with the proxy stuff for aio, specially lxc_hosts role
14:22:25 <fdegir> ttallgren: +1
14:22:36 <fdegir> electrocucaracha: was your change merged?
14:23:09 <electrocucaracha> fdegir: the change for adding proxy vars into the xci tasks?
14:23:32 <electrocucaracha> fdegir: that needs more love hehehe
14:23:38 <fdegir> electrocucaracha: https://gerrit.opnfv.org/gerrit/#/c/45383/
14:23:45 <fdegir> :)
14:24:22 <fdegir> electrocucaracha: so you are trying this out locally and hitting issues with lxc_hosts role
14:24:34 <electrocucaracha> yeah, I figure out how to use the same approach without modifying the start_vm script
14:24:38 <fdegir> electrocucaracha: have you tried asking this in #openstack-ansible channel?
14:25:01 <electrocucaracha> fdegir: yes, specially when that tries to get pip
14:25:15 <fdegir> electrocucaracha: and you use start_vm for running stuff yourself?
14:25:50 <fdegir> electrocucaracha: that might make it a bit more complicated then as that script is for ci as hwoarang mentioned on the change
14:25:56 <electrocucaracha> fdegir: yes, because I want to keep my environment clean
14:26:22 <fdegir> electrocucaracha: I think what I mentioned above about more isolation will help you to develop/test things without needing to have that start_vm vm
14:26:33 <electrocucaracha> fdegir: so I figure out adding those things to externally
14:26:34 <electrocucaracha> https://gist.github.com/electrocucaracha/3b83004b0233b99c480546d895939839
14:26:51 <fdegir> electrocucaracha: and that was actually about when I found out how kolla-ansible uses bifrost
14:27:13 <fdegir> but that needs to be looked into later since it is much bigger change than we can afford right now
14:28:22 <fdegir> ok
14:28:37 <fdegir> anything more from anyone else?
14:28:44 <electrocucaracha> fdegir: agree, I'm not sure how that can be implemented in the current schemas
14:29:05 <fdegir> +1
14:29:09 <fdegir> we will fix it
14:29:19 <durschatz> ONAP status on vPODS?
14:29:33 <fdegir> durschatz: thanks for reminding
14:30:04 <fdegir> durschatz: I think it is also about Auto project, isn't it?
14:30:15 <durschatz> yes
14:30:36 <durschatz> ish
14:30:40 <fdegir> so, we will support Auto as soon as we fix the issues I mentioned above
14:30:46 <fdegir> and we need k8s as well
14:30:47 <durschatz> OK
14:30:59 <fdegir> David will work on it
14:31:11 <durschatz> are we on track for Plugfest?
14:31:19 <fdegir> my expectation is to have both vPOD and BM ready by plugfest
14:31:24 <fdegir> at least for OpenStack
14:31:40 <durschatz> OK
14:31:40 <fdegir> for k8s, we need s3wong's opinion
14:32:01 <fdegir> and I know David's colleague is looking into Rancher so we will probably have something by that time
14:32:34 <durschatz> Thanks.  That's it for me
14:32:44 <fdegir> our ambition is to put xci (OpenStack/k8s masters) on baremetal during plugfest
14:32:49 <fdegir> we will see
14:33:51 <fdegir> #info Next week's the meeting will be at 15:00CET and the invitation will be switched to UTC once all this time changes are over
14:33:58 <fdegir> thank you all and talk to you next week!
14:34:05 <fdegir> #endmeeting