#opnfv-pharos: Cross Community CI

Meeting started by fdegir at 14:00:43 UTC (full logs).

Meeting summary

  1. Rollcall (fdegir, 14:00:48)
    1. Victor Morales (electrocucaracha, 14:01:15)
    2. tianwei Wu (hw_wutianwei, 14:01:17)
    3. David Blaisonneau (David_Orange, 14:01:19)
    4. Manuel Buil (mbuil, 14:01:19)
    5. Trinath Somanchi - NXP (trinaths, 14:01:29)
    6. Joe Kidder (joekidder, 14:01:35)
    7. https://etherpad.opnfv.org/p/xci-meetings (fdegir, 14:01:45)

  2. Scenario Status: os-odl-sfc (fdegir, 14:02:12)
    1. TapioT (ttallgren, 14:03:58)
    2. Periyasamy Palanisamy (epalper, 14:04:29)
    3. We are doing two things. 1st thing is upstreaming features to os_neutron (mbuil, 14:04:37)
    4. https://review.openstack.org/#/c/517259/ (mbuil, 14:04:48)
    5. https://review.openstack.org/#/c/510909/ (mbuil, 14:05:01)
    6. 2nd thing, we are trying to make it work with master. Unfortunately, we are finding several issues when trying xci with simple ODL to do L2 and L3 (mbuil, 14:05:46)
    7. It deployes but things don't work. That is a consequence of not using tempest anymore :( (mbuil, 14:06:27)
    8. Dimitrios Markou (mardim, 14:06:42)
    9. Dave Urschatz (durschatz, 14:07:38)
    10. one issue came from xci, three issues came from os_neutron and another issue I suspect is coming from glance openstack (not able to create a image ==> https://hastebin.com/ewufafehaq.vbs) (fdegir, 14:08:23)
    11. Markos Chandras (hwoarang, 14:09:13)
    12. ACTION: fdegir to try tempest and enable it (fdegir, 14:10:11)
    13. https://hastebin.com/omonutovat.sm (mardim, 14:11:24)

  3. Scenario Status: os-nosdn-ovs (fdegir, 14:12:18)
    1. https://review.openstack.org/#/c/518964/ (mardim, 14:13:11)
    2. https://gerrit.opnfv.org/gerrit/#/c/43447/ (fdegir, 14:13:57)
    3. review for this scenario is at https://gerrit.opnfv.org/gerrit/#/c/43447/ (epalper, 14:14:08)
    4. i have tested this scenario locally and it works (epalper, 14:14:57)
    5. there is a dependent review https://gerrit.opnfv.org/gerrit/#/c/46859/ for above info (durschatz, 14:15:47)
    6. Once ovs integration is done, it will be combined together with ceph under the scenario os-nosdn-nofeature (fdegir, 14:20:32)
    7. Tina Tsou (tinatsou, 14:20:54)

  4. Scenario Status: os-odl-nofeature (fdegir, 14:21:05)
    1. I'm testing https://gerrit.opnfv.org/gerrit/#/c/39239/ again to look for any changes required at openstack-user-config.yml file (epalper, 14:22:13)
    2. when deploying xci + ODL in master, there is a problem because the ODL service in haproxy is conflicting with the repo service. A patch was proposed to fix it: https://review.openstack.org/#/c/519661/ (fdegir, 14:24:09)

  5. Scenario Status: kubernetes in XCI (fdegir, 14:24:54)
    1. https://gerrit.opnfv.org/gerrit/#/c/46153/ (hw_wutianwei, 14:26:01)
    2. k8s works with aio now, the patch is under review (fdegir, 14:26:11)
    3. CI for XCI needs to be adapted, enabling scenario based patchset verification (fdegir, 14:28:17)
    4. ha and noha will be added for k8s later on (fdegir, 14:29:37)

  6. Feature Status: Congress (fdegir, 14:37:32)
    1. Congress role has been merged upstream (fdegir, 14:38:02)
    2. github.com/openstack/openstack-ansible-os_congress (Taseer, 14:38:16)
    3. https://review.openstack.org/#/c/503971/ (Taseer, 14:39:17)

  7. Improving Stability (fdegir, 14:41:33)
    1. https://gerrit.opnfv.org/gerrit/#/c/46493/5/xci/file/ha/vpod-pdf.yaml (David_Orange, 14:45:50)
    2. What we mean with "improving stability" in this context is that, we want to isolate ourselves from the host as much as possible, ensuring when someone (users/developers/CI) attempts to use XCI, things work smoothly due to less number of things that might conflict with each other (fdegir, 14:48:05)
    3. Another aspect of this work is to increase the reuse by splitting node specific bifrost stuff from the actual stack/scenario installation so whatever you may want to install will work with the bifrost pieces we have (fdegir, 14:48:56)
    4. Incorporating PDF/IDF is important for ensuring we can run on any (type of) POD which has its PDF available (fdegir, 14:49:55)

  8. Zuulv3 Prototype (fdegir, 14:53:19)
    1. We had a discussion with OpenStack Infra last week to start a prototype in OPNFV to try things that are not tried by OpenStack Infra (fdegir, 14:53:57)
    2. The prototype will be limited in scope initially and the details can be seen on the link below (fdegir, 14:54:13)
    3. https://etherpad.opnfv.org/p/opnfv-zuul-prototype (fdegir, 14:54:21)
    4. Everyone is welcomed to share their thoughts on the scope of the prototype and help us to get it work (fdegir, 14:54:41)

  9. Hardware Availability (fdegir, 14:55:09)
    1. I have been told that we will not get second POD for XCI so we have an issue with hardware availability now (fdegir, 14:55:34)
    2. The only POD we have will be configured and mainly dedicated for CI (fdegir, 14:55:52)

  10. Working with other communities (fdegir, 14:57:22)
    1. We are in contact with DPDK and CNCF regarding XCI and more info will be shared once we have it (fdegir, 14:58:22)
    2. We are also talking to OpenStack OpenLab people regarding possible collaboration (fdegir, 14:58:40)
    3. More info to follow when we have it (fdegir, 14:58:50)

  11. AoB (fdegir, 14:58:59)


Meeting ended at 15:00:33 UTC (full logs).

Action items

  1. fdegir to try tempest and enable it


Action items, by person

  1. fdegir
    1. fdegir to try tempest and enable it


People present (lines said)

  1. fdegir (127)
  2. mbuil (21)
  3. David_Orange (19)
  4. hw_wutianwei (17)
  5. mardim (14)
  6. Taseer (11)
  7. electrocucaracha (7)
  8. epalper (6)
  9. hwoarang (6)
  10. durschatz (4)
  11. collabot (3)
  12. ttallgren (2)
  13. joekidder (1)
  14. trinaths (1)
  15. tinatsou (1)


Generated by MeetBot 0.1.4.