#opnfv-pharos: Cross Community CI

Meeting started by fdegir at 14:00:06 UTC (full logs).

Meeting summary

  1. Rollcall (fdegir, 14:00:10)
    1. David Blaisonneau (David_Orange, 14:00:17)
    2. Markos Chandras (hwoarang, 14:00:27)
    3. Tapio Tallgren (ttallgren, 14:00:35)
    4. tianwei (hw_wutianwei, 14:00:40)
    5. Agenda is available on https://etherpad.opnfv.org/p/xci-meetings and pretty same (fdegir, 14:00:50)
    6. Manuel Buil (mbuil, 14:00:56)
    7. Dimitrios Markou (mardim, 14:01:06)
    8. Joe KIdder (joekidder, 14:01:13)

  2. Scenarios/Feature Status: os-odl-sfc (fdegir, 14:01:31)
    1. Dave Urschatz (durschatz, 14:01:31)
    2. Victor Morales (electrocucaracha, 14:02:19)
    3. https://review.openstack.org/#/c/517259/ (mardim, 14:02:58)
    4. mardim has ovs-nsh patch (fdegir, 14:03:03)
    5. https://review.openstack.org/#/c/517259/ (fdegir, 14:03:10)
    6. The patch is in good state and few more minor updates are necessary (fdegir, 14:03:41)
    7. Some fixes have been done to neutron role (fdegir, 14:04:16)
    8. https://review.openstack.org/#/c/518964/ (mardim, 14:04:21)
    9. https://review.openstack.org/#/c/520367/ (mardim, 14:04:27)
    10. https://review.openstack.org/#/c/518964/ (fdegir, 14:04:37)
    11. https://review.openstack.org/#/c/496231/ (mardim, 14:04:46)
    12. https://review.openstack.org/#/c/520367/ (fdegir, 14:04:50)
    13. https://review.openstack.org/#/c/496231/ (fdegir, 14:04:57)

  3. Scenarios/Feature Status: os-nosdn-ovs (fdegir, 14:06:29)
  4. Scenarios/Feature Status: os-odl-nofeature (fdegir, 14:07:14)
    1. mbuil has been testing the deployment of xci + ODL in master and found several bugs. Deployment was ok but then it was not possible to create VMs, etc. (fdegir, 14:09:16)
    2. https://gerrit.opnfv.org/gerrit/#/c/47417/ (fdegir, 14:09:56)
    3. The patch linked above fixes one of the issues (fdegir, 14:10:22)
    4. It has also been found out that when deploying with ODL+OVS, the default network_mapping which is done in OSA is not correct (fdegir, 14:10:57)
    5. The conclusion was to add the provider_networks in the user_variables (fdegir, 14:11:26)
    6. the variable host_bind_override: eth12 in the vlan provider network should be added as well (fdegir, 14:11:51)
    7. otherwise it does a vlan:br-vlan mapping in the compute which breaks the connection of the compute to internet (fdegir, 14:12:14)
    8. ACTION: fdegir to find out how to incorporate scenario information to existing XCI documentation (fdegir, 14:13:13)
    9. A patch to fix minore issue on openSUSE is under review (fdegir, 14:13:44)
    10. https://gerrit.opnfv.org/gerrit/#/c/47643/ (fdegir, 14:13:51)
    11. As of this morning, ODL is deployable on XCI and L2 and L3 were working correctly without any manual modification (fdegir, 14:14:08)
    12. VMs can be pinged from each other, floating IPs can be attached and the VMs can be ssh'ed to the floating IPs from the opnfv VM (fdegir, 14:14:41)
    13. os-odl-nofeature either works on ubuntu and openSUSE or pretty close to be working (fdegir, 14:17:32)

  5. Scenario/Feature Status: K8S in XCI (fdegir, 14:18:11)
    1. k8-nosdn work is done for aio, mini, and noha flavors - ha is still under development (fdegir, 14:19:45)
    2. https://gerrit.opnfv.org/gerrit/#/c/46153/ (fdegir, 14:20:10)
    3. We had a meeting with CNCF Cross Cloud CI Team last week and learnt that they have a script to deploy k8s from master (fdegir, 14:25:24)
    4. As far as we know, the tools (kubespray/rancher) we evaluate doesn't support the deployment from master (fdegir, 14:25:47)
    5. We might need to look at what CNCF Cross Cloud CI Team has but it can wait until we fix the stability and get k8s working in XCI with what we have (fdegir, 14:26:16)

  6. Scenario/Feature Status: Congress in XCI (fdegir, 14:26:52)
    1. No change for congress yet (fdegir, 14:27:15)
    2. Upcoming Features: Promise/Blazar and HA/Masakari (fdegir, 14:27:53)
    3. We have been having some discussions with Promise and HA Teams to provide support for them within XCI (fdegir, 14:28:14)
    4. Taseer kindly offered help for Promise and we are waiting for project to decide (fdegir, 14:28:28)
    5. https://etherpad.opnfv.org/p/xci-blazar (fdegir, 14:28:58)
    6. We will have a meeting with HA Team during Plugfest to discuss the details (fdegir, 14:29:08)
    7. https://etherpad.opnfv.org/p/xci-ha (fdegir, 14:29:16)

  7. Improving Stability (fdegir, 14:29:51)
    1. I am working on stability improvement by pushing bifrost in a VM. This will be done with 2 new roles (David_Orange, 14:30:08)
    2. The first is to create local VMs based on PDF/IDF (David_Orange, 14:30:19)
    3. those definitions files have changed to use ipmi driver for bifrost and vbmc. i will update them with the code (David_Orange, 14:30:57)
    4.  This role is likely to be finished and already tested on virtual pod PDF/IDF and baremetal pod PDF/identifier. No more need of aio, mini, nonha, ha config files. (David_Orange, 14:31:04)
    5. The second role will be for bifrost. I am now testing bifrost install from Kolla to avoid deploying a VM with a cloud image and a config drive in the previous step. The goal is to deploy all VM, including opnfv_host from Bifrost. (David_Orange, 14:31:49)
    6. ACTION: David_Orange to finish the work for stability by plugfest (fdegir, 14:36:27)
    7. the biggest part will be the cleanup of unused var/script at the end. but we can find a slot for that cleaning during the plugfest (David_Orange, 14:37:56)

  8. Zuul Prototype (fdegir, 14:41:12)
    1. We got the machine up for the prototype and working on setting it up (fdegir, 14:41:28)
    2. The scope we have for the prototype seems to be pretty good (fdegir, 14:41:42)
    3. More info will be shared once we have some progress (fdegir, 14:42:01)

  9. Working with Other Communities (fdegir, 14:42:17)
    1. As I mentioned earlier, we met with CNCF Cross Cloud CI Team to find out how we can collaborate (fdegir, 14:42:33)
    2. The information will be documented on the link below and updates will be shared (fdegir, 14:42:49)
    3. Some of you might be pulled into that work when we get some traction (fdegir, 14:43:04)
    4. https://etherpad.opnfv.org/p/cross-cloud-and-xci (fdegir, 14:43:16)
    5. We also had a meeting with OpenStack OpenLab Team last week and it looks pretty good (fdegir, 14:43:36)
    6. I expect increased collaboration between OPNFV and OpenStack in Cross Community efforts (fdegir, 14:43:53)
    7. More info is available on the link below (fdegir, 14:44:07)
    8. https://etherpad.openstack.org/p/xciandopenlab (fdegir, 14:44:38)
    9. Similar to the CNCF collaboration, more people might need to be pulled into OpenLab work (fdegir, 14:45:38)
    10. We also met with Linaro/DPDK yesterday to see how we can contribute to efforts to improve CI for DPDK (fdegir, 14:46:16)

  10. Roadmap/Backlog (fdegir, 14:47:01)
    1. We need to take a breath and work on our roadmap because people are asking (fdegir, 14:47:18)
    2. And we also need to see what we all are working on and what else is in the pipeline (fdegir, 14:47:33)
    3. A highlevel roadmap will be created together with a backlog and will be shared during one of the meetings to collect feedback from the team (fdegir, 14:48:00)
    4. And then this information will be shared with OPNFV Community at large and other communities we work with (fdegir, 14:48:21)

  11. New Teammates (fdegir, 14:49:06)
    1. joekidder and sylvain_orange joined us so I welcome them (fdegir, 14:49:23)

  12. AOB (fdegir, 14:50:21)
    1. Intel lab will be in maintenance due to power stuff and will be down until next week (fdegir, 14:56:04)
    2. XCI on CentOS is WIP (fdegir, 14:57:58)


Meeting ended at 14:58:26 UTC (full logs).

Action items

  1. fdegir to find out how to incorporate scenario information to existing XCI documentation
  2. David_Orange to finish the work for stability by plugfest


Action items, by person

  1. David_Orange
    1. David_Orange to finish the work for stability by plugfest
  2. fdegir
    1. fdegir to find out how to incorporate scenario information to existing XCI documentation


People present (lines said)

  1. fdegir (158)
  2. David_Orange (32)
  3. mardim (23)
  4. mbuil (23)
  5. hwoarang (21)
  6. hw_wutianwei (11)
  7. durschatz (10)
  8. joekidder (6)
  9. ttallgren (6)
  10. electrocucaracha (5)
  11. Taseer (4)
  12. collabot (4)
  13. sylvain_orange (2)


Generated by MeetBot 0.1.4.