14:00:54 <fdegir> #startmeeting Cross Community CI
14:00:54 <collabot> Meeting started Wed Dec 20 14:00:54 2017 UTC.  The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:54 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:54 <collabot> The meeting name has been set to 'cross_community_ci'
14:01:01 <fdegir> #topic Rollcall
14:01:08 <ttallgren> #info Tapio Tallgren
14:01:13 <fdegir> please log your name in if you are here for xci meeting
14:01:19 <hw_wutianwei> #info Tianwei Wu
14:01:21 <mardim> #info Dimitrios Markou
14:01:23 <hwoarang> #iinfo Markos Chandras
14:01:23 <electrocucaracha> #info Victor Morales
14:01:24 <jmorgan1> #info Jack Morgan
14:01:38 <fandrieu> #info Fabien Andrieux
14:01:44 <epalper> #info Periyasamy Palanisamy
14:01:53 <joekidder> #info Joe Kidder
14:01:58 <david_Orange> #info David Blaisonneau - Orange
14:02:00 <fdegir> the agenda is on https://etherpad.opnfv.org/p/xci-meetings
14:02:03 <mbuil> #info Manuel Buil
14:02:19 <fdegir> lets start
14:02:34 <fdegir> #topic Scenario/Feature Status: os-nosdn-nofeature
14:02:36 <fdegir> that's me
14:02:49 <fdegir> #info ovs pieces have been moved into os-nosdn-nofeature
14:03:03 <fdegir> #info Functest healthcheck 100% passrate
14:03:10 <fdegir> #link https://paste.ubuntu.com/26220997/
14:03:30 <fdegir> #info Smoke tier is running now and will send all the logs to you and functest experts to see how serious the failures are
14:03:44 <fdegir> #info But it looks good given that we are pretty close to the tip of master
14:03:54 <fdegir> #info ceph will be moved into this as well
14:04:17 <fdegir> so, moving to our flagship scenario
14:04:18 <ttallgren> I have question about the scenarios. Probably missed something but
14:04:26 <fdegir> ttallgren: yes
14:04:47 <ttallgren> You are cloning from git.opnfv.org to $XCI_ROOT/.cache
14:05:17 <ttallgren> and then copying to $XCI_ROOT/scenarios/
14:06:03 <ttallgren> Am I missing something or are you cloning a repository to a branch of the same repository and then copying to a different location?
14:06:15 <hwoarang> yes that's correct
14:06:16 <hwoarang> inception :)
14:06:31 <fdegir> ttallgren: we want to have same way of handling for all the scenarios no matter where they reside
14:06:33 <hwoarang> we do that because we want to handle inbound scenarions the same way we handle the external ones
14:06:37 <fdegir> :)
14:06:56 <fdegir> here are the pieces that deal with scenario handling
14:06:58 <fdegir> https://gerrit.opnfv.org/gerrit/gitweb?p=releng-xci.git;a=blob;f=xci/opnfv-scenario-requirements.yml
14:07:10 <fdegir> https://gerrit.opnfv.org/gerrit/gitweb?p=releng-xci.git;a=blob;f=xci/playbooks/bootstrap-scenarios.yml
14:07:17 <fdegir> https://gerrit.opnfv.org/gerrit/gitweb?p=releng-xci.git;a=blob;f=xci/playbooks/get-opnfv-scenario-requirements.yml
14:07:51 <fdegir> ttallgren: do these answer your question?
14:07:56 <ttallgren> Yes. Inception
14:08:00 <fdegir> good
14:08:17 <fdegir> moving on
14:08:18 <fdegir> #topic Scenario/Feature Status: os-odl-sfc
14:08:24 <fdegir> mbuil: mardim: please #info in
14:08:58 <mardim> fdegir, we already #info in
14:09:00 <mbuil> fdegir:ok
14:09:07 <fdegir> I mean any updates you might have
14:09:14 <mardim> haha ok
14:09:19 <mardim> I do not have any
14:09:24 <mardim> maybe mbuil
14:09:37 <mbuil> #info There is one missing patch in os_neutron which should be now ready
14:09:42 <mbuil> #link https://review.openstack.org/#/c/510909/
14:10:22 <mbuil> Not much more... scenarios are still passing for pike and master
14:10:27 <fdegir> good
14:10:36 <fdegir> here is an update from me as in the etherpad
14:10:46 <fdegir> #info Post-merge job for SFC is up for review
14:10:54 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/49291/
14:11:42 <fdegir> #info This job is crucial for promotion; whever something changes/gets submitted for os-odl-sfc scenario in sfc repo, it will be promoted to daily baremetal
14:12:22 <fdegir> #info If it fails, the latest known/verified one will stay as working version/will not be replaced by the latest merged one
14:12:43 <fdegir> #info More info/documentation will be created once the basics are in place
14:13:02 <fdegir> moving to a new scenario
14:13:12 <fdegir> #topic Scenario/Feature Status: os-odl-bgpvpn
14:13:16 <fdegir> epalper: your turn
14:13:31 <epalper> The blueprint spec have to get merged https://review.openstack.org/#/c/523171/. It has couple of +1s
14:13:44 <fdegir> #link Blueprint is up for review
14:13:50 <fdegir> #link https://review.openstack.org/#/c/523171/
14:13:55 <epalper> Tested https://review.openstack.org/#/c/522598/ from releng-xci and it is working fine. able to attach router/vm into bgpvpn instance and get datapath working among tenant VMs
14:14:25 <epalper> Quagga integration is pending with this review https://review.openstack.org/#/c/523907/ for external DC-GW connecitivty. not yet tested
14:14:57 <fdegir> #info The patch for ml2 config for networking bgpvpn is also up for review. Works fine in XCI. Able to attach router/vm into bgpvpn instance and get datapath working among tenant VMs
14:15:04 <fdegir> #link https://review.openstack.org/#/c/522598/
14:15:29 <fdegir> #info Quagga integration is pending for external DC-GW connectivity. Not yet tested.
14:15:35 <fdegir> #link https://review.openstack.org/#/c/523907/
14:15:59 <fdegir> epalper: great to see so much progress with so little noise :)
14:16:10 <fdegir> epalper: anything else?
14:16:23 <epalper> :)
14:16:37 <epalper> that's all from me for now
14:16:42 <fdegir> thx epalper
14:16:54 <fdegir> #topic Scenario/Feature Status: Kubernetes
14:16:59 <fdegir> hw_wutianwei: any progress?
14:17:05 <hw_wutianwei> sorry no much update, rencently I am busy migrating the huawei-lab
14:17:15 <fdegir> hw_wutianwei: no problem
14:17:19 <hw_wutianwei> I am going to update the patch https://gerrit.opnfv.org/gerrit/#/c/46153/, which use master kubespray to deploy the kubernetes, and make k8s as a NFVI in XCI, according the https://gerrit.opnfv.org/gerrit/#/c/48711/.
14:17:33 <fdegir> hw_wutianwei: if you need hand, jmorgan1 might have time & interest :)
14:18:00 <fdegir> #info The patch https://gerrit.opnfv.org/gerrit/#/c/46153/ will be updated, which use master kubespray to deploy the kubernetes, and make k8s as a NFVI in XCI, according the https://gerrit.opnfv.org/gerrit/#/c/48711/
14:18:19 <hwoarang> it's good that we can deploy master
14:18:20 <hw_wutianwei> I also try to deploy the master branch kubernetes but have some trouble
14:19:01 <fdegir> #info hw_wutianwei attempted deploying k8s from master and there are some issues
14:19:04 <hw_wutianwei> hwoarang:  it just kebespray master not kubenetes
14:19:11 <fdegir> #undo
14:19:11 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2ccd510>
14:19:18 <fdegir> #info hw_wutianwei attempted deploying k8s from kubespray master and there are some issues
14:19:47 <fdegir> I am still waiting CNCF to respond our questions when it comes to their deployer which is able to deploy from master
14:19:56 <fdegir> will come back once I hear anything
14:20:10 <fdegir> I suppose that's all hw_wutianwei
14:20:11 <hw_wutianwei> fdegir: that's greate
14:20:19 <hw_wutianwei> I have a question about it,
14:20:46 <hw_wutianwei> which one we use, the master code of kubernetes or the release version in github https://github.com/kubernetes/kubernetes/releases
14:21:23 <fdegir> hw_wutianwei: we can stick to the one released on github until we know more about it from CNCF
14:21:52 <hw_wutianwei> fdegir:  thank you  that's all
14:22:03 <fdegir> they have this: https://github.com/cncf/cross-cloud#ci-status-dashboard-views
14:22:31 <fdegir> and I think we should get whatever is tested by/passed on their ci but we will see
14:22:42 <fdegir> so, the next topic is congress
14:22:59 <hw_wutianwei> fdegir:  this would be helpful, thanks
14:23:00 <fdegir> thx hw_wutianwei
14:23:02 <fdegir> #topic Scenario/Feature Status: Congress
14:23:17 <fdegir> Taseer is not here so I update status of his work
14:23:45 <fdegir> #info Congress is pretty close to completion. There is one change left, introducing os_congress role.
14:23:47 <fdegir> #link https://review.openstack.org/#/c/522491/
14:24:02 <fdegir> the next one Taseer is working on is
14:24:14 <fdegir> #topic Scenario/Feature Status: Promise/Blazar
14:24:41 <fdegir> #info The blueprint is under review with the help from OPNFV Promise and OpenStack Blazar projects
14:24:43 <fdegir> #link https://review.openstack.org/#/c/528567/
14:25:07 <fdegir> that's all for Taseer
14:25:18 <fdegir> #topic Scenario/Feature Status: HA/Masakari
14:25:37 <fdegir> #info We met with HA team during plugfest and continuing conversations around how we can support them
14:25:52 <fdegir> #info Few questions will be sent to Masakari team for further clarification
14:26:10 <fdegir> that was all we have for the scenarios
14:26:19 <fdegir> moving to next main topic if noone has any question/comment
14:26:37 <fdegir> #topic General Framework Updates: CentOS Support
14:26:42 <fdegir> ttallgren: how is it going?
14:27:03 <ttallgren> After rebasing, I got stuck with a new bug
14:27:25 <fdegir> which is
14:27:40 <ttallgren> lxc-stop --name $container times out
14:28:01 <fdegir> ttallgren: have you checked upstream gates to see if centos jobs behave there?
14:28:05 <fdegir> hwoarang: ^
14:28:10 <ttallgren> Nope
14:28:42 <fdegir> ttallgren: any chance we see some patches before 2018?
14:29:00 <hwoarang> sorry havent seen anything like that upstream
14:29:00 <ttallgren> You mean ones that would pass CI
14:29:02 <ttallgren> =
14:29:04 <ttallgren> ?
14:29:10 <fdegir> ttallgren: I mean whatever you have :)
14:29:26 <fdegir> cause staying local will cause you more trouble
14:29:26 <ttallgren> I can send the clean ones
14:29:38 <fdegir> please do so we can get them incorporated to ongoing work
14:29:43 <fdegir> so you will have less trouble later on
14:30:19 <ttallgren> I wanted to get the thing working locally before sending the patches, but it seems I am constantly chasing the upstream
14:30:30 <fdegir> living on the edge...
14:30:59 <fdegir> a sha bump is coming soon so better to send whatever you have
14:31:08 <ttallgren> Ok
14:31:14 <fdegir> thx ttallgren
14:31:31 <fdegir> now our favourite topic
14:31:36 <fdegir> #topic General Framework Updates: Stability Improvements
14:31:42 <fdegir> david_Orange: go ahead :)
14:32:00 <david_Orange> #info patches are sent
14:32:11 <david_Orange> #link https://gerrit.opnfv.org/gerrit/#/q/status:open+project:releng-xci+branch:master+topic:stabilization
14:32:46 <fdegir> I urge everyone to review them
14:32:47 <david_Orange> #info i corrected XCI integration one (never patch a friday evening)
14:33:11 <fdegir> not just for providing feedback but getting yourself familiar with how the things would look like
14:33:33 <david_Orange> #info jenkins failed 2 last times, one on bifrost not deploying one node, and the other before starting the script
14:34:32 <hwoarang> i am going to look at it but it's a big patchset so give it some time to rest :)
14:34:33 <david_Orange> those patchs are using pdf and idf, and give the possibility to deploy on VM and BM and mixed
14:34:58 <david_Orange> hwoarang, sure, i will disconnect during Xmas break :)
14:35:34 <fdegir> thx a lot for this david_Orange
14:36:05 <fdegir> david_Orange: should we move on?
14:36:08 <david_Orange> i think it can be a good thing to think about what do we need for vim deploy: still rely on PDF ? use inventory input... but that will be for next year
14:36:23 <fdegir> yes, we should get this one in first
14:36:23 <hwoarang> david_Orange: i am going to look at it next week or 1st week of january. at least comment on the higher level stuff
14:36:28 <david_Orange> fdegir, sure, i was just give something more to think about :)
14:36:49 <fdegir> david_Orange: thanks
14:37:06 <fdegir> #topic General Framework Updates: Multiple NFVi deployer support
14:37:37 <fdegir> #info hwoarang did this change, pushing osa separately to enable bringing in new NFVi stuff in, such as k8s and possibly kolla
14:37:43 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/48711/
14:37:50 <fdegir> hwoarang: anything to add?
14:38:08 <david_Orange> the selection is now on scenario name ?
14:38:09 <hwoarang> not much. still have some patches to move more stuff to nfvi dirs
14:38:40 <hwoarang> david_Orange: what do you mean?
14:38:48 <hwoarang> like what nfvi to use?
14:39:21 <david_Orange> hwoarang, not based on a pseudo sdf
14:39:41 <fdegir> david_Orange: https://gerrit.opnfv.org/gerrit/gitweb?p=releng-xci.git;a=blob;f=xci/config/user-vars#l25
14:39:41 <hwoarang> i don't follow :)
14:39:50 <fdegir> it's left to user to pick
14:39:59 <hwoarang> we don't parse the 'os' in 'os-nosdn-nofeature' if that's what you mean
14:40:08 <hwoarang> 'os' means nothing right now
14:40:22 <david_Orange> hwoarang, ok, it is on var name
14:40:26 <hwoarang> yes
14:41:01 <fdegir> the next topic is
14:41:13 <fdegir> #topic General Framework Updates: Enabling additional CI loops
14:41:26 <fdegir> #info Work has started to create periodic jobs against upstream osa
14:41:36 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/49271/
14:41:53 <fdegir> #info This will help us to integrate functest healthcheck without disturbing xci-verify jobs
14:42:22 <fdegir> #info Once it is done, those functest pieces will be pulled into xci-verify and sfc post merge jobs
14:42:55 <hwoarang> sfc post merge?
14:42:59 <fdegir> #info The purpose of this job is to find working version of upstream automatically but sha bump still needs to be done manually to keep ourselves sane
14:43:11 <fdegir> hwoarang: https://gerrit.opnfv.org/gerrit/#/c/49291/
14:43:15 <hwoarang> post merge in the sfc repo?
14:43:22 <fdegir> hwoarang: yes
14:43:26 <hwoarang> ok
14:43:41 <fdegir> mbuil has been waiting for months...
14:44:01 <fdegir> so the main agenda is over, moving to AoB
14:44:10 <fdegir> #topic Upcoming OSA SHA Bump
14:44:25 <fdegir> #info We might bump osa sha soon but it is unknown when
14:44:36 <hwoarang> what's blocking us?
14:44:36 <fdegir> #info We might need to keep current one until functest is integrated
14:44:42 <fdegir> hwoarang: ^
14:44:48 <hwoarang> ok
14:45:04 <fdegir> #link https://review.openstack.org/#/c/529163/
14:45:26 <fdegir> #topic Hardware Resources
14:45:33 <mbuil> I pay beers in LA if I can run functest-sfc tests in CI before ONS
14:45:42 <fdegir> #info Intel POD16 is dedicated to CI and all the nodes except node5 is operational on Jenkins
14:45:53 <fdegir> node5 is used for functest testing/troubleshooting
14:46:46 <fdegir> #info Intel POD21 is for development purposes and we currently have 3 people signed up for resources - electrocucaracha, Taseer, and fandrieu
14:46:53 <fdegir> if you need machine, tell me :)
14:47:17 <fdegir> #topic Intel OPNFV lab maintenance
14:47:23 <fdegir> jmorgan1: ^
14:47:27 <jmorgan1> yes
14:47:42 <fdegir> #info no power in the building again from Friday Jan. 12th - Tuesday Jan. 16th
14:47:51 <jmorgan1> i just got word yesterday about it
14:47:56 <fdegir> ok
14:48:02 <hw_wutianwei> fdegir:  if you need virtual pod, huawei lab has 2 to 3 available
14:48:04 <fdegir> jmorgan1: thanks for the heads up!
14:48:14 <fdegir> thx hw_wutianwei
14:48:38 <fdegir> I'll create ticket on JIRA when anyone needs resources
14:48:52 <fdegir> #topic Meetings during holiday period
14:49:12 <fdegir> I suggest to take 2 weeks off and meet again on January 10th
14:49:22 <fdegir> thoughts?
14:49:22 <ttallgren> Suits me...
14:49:25 <david_Orange> +1
14:49:28 <jmorgan1> i concur
14:49:33 <hw_wutianwei> +1
14:49:49 <mbuil> +1
14:49:56 <electrocucaracha> +1
14:50:15 <fdegir> +1
14:50:23 <fdegir> #agre Next meeting is on January 10th, 2018. New meeting series will be sent.
14:50:26 <fdegir> #agree Next meeting is on January 10th, 2018. New meeting series will be sent.
14:50:58 <fdegir> before we end, I would like to welcome Febien (fandrieu)
14:51:07 <fdegir> we have lots to do!
14:51:11 <fandrieu> Thanks
14:51:16 <jmorgan1> welcome
14:51:24 <hw_wutianwei> fandrieu: welcome
14:51:38 <david_Orange> fandrieu, Welcome
14:51:43 <ttallgren> Bienvenue!
14:51:45 <mbuil> fandrieu: welcome to xci!
14:51:45 <fdegir> Merry Christmas and Happy New Year to everyone!
14:51:52 <ttallgren> _...
14:51:52 <ttallgren> o_.-"`    `\
14:51:52 <ttallgren> .--.  _ `'-._.-'""-;     _
14:51:52 <ttallgren> .'    \`_\_  {_.-a"a-}  _ / \
14:51:52 <ttallgren> _/     .-'  '. {c-._o_.){\|`  |
14:51:53 <electrocucaracha> fandrieu: Bienvenido
14:51:55 <ttallgren> (@`-._ /       \{    ^  } \\ _/
14:51:56 <jmorgan1> thanks, you too
14:51:57 <ttallgren> `~\  '-._      /'.     }  \}  .-.
14:52:00 <ttallgren> |>:<   '-.__/   '._,} \_/  / ())
14:52:02 <ttallgren> |     >:<   `'---. ____'-.|(`"`
14:52:05 <ttallgren> \            >:<  \\_\\_\ | ;
14:52:07 <ttallgren> \                 \\-{}-\/  \
14:52:10 <ttallgren> \                 '._\\'   /)
14:52:12 <ttallgren> '.                       /(
14:52:15 <ttallgren> `-._ _____ _ _____ __.'\ \
14:52:17 <ttallgren> / \     / \     / \   \ \
14:52:20 <ttallgren> jgs _.'/^\'._.'/^\'._.'/^\'.__) \
14:52:22 <ttallgren> ,=='  `---`   '---'   '---'      )
14:52:25 <ttallgren> `"""""""""""""""""""""""""""""""`
14:52:33 <fdegir> I hope you have nice time off with your family and loved ones and talk to you in January 10th!
14:52:36 <hwoarang> fandrieu: welcome
14:52:37 <fdegir> thx ttallgren :)
14:52:44 <fdegir> #endmeeting